Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
07.07.2020, 05:47:09

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24236
  • Letzte: cornaby
Statistiken
  • Beiträge insgesamt: 669134
  • Themen insgesamt: 54199
  • Heute online: 194
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 3
Gäste: 94
Gesamt: 97

Autor Thema:  WLAN-Verbindung bricht ständig ab  (Gelesen 779 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

WLAN-Verbindung bricht ständig ab
« am: 30.05.2020, 22:20:13 »
Hallo zusammen,

ich habe vor Kurzem (endlich) Windows 10 von meinem PC geworfen und mir Linux Mint installiert. Seitdem habe ich leider das Problem, dass die WLAN-Verbindung ständig abbricht. Mir wird zwar angezeigt, die Verbindung sei vorhanden und gut, aber ich kann keine Internetseite mehr aufrufen. Wenn ich die Verbindung einmal aus- und wieder einschalte, gehts wieder (zumindest für die nächsten 10 sekunden-15 minuten).
Hat jemand eine Idee, woran das liegen könnte?
Der PC ist ein Acer Aspire E15


Vielen Dank schonmal für eure Hilfe :)

Jelka

Re: WLAN-Verbindung bricht ständig ab
« Antwort #1 am: 30.05.2020, 22:29:59 »
Welche Hardware?

inxi -Fz

Re: WLAN-Verbindung bricht ständig ab
« Antwort #2 am: 31.05.2020, 08:48:04 »
System:
  Host: franzi-Aspire-E5-574G Kernel: 5.0.0-32-generic x86_64 bits: 64
  Desktop: Cinnamon 4.4.8 Distro: Linux Mint 19.3 Tricia
Machine:
  Type: Laptop System: Acer product: Aspire E5-574G v: V1.14
  serial: <filter>
  Mobo: Acer model: Zoro_SL v: V1.14 serial: <filter> UEFI [Legacy]: Insyde
  v: 1.14 date: 03/04/2016
Battery:
  ID-1: BAT1 charge: 31.0 Wh condition: 31.0/37.0 Wh (84%)
CPU:
  Topology: Dual Core model: Intel Core i5-6200U bits: 64 type: MT MCP
  L2 cache: 3072 KiB
  Speed: 500 MHz min/max: 400/2700 MHz Core speeds (MHz): 1: 500 2: 500
  3: 500 4: 500
Graphics:
  Device-1: Intel Skylake GT2 [HD Graphics 520] driver: i915 v: kernel
  Device-2: NVIDIA GM108M [GeForce 940M] driver: nvidia v: 440.59
  Display: x11 server: X.Org 1.20.5 driver: modesetting,nvidia
  unloaded: fbdev,nouveau,vesa resolution: 1366x768~60Hz
  OpenGL: renderer: GeForce 940M/PCIe/SSE2 v: 4.6.0 NVIDIA 440.59
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
  Sound Server: ALSA v: k5.0.0-32-generic
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
  IF: enp2s0 state: down mac: <filter>
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
  driver: ath10k_pci
  IF: wlp3s0 state: up mac: <filter>
Drives:
  Local Storage: total: 931.51 GiB used: 14.82 GiB (1.6%)
  ID-1: /dev/sda vendor: Seagate model: ST1000LM024 HN-M101MBB
  size: 931.51 GiB
Partition:
  ID-1: / size: 914.21 GiB used: 14.74 GiB (1.6%) fs: ext4 dev: /dev/dm-1
  ID-2: /boot size: 703.5 MiB used: 83.3 MiB (11.8%) fs: ext4 dev: /dev/sda1
  ID-3: swap-1 size: 976.0 MiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-2
Sensors:
  System Temperatures: cpu: 46.0 C mobo: N/A gpu: nvidia temp: 46 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 213 Uptime: 25m Memory: 7.66 GiB used: 1.06 GiB (13.9%)
  Shell: bash inxi: 3.0.32

Re: WLAN-Verbindung bricht ständig ab
« Antwort #3 am: 31.05.2020, 09:44:15 »
iwconfig
und mal schauen ob da Power Management:off steht.

Re: WLAN-Verbindung bricht ständig ab
« Antwort #4 am: 31.05.2020, 10:43:08 »
Sollte an sein

lo        no wireless extensions.

enp2s0    no wireless extensions.

wlp3s0    IEEE 802.11  ESSID:"ZollstockSternchen" 
          Mode:Managed  Frequency:5.24 GHz  Access Point: 38:43:7D:34:3F:8C   
          Bit Rate=6 Mb/s   Tx-Power=30 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=52/70  Signal level=-58 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:46   Missed beacon:0

Re: WLAN-Verbindung bricht ständig ab
« Antwort #5 am: 31.05.2020, 11:23:37 »
Das könnte schon die Ursache deines Problems sein.

sudo nano /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
und

wifi.powersave = 3 ändern in

wifi.powersave = 2

Re: WLAN-Verbindung bricht ständig ab
« Antwort #6 am: 31.05.2020, 14:21:10 »
Hi :)
bevor du im system rum schraubst, solltest du das erstmal temporär testen.

PowerManagement ausschalten temporär abschalten

sudo iwconfig wlp3s0 power off

Re: WLAN-Verbindung bricht ständig ab
« Antwort #7 am: 01.06.2020, 10:26:57 »
Ich hab beides mal ausprobiert, leider ohne Erfolg :/

Re: WLAN-Verbindung bricht ständig ab
« Antwort #8 am: 01.06.2020, 14:51:53 »
Hi :)
was funkt denn da bei dir?
wlan aus und wieder an, dann
nmcli dev wifi list   

Re: WLAN-Verbindung bricht ständig ab
« Antwort #9 am: 01.06.2020, 15:20:17 »
IN-USE  SSID                   MODE   CHAN  RATE        SIGNAL  BARS  SECURITY 
        Anchorman              Infra  6     130 Mbit/s  80      ▂▄▆_  WPA1 WPA2
        Anchorman              Infra  116   405 Mbit/s  70      ▂▄▆_  WPA1 WPA2
*       ZollstockSternchen     Infra  48    405 Mbit/s  63      ▂▄▆_  WPA1 WPA2
        FRITZ BOX BOX BOX      Infra  6     130 Mbit/s  52      ▂▄__  WPA2     
        C.O.B.                 Infra  6     260 Mbit/s  50      ▂▄__  WPA2     
        UPC2491785             Infra  44    405 Mbit/s  42      ▂▄__  WPA1 WPA2
        FRITZ BOX BOX BOX      Infra  52    270 Mbit/s  42      ▂▄__  WPA2     
        7412                   Infra  1     130 Mbit/s  37      ▂▄__  WPA2     
        FRITZ BOX BOX BOX_EXT  Infra  6     130 Mbit/s  35      ▂▄__  WPA2     
        UPC2865685             Infra  1     130 Mbit/s  34      ▂▄__  WPA1 WPA2
        Vodafone Hotspot       Infra  1     130 Mbit/s  32      ▂▄__  --       
        Telekom_FON            Infra  6     540 Mbit/s  29      ▂___  --       
        WLAN-XZ7G4K            Infra  1     195 Mbit/s  27      ▂___  WPA2     
        Telekom_FON            Infra  1     195 Mbit/s  27      ▂___  --       
        WLAN-972191            Infra  6     540 Mbit/s  27      ▂___  WPA2     
        UPC53543EF             Infra  6     130 Mbit/s  24      ▂___  WPA1 WPA2
        Vodafone Hotspot       Infra  6     130 Mbit/s  22      ▂___  --       
        UPC2491785             Infra  11    130 Mbit/s  19      ▂___  WPA1 WPA2
        Vodafone Hotspot       Infra  11    130 Mbit/s  17      ▂___  --       

Re: WLAN-Verbindung bricht ständig ab
« Antwort #10 am: 01.06.2020, 15:24:14 »
Und noch als zusätzliche Info (weiß nicht, ob das hilfreich ist): Alle anderen Geräte haben keine Verbindungsprobleme, und wenn ich an meinem PC Tails nutze, funktionierts auch einwandfrei.

Re: WLAN-Verbindung bricht ständig ab
« Antwort #11 am: 01.06.2020, 15:31:31 »
Hi :)
ich würde für dein zollst.... für 2.4ghz und 5ghz jeweils eine eigene ssid vergeben..
dual betrieb macht gern mal probleme.

Re: WLAN-Verbindung bricht ständig ab
« Antwort #12 am: 01.06.2020, 17:22:30 »
Hi :)

Ich hab mich jetzt mal durch die Wlan einstellungen geklickt, und da steht, dass die 2.4 Ghz-Frequenz deaktiviert ist... kann das dann trotzdem noch ein problem sein?

Lg

Re: WLAN-Verbindung bricht ständig ab
« Antwort #13 am: 01.06.2020, 20:40:43 »
Hallo,
die Sendeleistung ist viel zu hoch, über das erlaubte Mass hinaus. zudem vermute ich, dass die Karte dadurch überhitzt und die Verbindung abbricht. Eine Überschneidung mit identischen ESSID gibt es nur beim Nachbarnetz "Anchorman".
Zitat
Bit Rate=6 Mb/s  Tx-Power=30 dBm
Regionseinstellung prüfen, korrigieren und erneut prüfen:
iw reg get
sudo sed -i "s/REGDOMAIN=/REGDOMAIN=DE/g" /etc/default/crda
sudo  systemctl stop NetworkManager.service
sudo modprobe -rfv iwlwifi
sudo modprobe -v iwlwifi
sudo  systemctl start NetworkManager.service
iwconfig
iw reg get
Siehe dazu auch https://wiki.ubuntuusers.de/iw/
« Letzte Änderung: 01.06.2020, 20:44:03 von Flash63 »

Re: WLAN-Verbindung bricht ständig ab
« Antwort #14 am: 04.06.2020, 10:27:08 »
Ich hab das mal ausprobiert und die letzten Tage getestet. Die Sendeleistung ist jetzt runter auf 20 dBm. Seitdem ist es besser, aber noch nicht weg. Macht es Sinn, die Sendeleistung noch weiter zu drosseln? Oder könnte da auch noch was anderes hinterstecken?