Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
11.07.2020, 23:46:58

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24252
  • Letzte: Mavel
Statistiken
  • Beiträge insgesamt: 670245
  • Themen insgesamt: 54299
  • Heute online: 435
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Ventoy Befehl -I und -u nicht gefunden  (Gelesen 689 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Ventoy Befehl -I und -u nicht gefunden
« am: 30.05.2020, 09:20:42 »
Schönen guten Morgen,
wollte gerade Ventoy auf einen USB-Stick installieren da kam folgende Fehlermeldung

kogl@kogl-ThinkPad-E580:~/Downloads/ventoy-1.0.11$ sudo sh Ventoy2Disk.sh { -i | -I | -u } /dev/sde1
[sudo] Passwort für kogl: -u: Befehl nicht gefunden.
-I: Befehl nicht gefunden.

was mach ich falsch, könnt Ihr mir helfen.

kogl@kogl-ThinkPad-E580:~$ inxi -Fz
System:
  Host: kogl-ThinkPad-E580 Kernel: 5.3.0-53-generic x86_64 bits: 64
  Desktop: Cinnamon 4.4.8 Distro: Linux Mint 19.3 Tricia
Machine:
  Type: Laptop System: LENOVO product: 20KS003GGE v: ThinkPad E580
  serial: <filter>
  Mobo: LENOVO model: 20KS003GGE v: SDK0J40697 WIN serial: <filter>
  UEFI: LENOVO v: R0PET41W (1.18 ) date: 06/11/2018
Battery:
  ID-1: BAT0 charge: 41.2 Wh condition: 41.8/45.7 Wh (91%)
CPU:
  Topology: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP
  L2 cache: 6144 KiB
  Speed: 800 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 800 2: 800
  3: 800 4: 800 5: 800 6: 800 7: 800 8: 800
Graphics:
  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa
  resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2)
  v: 4.5 Mesa 19.2.8
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
  Sound Server: ALSA v: k5.3.0-53-generic
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Intel Dual Band Wireless-AC 3165 Plus Bluetooth driver: iwlwifi
  IF: wlp5s0 state: up mac: <filter>
Drives:
  Local Storage: total: 7.52 TiB used: 2.77 TiB (36.8%)
  ID-1: /dev/nvme0n1 vendor: Toshiba model: KXG5AZNV256G size: 238.47 GiB
  ID-2: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB
  ID-3: /dev/sdb type: USB vendor: Western Digital model: WD Elements 25A2
  size: 1.82 TiB
  ID-4: /dev/sdc type: USB vendor: Western Digital model: WD20EARX-32PASB0
  size: 1.82 TiB
  ID-5: /dev/sdd type: USB vendor: Western Digital model: WD Elements 25A3
  size: 2.73 TiB
  ID-6: /dev/sde type: USB vendor: Transcend model: JetFlash Transcend 8GB
  size: 7.48 GiB
Partition:
  ID-1: / size: 233.24 GiB used: 78.62 GiB (33.7%) fs: ext4
  dev: /dev/nvme0n1p2
Sensors:
  System Temperatures: cpu: 52.0 C mobo: 0.0 C
  Fan Speeds (RPM): cpu: 12288
Info:
  Processes: 351 Uptime: 6h 13m Memory: 15.41 GiB used: 2.45 GiB (15.9%)
  Shell: bash inxi: 3.0.32
kogl@kogl-ThinkPad-E580:~$

Re: Ventoy Befehl -I und -u nicht gefunden
« Antwort #1 am: 30.05.2020, 10:00:40 »
sudo sh Ventoy2Disk.sh { -i | -I | -u } /dev/sde1
Optionen in geschweiften Klammern, getrennt mit einer Pipe, hab' ich noch nie gesehen...

Re: Ventoy Befehl -I und -u nicht gefunden
« Antwort #2 am: 30.05.2020, 10:15:32 »
so sieht es bei mir aus (und funktioniert)
billyfox@LMCin:~/Downloads/ventoy-1.0.11$ sudo sh Ventoy2Disk.sh -i /dev/sdbsdb ist der Stick
bei dir sollte der Befehl
sudo sh Ventoy2Disk.sh -i /dev/sdefunktionieren - vorausgesetzt du befindest dich im richtigen Verzeichnis - siehe oben

Befehle editiert - siehe Antwort #9 und 10
« Letzte Änderung: 30.05.2020, 14:24:30 von billyfox05 »

Re: Ventoy Befehl -I und -u nicht gefunden
« Antwort #3 am: 30.05.2020, 10:17:43 »
Die Parameter in den geschweiften Klammern sind einzelne Optionsmöglichkeiten:

Ventoy2Disk.sh  OPTION  /dev/XXX
  OPTION:
    -i   install ventoy to sdX (fail if disk already installed with ventoy)
    -I   force install ventoy to sdX (no matter installed or not)
    -u   update ventoy in sdX

Re: Ventoy Befehl -I und -u nicht gefunden
« Antwort #4 am: 30.05.2020, 10:32:32 »
Ich habs bislang nur einmal eingerichtet und es mir ganz einfach gemacht.

Habe auf dem Stick eine neue Partitionstabelle mit gparted erstellt, aber keine Partition angelegt. Da hab ich dann auch direkt gesehen, als was der Stick eingehängt ist (sdX)

sudo ./Ventoy2Disk.sh -i /dev/sdX

Anschließend wurde der Stick automatisch als "ventoy" eingehängt und der Dateimanager geöffnet. ISOs draufkopieren und nach dem Kopiervorgang den Stick mit dem Dateimanager auswerfen. Nicht vorher rausziehen, denn es werden noch Daten kopiert, obwohl es den Anschein hat, dass er fertig ist.

Am besten hat bei mit die Version 1.09 funktioniert und die hab ich immer noch. Die neuen Optionen mit Persistenz brauche ich nicht, da kein Platz mehr auf meinem Ventoy Stick ist. ;D

Re: Ventoy Befehl -I und -u nicht gefunden
« Antwort #5 am: 30.05.2020, 11:05:46 »
Danke für eure Antworten, jetzt habe ich eure Tipps beherzigt, jetzt erkennt Ventoy den USB-Stick nicht.

kogl@kogl-ThinkPad-E580:~/Downloads/ventoy-1.0.11$ sudo sh Ventoy2Disk.sh { -i -I -u } /dev/sde1
[sudo] Passwort für kogl:       

***********************************************************
*                Ventoy2Disk Script                       *
*             longpanda  admin@ventoy.net                 *
***********************************************************

{ is NOT a valid device
Usage:  Ventoy2Disk.sh CMD [ OPTION ] /dev/sdX
  CMD:
   -i  install ventoy to sdX (fail if disk already installed with ventoy)
   -u  update ventoy in sdX
   -I  force install ventoy to sdX (no matter installed or not)

  OPTION: (optional)
   -s  enable secure boot support (default is disabled)

scheinbar bin ich zu blöd dazu, habs übrigens mit dev/sde auch probiert mit dem selben Ergebniss. Fällt euch noch was ein dazu.

Re: Ventoy Befehl -I und -u nicht gefunden
« Antwort #6 am: 30.05.2020, 11:12:06 »
Hi
Zitat
scheinbar bin ich zu blöd dazu
kein Komentar  ;D

jetzt habe ich eure Tipps beherzigt Nein ! Hast Du nicht !

Gib doch einfach :
sudo sh Ventoy2Disk.sh -i /dev/sde1 ein und gut ist .

Obwohl ich nicht weiß was sde1 soll ?  Wenn es der ganze Stick ist , dann nehm ich sde
Bei Dir heiß der Stick ja auch nur sde  und nicht sde1


MfG soyo
« Letzte Änderung: 30.05.2020, 11:15:59 von soyo »

Re: Ventoy Befehl -I und -u nicht gefunden
« Antwort #7 am: 30.05.2020, 11:12:56 »
Du gibst immer noch die geschweifte Klammer mit ein:
"{ is NOT a valid device"
Die musst du natürlich weglassen.


Re: Ventoy Befehl -I und -u nicht gefunden
« Antwort #8 am: 30.05.2020, 11:25:43 »
Fällt euch noch was ein dazu.
Jooo- Antwort #2 - der untere Befehl

Re: Ventoy Befehl -I und -u nicht gefunden
« Antwort #9 am: 30.05.2020, 11:42:54 »
@billfox05:
Warum sollte er alle 3 Optionen auf einmal verwenden?

Normale Installation:
Zitat
sudo sh Ventoy2Disk.sh -i /dev/sde

Erzwungene Installation
Zitat
sudo sh Ventoy2Disk.sh -I /dev/sde

Update:
Zitat
sudo sh Ventoy2Disk.sh -u /dev/sde

Hylli

Re: Ventoy Befehl -I und -u nicht gefunden
« Antwort #10 am: 30.05.2020, 14:18:12 »
Ja, hast Recht - gibt`s keinen Grund für - das kleine "i" reicht.
« Letzte Änderung: 30.05.2020, 14:25:51 von billyfox05 »

Re: Ventoy Befehl -I und -u nicht gefunden
« Antwort #11 am: 31.05.2020, 09:15:04 »
Schönen Morgen,
jetzt hab ich endlich kapiert wie man installiert, bin halt ein bisschen schwer von Begriff, auf Laufwerke beide Partionen da, 34 MB EFI Rest für die ISOs und hab das nächste Problem.
Habe eine ISO von MX-Linux 64 Bit auf den Stick kopiert und wollte dann mit UEFI-Bootmenu starten, der Stick ist zwar  im Bootmenu vorhanden aber MX-Linux will nicht starten da kann ich noch so oft im Bootmenu auf Enter drücken es tut sich nichts Ventoy will mich nicht oder ich wirklich zu blöd, aber auf der Ventoy Seite ist es so beschrieben soweit ich das mit meinem armseligen Englisch übersetzen kann.
Also was mach ich jetzt wieder falsch, bin über mein Unvermögen schon verzweifelt, also nochmals Bitte um Hilfe.

Re: Ventoy Befehl -I und -u nicht gefunden
« Antwort #12 am: 31.05.2020, 09:28:45 »
Ich habe die antiX auf meinem Ventoy Stick und die läuft. Also wird MX-Linux auch unterstützt, denn die ISOs sind sozusagen baugleich.
Kopiere das ISO nochmal auf den Stick und lass den Stick im Rechner. Der Kopiervorgang dauert bei Ventoy länger, als wie es aussieht.
Werfe deshalb den Stick mit deinem Dateimanager aus. Abziehen erst, wenn er ausgehängt wurde.

Re: Ventoy Befehl -I und -u nicht gefunden
« Antwort #13 am: 31.05.2020, 11:03:48 »
Hi
Also ich würde erstmal ein paar verschiedene ISO's (z.B. auch dein 19.3 CINNAMON iso ) draufschieben .
Dann sieht man ob Ventoy überhaupt läuft .

Zu den ISO's die dort als "läuft" angegeben werden (die werden nicht laufend getestet)
Beispiel : Android , geht bei mir , Aber nicht am HP Laptop
HBCD_PE_x64 , läuft bei mir nur mit Ventoy 1.0.6 !    bei 9,10,11 nicht (egal welcher Rechner )
Bein eben erschienen 12 muß ich noch schauen .

Bei mir immer Gegenprobe , unter E2B (Easy2Boot) funktionieren sie. (nur Neue Systeme z.B. Ubuntu 20 mag E2B noch nicht)

MfG soyo

Re: Ventoy Befehl -I und -u nicht gefunden
« Antwort #14 am: 31.05.2020, 11:10:12 »
Hier funktioniert es mit MX-Linux 19.1 (Ventoy Vers. 1.0.12)
Welche Datei hast du denn auf den Stick kopiert ? Es sollte die "MX-19.1_x64.iso" sein.