Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
13.07.2020, 19:58:15

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 670639
  • Themen insgesamt: 54343
  • Heute online: 432
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  Sudo funktioniert nicht/ Revovery Modus startet nicht  (Gelesen 166 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Sudo funktioniert nicht/ Revovery Modus startet nicht
« am: 24.05.2020, 14:51:32 »
Hallo zusammen!

Ich nutze Linux Mint 19.3 Cinnamon mit dem 5.3.0-53-generic Kernel.
Ich habe eine Textdatei mit allen Systeminfos hochgeladen, falls davon was wichtig ist.

Ich habe folgendes Problem:
Gestern habe ich mit dem Befehl "sudo chmod 777 -c -R /usr/bin Vollzugriff auf den Ordner erlaubt, da ich ein plug-in für das Programm Audacity installieren wollte. Ohne diese Rechte konnte ich das Plug-in nicht installieren.

Heute musste ich feststellen, dass keine sudo-Befehle mehr funktionieren.
Die Fehlermeldung im Terminal lautet: "sudo: /usr/bin/sudo muss dem Benutzer mit UID 0 gehören und das >>setuid<<-Bit gesetzt haben.

Ich habe bereits mehrere Lösungsansätze gefunden. Einer davon ist dieser:
Im RecoveryModus als root diese Befehle eingeben:
mount -o remount, rw l
mount --all
chown root:root /usr/bin/sudo
chmod 4755/usr/bin/sudo
reboot

Ich komme allerdings nicht in den Recoverymodus!
Ich habe Shift und ESC mehrfach versucht zu drücken.
Einmal kam nur die Befehlzeile "grub:" zum Vorschein, womit ich aber überhaupt nichts anfangen konnte.
Ich habe in der grub Datei im "etc" Ordner gesehen, dass das grub menu anscheinend "hidden" ist. Kann es sein, dass ich somit gar nicht in den Recoverymodus gelange?

Über eine Live-DVD habe ich auch probiert, diese Befehle einzugeben, nachdem ich vorher "su sudo" eingegeben habe. Es kam allerdings keine Rückmeldung und nach einem Neustart hat sich nichts an dem Problem geändert.

Könnte mir vielleicht jemand weiterhelfen, ich habe leider keinen Weg gefunden das Problem zu lösen.
Ich bedanke mich schon einmal im Vorraus!
« Letzte Änderung: 24.05.2020, 15:17:54 von Rabensohn »

Re: Sudo funktioniert nicht/ Revovery Modus startet nicht
« Antwort #1 am: 24.05.2020, 15:15:48 »
Gestern habe ich mit dem Befehl "sudo chmod 777 -c -R /usr/bin Vollzugriff auf den Ordner erlaubt,...
Das entspricht in entweder der Amputation der Beine oberhalb der Knie, nur weil die Fussnägel zu lang waren.... mit anderen Worten, das System ist kaputt.... komplett neu installieren.

... da ich ein plug-in für das Programm Audacity installieren wollte. Ohne diese Rechte konnte ich das Plug-in nicht installieren.
Dafür muss man nicht das ganze System zerschießen. Du hast an den Rechten in /usr unter Linux üblicherweise überhaupt nichts verloren und Änderungen sind da auch nicht notwendig ... am allerwenigsten deshalb, um etwas zu installieren.

Re: Sudo funktioniert nicht/ Revovery Modus startet nicht
« Antwort #2 am: 24.05.2020, 15:17:43 »
Okay, dann werde ich das machen.
Vielen Dank!

Re: Sudo funktioniert nicht/ Revovery Modus startet nicht
« Antwort #3 am: 24.05.2020, 15:20:40 »
...es sei denn, Du bist in Besitzt einer Timeshift Sicherung.

Markus67

  • aka NeuerMintUser67
  • *****
Re: Sudo funktioniert nicht/ Revovery Modus startet nicht
« Antwort #4 am: 24.05.2020, 15:23:53 »

Moin

 Und was Lernen wir daraus.?

Gruß