Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
01.06.2020, 01:45:15

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24071
  • Letzte: atze48
Statistiken
  • Beiträge insgesamt: 663317
  • Themen insgesamt: 53656
  • Heute online: 330
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 2
Gäste: 198
Gesamt: 200

Autor Thema: [gelöst]  Plötzlich kein HDMI mehr  (Gelesen 270 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Plötzlich kein HDMI mehr
« am: 22.05.2020, 21:52:02 »
Guten Abend

Desktop: Cinnamon 4.4.8, Distro: Linux Mint 19.3 tricia Kernel 5.3.0-53, Laptop: Medion Erazer P6661, CPU i5 6200U, GK: iGPU+Geforce GTX 950M

Seid gestern Abend funktioniert mein HDMI Ausgang leider nicht mehr. Als ich den Rechner aus dem Ruhezustand aufweckte ging die Tastatur nicht mehr,
also habe ich Ihn neu gestartet und seid dem bekomme ich kein Bild mehr auf dem HDMI und meine Tastenkombination FN+F8 zeigt keine Wirkung mehr.
Ich habe die Vermutung das es irgendwas mit der Tastatur bzw. dem Treiber dafür zu tun hat.

Verhalten der FN Tasten: Die Tasten für Helligkeit und Abschalten des Displays funktionieren Problemlos, die Tasten für Trackpad aus, Lauter, Leiser und Ton aus
zeigen ein sehr komisches Verhalten. Möchte ich den Ton damit aus machen drücke ich einmal und er Schaltet den Ton so lange ein und aus bis ich wieder drücke,
das gleiche bei Lauter und Leiser hier wird jedes mal bis zum Endanschlag gefahren es seiden ich greife ein.

Somit vermute ich das ich den HDMI Ausgang nicht über FN+F8 aktivieren kann.

xrandr zeigt mir auch an das ich keinen HDMI Ausgang habe wenn ich versuche per xrandr --output HDMI1 den HDMI Ausgang zu aktivieren.

Den Nvidia Treiber habe ich installiert und es wird auch die Nvidia Graka genutzt.

Danke im vor raus für die Hilfe.
« Letzte Änderung: 24.05.2020, 00:41:09 von joernkemmerzehl »

Re: Plötzlich kein HDMI mehr
« Antwort #1 am: 22.05.2020, 22:38:36 »
Was sagen die Nvidia-settings?

Re: Plötzlich kein HDMI mehr
« Antwort #2 am: 22.05.2020, 23:05:20 »
Was meinst du was die sagen?

joern@joernlaptop:~$ nvidia-settings

(nvidia-settings:2226): GLib-GObject-CRITICAL **: 22:57:00.564: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
** Message: 22:57:00.727: PRIME: Requires offloading
** Message: 22:57:00.727: PRIME: is it supported? yes
** Message: 22:57:00.768: PRIME: Usage: /usr/bin/prime-select nvidia|intel|query
** Message: 22:57:00.768: PRIME: on-demand mode: "0"
** Message: 22:57:00.768: PRIME: is "on-demand" mode supported? no

oder was wolltest du daraus jetzt wissen? Ich nutze laut prime die Nvidia Karte.

Hier mal die Ausgabe aus xrandr:

Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 16384 x 16384
eDP-1-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1920x1080     60.02*+  60.01    59.97    59.96    59.93 
   1680x1050     59.95    59.88 
   1600x1024     60.17 
   1400x1050     59.98 
   1600x900      59.99    59.94    59.95    59.82 
   1280x1024     60.02 
   1440x900      59.89 
   1400x900      59.96    59.88 
   1280x960      60.00 
   1440x810      60.00    59.97 
   1368x768      59.88    59.85 
   1360x768      59.80    59.96 
   1280x800      59.99    59.97    59.81    59.91 
   1152x864      60.00 
   1280x720      60.00    59.99    59.86    59.74 
   1024x768      60.04    60.00 
   960x720       60.00 
   928x696       60.05 
   896x672       60.01 
   1024x576      59.95    59.96    59.90    59.82 
   960x600       59.93    60.00 
   960x540       59.96    59.99    59.63    59.82 
   800x600       60.00    60.32    56.25 
   840x525       60.01    59.88 
   864x486       59.92    59.57 
   800x512       60.17 
   700x525       59.98 
   800x450       59.95    59.82 
   640x512       60.02 
   720x450       59.89 
   700x450       59.96    59.88 
   640x480       60.00    59.94 
   720x405       59.51    58.99 
   684x384       59.88    59.85 
   680x384       59.80    59.96 
   640x400       59.88    59.98 
   576x432       60.06 
   640x360       59.86    59.83    59.84    59.32 
   512x384       60.00 
   512x288       60.00    59.92 
   480x270       59.63    59.82 
   400x300       60.32    56.34 
   432x243       59.92    59.57 
   320x240       60.05 
   360x202       59.51    59.13 
   320x180       59.84    59.32 
DP-1-1 disconnected (normal left inverted right x axis y axis)

und lspci

lspci | grep 3D
01:00.0 3D controller: NVIDIA Corporation GM107M [GeForce GTX 950M] (rev a2)
lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Skylake GT2 [HD Graphics 520] (rev 07)


Re: Plötzlich kein HDMI mehr
« Antwort #3 am: 23.05.2020, 15:20:42 »
Hi :)
die immer wieder gestellte frage... kernel update gelaufen?
wenn man die kernel automatik an lässt, muss man mit sowas immer rechnen.

Re: Plötzlich kein HDMI mehr
« Antwort #4 am: 23.05.2020, 20:39:20 »
Ja ein Kernelupdate ist gelaufen, ich suche nur noch eine Möglichkeit auf einen älteren Kernel zu kommen.
UKUU geht ja nicht mehr.

Re: Plötzlich kein HDMI mehr
« Antwort #5 am: 23.05.2020, 20:44:29 »
Probiere mal den vorherigen Kernel zu booten, müßte ja noch installiert sein.

https://www.linuxmintusers.de/index.php?action=wiki;page=Auf_einen_%C3%A4lteren_Kernel_zur%C3%BCck_gehen

Re: Plötzlich kein HDMI mehr
« Antwort #6 am: 23.05.2020, 22:12:04 »
Danke kann auf gelöst gesetzt werden  :D es war der Kernel bin wieder zurück auf 5.0 und schon läuft es wieder.

Re: Plötzlich kein HDMI mehr
« Antwort #7 am: 23.05.2020, 22:24:30 »
Danke kann auf gelöst gesetzt werden

Das kannst Du nur selber tun, indem Du den 1.Post von Dir änderst - siehe dazu die Hilfe auf dieser Seite.

es war der Kernel bin wieder zurück auf 5.0

Das ist leider keine gute Idee, weil bei diesem Kernel der Support bereits abgelaufen ist. Besser auf einen früheren 5.3 gehen, oder wenn die Hardware nicht zu neu ist den 4.15 mal probieren.