Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
01.06.2020, 01:13:28

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24071
  • Letzte: atze48
Statistiken
  • Beiträge insgesamt: 663317
  • Themen insgesamt: 53656
  • Heute online: 330
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 0
Gäste: 257
Gesamt: 257

Autor Thema:  Bekomme TechniSat Skystar S2 nicht zum Laufen!  (Gelesen 884 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Bekomme TechniSat Skystar S2 nicht zum Laufen!
« am: 22.05.2020, 12:27:04 »
Hallo!

Nachdem meine "alte" TT S2-3200 zuletzt weder mit LM Cin 18.1 noch LM 19.3 Cin. vernünftig funktionieren wollte(hat mit Ausnahme von Russia Today keine SD Sender mehr gezeigt) und die Skystar sehr günstig zu haben ist  habe ich mich dazu entschlossen, im Zuge einer Ram & Kraka Aufrüstung, die Karte zu tauschen!

Habe die Firmware "dvb-fe-cx24120-1.20.58.2.fw" mit Admin Rechten in den /lib/firmware/ Ordner kopiert und neu gestartet! w_scan kann aber keine Karte finden.

inxi -Fxz
Zitat
System:    Host: *********-System-Product-Name Kernel: 5.3.0-53-generic x86_64 bits: 64
           compiler: gcc v: 7.5.0 Desktop: Cinnamon 4.4.8 Distro: Linux Mint 19.3 Tricia
           base: Ubuntu 18.04 bionic
Machine:   Type: Desktop Mobo: ASUSTeK model: H170-PRO/USB 3.1 v: Rev X.0x serial: <filter>
           UEFI: American Megatrends v: 0501 date: 11/19/2015
CPU:       Topology: Quad Core model: Intel Core i5-6600K bits: 64 type: MCP arch: Skylake-S
           rev: 3 L2 cache: 6144 KiB
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 27999
           Speed: 800 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800
Graphics:  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: Gigabyte driver: nvidia
           v: 440.59 bus ID: 01:00.0
           Display: x11 server: X.Org 1.20.5 driver: nvidia
           unloaded: fbdev,modesetting,nouveau,vesa resolution: 1920x1080~60Hz
           OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 440.59
           direct render: Yes
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio
           vendor: ASUSTeK Sunrise Point-H driver: snd_hda_intel v: kernel bus ID: 00:1f.3
           Device-2: NVIDIA GP107GL High Definition Audio vendor: Gigabyte driver: snd_hda_intel
           v: kernel bus ID: 01:00.1
           Sound Server: ALSA v: k5.3.0-53-generic
Network:   Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k port: f000
           bus ID: 00:1f.6
           IF: enp0s31f6 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Device-2: Techsan Co B2C2 FlexCopII DVB chip / Technisat SkyStar2 DVB card
           driver: N/A port: d000 bus ID: 04:00.0
           Device-3: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
           vendor: TP-LINK TG-3468 driver: r8169 v: kernel port: c000 bus ID: 05:00.0
           IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    Local Storage: total: 9.32 TiB used: 6.08 TiB (65.2%)
           ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO M.2 250GB size: 232.89 GiB
           ID-2: /dev/sdb vendor: Seagate model: ST4000DM000-1F2168 size: 3.64 TiB
           ID-3: /dev/sdc vendor: Western Digital model: WD60EZRZ-00GZ5B1 size: 5.46 TiB
Partition: ID-1: / size: 37.30 GiB used: 18.00 GiB (48.3%) fs: ext4 dev: /dev/sda2
           ID-2: /home size: 91.49 GiB used: 33.28 GiB (36.4%) fs: ext4 dev: /dev/sda3
           ID-3: swap-1 size: 16.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda4
Sensors:   System Temperatures: cpu: 30.0 C mobo: N/A gpu: nvidia temp: 37 C
           Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 0%
Info:      Processes: 276 Uptime: 1h 15m Memory: 31.28 GiB used: 4.47 GiB (14.3%) Init: systemd
           runlevel: 5 Compilers: gcc: 7.5.0 Shell: bash v: 4.4.20 inxi: 3.0.32

dmesg | grep -i b2c2
Zitat
[   14.017260] b2c2-flexcop: B2C2 FlexcopII/II(b)/III digital TV receiver chip loaded successfully
[   14.042011] b2c2_flexcop_pci 0000:04:00.0: enabling device (0000 -> 0003)
[   14.066832] b2c2-flexcop: MAC address = 00:08:c9:e1:c8:5e
[   14.399768] b2c2-flexcop: no frontend driver found for this B2C2/FlexCop adapter

lspci -vvv
Zitat
04:00.0 Network controller: Techsan Electronics Co Ltd B2C2 FlexCopII DVB chip / Technisat SkyStar2 DVB card (rev 02)
   Subsystem: Techsan Electronics Co Ltd B2C2 FlexCopII DVB chip / Technisat SkyStar2 DVB card
   Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
   Status: Cap- 66MHz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
   Interrupt: pin A routed to IRQ 18
   Region 0: Memory at f7200000 (32-bit, non-prefetchable) [size=64K]
   Region 1: I/O ports at d000 [size=32]
   Kernel modules: b2c2_flexcop_pci

Habe ich noch was vergessen?

Re: Bekomme TechniSat Skystar S2 nicht zum Laufen!
« Antwort #1 am: 22.05.2020, 13:58:08 »
Hi
Vielleicht hilft dir das :
https://www.linuxmintusers.de/index.php?action=wiki;page=Satellittenkarte_(PCI)_unter_LM_installieren

Bei mir (allerdings DVB-C  Cabelstar) , geht es erst wenn ich die DVB-Tools und DVB-Apps (nehm immer beide , gewohnheit) aus der Anwenderverwaltung installiert hab und den Rechner neu gestartet hab .

PS: Welche w_scan Version nutzt du ?  Und gibts noch nen paar SD Sender , die ÖR wollen ja Mitte 2020 (ist ja gleich) auch nur noch HD senden ?

MfG soyo
« Letzte Änderung: 22.05.2020, 14:25:29 von soyo »

Re: Bekomme TechniSat Skystar S2 nicht zum Laufen!
« Antwort #2 am: 22.05.2020, 15:33:39 »
Hatte DVB-tools schon drauf und ein Hinzufügen von DVB-Apps hat leider nichts gebracht.

Meine w_scan Version ist 20170107-2 jedoch erschließt sich mir nicht wie w_scan der Schuldige sein könnte solange kein Treiber für die Karte gefunden wird?

Ist es möglich dass der Fehler darin liegt indem ich die Firmware erst nach dem Einbau der Karte in den /lib/firmware/ Ordner kopiert habe?

Haben die hier beschrieben Schritte irgendeine Relevanz für mein Problem?

https://hardware.linuxnetz.de/technisat-skystar-2/

Re: Bekomme TechniSat Skystar S2 nicht zum Laufen!
« Antwort #3 am: 22.05.2020, 16:33:45 »
Hm?
Also ich würd erstmal in lib/firmware nach deiner Firmware schauen , und nach ihren Eigenschaften/Zugriffsrechte   wenn da Root steht , OK.

Dann würd ich mal nen anderen Kernel (vielleicht nen älterne z.B.4.15 ) versuchen .

MfG soyo

Re: Bekomme TechniSat Skystar S2 nicht zum Laufen!
« Antwort #4 am: 22.05.2020, 17:11:26 »
Das steht root!

Zitat
-rw-r--r--  1 root root   44924 Mai 22 10:04 dvb-fe-cx24120-1.20.58.2.fw

Ich werde erst nochmal ein wenig recherchieren bevor ich anfange "Kernelumbauten" zu machen.

Danke für die Hilfe soyo

Re: Bekomme TechniSat Skystar S2 nicht zum Laufen!
« Antwort #5 am: 22.05.2020, 17:23:13 »
Hi
Ich werde erst nochmal ein wenig recherchieren bevor ich anfange "Kernelumbauten" zu machen.
Was für "Umbauten" ?

Beim Starten des Rechners , SHIFT Taste drücken , bis das Grub Startmenü erscheint , dann dort auf Erweiterte OPtionem .
Anderen Kernel auswählen , und schauen obs mit dem geht.
Wenn nicht Rechner runterfahren/ausmachen .
Beim nächsten Neustart startet er dann eh mit deinem Ursprünglichen Kernel .
Schließlich hast Du ja keinen Kernel gelöscht , sonden nur einen anderen für den Versuch Getestet .

Kriegst Du mal nen Kernelupdate , mit dem dein Rechner garnicht startet , ist das der Weg ihn mit dem vorherigen Kernel wieder zu starten .

MfG soyo
PS:
das gesuchte Frontend heißt stv0299
gibts auf meinem Rechner Mint Mate 19.3 64bit
sollte früher in die Datei etc/modprobe.conf  eingetragen werden .   Die gibts aber nicht .  Weiß also nicht wo man das nun machen könnte.
« Letzte Änderung: 22.05.2020, 17:41:20 von soyo »

Re: Bekomme TechniSat Skystar S2 nicht zum Laufen!
« Antwort #6 am: 23.05.2020, 08:06:21 »
Der Wechsel auf den 4.15er Kernel hat leider auch nichts gebracht.

Ich habe auch schon versucht die Module mit
Zitat
sudo modprobe -v stv0299
&
Zitat
sudo modprobe -v b2c2_flexcop_pci
zu laden.
Auch das hat leider nichts geändert obwohl da keine Fehlermeldung kam.

Re: Bekomme TechniSat Skystar S2 nicht zum Laufen!
« Antwort #7 am: 23.05.2020, 08:45:54 »
Hi
Zitat
obwohl da keine Fehlermeldung kam
Wo bei ?
Hier bei ?
dmesg | grep -i b2c2
und dann kommt diese Fehlermeldung nicht mehr ?
Zitat
[   14.399768] b2c2-flexcop: no frontend driver found for this B2C2/FlexCop adapter
MfG soyo

Re: Bekomme TechniSat Skystar S2 nicht zum Laufen!
« Antwort #8 am: 23.05.2020, 10:00:06 »
Beim Ausführen der Befehle zum Laden der Module kam keine Fehlermeldung. Der Treiber wurde aber auch danach nicht gefunden.

Mit Gruß & Dank

cherusci

Re: Bekomme TechniSat Skystar S2 nicht zum Laufen!
« Antwort #9 am: 23.05.2020, 11:38:30 »
Hi
Was gibt eigendlich :
dmesg | grep -i dvbund
lsmodaus ?
MfG soyo
Einige schrieben , das sie die Karte wieder ausgebaut , Rechner gestartet , Rechner wieder runtergefahren , Karte wieder eingaut haben , und dann lief sie bei Einigen .
« Letzte Änderung: 23.05.2020, 11:43:22 von soyo »

Re: Bekomme TechniSat Skystar S2 nicht zum Laufen!
« Antwort #10 am: 23.05.2020, 12:35:54 »
Hatte DVB-tools schon drauf und ein Hinzufügen von DVB-Apps hat leider nichts gebracht.

Meine w_scan Version ist 20170107-2 jedoch erschließt sich mir nicht wie w_scan der Schuldige sein könnte solange kein Treiber für die Karte gefunden wird?

Ist es möglich dass der Fehler darin liegt indem ich die Firmware erst nach dem Einbau der Karte in den /lib/firmware/ Ordner kopiert habe?
...

Hi,
sofern die w_scan aus den Quellen der Version ist sollte es nicht an der w_scan liegen. Ist w_scan aber vom Entwickler so sollte die aus den Quellen auf jeden Fall entfernt werden bevor die vom Entwickler genommen wird.
Je nach Versionsstand der w_scan kann ein höherer Kernel als 4 möglicherweise Probleme machen, zumal die Karte TechniSat Skystar S2 überhaupt erst ab 4.2 erkannt wird.

... und parallel eine 2te Kernelline nur für die Karte kann  a) nicht verkehrt sein und  b) beim booten ja bequem ausgewählt werden ...
Es sollte aber die komplette Installation unter einem Kernel gemacht werden unter der die Karte benutzt werden soll.

Ganz wichtig ist dies :
1. Die Firmware laden
2. Dann wird die Karte eingebaut
3. Nun das Paket w-scan installieren
und weiter wie es hier beschrieben ist:

https://www.linuxmintusers.de/index.php?action=wiki;page=Satellittenkarte_(PCI)_unter_LM_installieren

Besonderheit bei mir war der Multiswitch. Da muss Du vielleicht was anderes machen ... Siehe Quellliste obriger Seite (Aktuell)
« Letzte Änderung: 23.05.2020, 12:41:49 von Nuffi »

Re: Bekomme TechniSat Skystar S2 nicht zum Laufen!
« Antwort #11 am: 23.05.2020, 14:09:55 »
Hallo Nuffi
Nur so :
Der Link:
 http://wirbel.htpc-forum.de/w_scan/index2.html

von hier :
https://www.linuxmintusers.de/index.php?action=wiki;page=Satellittenkarte_(PCI)_unter_LM_installieren

3.1 w_scan
Geht nicht mehr . Seite wird zum Verkauf angeboten .
MfG soyo

Re: Bekomme TechniSat Skystar S2 nicht zum Laufen!
« Antwort #12 am: 23.05.2020, 14:59:21 »
Ist seit 11.50 editiert ...  ;)

Nur da geht es nicht mehr, da zu lange her ... ;)

https://www.linuxmintusers.de/index.php?topic=50701.msg701467#msg701467

Alles Klar ? 8)

Re: Bekomme TechniSat Skystar S2 nicht zum Laufen!
« Antwort #13 am: 23.05.2020, 16:55:12 »
Sorry für die verspätete Antwort!

dmesg | grep -i dvb gibt Nichts aus.

lsmod zeigt rfcomm                 81920  16
nls_utf8               16384  1
udf                    94208  1
crc_itu_t              16384  1 udf
pci_stub               16384  1
vboxpci                24576  0
vboxnetadp             28672  0
vboxnetflt             28672  0
vboxdrv               471040  4 vboxpci,vboxnetadp,vboxnetflt
cmac                   16384  1
bnep                   24576  2
intel_rapl_msr         20480  0
intel_rapl_common      24576  1 intel_rapl_msr
x86_pkg_temp_thermal    20480  0
intel_powerclamp       20480  0
coretemp               20480  0
kvm_intel             245760  0
kvm                   655360  1 kvm_intel
irqbypass              16384  1 kvm
cx24120                36864  0
mt312                  20480  0
stv0297                20480  0
bcm3510                20480  0
lgdt330x               24576  0
nxt200x                28672  0
mt352                  16384  0
snd_hda_codec_hdmi     57344  1
crct10dif_pclmul       16384  1
crc32_pclmul           16384  0
ghash_clmulni_intel    16384  0
stv0299                20480  0
nvidia_uvm            933888  0
aesni_intel           372736  2
aes_x86_64             20480  1 aesni_intel
crypto_simd            16384  1 aesni_intel
b2c2_flexcop_pci       16384  0
cryptd                 24576  2 crypto_simd,ghash_clmulni_intel
glue_helper            16384  1 aesni_intel
mei_hdcp               24576  0
intel_cstate           20480  0
intel_rapl_perf        20480  0
b2c2_flexcop           32768  1 b2c2_flexcop_pci
nvidia_drm             49152  6
s5h1420                20480  1 b2c2_flexcop
snd_hda_codec_realtek   118784  1
nvidia_modeset       1114112  13 nvidia_drm
eeepc_wmi              16384  0
cx24113                20480  1 b2c2_flexcop
snd_hda_codec_generic    81920  1 snd_hda_codec_realtek
btusb                  57344  0
ledtrig_audio          16384  2 snd_hda_codec_generic,snd_hda_codec_realtek
btrtl                  20480  1 btusb
cx24123                20480  1 b2c2_flexcop
asus_wmi               32768  1 eeepc_wmi
serio_raw              20480  0
btbcm                  16384  1 btusb
wmi_bmof               16384  0
sparse_keymap          16384  1 asus_wmi
btintel                24576  1 btusb
dvb_core              131072  3 b2c2_flexcop,stv0299,lgdt330x
snd_hda_intel          53248  6
nvidia              20418560  648 nvidia_uvm,nvidia_modeset
nls_iso8859_1          16384  1
mc                     53248  1 dvb_core
mxm_wmi                16384  0
snd_intel_dspcfg       24576  1 snd_hda_intel
bluetooth             573440  43 btrtl,btintel,btbcm,bnep,btusb,rfcomm
snd_hda_codec         131072  4 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek
snd_hda_core           90112  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek
ecdh_generic           16384  2 bluetooth
snd_hwdep              20480  1 snd_hda_codec
input_leds             16384  0
ecc                    32768  1 ecdh_generic
snd_pcm               102400  5 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_hda_core
joydev                 28672  0
snd_seq_midi           20480  0
snd_seq_midi_event     16384  1 snd_seq_midi
snd_rawmidi            36864  1 snd_seq_midi
drm_kms_helper        180224  1 nvidia_drm
snd_seq                69632  2 snd_seq_midi,snd_seq_midi_event
drm                   491520  9 drm_kms_helper,nvidia_drm
ipmi_devintf           20480  0
snd_seq_device         16384  3 snd_seq,snd_seq_midi,snd_rawmidi
ipmi_msghandler       102400  2 ipmi_devintf,nvidia
snd_timer              36864  2 snd_seq,snd_pcm
fb_sys_fops            16384  1 drm_kms_helper
syscopyarea            16384  1 drm_kms_helper
sysfillrect            16384  1 drm_kms_helper
snd                    86016  22 snd_hda_codec_generic,snd_seq,snd_seq_device,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_pcm,snd_rawmidi
mei_me                 40960  1
sysimgblt              16384  1 drm_kms_helper
soundcore              16384  1 snd
mei                   102400  3 mei_hdcp,mei_me
acpi_pad              184320  0
mac_hid                16384  0
ip6t_REJECT            16384  1
nf_reject_ipv6         20480  1 ip6t_REJECT
nf_log_ipv6            16384  5
xt_hl                  16384  22
ip6t_rt                20480  3
ipt_REJECT             16384  1
nf_reject_ipv4         16384  1 ipt_REJECT
nf_log_ipv4            16384  5
nf_log_common          16384  2 nf_log_ipv4,nf_log_ipv6
xt_LOG                 20480  10
xt_multiport           20480  8
xt_limit               16384  13
xt_tcpudp              20480  35
xt_addrtype            16384  4
xt_conntrack           16384  16
ip6table_filter        16384  1
ip6_tables             32768  53 ip6table_filter
nf_conntrack_netbios_ns    16384  0
nf_conntrack_broadcast    16384  1 nf_conntrack_netbios_ns
sch_fq_codel           20480  3
nf_nat_ftp             20480  0
nf_nat                 40960  1 nf_nat_ftp
nf_conntrack_ftp       24576  1 nf_nat_ftp
nf_conntrack          139264  6 xt_conntrack,nf_nat,nf_nat_ftp,nf_conntrack_netbios_ns,nf_conntrack_broadcast,nf_conntrack_ftp
nf_defrag_ipv6         24576  1 nf_conntrack
nf_defrag_ipv4         16384  1 nf_conntrack
parport_pc             40960  0
ppdev                  24576  0
iptable_filter         16384  1
bpfilter               24576  0
lp                     20480  0
parport                53248  3 parport_pc,lp,ppdev
ip_tables              32768  9 iptable_filter
x_tables               40960  14 ip6table_filter,xt_conntrack,iptable_filter,xt_LOG,xt_multiport,xt_tcpudp,xt_addrtype,ip6t_rt,ip6_tables,ipt_REJECT,ip_tables,xt_limit,xt_hl,ip6t_REJECT
autofs4                45056  2
btrfs                1236992  0
xor                    24576  1 btrfs
zstd_compress         163840  1 btrfs
raid6_pq              114688  1 btrfs
libcrc32c              16384  3 nf_conntrack,nf_nat,btrfs
dm_mirror              24576  0
dm_region_hash         20480  1 dm_mirror
dm_log                 20480  2 dm_region_hash,dm_mirror
hid_generic            16384  0
usbhid                 53248  0
hid                   126976  2 usbhid,hid_generic
uas                    28672  0
usb_storage            77824  1 uas
ahci                   40960  11
psmouse               151552  0
e1000e                253952  0
r8169                  81920  0
realtek                20480  1
libahci                32768  1 ahci
wmi                    32768  3 asus_wmi,wmi_bmof,mxm_wmi
video                  49152  1 asus_wmi

w_scan -fs -sS19E2 -L Astrta.xspf
w_scan version 20170107 (compiled for DVB API 5.10)
using settings for 19.2 east Astra 1KR/1L/1N/1M
scan type SATELLITE, channellist 68
output format vlc xspf playlist
output charset 'ISO-8859-1'
Info: using DVB adapter auto detection.
main:4007: FATAL: ***** NO USEABLE SATELLITE CARD FOUND. *****
Please check wether dvb driver is loaded and
verify that no dvb application (i.e. vdr) is running.

w_scan habe ich über Synaptik installiert. Inzwischen nochmal neu(incl config) nachdem wir die Karte testweise auf einen anderen PCI-Slot gesteckt haben.

Nun das ich die FW nach dem Einbau hinzugefügt habe kann ich leider nicht mehr ändern.

Re: Bekomme TechniSat Skystar S2 nicht zum Laufen!
« Antwort #14 am: 23.05.2020, 17:28:11 »
Hi
Da zu sein scheint ja alles
Beispiel :
Zitat
dvb_core              131072  3 b2c2_flexcop,stv0299,lgdt330x
Und es läuft kein Programm das ev schon auf die Karte zugreift ?
Bei Programmen wie TVHeadend oder VDR usw.. ist das ja nicht gleich ersichtlich (weil im Hintergrund)
Leider weiß ich nicht mehr  ob das für ihr Neztwerkmöglichkeit auch gilt .
Die Karte wird ja unter Windows und Linux als Netzwerkkarte (und nicht als reine TV Karte) erkannt , da sie ja auch SKY-DSL wunderbar beherscht .
MfG soyo