Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
31.03.2020, 12:59:08

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 23692
  • Letzte: pr131fas
Statistiken
  • Beiträge insgesamt: 650259
  • Themen insgesamt: 52636
  • Heute online: 695
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  LM 19.3 Xfce 64bit - Autologin, aber Passwort zum Screen-Entsperren?  (Gelesen 360 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Sorry, der Betreff ist nicht ganz gelungen, mir fiel leider keine bessere Formulierung ein.

Ich überlege derzeit einen Umstieg auf Mint Xfce aus folgendem Grund:

Ich habe auf einem Laptop eine Partition mit Xubuntu 18.04.4-64bit, die wie folgt funktionieren soll:
Nach dem Autologin soll der Bildschirm schwarz und gesperrt werden, sowie nur mit Passwort zu entsperren sein.

Ich bräuchte diese Funktion übrigens, um VNC- oder SMB-Zugriffe zu ermöglichen.

Für den Autologin habe ich eine bisher nicht vorhandene Datei /etc/lightdm/lightdm.conf erstellt, die mich als Autologin-User enthält.

Der Autologin klappt, ebenso das Bildschirm sperren, indem ich folgendes Script dem Autostart zugefügt habe.

sleep 4; xflock4
Aber leider verhalten sich Autologin und Bildschirm entsperren unerwünschterweise gleichermaßen, denn in beiden Fällen ist ein Passwort nicht nötig.

Das Passwort soll aber sehr wohl beim Bildschirm entsperren abgefragt werden.

Nun suche ich dafür eine Lösung, entweder für Xubuntu, oder, wenn das dort nicht geht, evtl. für Mint Xfce, auf das ich ggf. umsteigen würde.

Weiß bitte jemand, wie ich das gewünschte Verhalten auf Xubuntu oder auf Mint Xfce erreichen kann?

Du willst also nach der Bildschirmsperre ein Passwort eingeben müssen. Der Rechner soll aber ohne Passwort starten?

Ja, richtig.
Wobei der Rechner nach dem Start sofort in die Sperre gehen soll (gewissermaßen als Ersatz für das deaktivierte Login-Passwort).
Von MATE kenne ich das bereits so.
Deshalb suche ich was Entsprechendes für Xubuntu oder für Mint Xfce, je nachdem, wo es machbar ist.

Hintergrund war damals bei Mint z.B., dass Vino erst nach dem Login läuft und ich trotzdem noch eine Sperre brauchte, um die Sicherheit zu gewährleisten.
« Letzte Änderung: 22.03.2020, 18:26:09 von Centauri39 »

Unter Benutzer und Gruppen kannst unter Passwort, Ändern das Häkchen bei "Nicht bei Anmeldung nach einem Kennwort fragen" auswählen.
Unter Bildschirmschoner kannst du die Zeit einstellen wann der Bildschirm gesperrt werden soll.

Ein solcher Versuch war leider bereits erfolglos.
Diese Einstellung hat das Passwort leider für beide Fälle deaktiviert.

EDIT:
Den Bildschirmschoner muss ich auch per Autostart-Script starten, da der sofort nach dem Start kommen muss.
Ein Timeout in den Einstellungen reicht da nicht.
« Letzte Änderung: 22.03.2020, 18:32:17 von Centauri39 »

Schon mal mit den Einstellungen im LightDM -Anmeldefenster gespielt?
https://wiki.ubuntuusers.de/LightDM/
« Letzte Änderung: 22.03.2020, 18:39:22 von peter_deister »

Das GUI dieser Einstellungen enthält nichts das Passwort betreffendes.

Ich kann nur eine lightdm.conf erstellen, da die bisher nicht existierte und mich dort als autologin-user eintragen.

Das hat aber leider auch wieder nur Einfluss auf beide Fälle, Login UND Entsperren.
« Letzte Änderung: 22.03.2020, 18:54:20 von Centauri39 »

Ähm, nur so ein Gedanke, kann es sein, dass dir seahorse "dazwischen funkt"?
Mal schauen ob Gnome Dienste mit gestartet werden, worunter das fällt.
Aber wie geschrieben, nur so mir spontan eingefallen.

Das scheint nicht so zu sein.
Ich finde nichts, was sich auf seahorse bezieht.

EDIT:
Ha, ich hab's!!!
Bin ich gut oder bin ich gut?  :P ;D

Ich war bisher immer in der falschen Datei.
Die Lösung steckt nicht in /etc/lightdm/lightdm.conf.
Die hat nämlich in der ursprünglichen Installation eh nicht existiert und kann insofern auch wieder weg (alle anderen in dem Ordner bleiben natürlich!).

Meine Lösung sieht stattdessen folgendermaßen aus (für Xubuntu):

Das Autostart-Script bleibt wie gehabt, aber der Autologin-User muss nicht in die genannte lightdm.conf, sondern hier rein:
/usr/share/lightdm/lightdm.conf.d/60-xubuntu.conf

Also einfach nur einfügen:
autologin-user=DeinUsername

Dann sieht es so aus:
[Seat:*]
user-session=xubuntu
autologin-user=DeinUsername

Der sleep-Wert im Autostart-Script muss ggf. angepasst werden,
damit je nach vorhandenem System eine sinnvolle Reihenfolge der Schritte entsteht.

Anm.:
Vielleicht kann gelegentlich ein Mint Xfce-User verifizieren, ob diese Lösung tatsächlich auch dort passt...?
« Letzte Änderung: 22.03.2020, 21:17:06 von Centauri39 »

Zu früh gefreut!  >:(

Am 64bit-Notebook läuft es zwar, aber nun bin ich gerade an einem 32bit-Netbook mit Xubuntu 18.04.4, wo ich das Gleiche einrichten will.

Dort ging es erst wie am Notebook, aber plötzlich nicht mehr.

Das Login läuft noch planmäßig, aber beim Entsperren kommt keine Passwort-Abfrage mehr.

Wenn ich das Script manuell starte, ist es ebenfalls ok.
Auch wenn ich
xflock4
im Terminal eingebe, klappt es.

Aber, wenn ich den Timeout bis in die Sperrung abwarte und anschließend das Touchpad betätige, wird ohne Passwort entsperrt.

Ich habe den autologin-user auch aus der 60-xubuntu.conf
rausgeholt und abwechselnd mehrere der anderen Dateien im gleichen Ordner probiert, zumindest die, die sich auf den Greeter beziehen.

Keine Chance, das Passwort wird beim Entsperren nicht abgefragt.
Es findet also offenbar keine Unterscheidung zwischen dem Autologin ohne Passwort
und dem gewünschten Passwort beim Entsperren nach dem schwarzen Bildschirm statt.
« Letzte Änderung: 23.03.2020, 03:17:12 von Centauri39 »

Hi :)
schau einfach auf meine seite, da ist das schon seit jahren beschrieben. :)

Du meinst den Abschnitt "Sperrbildschirm nach System Start aktivieren"?
Da sind alle DE's beschrieben, nur nicht Xfce.

Das Problem ist auch nicht, den Bildschirm zu sperren, sondern dass, wenn der Auto-Login funktioniert,
später beim Bildschirm entsperren nach einem schwarzen Schirm ebenfalls keine Passwort-Abfrage kommt.

Ich kriege da keine Unterscheidung zwischen diesen beiden Fällen hin.
« Letzte Änderung: 27.03.2020, 13:59:31 von Centauri39 »

Hi :)
sollte sich rausfinden lassen wie der schoner unter xfce heisst...
kannst es ja jederzeit vorher im terminal testen.

Im Terminal gehen sowohl

xflock4
als auch

light-locker-command -l
Ich starte immer per Autostart-Script den xflock4.

Ich denke nicht, dass es der Schoner an sich ist, denn der geht ja.

Da scheint was faul zu sein mit dem autologin-user.
« Letzte Änderung: 27.03.2020, 15:06:21 von Centauri39 »

Hi :)
ich kann mir nicht vorstellen, das der xfce schoner eine gänzlich andere parameter syntax verwendet...
den gnome befehl mal getestet?