Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
25.05.2020, 17:18:44

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 662318
  • Themen insgesamt: 53566
  • Heute online: 470
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  Grafikkartentreiberproblem unter Linux-Mint 19.1  (Gelesen 1471 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #30 am: 01.03.2020, 11:16:42 »
Hallo thanos,

hast Du die Grafikkarte mal herausgenommen und wieder eingesetzt?

Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #31 am: 01.03.2020, 13:50:09 »
Hallo harmless,
das möchte ich nicht, es sind noch 2 Windows-Produktivsysteme auf dem Rechner, die tadelos mit der selben Grafikkarte funtionieren und auf die ich angewiesen bin. Wenn die nach der Aktion nicht mehr richtig funktionieren würden, wäre das nicht so gut. ::)

Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #32 am: 01.03.2020, 14:40:20 »
Hallo Thanos,

ich kann Deine Bedenken verstehen. Dann bleibt nur, es mit einer anderen Linux-Version zu probieren. Zum einen würde ich es mal mit Linux Mint 19.2 hier vom Forum probieren und danach auch mal mit Ubuntu. Dann spätestens wissen wir mehr.

Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #33 am: 01.03.2020, 21:45:28 »
Hallo harmless,
ich habe es jetzt mal mit Ubuntu bionic beaver probiert, hier ist es dasselbe wie unter Linux Mint, die Live-Version friert nach 1 bis 3 Minuten ein.
Und ich habe Linux Manjaro probiert, hier bleibt die Live-Version schon während des Ladens hängen, bei so was wie "starte TLS-System".
Anscheinend will Linux egal welche Distribution nicht bei mir starten :( Scheint ein reiner Windows-Rechner zu sein, verdammt  >:(
Ich glaube die Grafikkarte bräuchte Ihren originären Treiber von AMD/ATI, ich weiss das ist Windowsdenken. aber hey, eben genau funktioniert sie ja auch in Windows.
Ach ja bei Manjaro stand bevor die Installation dann vollständig einfror "starting graphic device" "ok", also doch etwas mit der Grafikkarte.
Noch ein Gedanke, kann ich die live Versionb von Mint nicht mit nomodeset aus grub heraus laden????
Funktioniert das ?????

Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #34 am: 01.03.2020, 22:39:00 »
Hallo Thanos,

es gibt die Möglichkeit mit nomodeset und wird auf der linuxmint-Seite unter den release notes beschrieben mit Videos:

https://linuxmint.com/rel_tina_cinnamon.php

Aber es ist eigentlich natürlich nur als Übergangslösung gedacht. Versuche es mal.

Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #35 am: 01.03.2020, 23:04:47 »
Als ich vom USB-Stick alles noch mal neu installieren wollte, merkte ich, dass sich dieses System vom USB-Stick nach 1-3 Minuten ebenfalls aufhängt,

Hallo, versuch es mal mit einer Live CD, denke das es vielleicht etwas mit dem USB Anschluss zu tun hat, oder USB Stick.

Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #36 am: 01.03.2020, 23:26:20 »
Hallo harmless,
ich habe Mint neu installiert und grub mit nomodeset modifiziert und siehe da, das System startet normal und bleibt nicht hängen (muss nicht mehr den recovery-modus anwählen). Naturlich habe ich keine Hardewarebeschleunigung der Grafikkarte. Jetzt sieht es so aus als würde das Installationsmenü tatsächlich den falschen Treiber für meine Grafikkarte beim automatischen Installationsprozess laden.
Wie bekomme ich jetzt den Grafikkartentreiber für meine Karte installiert?

Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #37 am: 02.03.2020, 01:21:17 »
Hallo harmless,
habe nochmal nomodeset rückgängig gemacht und mit dmesg | egrep 'drm|radeon' im Terminal folgende Ausgabe:

[    1.966856] [drm] VGACON disable radeon kernel modesetting.
[    1.966939] [drm:radeon_init [radeon]] *ERROR* No UMS support in radeon module!
[    2.058213] [drm:amdgpu_init [amdgpu]] *ERROR* VGACON disables amdgpu kernel modesetting.
[   19.916080] [drm] VGACON disable radeon kernel modesetting.
[   19.916102] [drm:radeon_init [radeon]] *ERROR* No UMS support in radeon module!
[   20.210801] [drm:amdgpu_init [amdgpu]] *ERROR* VGACON disables amdgpu kernel modesetting.

Kannst Du damit etwas anfangen ?

Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #38 am: 02.03.2020, 19:54:21 »
Hallo Thanos,

welche Mint Version hast Du neu installiert und welcher Treiber war mit nomodeset "in use"? Ich kann bei den Fehlermeldungen auch nur suchen, da ich nicht so tief mit solchen Dingen vertraut bin. Mir ist aber bei der Suche etwas über den Weg gelaufen, an das ich zwischenzeitlich gedacht hatte. Es gibt das sogenannte oibaf-PPA, welches aktualisierte offene Treiber auch für Radeon Grafiken zur Verfügung stellt. Probiere es mal damit, vielleicht hilft es:

https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers

Zitat
Adding this PPA to your system
You can update your system with unsupported packages from this untrusted PPA by adding ppa:oibaf/graphics-drivers to your system's Software Sources. (Read about installing)

sudo add-apt-repository ppa:oibaf/graphics-drivers
sudo apt-get update

Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #39 am: 02.03.2020, 20:35:22 »
Hallo harmless,

ich habe wieder mint 19.1 installiert. Mit nomodeset war kein Treiber in use. Aber wenn ich nomodeset in grub entferne und das System normal starte. konnte ich im Terminal nach entsprechendem Befehl sehen, dass radeon in use war. Musste mich höllisch beeilen, nicht mal 5 sekunden später fror Linux mint wieder ein.

Eigentlich müsste radeon meine Grafikkarte ja unterstützen (Curacao-pro chipsatz), sie steht bei den unterstützten Grafikkarten dabei.

Was ich noch gelesen habe: Der curacoa-pro chipsatz ist gcn1 (graphic core next oder so ähnlich) und für den wird der amdgpu emphohlen, obwohl ich bei dem in den unterstützten Grafikkarten meine nicht finden konnte.

Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #40 am: 02.03.2020, 21:19:12 »
Hallo Thanos,

Zitat
Was ich noch gelesen habe: Der curacoa-pro chipsatz ist gcn1 (graphic core next oder so ähnlich) und für den wird der amdgpu emphohlen, obwohl ich bei dem in den unterstützten Grafikkarten meine nicht finden konnte.

Wie ich schon mal geschrieben habe, kam die Unterstützung Deiner Karte (Southern Islands wie auch Sea Islands) durch amdgpu erst später. Standardmäßig wird aber radeon von Linux genommen. Deshalb hatten wir ja schon mal die Aktivierung von amdgpu gemacht.

Wenn Du bis zum Login-Screen kommst, dann logge Dich nicht ein und drücke mal Strg+Alt+F1, damit wechselst Du auf eine Eingabeebene. Du mußt Dich mit Deinem Nutzernamen und Paßwort anmelden. Dort fügen wir mal das oibaf-PPA hinzu und starten danach neu:

sudo add-apt-repository ppa:oibaf/graphics-driverssudo apt-get updateDanach Neustart
sudo reboot
Dann logge Dich mal normal ein und schau', was passiert.
« Letzte Änderung: 02.03.2020, 21:25:06 von harmless »

Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #41 am: 02.03.2020, 21:41:45 »
Hallo harmless,

das versuche ich jetzt, mal sehen was passiert. ;D

Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #42 am: 02.03.2020, 22:45:46 »
Hallo harmless,

das funktioniert so nicht. Wenn ich beim login-screen bin und strg+alt+f1 drücke, wechselt es zwar zu einer Eingabeebene, hier kann ich mich aber nicht einloggen.
Der Grund ist: den Benutzernamen kann ich noch eingeben, beim Passwort kann ich keine Buchstaben oder Zahlen eingeben !

Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #43 am: 02.03.2020, 23:12:19 »
Hallo Thanos,

es kann gut sein (ne, es ist so  :D), daß Du keine Eingabe erkennst, aber es wird trotzdem angenommen. Achte drauf, daß Du Dein Paßwort genau eingibst und dann drücke Enter.
« Letzte Änderung: 02.03.2020, 23:18:21 von harmless »

Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #44 am: 03.03.2020, 12:42:51 »
Hallo harmless,

habe die Pakete installiert und es hat alles geklappt. Jedoch ist das Ergebnis weiterhin dasselbe. Wenn ich Linux Mint normal starte friert es nach 1- 3 min später ein.

Ich verstehe das nicht, meine Grafikkarte ist einfach Schrott. >:(