Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
09.08.2020, 07:55:43

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24370
  • Letzte: Petervo
Statistiken
  • Beiträge insgesamt: 676199
  • Themen insgesamt: 54815
  • Heute online: 403
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  Grafikkartentreiberproblem unter Linux-Mint 19.1  (Gelesen 1631 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Grafikkartentreiberproblem unter Linux-Mint 19.1
« am: 25.02.2020, 15:06:51 »
Hallo, ich habe Linux Mint 19.1 Cinnamon neu auf meinem Multiboot-System installiert. Die Installation ist jedoch fehlerhaft, wenn ich sie normal starte, friert sie nach 10 Sekunden permanent ein. Wird Linux jedoch im recovery-mode gestartet und später resumed, läuft sie stabil.
Ich denke Linux Mint hat bei der Installation des falschen oder einen ungeeigneten Grafikkartentreiber installiert. Da es sich um eine ATI Radeon R9 270 handelt, habe ich den Treiber auf der ATI homepage runtergeladen und komme jetzt nicht weiter. Wie installiere ich diesen wirklich alten Treiber auf dem neuen Linux Mint 19.1 und geht das überhaupt?
« Letzte Änderung: 05.03.2020, 20:23:33 von Thanos »

Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #1 am: 25.02.2020, 15:14:01 »
Herzlich willkommen bei uns im Grünen! :)
Zeige bitte erstmal die Ausgabe von
inxi -FzAusgabe bitte als Text (!) im Codeblock zeigen. Dazu im Volleditor (nicht Schnellantwort benutzen) den Text markieren und auf '#' klicken. Details: siehe Hilfe oben.

Falls du dir da den fglrx geladen haben solltest, den kannst du unter LM 19 nicht mehr verwenden!
« Letzte Änderung: 25.02.2020, 15:17:32 von toffifee »

Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #2 am: 25.02.2020, 15:15:36 »
Hi :)
Zitat
Hallo, ich habe Linux Mint 19.1 Cinnamon neu auf meinem Multiboot-System installiert

warum die alte version?

amd treiber sind im kernel, und es ist meist nicht sinnvoll die externen kernel module von amd zu installieren..
wechsele den kernel in der aktualisierungsverwaltung... und teste erneut.

Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #3 am: 25.02.2020, 15:25:31 »
System:
  Host: matrix-3 Kernel: 4.15.0-88-generic x86_64 bits: 64
  Desktop: Cinnamon 4.0.10 Distro: Linux Mint 19.1 Tessa
Machine:
  Type: Desktop Mobo: ASUSTeK model: M5A97 EVO R2.0 v: Rev 1.xx
  serial: <filter> BIOS: American Megatrends v: 2501 date: 04/09/2014
CPU:
  Topology: 6-Core model: AMD FX-6300 bits: 64 type: MCP L2 cache: 2048 KiB
  Speed: 1657 MHz min/max: 1400/3500 MHz Core speeds (MHz): 1: 1624 2: 2111
  3: 1631 4: 2655 5: 2892 6: 2962
Graphics:
  Device-1: AMD Curacao PRO [Radeon R7 370 / R9 270/370 OEM] driver: N/A
  Display: x11 server: X.Org 1.19.6 driver: vesa resolution: 1024x768~61Hz
  OpenGL: renderer: llvmpipe (LLVM 9.0 128 bits) v: 3.3 Mesa 19.2.8
Audio:
  Device-1: AMD SBx00 Azalia driver: snd_hda_intel
  Device-2: AMD Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series]
  driver: snd_hda_intel
  Sound Server: ALSA v: k4.15.0-88-generic
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 43.66 TiB used: 31.56 TiB (72.3%)
  ID-1: /dev/sda vendor: Western Digital model: WD10EZRX-00A8LB0
  size: 931.51 GiB
  ID-2: /dev/sdb vendor: Western Digital model: WD10EURS-630AB1
  size: 931.51 GiB
  Partition:
  ID-1: / size: 407.85 GiB used: 18.02 GiB (4.4%) fs: ext4 dev: /dev/sda2
  ID-2: swap-1 size: 14.99 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3
Sensors:
  System Temperatures: cpu: 26.2 C mobo: N/A
  Fan Speeds (RPM): cpu: 0
Info:
  Processes: 265 Uptime: 4m Memory: 7.69 GiB used: 873.7 MiB (11.1%)
  Shell: bash inxi: 3.0.27

Hat leider etwas länger gedauert - Sorry

Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #4 am: 25.02.2020, 17:15:24 »
An ehtron:

Ich habe mittlerweile auf Linux Mint 19.3 aktualisiert und der Kernel ist bei 5.3.0.40. Alles auf aktuellstem Stand, jedoch ist der Fehler immer noch der Gleiche. Ein Normalstart vom Linux Mint 19.3 lääst das Bild nach ungefähr 1 Minute nun einfrieren. Im recovery mode gestartet läuft es stabil. Leider gibt es hier dann keine HDMI-Ausgabe. Vielleicht weiss ja noch jemand woran es liegen könnte ?

Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #5 am: 25.02.2020, 18:18:23 »
Hallo Thanos,

Deine AMD Curacao PRO Grafikkarte gehört von der Architektur zu den sogenannten "Southern Islands (SI)" und wird auch vom Kernel Treiber/Modul amdgpu unterstützt. Der Kernel verwendet aber oft das Modul radeon bei diesen Karten, weil wahrscheinlich die amdgpu-Unterstützung nicht von vornherein gegeben war. Es gibt aber eine relativ einfache Möglichkeit, amdgpu statt radeon zu verwenden. Bei Dir in der inxi-Ausgabe wird bisher aber leider kein Treiber angegeben. Kannst Du bitte die Ausgabe des nachfolgenden Befehls anzeigen, in dem u.a. der aktuell genutzte Treiber (sofern einer genutzt wird) und die zur Verfügung stehenden Module für Deine Karte angezeigt werden:

lspci -nnk | egrep -i "VGA|3D|Display" -A2

Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #6 am: 25.02.2020, 20:36:50 »
Hallo harmless, hier die Anzeige aus dem Terminal:
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Curacao PRO [Radeon R7 370 / R9 270/370 OEM] [1002:6811]
Subsystem: ASUSTeK Computer Inc. Curacao PRO [Radeon R7 370 / R9 270/370 OEM] [1043:048d]
Kernel modules: radeon, amdgpu

Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #7 am: 25.02.2020, 20:49:41 »
Hallo Thanos,

kennst Du Dich ein bißchen mit Linux und dem Terminal aus? Ich frage deshalb, weil es ein kurzes gutes Video zur Verwendung von amdgpu gibt, wo zusätzlich auch textlich unter dem Video die Schritte stehen. Du kannst ja auch einfach mal schauen:

https://www.youtube.com/watch?v=Mr_UFL5ZeKQ

Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #8 am: 25.02.2020, 20:59:03 »
Hi! Ich bin nicht der Experte hier, möchte aber von meinem Radeon R7 240 Problem aus meinem Vor-vor-Rechner erzählen.

Manchmal fror mein Rechner auch ein. War aber verschmerzbar. Dann nach vielen vielen Bootvorgängen bei Neustarts kam ständig die Meldung (BusyBox initramfs, oder so ähnlich?) Ich wusste bereits, wie man Kernel wechselt und genau das war der Schlüssel zum Erfolg!

Ich legte mir eine Sicherung an und experimentierte solange mit den Kernels, bis kein initramfs Fehler da war und das System prima startete. Seither war auch der Fehler behoben, daß das System einfror!

Vielleicht hilft es?

Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #9 am: 25.02.2020, 21:03:17 »
Hallo harmless,

ich werde mir das Youtube-Video gleich mal anschauen. Da ich unter Linux wegen dem Treiberproblem gerade keinen Ton habe, muss ich auf Windows wechseln, habe ja ein Multiboot-System.

Danke erstmal für den Link, melde mich wieder sollte ich nur Bahnhof verstehen.

Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #10 am: 25.02.2020, 21:07:23 »
Hallo Linuxminz,
einen initramfs Fehler habe ich nicht.

Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #11 am: 25.02.2020, 21:11:10 »
Hallo Thanos,

einen Sound braucht es bei dem Video nicht unbedingt, aber die Musik ist irgendwie doch auch "beschwinglich"  ;D

Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #12 am: 25.02.2020, 22:29:10 »
Hallo harmless,

bist Du noch da ? Ich bin zu blöd der Anleitung zu folgen und scheitere bei der Bedienung des Terminals. Kannst Du mich da durch lotsen? Windows-User halt, ohne GUI geht gar nichts.

Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #13 am: 25.02.2020, 22:53:01 »
Hallo Thanos,

kann ich machen. Ein bißchen Terminal muß aber trotzdem sein. Also terminal öffnen und ausführen:

xed admin:///etc/default/grub
Warnungen ignorieren, das Paßwort wahrscheinlich zwei mal eingeben. Dann gehe zur folgenden Zeile:

Zitat
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

ändern in

Zitat
GRUB_CMDLINE_LINUX_DEFAULT="radeon.cik_support=0 amdgpu.cik_support=1 radeon.si_support=0 amdgpu.si_support=1 quiet splash"

Jetzt Datei speichern und Texteditor schließen.

Danach im Terminal:

sudo -H xed /etc/modprobe.d/amdgpu.conf
Das öffnet die leere Datei amdgpu.conf. In diese folgendes einfügen:

Zitat
options amdgpu si_support=1
options amdgpu cik_support=1

Speichern und schließen. Danach im Terminal:

sudo -H xed /etc/modprobe.d/radeon.conf
Einfügen:

Zitat
options radeon si_support=0
options radeon cik_support=0

Danach im Terminal folgenden Befehl ausführen:

sudo update-grub
Danach alles schließen und neustarten. Sollte es Probleme beim Booten geben, dann im grub-Menü die Taste e drücken und zur Zeile mit

Zitat
"radeon.cik_support=0 amdgpu.cik_support=1 radeon.si_support=0 amdgpu.si_support=1 quiet splash"

gehen und alles bis auf quiet splash aus den Hochkommas löschen. Danach Strg+X drücken.

Siehst Du das grub-Menü beim Booten?
 

Re: Grafikkartentreiberproblem unter Linux-Mint 19.1
« Antwort #14 am: 25.02.2020, 23:23:14 »
Hallo harmless,

bin durch hartnäckiges Probieren einen Schritt weiter gekommen, jedoch gibt es einige Abweichungen von der Anleitung:
1. Nach der Abfrage mit lspci -v fehlt bei mir der Eintrag "Kernel driver in use" vollständig.
2. Nachdem ich die Modifikation "radeon.cik_support=0 amdgpu.cik_support=1 radeon.si_support=0 amdgpu.si_support=1" durchgeführt und gespeichert habe und danach mit "sudo nano /etc/modprobe.d/amdgpu.conf" oder "sudo nano /etc/modprobe.d/radeon.conf" das Geänderte überprüfen will, bleiben die Inhalte leer, es erscheint gar nichts.

Also irgend etwas scheint hier nicht zu stimmen, brauche also dringend nochmal Hilfe.