Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
04.04.2020, 13:38:44

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 651152
  • Themen insgesamt: 52716
  • Heute online: 665
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Gelöst Installation erkennt vorhandenes Windows 10 nicht. / Bootmgr is missing  (Gelesen 695 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Also man kann schon erkennen, nachdem man Windows per Super Grub Disk startete, ob das gestartete System auf der SSD liegt oder auf der Platte. Entweder im Explorer nachschauen, in der Datenträgerverwaltung oder per "Systeminformationen" in das Suchfeld eingeben.

Ich würde so heran gehen:
Zuerst heraus finden von wo Windows gestartet ist.
Liegt das per Super Grub gestartete OS auf der SSD dann...

Klemme die große Platte ab.
Dann den Windows Bootmanager per Installationsträger auf der sda reparieren.
Anschließend testen ob Windows dann richtig startet.
Und dann per Super grub Disk Linux starten, ein Terminal öffnen und
sudo grub-install /dev/sdaeingeben. Danach sollte hoffentlich alles i.O. sein. Und Windows sowie Linux per grub zu starten sein. Beides auf der sda, sprich der ssd liegend.
Anschließend die zweite Platte wieder anschließen. Und jene sich zurecht machen (14 Parttitionen mit ntfs auf der Platte... holla die Waldfee!  :o)


Startet Windows von der Platte, dann Windows neu auf die SSD installieren, mit abgeklemmter Platte. Anschließend Linux mit der Super Grub starten und Grub  reparieren.
Danach kann die Platte wieder angeschlossen werden und weiter verwurstet werden, sprich eingerichtet oder zurecht gemacht.

Hallo,

danke für eure Antworten, klasse Forum!  :)
Ich werde erst am Wochenende wie von BR01 vorgeschlagen tätig werden, da ich diese Woche mit Erwerbstätigkeit voll ausgelastet bin.
Es soll also nicht unfreundlich meinerseits sein, wenn die nächsten Tage keine Rückmeldung von mir kommt.

Der aktuelle Status ist ja völlig okay: Linux startet normal und funktioniert bestens, und Windows starte ich derzeit halt über das DVD Laufwerk- was kein Beinbruch ist.

Das Windows auf der SSD liegt ist übrigens sicher- daher wundert es mich ja, dass die zweite Festplatte für den Windows-Start überhaupt ins Spiel zu kommen scheint.
Daher ist BR01 Vorschlag eigentlich Super: Die zweite Festplatte raus nehmen, und nach erfolgten Korrekturmaßnahmen wieder zurückstecken.

Schade, dass es nicht so einfach geht, wie ich gehofft habe, nämlich in den Bootmanager auf der Festplatte einfach den selben Befehl einzutragen, welchen der Bootmanager auf der DVD ausführt. Denn dann startet ja Windows auch: und ich hätte weniger Arbeit.

Bis zum Wochende euch eine gute Zeit!

VG Benjamin

Hallo Benjamin, bevor du am Wochenende los legst, klemme doch zuerst die Platte ab und starte danach Linux und führe im Terminal durch
sudo update-grubVielleicht wird so die Windowsinstallation auf der SSD doch gefunden und richtig eingetragen in grub. Und du kannst es danach gleich aus grub starten.

Wenn nicht, dann maches so wie in #15 beschrieben weiter.
Hier noch eine relativ gute Erklärung zwecks Bootreparatur von Windows. https://www.heise.de/tipps-tricks/Windows-10-Bootmanager-reparieren-so-geht-s-4268553.html
Du musst da ab "Reparatur des Bootmanagers: MBR" beginnen. GPT hast du nicht.
Wenn du in beschriebene Rettungsumgebung nicht kommst, dann starte Windows per Super grub und am Anmeldefenster drückst du die Shift Taste und klickst bei gedrückter Shift Taste auf das Ausschaltsymbol/neustarten unten rechts. Kurzer Moment Geduld, anschließend bist du in der Rettungsumgebung. Dann wie im Link beschrieben verfahren (man kommt auch aus den Windows Einstellungen dahin - ist aber länger der Weg)

Viel Erfolg dir.

Hi,

gesagt, getan  ;D.
Jetzt startet LinuxMint direkt durch, ich bekomme Grub also gar nicht mehr zu Gesicht.

Ansonsten ist der Zustand wie bisher: Windows über DVD starten, LinuxMint direkt.

Kleine Anmerkung: Seit sudo update-grub kommt beim herunterfahren nach Abmeldung der grafischen Oberflläche jeweils kurz 4x eine Error-Meldung.

Lange Rede, kurzer Sinn:
- externe Platte abklemmen
- zuerst Windows Bootloader wieder herstellen (anschließend erst testen ob Windows alleine hochfährt)
- danach Linux mit Super Grub starten und dessen grub wiederherstellen
- sich hoffentlich freuen.

Ist alles in Antw. 15 beschrieben.

Hallo @BR01, Hallo @tommix,

es hat geklappt.
Allerdings über Umwege  ???

Herzlichen Dank ohne euch hätte ich es nicht geschafft.

Die Umwege:

- externe Platte abklemmen [check: erfolgreich]
- zuerst Windows Bootloader wieder herstellen [check: erfolgreich]
- anschließend erst testen ob Windows alleine hochfährt [check: erfolgreich, jedoch mit den Befehlen bdcboot C:\Windows dann Chkdsk /f /r C:]
- sudo update-grub [check: erfolgreich]
-oh je... wieder ist direkt LinuxMint gestartet  :o
- Umweg: https://www.linuxmintusers.de/index.php?topic=2457.0  Grub Customizer installiert
- Keine Ahnung warum, hier wurden mir 1x das "richtige" und 1x das "falsche" Windows gezeigt.
- Den falschen Eintrag entfernt, Ubuntu umbenannt in Linux Mint, Windows nach oben gerückt, alle anderen Einträge in Unterordner verschoben, Startzeit auf 60sek hochgesetzt

Jetzt kommt im Linux-Mint-Design der Bootloader nach Starten des Computers. Ich sehe 1x Linux Mint 1x Windows und den Unterordner und kann stressfrei entweder das eine oder das andere System starten.

  :D :D :D

P.S.: Gibt es bei euch die Möglichkeit einen Diskussionsverlauf als gelöst zu markieren?



P.S.: Gibt es bei euch die Möglichkeit einen Diskussionsverlauf als gelöst zu markieren?

Ja,  bitte im erste Beitrag!

Moin
Umweg: https://www.linuxmintusers.de/index.php?topic=2457.0  Grub Customizer installiert
der Grub Customizer und dessen Anwendung ist zwar hier im Forum umstritten, aber wenn er bei dir zur Lösung verholfen hat ists ja gut gegangen.

Gibt es bei euch die Möglichkeit einen Diskussionsverlauf als gelöst zu markieren?
dazu wie von @tommix bereits geschrieben deinen ersten Beitrag "Ändern" und das Präfix auf "Gelöst" setzen, Schreiben. Siehe dazu die Hilfe Oben im Site-Menü