Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
30.09.2020, 20:57:42

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24584
  • Letzte: klaatu2
Statistiken
  • Beiträge insgesamt: 685664
  • Themen insgesamt: 55502
  • Heute online: 751
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Linux Mint und WoW mit PlayonLinux und Wine  (Gelesen 834 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Linux Mint und WoW mit PlayonLinux und Wine
« am: 15.02.2020, 17:38:40 »
Ich bin vor kurzem halb auf Linux Mint umgestiegen und habe den Dreh, fürchte ich, noch nicht ganz raus... nachdem ich mich durch zig Threads und Anleitungen gewühlt habe und jetzt eine grobe eine Idee habe, wie Wine arbeitet und wie ich es wozu konfigurieren muss, habe ich es soweit hinbekommen, World of Warcraft zu installieren. Juhu! Wenn ich nun allerdings im Launcher auf "Spielen" klicke, passiert nicht mehr wirklich etwas. Der Status im Launcher ändert sich zwar zu "Spiel wird ausgeführt" und für einen kurzen Moment sieht es jeweils so aus, als ginge auch WoW als neues Fenster auf, aber es schaltet dann quasi nicht dorthin um. Es scheint, als würde es ausgeführt, aber ich sehe es nicht. Hat jemand eine Idee, was ich dagegen tun kann? Windows-Taste läßt mich zwar am Anfang noch das Menü aufrufen, aber irgendwann hängt er sich dann so auf, dass nur noch Strg+Alt+Backspace helfen. Ich habe keinen zweiten Monitor oder ähnliches...

Freue mich natürlich über jeden Hinweis, der helfen könnte... :)
« Letzte Änderung: 15.02.2020, 22:09:07 von MissHapgood »

Re: Linux Mint und WoW mit PlayonLinux und Wine
« Antwort #1 am: 15.02.2020, 17:40:08 »
Bitte beachte beim Erstellen eines Themas den roten Hinweis, deine Mint-Version und den Desktop anzugeben, das erspart unnötige Nachfragen. Zu ermitteln u.a. im Programm "Willkommensbildschirm" oder im Terminal mit inxi -S.

Wichtig wären auch die Versionen von wine und WoW. Klingt logisch, ist aber so. ;)

Re: Linux Mint und WoW mit PlayonLinux und Wine
« Antwort #2 am: 15.02.2020, 17:50:22 »
Ups, entschuldigung, klingt in der Tat logisch! ...

Also, Desktop ist Cinnamon 4.4.8,  Distro: Linux Mint 19.3 Tricia.

Von Wine ist Version 4.0.5 drauf und von WoW hatte ich die Classic Version über den Blizzard Launcher gestern direkt installiert.

Re: Linux Mint und WoW mit PlayonLinux und Wine
« Antwort #3 am: 15.02.2020, 18:19:46 »
Off-Topic:
Ich bin vor kurzem halb auf Linux Mint umgestiegen und habe den Dreh, fürchte ich, noch nicht ganz raus...
Wenn Du als erstes Wine installierst um PC-Spiele zu daddeln, wird das auch nicht mehr als halb werden.

Re: Linux Mint und WoW mit PlayonLinux und Wine
« Antwort #4 am: 15.02.2020, 18:25:03 »
Herzlichen Dank für diesen hilfreichen Hinweis...

Re: Linux Mint und WoW mit PlayonLinux und Wine
« Antwort #5 am: 15.02.2020, 22:08:04 »
So, Problem scheint vorerst gelöst, nachdem ich in diesem Thread (https://www.linuxmintusers.de/index.php?topic=44459.0) noch einmal haarklein Pengu's Post gefolgt bin, aber das Repository angepasst hatte (von xenial main auf bionic main, entsprechend der Linux Version. Hatte wohl beim ersten Versuch übersehen, dass es da mittlerweile eine neuere Version gibt.

Im übrigen möchte ich noch @aexe ergänzen, dass solche Antworten genau der Grund dafür sein können, dass es dann bei "halb" bleibt, weil sowas einfach abschreckt. Die Antwort hat nichts mit meiner Frage zu tun und es kann auch allen völlig egal sein, ob ich gar nicht, halb oder ganz umsteige, das ist doch völlig belanglos. Oder wird Libre Office Nutzern auch nur Hilfe bewährt, wenn sie vorher beschwören, nie wieder MS Office zu nutzen? Sorry, aber sowas unnötiges ärgert mich einfach und schreckt Neulinge, die dann und wann vllt. mal ne Frage haben, definitiv ab.

Re: Linux Mint und WoW mit PlayonLinux und Wine
« Antwort #6 am: 01.06.2020, 12:45:32 »
Ich mache mal keinen neuen Thread auf und hänge mich mit exakt demselben Problem hier dran... Allerdings habe ich es trotz Pengus Anleitung nicht geschafft WOW zum laufen zu bekommen...

inxi -Fz
System:
  Host: TowerLinux Kernel: 5.3.0-53-generic x86_64 bits: 64
  Desktop: Cinnamon 4.4.8 Distro: Linux Mint 19.3 Tricia
Machine:
  Type: Desktop Mobo: ASUSTeK model: PRIME X370-A v: Rev X.0x
  serial: <filter> UEFI: American Megatrends v: 3803 date: 01/22/2018
CPU:
  Topology: 8-Core model: AMD Ryzen 7 1700X bits: 64 type: MT MCP
  L2 cache: 4096 KiB
  Speed: 2034 MHz min/max: 2200/3400 MHz Core speeds (MHz): 1: 1925 2: 1885
  3: 1882 4: 1883 5: 2018 6: 1882 7: 1882 8: 1911 9: 1882 10: 1891 11: 1883
  12: 1889 13: 2195 14: 2030 15: 1882 16: 1883
Graphics:
  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] driver: nvidia v: 390.132
  Display: x11 server: X.Org 1.19.6 driver: nvidia
  unloaded: fbdev,modesetting,nouveau,vesa resolution: 1360x768~60Hz
  OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 390.132
Audio:
  Device-1: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel
  Device-2: AMD Family 17h HD Audio driver: snd_hda_intel
  Sound Server: ALSA v: k5.3.0-53-generic
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
  IF: enp7s0 state: down mac: <filter>
  Device-2: Intel Wireless 8265 / 8275 driver: iwlwifi
  IF: wlp8s0 state: up mac: <filter>
Drives:
  Local Storage: total: 2.05 TiB used: 1.08 TiB (52.7%)
  ID-1: /dev/sda vendor: Intenso model: INTENSO size: 238.47 GiB
  ID-2: /dev/sdb vendor: Toshiba model: HDWD120 size: 1.82 TiB
Partition:
  ID-1: / size: 218.43 GiB used: 116.55 GiB (53.4%) fs: ext4 dev: /dev/sda2
  ID-2: /home size: 1.79 TiB used: 990.49 GiB (54.0%) fs: ext4 dev: /dev/sdb
  ID-3: swap-1 size: 15.94 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3
Sensors:
  System Temperatures: cpu: 39.5 C mobo: N/A gpu: nvidia temp: 32 C
  Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 27%
Info:
  Processes: 312 Uptime: 7m Memory: 47.06 GiB used: 1.08 GiB (2.3%)
  Shell: bash inxi: 3.0.32

und wenn ich WOW starten will, habe ich denselben Fehler. Ein "Fenster öffnet sich" - man sieht also den Rahmen, der sich öffnet. Dann hat man noch ca. 20 Sekunden um das wieder zu schließen, danach friert das System komplett ein und lässt sich nur noch durch einen Hardware-Reset neu starten.

Das Log dazu:
env WINEPREFIX="/home/chris/.wine" wine C:\\windows\\command\\start.exe /Unix /home/christof/.wine/dosdevices/c:/users/Public/Desktop/World\ of\ Warcraft.lnk

0125:fixme:d3d11:d3d_blend_state_create Color mask 0 not supported for render target 7.
0125:fixme:d3d_shader:shader_sm4_read_instruction_modifier Unhandled modifier 0x800000c2.
# dieser Text wiederholt sich mit jedem Mouseover, den ich hier ausblende #


0125:fixme:winsock:convert_af_w2u unhandled Windows address family 1
0127:fixme:kernelbase:AppPolicyGetThreadInitializationType 0xfffffffffffffffa, 0x3bffdc0
0128:fixme:kernelbase:AppPolicyGetThreadInitializationType 0xfffffffffffffffa, 0x3d0fdc0
0125:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
0125:fixme:winsock:convert_af_w2u unhandled Windows address family 1
0125:fixme:mpr:WNetGetUniversalNameW (L"C:\\Program Files (x86)\\World of Warcraft\\Data\\data", 0x00000001, 0x23a664, 0x23a660): stub
012c:fixme:winhttp:get_system_proxy_autoconfig_url no support on this platform
012c:fixme:winhttp:WinHttpDetectAutoProxyConfigUrl discovery via DHCP not supported
005d:fixme:dxgi:d3d11_swapchain_Present1 Ignored present parameters 0x33c494.
005d:fixme:dxgi:d3d11_swapchain_Present1 Ignored present parameters 0x33c494.
0125:fixme:win:EnumDisplayDevicesW ((null),0,0x23f4c0,0x00000000), stub!
0125:fixme:d3d11:d3d11_device_CheckFeatureSupport Returning fake threading support data.
0125:fixme:win:EnumDisplayDevicesW ((null),0,0x23f290,0x00000000), stub!
0125:fixme:dxgi:DXGID3D10CreateDevice Ignoring flags 0x80.
0125:fixme:d3d11:d3d11_device_CheckFeatureSupport Returning fake Options support data.
005d:fixme:dxgi:d3d11_swapchain_Present1 Ignored present parameters 0x33c494.
005d:fixme:dxgi:d3d11_swapchain_Present1 Ignored present parameters 0x33c494.
0125:fixme:d3d11:d3d11_device_CheckFeatureSupport Returning fake threading support data.
0125:fixme:d3d11:d3d11_device_CreateDeferredContext1 iface 0x67774c8, flags 0, context 0x14295b5c8 stub!
0125:fixme:d3d11:d3d11_device_CreateDeferredContext iface 0x67774c8, flags 0, context 0x14295b5c0 stub!
0125:fixme:d3d11:d3d11_device_CreateDeferredContext1 iface 0x67774c8, flags 0, context 0x14295c118 stub!
0125:fixme:d3d11:d3d11_device_CreateDeferredContext iface 0x67774c8, flags 0, context 0x14295c110 stub!
0125:fixme:d3d11:d3d11_immediate_context_Flush iface 0x67774f8 stub!
0125:fixme:dxgi:DXGID3D10CreateDevice Ignoring flags 0x81.
0125:fixme:dxgi:dxgi_swapchain_factory_create_swapchain Unhandled mode scaling 0x2.
0125:fixme:d3d:swapchain_init The application requested more than one back buffer, this is not properly supported.
Please configure the application to use double buffering (1 back buffer) if possible.
0125:fixme:dxgi:dxgi_factory_MakeWindowAssociation iface 0x6777430, window 0x30122, flags 0x6 stub!
0125:fixme:dxgi:d3d11_swapchain_GetDesc Ignoring ScanlineOrdering and Scaling.
0125:fixme:msctf:ThreadMgr_ActivateEx Unimplemented flags 0x4
0125:fixme:msctf:ThreadMgrSource_AdviseSink (0x18c6fb40) Unhandled Sink: {ea1ea136-19df-11d7-a6d2-00065b84435c}



0125:err:seh:setup_exception stack overflow 1600 bytes in thread 0125 eip 000000007bc95e5d esp 0000000000140fd0 stack 0x140000-0x141000-0x240000



Was soll ich / kann ich machen?

MfG
Chris

Re: Linux Mint und WoW mit PlayonLinux und Wine
« Antwort #7 am: 02.06.2020, 21:37:59 »
Jetzt habe ich es soweit, dass das System wenigstens nicht mehr einfriert.
Starte ich jetzt WOW (der Launcher startet ja unproblematisch) und klicke auf "Spielen" passiert aber nichts.

Starte ich aus dem Terminal, kommt folgender Fehler:

*** stack smashing detected ***: <unknown> terminated
014e:err:seh:setup_exception nested exception on signal stack in thread 014e eip 00007f9c39d7ce97 esp 00007fffffeab610 stack 0x132000-0x230000

Weiß wer Rat?

MfG
Chris

Re: Linux Mint und WoW mit PlayonLinux und Wine
« Antwort #8 am: 03.06.2020, 09:14:36 »
WoW ist doch genau wie Diablo von Blizzard, wenn ich nicht irre...

Für Spaß schon mal über Lutris probiert?
hab am Wochenende mal Diablo3 bei meiner Holden darüber installiert bzw hat sie selbst gemacht. Und die ist garantiert kein Crack was Linux angeht.

Ich selber habe über Lutris auch D3 am laufen. Vermutlich wirds bei Lutris da auch was geben für WoW, ich habe danach jedoch noch nicht gesucht.

Re: Linux Mint und WoW mit PlayonLinux und Wine
« Antwort #9 am: 21.06.2020, 09:44:30 »
Servus,
Habs über Lutris installiert zuerst Blizzard app danach über den Shop Laden und installieren klappt bei mir einwandfrei.
Grüße