Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
24.11.2020, 19:02:56

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 696520
  • Themen insgesamt: 56375
  • Heute online: 684
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Installation: Bootprobleme  (Gelesen 1596 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Re: Installation: Bootprobleme
« Antwort #15 am: 29.01.2020, 21:23:11 »
Anscheinend dreht es sich hier um gewisse Systeme, von denen ich rein gar nichts verstehe. UEFI, EOL... mir ist das eigentlich völlig wurscht, und ich habe keine Ahnung, wo was eingestellt werden soll. Wenn es ein anderes Mint 17.3 gibt, das ich runterladen muss, und meins falsch ist... wo finde ich das und woran erkenne ich es?

Ich würde jetzt als nächstes vielleicht Grub neu installieren (das soll ja aus einem laufenden Linux relativ einfach sein, vorausgesetzt, ich erwische die richtige sdx und die richtige Partition...), und lese mich gerade durch böhmische Dörfer...

Wie gesagt: dasselbe Linux 64 bit ließ sich lauffähig auf einem Stick installieren. Nur dort ist es mit USB 2.0 natürlich so langsam, dass es eher unsinnig ist... Es ist nur ein Not-Linux...

Re: Installation: Bootprobleme
« Antwort #16 am: 29.01.2020, 21:55:49 »

Re: Installation: Bootprobleme
« Antwort #17 am: 29.01.2020, 22:05:00 »
Ach soooo... und ich dachte schon, es sei irgendein ominöses BIOS-System oder so...  ;D

Nichtsdestotrotz: auch wenn es tot ist, sollte man es installieren können. Oder holt sich der Installer aktualisierte Dateien aus dem Internet (Internet wird ja vorausgesetzt... warum denn also sonst, wenn die Distribution doch auf DVD ist?), die dann vielleicht zu Inkompatibilitäten führen können?

Re: Installation: Bootprobleme
« Antwort #18 am: 29.01.2020, 22:07:26 »
Es geht ganz einfach um Linux Mint 17.X!
Dieses System ist halt Tot. seit 04/2019!

Du solltest versuchen ein neueres System installieren oder wenn du viele Anpassungen und Einstellungen gemacht hast, auch ein Upgrade auf Linux Mint 18 durchführen.

Re: Installation: Bootprobleme
« Antwort #19 am: 29.01.2020, 22:12:32 »
Du solltest versuchen ein neueres System installieren oder wenn du viele Anpassungen und Einstellungen gemacht hast, auch ein Upgrade auf Linux Mint 18 durchführen.

Mein laufendes Linux Mint 17.1 ist ja ein 32Bit-System und außerdem auf einer nur 20 GB großen Partition. Es stammt ursprünglich tatsächlich von einer IBM-Platte mit nur 20GB!
Ich würde es gerne „aufrüsten“, wenn es denn ginge, denn Einstellungen und Programme neu aufzusetzen dauert ja auch einige Zeit. Vor allem die Bildschirmdarstellung musste ich massiv verändern, weil meine Augen auch nicht mehr so toll sind... Deshalb hatte ich vor, die Partition auf eine größere Platte zu klonen und auszuweiten, aber das hat nicht geklappt. Ob ich von 32 auf 64 bit umsatteln / aufrüsten kann, weiß ich auch nicht.

Re: Installation: Bootprobleme
« Antwort #20 am: 29.01.2020, 22:17:27 »
Ob ich von 32 auf 64 bit umsatteln

Nur durch Neuinstallation!

CPU:       Dual core AMD Athlon II X2 255

Und der sollte 64 Bit können!

Habe ich auch!

Re: Installation: Bootprobleme
« Antwort #21 am: 29.01.2020, 23:22:55 »
Ein neueres Linux-System wollte ich jetzt nicht probieren, weil auch der Rechner schon älter ist, und die neuesten Distributionen vielleicht nicht verkraftet.
   
So ein Unsinn.CPU:       Dual core AMD Athlon II X2 255 (-MCP-) cache: 2048 KB flags: (lm nx sse sse2 sse3 sse4a svm)
           Clock Speeds: 1: 3114.153 MHz 2: 3114.153 MHz
Graphics:  Card: NVIDIA Device 0f02

Ein zwar älterer 64bit- 2 Kerner aber sogar mit einer Nvidia GT 730.
Da laufen alle akt. Mint-Versionen mit allen Desktops - auch 19.3 mit Cinnamon, den ich dir  empfehlen würde.
Dein gezeigter Fehler liegt vermutlich an Mint 17. 
Mehr dazu: https://de.wikipedia.org/wiki/File

Re: Installation: Bootprobleme
« Antwort #22 am: 29.01.2020, 23:46:26 »
Ja klar, kann der PC 64bit - Windows läuft ja drauf. Ich hatte gehofft, die Linux-32bit-Installation auf 64bit „upzugraden“ - aber das scheint eben nicht zu gehen. Schade. Also bleibt nur eine Neuinstallation. Ich kann nur nicht mehr als 4 GB RAM einsetzen, was für Linux noch gut reicht, für Windows10 aber schon nicht mehr.

Durch die verschiedenen Listen ist mir aufgefallen, dass die Zählung - je nachdem, in welchem Port die Festplatte eingestöpselt ist - immer anders ist. Sda und sdb sind immer gleich, weil das feste interne Platten sind. Auf sda ist NUR Windows.

Befindet sich nun die Linux-Partition (angenommen), auf sdg - muss ich dann mit sudo grub-install /dev/sdg wählen? Denn diese Platte wird ja als Bootmedium genutzt (bei mir mit dem BIOS-Bootmanager F8 ausgewählt) und von dort aus soll Linux ja starten. Wo genau muss also der Bootmanager installiert werden... auf die Partition, auf Root oder noch woanders hin? Der Installer bietet mir eine Reihe von Möglichkeiten an.

Und was passiert, wenn ich die Platte in einen anderen USB-Port stecke und plötzlich zu sdh wird? Wird Linux dann nicht mehr gefunden?
« Letzte Änderung: 29.01.2020, 23:52:53 von Tutnix »

Re: Installation: Bootprobleme
« Antwort #23 am: 30.01.2020, 01:18:35 »
muss ich dann mit sudo grub-install /dev/sdg wählen? Denn diese Platte wird ja als Bootmedium genutzt (bei mir mit dem BIOS-Bootmanager F8 ausgewählt)
Du musst mit dem Terminal gar nichts tun.  Während der Installation wirst du danach gefragt,  wo du den Grub hin haben willst.  Ja, auf sdg - nicht etwa sdg1.  Und du solltest  per Kabel bei der Installation Online sein. 

Nimm eine Iso von hier, die ist weitgehend deutsch. 
https://www.linuxmintusers.de/index.php?topic=9668.msg783649#msg783649


Und was passiert, wenn ich die Platte in einen anderen USB-Port stecke
 
Erreichst du den mit F8, startet Mint. Auch an jedem anderen Bios-Rechner.
« Letzte Änderung: 30.01.2020, 01:33:50 von geobart »

Re: Installation: Bootprobleme
« Antwort #24 am: 30.01.2020, 17:59:17 »
Hallo. Linux wird mir immer ein Rätsel bleiben...

Wollte mit der Linux-DVD booten, während die externe Platte mit dem defekten Linux in einem USB-Slot steckte. Alles schön brav, Linux wird von der DVD geladen. Tacker, tacker, tacker...

Doch plötzlich erscheint ein Login-Fenster mit Eingabe auf Englisch. Nun gut, dachte mir: hat er das neue Linux also doch gefunden, ist ja fein - ich wüsste nämlich nicht, dass eine Live-DVD ein Login braucht (und vorher brauchte sie auch keins)... Doch wieso eigentlich? Soll nicht das Read-Only-System von der DVD geladen werden? Rätsel über Rätsel...

Doch er wollte keinen meiner Benutzernamen und Passwörter akzeptieren (nachdem es wieder mal ans Suchen auf der deutschen Tastatur ging...). Ich kam partout nicht weiter. Vielleicht habe ich dauernd einen Buchstaben falsch getippt oder er will ein mir unbekanntes Administrator-Login; egal, ich kam nicht rein. Es gab auch keinen Ausgang zu einem anderen Login.

Festplatte also abgestöpselt, RESET und nochmal mit der DVD gebootet - ohne irgendein anderes Linux am Rechner.

Der PC hängt. Hat sich der Rechner irgendwas irgendwo gemerkt..? Warum liest er die DVD nicht weiter?

Nach zwei RESETs und Boot-Versuchen dann endlich erscheint die Oberfläche des Live-Systems von der DVD. Er hat diesmal sehr lange gebraucht und auch häufiger mal Popup-Fenster gezeigt, die ich aber so schnell nicht lesen konnte und die vorher nicht dabei waren.

Also: neuer Versuch. Festplatte für die 64bit-Version auf sdg eingesteckt und eine neue Installation auf der bestehenden Partition ausgeführt (also an der gleichen Stelle übergebügelt), mit Bootloader auf sdg.

Installation wird ordentlich abgeschlossen, DVD raus, Neustart, F8 um von der Linux-Platte zu booten. Die steckt natürlich immer noch im selben Port.

Fehlermeldung mit Grub-Rescue. Das eben installierte Linux wird nicht gefunden. Großes Fragezeichen. DAS hatte ich bislang noch nicht. Also diesmal keine ELF-Magic-Meldungen und so was.

Da ich nicht weiß, was ich da eingeben muss, und es auch kein EXIT oder ähnliches zu geben scheint, um da raus zu kommen, also RESET  und diesmal mit der funktionierenden 32bit-Linux-Version von der anderen Platte gebootet. DIE läuft ja gottlob noch.

Nun habe ich die kaputte Linux-Partition auch mal hinzugesteckt. Ich kann wie gehabt die Installation auf der Platte sehen, es wurde was installiert. Jetzt liegt die Partition aber auf sdh.

Was passiert denn jetzt bei der Eingabe von sudo grub-install? Muss ich jetzt sdg oder sdh wählen? Oder kriege ich die neue Distribution sowieso nicht zum Laufen? Immerhin hat er ja einmal mit Login-Fenster reagiert, also muss ja DOCH was installiert worden sein...

Bei jedem Schritt geschieht immer irgendwas Neues und Unerwartetes. Fast möchte ich wetten, dass es nach den nächsten drei Versuchen alles problemlos klappt - und dann vielleicht die nächsten drei Male nicht mehr. Alles scheint möglich, ich kann es nicht nachvollziehen. Diese ganze Grub und Boot-Geschichte scheint aber auch ein ewiges Thema zu sein - und dabei habe ich noch nicht mal Windows und Linux auf einer Platte... ;)

Ich kann nun eine neuere Version herunterladen und brennen, aber wenn diese schon nicht klappt... warum sollte es bei den neueren besser klappen? Gut, vielleicht ist auch die verwendete Platte kaputt, aber Testdateien hin- und hergeschoben zeigen, dass beide Partitionen (EXT4 und NTFS) anscheinend okay sind.

Das nächste Mal mache ich statt RESET immer Kaltstarts!

PS Das Herunterladen des 19er Mate muss ich in Windows machen - auf der Linux-Partition ist nicht genügend Platz. Ich weiß nicht, warum Firefox den Zielordner nicht ändern will, sondern immer den persönlichen Ordner will...
« Letzte Änderung: 30.01.2020, 18:30:19 von Tutnix »

Re: Installation: Bootprobleme
« Antwort #25 am: 30.01.2020, 19:51:37 »
wobei dein Nick ein toller Name für eine neue Distribution wäre. Reiht sich wunderbar ein zwischen Knoppix, Kanotix,etc. ;) :)

Re: Installation: Bootprobleme
« Antwort #26 am: 30.01.2020, 20:03:06 »
Das Herunterladen von 19.3 Mate auf eine NTFS-Partition hat immerhin geklappt. Allerdings hat die ISO keine Zugriffs-Rechte (das passiert immer, wenn man von Linux was auf eine Windows-Platte kopiert). Aber ich hoffe, zum Brennen ist das egal. Bei Dateien ist das allerdings ärgerlich, wenn man vergisst, die Zugriffsrechte in Linux vorher auf Jeder darf alles zu ändern, bevor man zu Windows wechselt. Sonst kann man nämlich die Dateien dort weder löschen (!) noch bearbeiten, Bilder nicht mal anschauen...

Ach ja, nebenbei: jetzt, beim zweiten Versuch, mit Live-System UND 64bit-Linux zu booten, hat das mit dem Login wie beim ersten Mal leider nicht geklappt. Er sagt immer noch Grub-Rescue. Schade.

Ich habe festgestellt, dass Linux auch gerne mal meinen Dual-Core abschaltet und ich deshalb nicht hochfahren kann. Jedenfalls ist mir das gerade zum xten Mal passiert. Womöglich hängt deshalb die DVD auch, denn ohne Dual-Core gibt es kein 64bit...

Ach ja: die Platte zeigt jetzt sdc an. Auch nach dem Wechseln des USB-Ports... Es wird immer wunderlicher. Ich kapiere dieses sda, sdb, sdc einfach nicht...
« Letzte Änderung: 30.01.2020, 20:12:12 von Tutnix »

Re: Installation: Bootprobleme
« Antwort #27 am: 30.01.2020, 20:15:18 »
Ich denke, du solltest die Linux Installation von jemand machen lassen, der sich mit PCs auskennt. Im Wiki ist eine Liste von Leuten, die sowas anbieten.

Re: Installation: Bootprobleme
« Antwort #28 am: 30.01.2020, 21:25:48 »
Dieser PC wird auch nur noch genutzt, so lange er hält. Das 32bit-Linux habe ich jetzt auf drei PCs und das 64bit auf einem Stick installiert - das geht offensichtlich besser. Und irgendwie völlig unproblematisch. Wahrscheinlich ist doch der Wurm in der 64er-Version, im Zusammenspiel mit meinem BIOS. Oder mein Rechner klappert schon ordentlich und nimmt falsche Befehle und unsauberen Code inzwischen krummer als früher... Da ich zum Arbeiten mit Windows auf einen neuen 8-Kerner aufrüste, reicht dieses alte Linux zum Surfen allemal.
« Letzte Änderung: 30.01.2020, 21:33:57 von Tutnix »

Re: Installation: Bootprobleme
« Antwort #29 am: 30.01.2020, 22:25:00 »
ist doch der Wurm in der 64er-Version, im Zusammenspiel mit meinem BIOS. Oder mein Rechner klappert schon ordentlich und nimmt falsche Befehle
Dein Rechner nimmt alle Befehle, auch wenn sie falsch sind. Das ist ja das Kernproblem. Des Weiteren ist es deinem BIOS völlig egal ob du eine 32 oder 64 bit Version installiert hast. Den Rat von @toffifee solltest du wirklich beherzigen.
Ich denke, du solltest die Linux Installation von jemand machen lassen, der sich mit PCs auskennt. Im Wiki ist eine Liste von Leuten, die sowas anbieten.
Ansonsten kannst du dir eine Glaskugel besorgen oder dir jemanden suchen der Sandalen trägt und Moos an den Füßen hat. Mit deiner unstrukturierten Arbeitsweise wirst du leider den Rechner nicht zum Laufen bringen.