Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
27.02.2020, 23:31:46

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 23513
  • Letzte: stefan555
Statistiken
  • Beiträge insgesamt: 642951
  • Themen insgesamt: 52096
  • Heute online: 765
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 9
Gäste: 486
Gesamt: 495

Autor Thema: [gelöst]  Paketsystem defekt NVIDIA lädt nicht nach Aktualisierung  (Gelesen 445 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Paketsystem defekt NVIDIA lädt nicht nach Aktualisierung
« am: 22.01.2020, 11:31:09 »
Mint 19.3 Cinnamon
Kernel 5.3.0-26-generic

Moin,
sorry, aber ich komme wieder mal nicht weiter,
habe gestern die anstehenden Aktualisierungen laufen lassen mit dem Erfolg das meine NVIDIA nicht mehr geladen wird und ich auf meinen zweiten Monitor nicht mehr zugreifen kann.
 
hatte bis vorgestern komischerweise noch 19.1 und Kernel 4.15

"sudo apt-get update && sudo apt-get dist-upgrade" bringt diese Meldungen:

OK:1 http://linux.teamviewer.com/deb stable InRelease
Ign:2 http://ftp-stud.hs-esslingen.de/pub/Mirrors/packages.linuxmint.com tricia InRelease
OK:3 http://security.ubuntu.com/ubuntu bionic-security InRelease         
OK:4 http://archive.canonical.com/ubuntu bionic InRelease                 
OK:5 http://ftp-stud.hs-esslingen.de/pub/Mirrors/packages.linuxmint.com tricia Release
OK:6 http://mirror.kamp.de/ubuntu bionic InRelease                           
OK:7 http://mirror.kamp.de/ubuntu bionic-updates InRelease                   
OK:8 http://mirror.kamp.de/ubuntu bionic-backports InRelease
Paketlisten werden gelesen... Fertig
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Probieren Sie »apt --fix-broken install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 libnvidia-ifr1-390 : Hängt ab von: libnvidia-gl-390 ist aber nicht installiert
 nvidia-driver-390 : Hängt ab von: libnvidia-gl-390 (= 390.116-0ubuntu0.18.04.1) ist aber nicht installiert
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt --fix-broken install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).

Kann mir jemand helfen wie ich das behoben bekomme?
wenn ich versuche über die Anwendungsverwaltung irgend
etwas zu deinstallieren bekomme ich die Meldung das das
Paketsystem defekt wäre.
»apt --fix-broken install« funktioniert gar nicht.
Danke schon mal
« Letzte Änderung: 24.01.2020, 13:08:00 von Don Koni »

Re: Paketsystem defekt NVIDIA lädt nicht nach Aktualisierung
« Antwort #1 am: 22.01.2020, 14:24:33 »
Was passiert denn mit apt install -f ?

Re: Paketsystem defekt NVIDIA lädt nicht nach Aktualisierung
« Antwort #2 am: 22.01.2020, 16:00:39 »
Sorry, habe jetzt solange rumgespielt das ich nicht mal mehr über den Anmeldeschirm rauskomme, lässt mich das Passwort eingeben und lädt dann den Anmeldebildschirm neu, password stimmt, wenn ich ein falsches eingebe meckert er.
Bin jetzt auffem Smarthphone

Re: Paketsystem defekt NVIDIA lädt nicht nach Aktualisierung
« Antwort #3 am: 22.01.2020, 16:04:14 »
Bin jetzt auf der root Befehlszeile über das Wiederherstellungsmenü

Re: Paketsystem defekt NVIDIA lädt nicht nach Aktualisierung
« Antwort #4 am: 22.01.2020, 17:20:18 »
Na dann viel Vergnügen weiterhin, beim Herumspielen.  :D

Re: Paketsystem defekt NVIDIA lädt nicht nach Aktualisierung
« Antwort #5 am: 22.01.2020, 17:30:15 »
Ich installiere neu und hoffe es hilft
Einmal nicht aufgepasst was da aktualisiert wird und in Hektik machen lassen ohne vorher zu sichern mist

Re: Paketsystem defekt NVIDIA lädt nicht nach Aktualisierung
« Antwort #6 am: 22.01.2020, 18:05:34 »
Hallo,
in diesem Falle ist wohl die Neuinstallation der beste Weg.

Aber - falls es danach erneut Probleme geben sollte - ich betreue mehrere Rechner, sei es mit AMD- oder Intel-Prozessor. In fast jedem Gerät ist auch eine NVidia verbaut, verschiedenste Typen, auch Laptop-Versionen. Bei VEREINZELTEN Rechnern habe ich enorme Probleme mit dem aktuellen Kernel 5.3.0-26
Treiber lässt sich installieren, läuft mal kurz, beim nächsten Start ist jedoch der zweite Bildschirm schwarz und die "Software-Rendering"-Warnung kommt.
Am betroffenen PC hilft aktuell nur der vorige 5.0er Kernel, damit läuft es ohne Probleme.

Wohlgemerkt ist es bei anderen PCs mit dem aktuellen Kernel überhaupt kein Problem, auch nicht mit dem neusten 440er Treiber aus dem ubuntu-ppa.
Ist möglicherweise eine Hardwarekomponente, die mit dem 5.3er Kernel nicht mag, wobei es ausgerechnet das jüngste Board im Pool ist, das mit dem neueren Kernel Probleme hat.

Falls Du also nach der Neuinstallation erneut Probleme bekommen solltest, gehe vorerst mal auf den 5.0er Kernel (oder 4.x, wenn es keinen zwingenden Grund für 5.x gibt) zurück.

Re: Paketsystem defekt NVIDIA lädt nicht nach Aktualisierung
« Antwort #7 am: 22.01.2020, 18:35:06 »
Hab ich heute die Seuche...
kann das sein das Mint 19.3 nicht mehr mit meiner Nvidia 630 Karte will?
Kann nicht installieren, bekomme Meldung Eingangssignal außerhalb des Bereichs...
Oder kann ich da irgend etwas einstellen? Bisher auf 19.1 lief alles bestens.
an anderem Rechner laufen beide Monitore auch einwandfrei ander Videoüberwachung auch.

Re: Paketsystem defekt NVIDIA lädt nicht nach Aktualisierung
« Antwort #8 am: 22.01.2020, 19:03:39 »
Was zeigt sich denn, wenn Du das Live-System einfach nur startest, spricht dieses dann beide Monitore korrekt an?

Re: Paketsystem defekt NVIDIA lädt nicht nach Aktualisierung
« Antwort #9 am: 22.01.2020, 19:19:55 »
Moin,
wenn ich mit der CD boote um zu installieren zeigt er erst auf beiden Monitoren das Mint Logo, dann werden beide dunkel und kurz darauf kommt die Meldung und die bleibt bis ich die Kiste ausschalte.
habe jetzt mal die CD im abgesicherten Modus gebootet und habe das gleiche Problem wie auf dem normalen System auf dem Rechner, er Zeigt mir als Monitor nur Laptop an, der zweite Monitor bleibt ganz dunkel und NVIDIA Treiber lassen sich nicht installieren.
Wenn ich jetzt wüsste wie ich auf meinem installierten System aus dem Login loop käme würde ich dort ja versuchen den Kernel zu ändern und es mal mit dem 5.0er ausprobieren.

Re: Paketsystem defekt NVIDIA lädt nicht nach Aktualisierung
« Antwort #10 am: 22.01.2020, 19:34:52 »
Habe mein normales System jetzt  gebootet, den Login umgangen mitstrg alt F1, mich eingeloggt, was er diesmal sogar zugelassen hat
Aber den x Server startet er mit schwarzem Schirm

Re: Paketsystem defekt NVIDIA lädt nicht nach Aktualisierung
« Antwort #11 am: 22.01.2020, 19:35:08 »
Hattest Du denn inzwischen neu installiert, oder reden wir noch vom bisherigen System?

Re: Paketsystem defekt NVIDIA lädt nicht nach Aktualisierung
« Antwort #12 am: 22.01.2020, 20:46:38 »
Nein, nachdem ich mit der Version die ich von der CD gebootet habe das gleiche hatte, habe ich das erst mal gelassen.
habe jetzt mit Timeshift einen Punkt wiederhergestellt bei dem das nvidia Problem behoben ist.
Ich sehe wieder auf beiden Monitoren, jetzt geht's noch um den Login loop, aber das mache ich dann morgen, habe da auch schon was gelesen woran es liegen kann.
Danke erst mal, morgen dann mehr.

Re: Paketsystem defekt NVIDIA lädt nicht nach Aktualisierung
« Antwort #13 am: 23.01.2020, 12:33:25 »
so, auch das Loop Problem ist gelöst, so wie es aussah hat Timeshift mir die Rechte verbeutelt.
Das Problem das meine NVIDIA nicht mit dem Kernel 5.03 läuft besteht weiterhin, behalte ich halt erst mal den 5.0er

hier steht die Lösung für das Login loop:
https://www.linuxmintusers.de/index.php?topic=56362.msg759308#msg759308
Danke für eure Hilfe
« Letzte Änderung: 24.01.2020, 13:07:42 von Don Koni »

Re: Paketsystem defekt NVIDIA lädt nicht nach Aktualisierung
« Antwort #14 am: 24.01.2020, 19:39:02 »
Hallo

ich bin auch gerade auf Cinnamon 4.4.8 wm umgestiegen. Bisher lief alles super.

Nach einer Aktualisierung hatte ich leider auch das Problem, dass meine NVIDIA GF119 [GeForce GT 610] nicht mehr so richtig wollte. Zum Glück hatte ich zuvor ein Abbild gemacht. Allerdings auch bei den Servern für die Aktualisierung etwas geändert.
Nun habe ich bereits an anderer Stelle gelesen, dass man bei den Treibern für NVIDIA sensibel sein muss, wenn man diese auffrischt.
Meine Frage: Was muss man bei den Servern zur Aktualisierung für die Treiber für NVIDIA beachten, damit es möglichst keine Probleme gibt?
Gibt es Empfehlungen für Spiegelserver? Und was hat es mit PPA aufsich? Da stand mal was mit launch (?) drin, leider nicht genau gemerkt und ist nun weg.

Danke schon mal für Tipps