Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
12.08.2020, 17:46:08

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24386
  • Letzte: tomster
Statistiken
  • Beiträge insgesamt: 676852
  • Themen insgesamt: 54860
  • Heute online: 580
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  Keine Temperaturen mit 19.3 und Ryzen3700x  (Gelesen 825 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Keine Temperaturen mit 19.3 und Ryzen3700x
« am: 11.01.2020, 09:00:27 »
Moin in die Runde,

nun wollte ich am frühen Morgen endlich das Linux-Debakel mit der
fehlenden Temp-Anzeige von meinem Ryzen3700x mit Tricia 19.3 lösen.
Habe artig die empfohlene deutsche Version aus dem Forum genutzt.

Ist nicht: Auch Tricia ist nicht in der Lage, dies zu lösen. Liegt wohl am Kernel, keine Ahnung.
Bin Anfänger, der sich mal wieder die Haare rauft und seit 3 Monaten sehr zufrieden (bis auf die fehlenden Temps) mit Tina saust..

Für mich als intensiver Boinc Nutzer ist dies überaus in dem hoffentlich kommenden Sommer sehr wichtig!
Ich möchte meine Temps mit Psensor (würg) oder eben besser mittels Conky anzeigen lassen und nicht meine CPU braten.

Wie kann ich  das Ziel erreichen?
Im Forum hatte irgendwo gelesen, ein 19.2 mit Kernel 5.3xx zu installieren um dann mit einem Update auf Tricia zu kommen.
Warum diese Bastelei, warum wird nicht gleich ein vernünftiger Kernel „beigelegt“?
Denn im Forum und Anleitungen wird auch geschrieben,  das eine Neuinstallation der sauberste Weg ist.

Sorry, bin etwas gestresst. Es ist nur eine blöde Anzeige.. :'(

Helft mir bitte, mit für mich verständlichen Wegen,  auf die Sprünge.
Danke Rainer;


[MOD: Titel weniger mehrdeutig gemacht.]
« Letzte Änderung: 12.01.2020, 22:04:54 von LinuxDAU »

Re: Kein Temps mit 19.3 und Ryzen3700x
« Antwort #1 am: 11.01.2020, 09:24:08 »
Warum diese Bastelei, warum wird nicht gleich ein vernünftiger Kernel „beigelegt“?
Mint wird mit dem aktuellen Ubuntu LTS Kernel geliefert, Mainline Kernel, wie z.b. 5.3 kann man mit ukuu installieren oder man holt sich die .deb direkt bei Kernel.org.

Zur Temp, was sagt den inxi -s


Re: Keine Temperaturen mit 19.3 und Ryzen3700x
« Antwort #3 am: 11.01.2020, 19:08:43 »
Host: Ryzen3700x Kernel: 5.0.0-37-generic x86_64 bits: 64 compiler: gcc v: 7.4.0
           Desktop: MATE 1.22.2 wm: marco dm: LightDM Distro: Linux Mint 19.3 Tricia
           base: Ubuntu 18.04 bionic Mobo Asrock x470 Taichi


Moin, Danke für das Umbenennen und die Rückmeldung.
Habe das System mit mehreren Installations-Files aufgesetzt. Immer das gleiche.

Die Anwort auf inxi -s ist

Sensors:
  System Temperatures: cpu: 55.5 C mobo: N/A gpu: nvidia temp: 61 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 42%

Anscheinend wird die Temperatur doch gelesen: 16x Volllast mit 3,6 Ghz
Warum wird die dann nicht angezeigt?
Bedanke mich artig für weitere Infos.
Gruß Rainer

:-(  ich weiß noch nicht einmal was es mit dem Code von der Webseite auf sich hat und habe es nicht gefunden.
Deshalb meine Antwort so..

Re: Keine Temperaturen mit 19.3 und Ryzen3700x
« Antwort #4 am: 11.01.2020, 23:35:23 »
Moin, nun lacht nicht, aber gerade nach etlichen Tools mit Anzeigemöglichkeiten usw.
habe ich nun mit Psensor eine Temparatur Anzeige mittels k10Temp.
Verstehen kann ich es nicht, aber Hauptsache vorhanden. ::)

Werde ich gleich versuchen das nach Conky übertragen.
Psensor ist ein Anschlag auf mein Auge.. :o

Ich bedanke mich für Hinweise
Rainer

Re: Keine Temperaturen mit 19.3 und Ryzen3700x
« Antwort #5 am: 12.01.2020, 03:12:50 »
Host: Ryzen3700x Kernel: 5.0.0-37-generic x86_64 bits: 64 compiler: gcc v: 7.4.0
           Desktop: MATE 1.22.2 wm: marco dm: LightDM Distro: Linux Mint 19.3 Tricia
           base: Ubuntu 18.04 bionic Mobo Asrock x470 Taichi

Entweder versuchst es es mit dem Ubuntu - Distributionskernel 5.3.0 - 24
oder mit dem im Link von @garfield121 genannten Mainline - Kernel aktuell 5.4.10 installierbar mit UKUU.

Re: Keine Temperaturen mit 19.3 und Ryzen3700x
« Antwort #6 am: 12.01.2020, 07:33:04 »
Moin, @tommix:Danke für den Tip

Aber mein Rechner hat wohl ein Eigenleben und NEIN: ich trinke nicht und auch keine dampfenden Kräuter..

Gestern Abend noch Conky dazu gebracht identische Temperaturen im Vergleich mit inxi -s zu zeigen.
Heute morgen nach einem Neustart waren die Temps bei Conky gegenüber inxi -s >10′ zu niedrig.  :o

Auch werden in der Ausgabe von inxi -s nun mehrere Ventilatoren und die Mobo-Temp angezeigt.
Finde ich ja gut, aber wieso kommt das nach und nach?

War mein Kaffee heute morgen schlecht? :)
Das hört sich so merkwürdig an, das ich es fast nicht schreiben möchte..
Gruß Rainer

Re: Keine Temperaturen mit 19.3 und Ryzen3700x
« Antwort #7 am: 12.01.2020, 08:32:57 »
Zeig mal bitte die betreffende Zeile der conkyrc und die Ausgabe von sensors

Re: Keine Temperaturen mit 19.3 und Ryzen3700x
« Antwort #8 am: 12.01.2020, 08:56:09 »
Auszug Conky.conf:
${font Montserrat Light:size=8}${color1}CPU${color}${font} ${font :size=10}${alignr}${hwmon 0 temp 7}°${color4} C       
${font Montserrat Light:size=8}${color1}CPU-Fan${color}${font} ${font :size=10}${alignr}${hwmon 0 fan 2}°${color4}U/min
${font Montserrat Light:size=8}${color1}MOBO${color}${font} ${font :size=10}${alignr}${hwmon 0 temp 1}°${color4} C       
${font Montserrat Light:size=8}${color1}NVIDIA${color}${font} ${font :size=10}${alignr}${nvidia temp}°${color4} C 

Ausgabe sensors:
rainer@Ryzen3700x:~$ sensors
nct6779-isa-0290
Adapter: ISA adapter
Vcore:                  +0.50 V  (min =  +0.00 V, max =  +1.74 V)
in1:                    +1.28 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
AVCC:                   +3.44 V  (min =  +2.98 V, max =  +3.63 V)
+3.3V:                  +3.44 V  (min =  +2.98 V, max =  +3.63 V)
in4:                    +1.84 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in5:                    +1.09 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in6:                    +1.37 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
3VSB:                   +3.46 V  (min =  +2.98 V, max =  +3.63 V)
Vbat:                   +3.30 V  (min =  +2.70 V, max =  +3.63 V)
in9:                    +0.00 V  (min =  +0.00 V, max =  +0.00 V)
in10:                   +0.60 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in11:                   +1.08 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in12:                   +1.69 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in13:                   +0.93 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in14:                   +1.85 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
fan1:                   833 RPM  (min =    0 RPM)
fan2:                   591 RPM  (min =    0 RPM)
fan3:                     0 RPM  (min =    0 RPM)
fan4:                  1288 RPM  (min =    0 RPM)
fan5:                   854 RPM  (min =    0 RPM)
SYSTIN:                 +42.0°C  (high =  +0.0°C, hyst =  +0.0°C)  ALARM  sensor = thermistor
CPUTIN:                 +45.0°C  (high = +80.0°C, hyst = +75.0°C)  sensor = thermistor
AUXTIN0:                 +7.0°C    sensor = thermistor
AUXTIN1:                +49.0°C    sensor = thermistor
AUXTIN2:                +21.0°C    sensor = thermistor
AUXTIN3:                -28.0°C    sensor = thermistor
SMBUSMASTER 0:          +57.0°C 
PCH_CHIP_CPU_MAX_TEMP:   +0.0°C 
PCH_CHIP_TEMP:           +0.0°C 
PCH_CPU_TEMP:            +0.0°C 
intrusion0:            ALARM
intrusion1:            ALARM
beep_enable:           disabled

k10temp-pci-00c3
Adapter: PCI adapter
Tdie:         +57.5°C  (high = +70.0°C)
Tctl:         +57.5°C 

Danke für deine/eure Mühe; mach Diener Icon fehlt

[MOD: "Diener" hat Codeblock hinzugefügt. Bitte nutze Codeblöcke für Terminalausgaben. Siehe Hilfe.]
« Letzte Änderung: 12.01.2020, 12:04:18 von toffifee »

Re: Keine Temperaturen mit 19.3 und Ryzen3700x
« Antwort #9 am: 12.01.2020, 09:11:51 »
Moin, @tommix:Danke für den Tip

Aber mein Rechner hat wohl ein Eigenleben
Das glaube ich nicht, und mir ist es auch egal, da wir einen eigenen Thread dazu hatten:
https://www.linuxmintusers.de/index.php?topic=58015.0

Und ich zitiere aus dem Heise Online Beitrag:

Zitat
Der Kernel kann die Prozessortemperatur jetzt auch bei Ryzen-3000-CPUs auslesen.
Überhaupt ist wohl im 5.4er Mainline - Kernel viel für AMD enthalten.

Noch ein anderer Tipp:
Neueste Hardware  --->> neuester Kernel.

Noch ein P.S.:  dein 5.0er ist eh in 1,5 Monaten EOL.

Noch ein P.S.: Im Gegensatz zu den 5.0er und 5.3er Ubuntu - Distributionskernel (EOL 02/2020 sowie 08/2020) ist der 5.4er Mainline erst einmal für min 2 Jahre LTS
« Letzte Änderung: 12.01.2020, 09:58:18 von tommix »

Re: Keine Temperaturen mit 19.3 und Ryzen3700x
« Antwort #10 am: 12.01.2020, 09:59:14 »
Überhaupt ist wohl im 5.4er Mainline - Kernel viel für AMD enthalten.

Noch ein anderer Tipp:
Neueste Hardware  --->> neuester Kernel.

Noch ein P.S.:  dein 5.0er ist eh in 1,5 Monaten EOL.

Du sagst es so leicht: DU/ihr habt Plan, ich bin ein alter Knacker mit so gut wie keiner Linux-Erfahrung: einer der LInux gerade mal starten kann.
Ich traue mich kaum etwas zu verändern und möchte nicht wie früher bei Win alles zu verändern..
Mit Eurer Hilfe allerdings ist es schon leichter für die Newbies.
Aber zur Zeit sieht es gut aus mit den Anzeigen.

Was mich immer noch beschäftigt: Gestern Abend noch keine Temperaturen und heute Morgen schon, sogar mit Lüfter.
Aber gut, ich möchte euch nicht zur Last fallen mit meinen komischen Gedanken.
Gruß Rainer

Re: Keine Temperaturen mit 19.3 und Ryzen3700x
« Antwort #11 am: 12.01.2020, 11:45:07 »
Ja, was soll ich jetzt sagen?

Wenn du also den 5.4er Mainline installieren willst, zeige ich dir wie.
Wenn du den 5.3er Ubuntu installieren möchtest, zeige ich dir auch, wie es geht.
 

Re: Keine Temperaturen mit 19.3 und Ryzen3700x
« Antwort #12 am: 12.01.2020, 12:05:05 »
Wenn alles läuft, dann läufts, wozu ändern? Prima.
Setze dann bitte ggf. hier noch auf "erledigt" oder "gelöst". Dazu den Startpost "ändern" und das passende Präfix auswählen. Danke.

Re: Keine Temperaturen mit 19.3 und Ryzen3700x
« Antwort #13 am: 12.01.2020, 22:04:36 »
tommix@ Danke für dein Angebot. Vielleicht muss ich ja mal darauf zurück kommen.
Aber zur Zeit klappt es ja und ich werde den Rat von toffifee annehmen und nichts ändern.

Setze den Fred auf Gelöst. Danke an die Rat gebenden. Rainer :-*

Re: Keine Temperaturen mit 19.3 und Ryzen3700x
« Antwort #14 am: 13.01.2020, 01:40:12 »
Deine Temperaturanzeigen werden auch weiterhin "spinnen", der 5.4er Kernel, von dem garfield121 schrieb, wird voraussichtlich das Problem lösen.Es ist zu erwarten, dass er bald auch in Mint als Kernel angeboten wird. 
Dann allerdings solltest du ihn installieren, geht dann ganz einfach.