Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
02.12.2020, 01:22:48

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24844
  • Letzte: outis
Statistiken
  • Beiträge insgesamt: 697886
  • Themen insgesamt: 56475
  • Heute online: 448
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 3
Gäste: 358
Gesamt: 361

Autor Thema: [gelöst]  Canon MG6250 Netzwerkdrucker  (Gelesen 1337 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Canon MG6250 Netzwerkdrucker
« am: 30.12.2019, 20:08:43 »
Hallo zusammen,

nach tagelangem Rumprobieren und lesen im Forum bekomme ich es trotzdem nicht hin.
Canon Drucker sollen nicht die Beste Wahl für Linux-Systeme sein und manche Laptops auch nicht.
Lokal funktioniert der Drucker(jedoch ohne Scanner, auch mit easyprint soll es nicht richtig gehen).
Ich will aber 3 weitere Rechner "im Grünen Bereich" haben, darum soll der Canon im Netzwerk drucken.

Kann der Rechner und Drucker mit Linux gut funktionieren?
Funktionieren die Canon-Treiber vernünftig mit Linux?
Wie kann ich manuell den Treiber installieren?


rd@rd-Leppi:~$ inxi -FzAus
System:    Host: rd-Leppi Kernel: 5.0.0-32-generic x86_64 bits: 64 Desktop: MATE 1.22.2 Distro: Linux Mint 19.3 Tricia
Machine:   Type: Laptop System: eMachines product: eMachines G640 v: V1.18 serial: <filter>
           Mobo: eMachines model: eMachines G640 v: V1.18 serial: <filter> BIOS: Phoenix v: 1.18 date: 04/25/2011
Battery:   ID-1: BAT0 charge: 35.1 Wh condition: 37.4/47.5 Wh (79%)
CPU:       Topology: Dual Core model: AMD Athlon II P320 bits: 64 type: MCP L2 cache: 1024 KiB
           Speed: 800 MHz min/max: 800/2100 MHz Core speeds (MHz): 1: 800 2: 800
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Park [Mobility Radeon HD 5430/5450/5470] driver: radeon v: kernel
           Display: x11 server: X.Org 1.20.4 driver: ati,radeon unloaded: fbdev,modesetting,vesa resolution: 1600x900~60Hz
           OpenGL: renderer: AMD CEDAR (DRM 2.50.0 / 5.0https://www.linuxmint.com/start/tricia/.0-32-generic LLVM 8.0.0) v: 3.3 Mesa 19.0.8
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] SBx00 Azalia driver: snd_hda_intel
           Device-2: Advanced Micro Devices [AMD/ATI] Cedar HDMI Audio [Radeon HD 5400/6300/7300 Series] driver: snd_hda_intel
           Sound Server: ALSA v: k5.0.0-32-generic
Network:   Device-1: Broadcom and subsidiaries NetLink BCM57780 Gigabit Ethernet PCIe driver: tg3
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Device-2: Qualcomm Atheros AR9287 Wireless Network Adapter driver: ath9k
           IF: wlp6s0 state: down mac: <filter>
Drives:    Local Storage: total: 238.47 GiB used: 8.84 GiB (3.7%)
           ID-1: /dev/sda vendor: Samsung model: SSD 850 PRO 256GB size: 238.47 GiB https://www.linuxmint.com/start/tricia/
Partition: ID-1: / size: 233.73 GiB used: 8.84 GiB (3.8%) fs: ext4 dev: /dev/sda1
Sensors:   System Temperatures: cpu: 45.6 C mobo: N/A gpu: radeon temp: 44 C
           Fan Speeds (RPM): N/A https://www.linuxmint.com/start/tricia/
Info:      Processes: 145 Uptime: 55m Memory: 3.85 GiB used: 745.0 MiB (18.9%) Shell: bash inxi: 3.0.32
« Letzte Änderung: 01.01.2020, 16:14:03 von mintman007 »

Re: Canon MG6250 Netzwerkdrucker
« Antwort #1 am: 30.12.2019, 22:01:53 »
Diese pauschale Aussage stimmt so nicht - immerhin gibt es auch für Dein Gerät Treiber vom Hersteller!
:-)

https://www.canon.de/support/consumer_products/products/fax__multifunctionals/inkjet/pixma_mg_series/pixma_mg6250.html?type=drivers&language=de&os=linux%20(32-bit)
Lass Dich nicht verwirren - es steht zwar im link 32bit und man mußte auch "Linux 32bit" bei der Suche wählen, aber es sind beide Systeme abgedeckt.

schau mal hier - hier gibt es eine gründliche Anleitung:
https://www.linuxmintusers.de/index.php?topic=56758.0 #3 ... bezieht sich zwar in den links auf einen anderen Drucker - läßt sich aber sonst adäquat abarbeiten.

Dann zum Scanner - Du kannst noch das Sane-ppa einbinden, dann funktioniert das Scannen ggfs. auch außerhalb des Canon-eigenen "Scangearmp"
https://www.linuxmintusers.de/index.php?topic=57649.msg774707#msg774707 #1
« Letzte Änderung: 30.12.2019, 22:12:25 von Michelle_Br »

Re: Canon MG6250 Netzwerkdrucker
« Antwort #2 am: 30.12.2019, 22:43:05 »
was mach ich falsch?

rd@rd-Leppi:~/Downloads/cnijfilter-source-3.60-1/debian$ ./install
bash: ./install: Datei oder Verzeichnis nicht gefunden
rd@rd-Leppi:~/Downloads/cnijfilter-source-3.60-1/debian$

Re: Canon MG6250 Netzwerkdrucker
« Antwort #3 am: 31.12.2019, 10:20:01 »
Du hast die Anleitung nicht befolgt!
Wie ich sehe, hast Du wohl die Quelldateien (den Quellcode) versucht zu installieren? Das klappt nicht.

Bitte die Anleitung EXAKT abarbeiten!

Re: Canon MG6250 Netzwerkdrucker
« Antwort #4 am: 31.12.2019, 10:59:46 »
sorry, habe ich gestern Abend nicht richtig gelesen, war schon zu spät.
Vielleicht habe ich jetzt auch schon wieder Quatsch gemacht, mir fällt es echt schwer mich in Linux-Welt zurecht zu finden.
In der Treiber-Datei(cnijfilter-source-3.60-1) der Anleitung fand ich keine "./install".
In einer anderen Treiber-Datei (cnijfilter-mg6200series-3.60-1-deb) gab es eine Datei "./install.sh" die ich installiert habe.
Für den Scanner-Treiber sieht es genauso aus. Anleitung: "scangearmp-source-1.80-1" ohne "./install"
Anderer Treiber: "scangearmp-mg6200series-1.80-1-deb" gibt es eine ./install.sh

Ist das auch in Ordnung?
Kann ich die fehlenden Pakete über die Synaptik-Paketverwaltung installieren?

Hier die Terminal-Ausgabe dazurd@rd-Leppi:~/Downloads/cnijfilter-mg6200series-3.60-1-deb$ ./install
bash: ./install: Datei oder Verzeichnis nicht gefunden
rd@rd-Leppi:~/Downloads/cnijfilter-mg6200series-3.60-1-deb$ ./install.sh
[sudo] Passwort für rd:       
==================================================
rd@rd-Leppi:~/Downloads/cnijfilter-mg6200series-3.60-1-deb$ ./install
bash: ./install: Datei oder Verzeichnis nicht gefunden
rd@rd-Leppi:~/Downloads/cnijfilter-mg6200series-3.60-1-deb$ ./install.sh
[sudo] Passwort für rd:       
==================================================

Canon Inkjet Printer Driver
Version 3.60
Copyright CANON INC. 2001-2011
All Rights Reserved.

==================================================
Command executed = sudo dpkg -iG ./packages/cnijfilter-common_3.60-1_amd64.deb
Vormals nicht ausgewähltes Paket cnijfilter-common wird gewählt.
(Lese Datenbank ... 332829 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../cnijfilter-common_3.60-1_amd64.deb ...
Entpacken von cnijfilter-common (3.60-1) ...
cnijfilter-common (3.60-1) wird eingerichtet ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...
Command executed = sudo dpkg -iG ./packages/cnijfilter-mg6200series_3.60-1_amd64.deb
Vormals nicht ausgewähltes Paket cnijfilter-mg6200series wird gewählt.
(Lese Datenbank ... 332845 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../cnijfilter-mg6200series_3.60-1_amd64.deb ...
Entpacken von cnijfilter-mg6200series (3.60-1) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von cnijfilter-mg6200series:
 cnijfilter-mg6200series hängt ab von libpango1.0-0 (>= 1.12.3); aber:
  Paket libpango1.0-0 ist nicht installiert.
 cnijfilter-mg6200series hängt ab von libpng12-0 (>= 1.2.8rel); aber:
  Paket libpng12-0 ist nicht installiert.
 cnijfilter-mg6200series hängt ab von libtiff4; aber:
  Paket libtiff4 ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes cnijfilter-mg6200series (--install):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 cnijfilter-mg6200series
Command executed = sudo dpkg -P cnijfilter-mg6200series
(Lese Datenbank ... 333048 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von cnijfilter-mg6200series (3.60-1) ...rd@rd-Leppi:~/Downloads/cnijfilter-mg6200series-3.60-1-deb$ ./install
bash: ./install: Datei oder Verzeichnis nicht gefunden
rd@rd-Leppi:~/Downloads/cnijfilter-mg6200series-3.60-1-deb$ ./install.sh
[sudo] Passwort für rd:       
==================================================

Canon Inkjet Printer Driver
Version 3.60
Copyright CANON INC. 2001-2011
All Rights Reserved.

==================================================
Command executed = sudo dpkg -iG ./packages/cnijfilter-common_3.60-1_amd64.deb
Vormals nicht ausgewähltes Paket cnijfilter-common wird gewählt.
(Lese Datenbank ... 332829 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../cnijfilter-common_3.60-1_amd64.deb ...
Entpacken von cnijfilter-common (3.60-1) ...
cnijfilter-common (3.60-1) wird eingerichtet ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...
Command executed = sudo dpkg -iG ./packages/cnijfilter-mg6200series_3.60-1_amd64.deb
Vormals nicht ausgewähltes Paket cnijfilter-mg6200series wird gewählt.
(Lese Datenbank ... 332845 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../cnijfilter-mg6200series_3.60-1_amd64.deb ...
Entpacken von cnijfilter-mg6200series (3.60-1) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von cnijfilter-mg6200series:
 cnijfilter-mg6200series hängt ab von libpango1.0-0 (>= 1.12.3); aber:
  Paket libpango1.0-0 ist nicht installiert.
 cnijfilter-mg6200series hängt ab von libpng12-0 (>= 1.2.8rel); aber:
  Paket libpng12-0 ist nicht installiert.
 cnijfilter-mg6200series hängt ab von libtiff4; aber:
  Paket libtiff4 ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes cnijfilter-mg6200series (--install):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 cnijfilter-mg6200series
Command executed = sudo dpkg -P cnijfilter-mg6200series
(Lese Datenbank ... 333048 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von cnijfilter-mg6200series (3.60-1) ...
Löschen der Konfigurationsdateien von cnijfilter-mg6200series (3.60-1) ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...
Command executed = sudo dpkg -P cnijfilter-common
(Lese Datenbank ... 332844 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von cnijfilter-common (3.60-1) ...
Löschen der Konfigurationsdateien von cnijfilter-common (3.60-1) ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...rd@rd-Leppi:~/Downloads/cnijfilter-mg6200series-3.60-1-deb$ ./install
bash: ./install: Datei oder Verzeichnis nicht gefunden
rd@rd-Leppi:~/Downloads/cnijfilter-mg6200series-3.60-1-deb$ ./install.sh
[sudo] Passwort für rd:       
==================================================

Canon Inkjet Printer Driver
Version 3.60
Copyright CANON INC. 2001-2011
All Rights Reserved.

==================================================
Command executed = sudo dpkg -iG ./packages/cnijfilter-common_3.60-1_amd64.deb
Vormals nicht ausgewähltes Paket cnijfilter-common wird gewählt.
(Lese Datenbank ... 332829 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../cnijfilter-common_3.60-1_amd64.deb ...
Entpacken von cnijfilter-common (3.60-1) ...
cnijfilter-common (3.60-1) wird eingerichtet ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...
Command executed = sudo dpkg -iG ./packages/cnijfilter-mg6200series_3.60-1_amd64.deb
Vormals nicht ausgewähltes Paket cnijfilter-mg6200series wird gewählt.
(Lese Datenbank ... 332845 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../cnijfilter-mg6200series_3.60-1_amd64.deb ...
Entpacken von cnijfilter-mg6200series (3.60-1) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von cnijfilter-rd@rd-Leppi:~/Downloads/cnijfilter-mg6200series-3.60-1-deb$ ./install
bash: ./install: Datei oder Verzeichnis nicht gefunden
rd@rd-Leppi:~/Downloads/cnijfilter-mg6200series-3.60-1-deb$ ./install.sh
[sudo] Passwort für rd:       
==================================================

Canon Inkjet Printer Driver
Version 3.60
Copyright CANON INC. 2001-2011
All Rights Reserved.

==================================================
Command executed = sudo dpkg -iG ./packages/cnijfilter-common_3.60-1_amd64.deb
Vormals nicht ausgewähltes Paket cnijfilter-common wird gewählt.
(Lese Datenbank ... 332829 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../cnijfilter-common_3.60-1_amd64.deb ...
Entpacken von cnijfilter-common (3.60-1) ...
cnijfilter-common (3.60-1) wird eingerichtet ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...
Command executed = sudo dpkg -iG ./packages/cnijfilter-mg6200series_3.60-1_amd64.deb
Vormals nicht ausgewähltes Paket cnijfilter-mg6200series wird gewählt.
(Lese Datenbank ... 332845 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../cnijfilter-mg6200series_3.60-1_amd64.deb ...
Entpacken von cnijfilter-mg6200series (3.60-1) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von cnijfilter-mg6200series:
 cnijfilter-mg6200series hängt ab von libpango1.0-0 (>= 1.12.3); aber:
  Paket libpango1.0-0 ist nicht installiert.
 cnijfilter-mg6200series hängt ab von libpng12-0 (>= 1.2.8rel); aber:
  Paket libpng12-0 ist nicht installiert.
 cnijfilter-mg6200series hängt ab von libtiff4; aber:
  Paket libtiff4 ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes cnijfilter-mg6200series (--install):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 cnijfilter-mg6200series
Command executed = sudo dpkg -P cnijfilter-mg6200series
(Lese Datenbank ... 333048 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von cnijfilter-mg6200series (3.60-1) ...
Löschen der Konfigurationsdateien von cnijfilter-mg6200series (3.60-1) ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...
Command executed = sudo dpkg -P cnijfilter-common
(Lese Datenbank ... 332844 Dateien und Verzeichnisse sind derzeit inrd@rd-Leppi:~/Downloads/cnijfilter-mg6200series-3.60-1-deb$ ./install
bash: ./install: Datei oder Verzeichnis nicht gefunden
rd@rd-Leppi:~/Downloads/cnijfilter-mg6200series-3.60-1-deb$ ./install.sh
[sudo] Passwort für rd:       
==================================================

Canon Inkjet Printer Driver
Version 3.60
Copyright CANON INC. 2001-2011
All Rights Reserved.

==================================================
Command executed = sudo dpkg -iG ./packages/cnijfilter-common_3.60-1_amd64.deb
Vormals nicht ausgewähltes Paket cnijfilter-common wird gewählt.
(Lese Datenbank ... 332829 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../cnijfilter-common_3.60-1_amd64.deb ...
Entpacken von cnijfilter-common (3.60-1) ...
cnijfilter-common (3.60-1) wird eingerichtet ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...
Command executed = sudo dpkg -iG ./packages/cnijfilter-mg6200series_3.60-1_amd64.deb
Vormals nicht ausgewähltes Paket cnijfilter-mg6200series wird gewählt.
(Lese Datenbank ... 332845 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../cnijfilter-mg6200series_3.60-1_amd64.deb ...
Entpacken von cnijfilter-mg6200series (3.60-1) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von cnijfilter-mg6200series:
 cnijfilter-mg6200series hängt ab von libpango1.0-0 (>= 1.12.3); aber:
  Paket libpango1.0-0 ist nicht installiert.
 cnijfilter-mg6200series hängt ab von libpng12-0 (>= 1.2.8rel); aber:
  Paket libpng12-0 ist nicht installiert.
 cnijfilter-mg6200series hängt ab von libtiff4; aber:
  Paket libtiff4 ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes cnijfilter-mg6200series (--install):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 cnijfilter-mg6200series
Command executed = sudo dpkg -P cnijfilter-mg6200series
(Lese Datenbank ... 333048 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von cnijfilter-mg6200series (3.60-1) ...
Löschen der Konfigurationsdateien von cnijfilter-mg6200series (3.60-1) ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...
Command executed = sudo dpkg -P cnijfilter-common
(Lese Datenbank ... 332844 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von cnijfilter-common (3.60-1) ...
Löschen der Konfigurationsdateien von cnijfilter-common (3.60-1) ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...rd@rd-Leppi:~/Downloads/cnijfilter-mg6200series-3.60-1-deb$ ./install
bash: ./install: Datei oder Verzeichnis nicht gefunden
rd@rd-Leppi:~/Downloads/cnijfilter-mg6200series-3.60-1-deb$ ./install.sh
[sudo] Passwort für rd:       
==================================================

Canon Inkjet Printer Driver
Version 3.60
Copyright CANON INC. 2001-2011
All Rights Reserved.

==================================================
Command executed = sudo dpkg -iG ./packages/cnijfilter-common_3.60-1_amd64.deb
Vormals nicht ausgewähltes Paket cnijfilter-common wird gewählt.
(Lese Datenbank ... 332829 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../cnijfilter-common_3.60-1_amd64.deb ...
Entpacken von cnijfilter-common (3.60-1) ...
cnijfilter-common (3.60-1) wird eingerichtet ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...
Command executed = sudo dpkg -iG ./packages/cnijfilter-mg6200series_3.60-1_amd64.deb
Vormals nicht ausgewähltes Paket cnijfilter-mg6200series wird gewählt.
(Lese Datenbank ... 332845 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../cnijfilter-mg6200series_3.60-1_amd64.deb ...
Entpacken von cnijfilter-mg6200series (3.60-1) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von cnijfilter-mg6200series:
 cnijfilter-mg6200series hängt ab von libpango1.0-0 (>= 1.12.3); aber:
  Paket libpango1.0-0 ist nicht installiert.
 cnijfilter-mg6200series hängt ab von libpng12-0 (>= 1.2.8rel); aber:
  Paket libpng12-0 ist nicht installiert.
 cnijfilter-mg6200series hängt ab von libtiff4; aber:
  Paket libtiff4 ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes cnijfilter-mg6200series (--install):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 cnijfilter-mg6200series
Command executed = sudo dpkg -P cnijfilter-mg6200series
(Lese Datenbank ... 333048 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von cnijfilter-mg6200series (3.60-1) ...
Löschen der Konfigurationsdateien von cnijfilter-mg6200series (3.60-1) ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...
Command executed = sudo dpkg -P cnijfilter-commonrd@rd-Leppi:~/Downloads/cnijfilter-mg6200series-3.60-1-deb$ ./install
bash: ./install: Datei oder Verzeichnis nicht gefunden
rd@rd-Leppi:~/Downloads/cnijfilter-mg6200series-3.60-1-deb$ ./install.sh
[sudo] Passwort für rd:       
==================================================

Canon Inkjet Printer Driver
Version 3.60
Copyright CANON INC. 2001-2011
All Rights Reserved.

==================================================
Command executed = sudo dpkg -iG ./packages/cnijfilter-common_3.60-1_amd64.deb
Vormals nicht ausgewähltes Paket cnijfilter-common wird gewählt.
(Lese Datenbank ... 332829 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../cnijfilter-common_3.60-1_amd64.deb ...
Entpacken von cnijfilter-common (3.60-1) ...
cnijfilter-common (3.60-1) wird eingerichtet ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...
Command executed = sudo dpkg -iG ./packages/cnijfilter-mg6200series_3.60-1_amd64.deb
Vormals nicht ausgewähltes Paket cnijfilter-mg6200series wird gewählt.
(Lese Datenbank ... 332845 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../cnijfilter-mg6200series_3.60-1_amd64.deb ...
Entpacken von cnijfilter-mg6200series (3.60-1) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von cnijfilter-mg6200series:
 cnijfilter-mg6200series hängt ab von libpango1.0-0 (>= 1.12.3); aber:
  Paket libpango1.0-0 ist nicht installiert.
 cnijfilter-mg6200series hängt ab von libpng12-0 (>= 1.2.8rel); aber:
  Paket libpng12-0 ist nicht installiert.
 cnijfilter-mg6200series hängt ab von libtiff4; aber:
  Paket libtiff4 ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes cnijfilter-mg6200series (--install):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 cnijfilter-mg6200series
Command executed = sudo dpkg -P cnijfilter-mg6200series
(Lese Datenbank ... 333048 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von cnijfilter-mg6200series (3.60-1) ...
Löschen der Konfigurationsdateien von cnijfilter-mg6200series (3.60-1) ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...
Command executed = sudo dpkg -P cnijfilter-common
(Lese Datenbank ... 332844 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von cnijfilter-common (3.60-1) ...
Löschen der Konfigurationsdateien von cnijfilter-common (3.60-1) ...rd@rd-Leppi:~/Downloads/cnijfilter-mg6200series-3.60-1-deb$ ./install
bash: ./install: Datei oder Verzeichnis nicht gefunden
rd@rd-Leppi:~/Downloads/cnijfilter-mg6200series-3.60-1-deb$ ./install.sh
[sudo] Passwort für rd:       
==================================================

Canon Inkjet Printer Driver
Version 3.60
Copyright CANON INC. 2001-2011
All Rights Reserved.

==================================================
Command executed = sudo dpkg -iG ./packages/cnijfilter-common_3.60-1_amd64.deb
Vormals nicht ausgewähltes Paket cnijfilter-common wird gewählt.
(Lese Datenbank ... 332829 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../cnijfilter-common_3.60-1_amd64.deb ...
Entpacken von cnijfilter-common (3.60-1) ...
cnijfilter-common (3.60-1) wird eingerichtet ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...
Command executed = sudo dpkg -iG ./packages/cnijfilter-mg6200series_3.60-1_amd64.deb
Vormals nicht ausgewähltes Paket cnijfilter-mg6200series wird gewählt.
(Lese Datenbank ... 332845 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../cnijfilter-mg6200series_3.60-1_amd64.deb ...
Entpacken von cnijfilter-mg6200series (3.60-1) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von cnijfilter-mg6200series:
 cnijfilter-mg6200series hängt ab von libpango1.0-0 (>= 1.12.3); aber:
  Paket libpango1.0-0 ist nicht installiert.
 cnijfilter-mg6200series hängt ab von libpng12-0 (>= 1.2.8rel); aber:
  Paket libpng12-0 ist nicht installiert.
 cnijfilter-mg6200series hängt ab von libtiff4; aber:
  Paket libtiff4 ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes cnijfilter-mg6200series (--install):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 cnijfilter-mg6200series
Command executed = sudo dpkg -P cnijfilter-mg6200series
(Lese Datenbank ... 333048 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von cnijfilter-mg6200series (3.60-1) ...
Löschen der Konfigurationsdateien von cnijfilter-mg6200series (3.60-1) ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...
Command executed = sudo dpkg -P cnijfilter-common
(Lese Datenbank ... 332844 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von cnijfilter-common (3.60-1) ...
Löschen der Konfigurationsdateien von cnijfilter-common (3.60-1) ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...
rd@rd-Leppi:~/Downloads/cnijfilter-mg6200series-3.60-1-deb$

Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...
rd@rd-Leppi:~/Downloads/cnijfilter-mg6200series-3.60-1-deb$

(Lese Datenbank ... 332844 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von cnijfilter-common (3.60-1) ...
Löschen der Konfigurationsdateien von cnijfilter-common (3.60-1) ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...
rd@rd-Leppi:~/Downloads/cnijfilter-mg6200series-3.60-1-deb$

rd@rd-Leppi:~/Downloads/cnijfilter-mg6200series-3.60-1-deb$
stalliert.)
Entfernen von cnijfilter-common (3.60-1) ...
Löschen der Konfigurationsdateien von cnijfilter-common (3.60-1) ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...
rd@rd-Leppi:~/Downloads/cnijfilter-mg6200series-3.60-1-deb$
mg6200series:
 cnijfilter-mg6200series hängt ab von libpango1.0-0 (>= 1.12.3); aber:
  Paket libpango1.0-0 ist nicht installiert.
 cnijfilter-mg6200series hängt ab von libpng12-0 (>= 1.2.8rel); aber:
  Paket libpng12-0 ist nicht installiert.
 cnijfilter-mg6200series hängt ab von libtiff4; aber:
  Paket libtiff4 ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes cnijfilter-mg6200series (--install):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 cnijfilter-mg6200series
Command executed = sudo dpkg -P cnijfilter-mg6200series
(Lese Datenbank ... 333048 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von cnijfilter-mg6200series (3.60-1) ...
Löschen der Konfigurationsdateien von cnijfilter-mg6200series (3.60-1) ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...
Command executed = sudo dpkg -P cnijfilter-common
(Lese Datenbank ... 332844 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von cnijfilter-common (3.60-1) ...
Löschen der Konfigurationsdateien von cnijfilter-common (3.60-1) ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...
rd@rd-Leppi:~/Downloads/cnijfilter-mg6200series-3.60-1-deb$

rd@rd-Leppi:~/Downloads/cnijfilter-mg6200series-3.60-1-deb$

Löschen der Konfigurationsdateien von cnijfilter-mg6200series (3.60-1) ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...
Command executed = sudo dpkg -P cnijfilter-common
(Lese Datenbank ... 332844 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von cnijfilter-common (3.60-1) ...
Löschen der Konfigurationsdateien von cnijfilter-common (3.60-1) ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...
rd@rd-Leppi:~/Downloads/cnijfilter-mg6200series-3.60-1-deb$

Canon Inkjet Printer Driver
Version 3.60
Copyright CANON INC. 2001-2011
All Rights Reserved.

==================================================
Command executed = sudo dpkg -iG ./packages/cnijfilter-common_3.60-1_amd64.deb
Vormals nicht ausgewähltes Paket cnijfilter-common wird gewählt.
(Lese Datenbank ... 332829 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../cnijfilter-common_3.60-1_amd64.deb ...
Entpacken von cnijfilter-common (3.60-1) ...
cnijfilter-common (3.60-1) wird eingerichtet ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...
Command executed = sudo dpkg -iG ./packages/cnijfilter-mg6200series_3.60-1_amd64.deb
Vormals nicht ausgewähltes Paket cnijfilter-mg6200series wird gewählt.
(Lese Datenbank ... 332845 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../cnijfilter-mg6200series_3.60-1_amd64.deb ...
Entpacken von cnijfilter-mg6200series (3.60-1) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von cnijfilter-mg6200series:
 cnijfilter-mg6200series hängt ab von libpango1.0-0 (>= 1.12.3); aber:
  Paket libpango1.0-0 ist nicht installiert.
 cnijfilter-mg6200series hängt ab von libpng12-0 (>= 1.2.8rel); aber:
  Paket libpng12-0 ist nicht installiert.
 cnijfilter-mg6200series hängt ab von libtiff4; aber:
  Paket libtiff4 ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes cnijfilter-mg6200series (--install):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Fehler traten auf beim Bearbeiten von:
 cnijfilter-mg6200series
Command executed = sudo dpkg -P cnijfilter-mg6200series
(Lese Datenbank ... 333048 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von cnijfilter-mg6200series (3.60-1) ...
Löschen der Konfigurationsdateien von cnijfilter-mg6200series (3.60-1) ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...
Command executed = sudo dpkg -P cnijfilter-common
(Lese Datenbank ... 332844 Dateien und Verzeichnisse sind derzeit installiert.)
Entfernen von cnijfilter-common (3.60-1) ...
Löschen der Konfigurationsdateien von cnijfilter-common (3.60-1) ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...
rd@rd-Leppi:~/Downloads/cnijfilter-mg6200series-3.60-1-deb$
« Letzte Änderung: 31.12.2019, 11:21:09 von mintman007 »

Re: Canon MG6250 Netzwerkdrucker
« Antwort #5 am: 31.12.2019, 14:31:02 »

Mach´ langsam .... lese erst .... wenn Du es nicht weißt, frage erst und agiere dann! Man kann sich schneller das System verbasteln, als einem lieb ist, wenn man wie bei Win agiert, nicht? *lächelt

Die Quelldatei ist eine Datei, die für die jeweilige Plattform erst noch kompiliert werden muss - die bleibt vollkommen außen vor! Du solltest die Anleitung lesen - da steht nirgendwo etwas von einer Quelldatei, die es zu downloaden gilt!

Die libtiff4 installierst Du von hier
http://old-releases.ubuntu.com/ubuntu/pool/universe/t/tiff3/libtiff4_3.9.7-2ubuntu1_amd64.deb
... die *.deb einfach öffnen und der Rest geschieht automatisch.

Hier noch eine gute Zusammenfassung:
https://mun-steiner.de/wordpress/index.php/linux/scannen-und-drucken/canon-software-pixma-mg5250/libtiff4-erforderlich/

Die anderen beiden fehlenden Dateien suchst Du über "Synaptic" (die Paketverwaltung) in Deinem System. Bitte geben dazu die Namen exakt ein - WICHTIG!
Hier dazu eine Zusammenfassung:
https://mun-steiner.de/wordpress/index.php/linux/scannen-und-drucken/canon-software-pixma-mg5250/libpng12-erforderlich/

Prüfe auch, ob Du ggfs. diese Datei noch brauchst:
sudo apt-get install lib32stdc++6Quelle: https://wiki.ubuntuusers.de/Drucker/Canon/

Dann startest Du die Treiberinstallation noch einmal ... jeweils die Debian - Dateien bitte.

Danach neu booten.
« Letzte Änderung: 31.12.2019, 14:53:55 von Michelle_Br »

Re: Canon MG6250 Netzwerkdrucker
« Antwort #6 am: 31.12.2019, 14:54:18 »
Meine Ohren sind jetzt ganz schön rot vom langziehen :D, ist schon o.k. hab ja verstanden - erst fragen.
Also, ist dann der Treiber "cnijfilter-mg6200series-3.60-1-deb" der richtige und nicht der in deiner Auswahl?

Wenn ich es richtig verstanden habe funktioniert die Treiber-Installation erst wenn libtiff4, libpango1.0-0, libpng12-0 installiert sind ?????
« Letzte Änderung: 31.12.2019, 15:06:46 von mintman007 »

Re: Canon MG6250 Netzwerkdrucker
« Antwort #7 am: 31.12.2019, 15:13:22 »
*lacht
Wir sind ja ganz lieb...... :-*

Zuerst müssen natürlich die fehlenden Pakete installiert werden (siehe Terminalausgaben) ... die:
- libtiff4
- libpango1.0-0
- libpng12-0

Das liegt wohl daran, dass bei der hohen "Schlagzahl" der Linux-Entwicklungen die Hersteller mit der jeweils richtigen Treiberpflege nicht mehr so richtig nachkommen / dies sogar teilweise nicht richtig wollen. Der unsäglichen Machtposition von "Winzigweich" (Micros.....) und dem angebissenen Apfel sei Undank.

Achte bitte bei den Treiberinstallationen auf die Abfragen, wie das Gerät angeschlossen ist bzw. angesprochen werden soll (USB, WLAN, evtl. Lan?) und beantworte diese richtig, damit die Kommunikation den richtigen Weg findet.
Dann den Druckertreiber (damit das Gerät überhaupt gefunden wird - hier die Debian-Pakete, weil Mint auf Ubuntu und das wiederrum auf Debian basiert:
MG6200 series IJ Printer Driver Ver. 3.60 for Linux (debian Packagearchive)

dann Scannerteil:
MG6200 series ScanGear MP Ver. 1.80 for Linux (debian Packagearchive)

Meine Beispiele dienen ja nur dem Herangehen, wie man es macht ... man muss natürlich die richtigen Treiber für DEIN Gerät installieren, gelle?
:-)

Vergiss auch das Sane-ppa nicht, damit Du ggfs außerhalb des Canon-eigenen Scangearmp scannen kannst. Nach einem Neustart könnte es nämlich sein, dass Du dann mit allen Programmen unter Linux scannen kannst ... XSane, Simple Scan etc. - regulär geht das meist nicht.

« Letzte Änderung: 31.12.2019, 15:19:17 von Michelle_Br »

Re: Canon MG6250 Netzwerkdrucker
« Antwort #8 am: 01.01.2020, 02:35:06 »
Hurra ;D ,ich habs hinbekommen, der Canon druckt und scannt wieder.
Danke Michelle.

Nach der Silvesterparty habe ich gleich noch zusammen gefasst wie ich es genau gemacht habe.
Damit weitere Neulinge mit ähnlichen Drucken schneller zum Ziel kommen.


1. Treiber(für64-bit) von Canon laden, speichern und entpacken
   -Drucker: cnijfilter-mg6200series-3.60-1-deb
   -Scanner: scangearmp-mg6200series-1.80-1-deb
https://www.canon.de/support/consumer_products/products/fax__multifunctionals/inkjet/pixma_mg_series/pixma_mg6250.html?type=drivers&language=de&os=linux%20(64-bit)

2. Fehlende Dateien laden(libtiff4, libpango1.0-0, libpng12-0)
   -Die libtiff4 wird von hier automatisch installiert, durch „OK“ drücken
http://old-releases.ubuntu.com/ubuntu/pool/universe/t/tiff3/libtiff4_3.9.7-2ubuntu1_amd64.deb
   
   -Die libpango1.0-0 in Synaptic-Paketverwaltung suchen und installieren
 
   -Die libpng12-0 wird von hier automatisch installiert, durch „OK“ drücken
 https://mirrors.aliyun.com/ubuntu/pool/main/libp/libpng/libpng12-0_1.2.54-1ubuntu1.1_amd64.deb

   -Prüfen ob diese Datei benötigt wird(Quelle: https://wiki.ubuntuusers.de/Drucker/Canon/):
         sudo apt-get install lib32stdc++6

Vorsicht: Bei Treiberinstallationen auf Abfragen achten und richtig beantworten, damit die Kommunikation den richtigen Weg findet.
    -wie ist das Gerät angeschlossen (USB, WLAN, LAN)
    -Gerätename

3. Treiber installieren
   -rechte Maustaste auf „cnijfilter-mg6200series-3.60-1-deb“ im Terminal ausführen
    mit „./install.sh“ installieren
   -rechte Maustaste auf „scangearmp-mg6200series-1.80-1-deb“ im Terminal ausführen
    mit „./install.sh“ installieren


4. Sane-ppa die Scanner-Schnittstelle für Linux im Terminal installieren

   sudo add-apt-repository ppa:rolfbensch/sane-git-> Enter
   sudo apt-get update-> Enter
   sudo apt-get dist-upgrade-> Enter
   sudo reboot-> Enter

Re: Canon MG6250 Netzwerkdrucker
« Antwort #9 am: 01.01.2020, 14:12:36 »
Absolut vorbildlich (!), dass Du diese Zusammenfassung Deiner Problemlösung erstellt hast!
Sowas macht es für andere Suchende wesentlich leichter! Danke dafür.  :-*

Wärst Du bitte noch so lieb, in Deinem Eröffnungsthread den Präfix auf "erledigt" zu setzen, damit Andere sehen, dass hier die Er-lösung steht?
:-)

 

1. Advent
1. Advent