Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
06.07.2020, 11:08:17

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 668967
  • Themen insgesamt: 54177
  • Heute online: 386
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Automatischer Wechsel der Auflösung mit ungültiger Refreshrate  (Gelesen 612 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

EDIT: ERLEDIGT entfernt.

Hi @all

Beim wechsel in eine andere Auflösung wird scheinbar immer die höchstmögliche Refreshrate bevorzugt. Leider ist die bei mir aus irgendeinem Grund eine, die nicht vom Monitor unterstützt wird.

launacorp@Moon:~$ xrandr --query
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
HDMI-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 531mm x 298mm
   1920x1080     60.00*+  59.96    50.00    59.94    59.93 
   1680x1050     69.88    59.95    59.88 
   1600x1024     60.17 
   1400x1050     74.76    70.00    59.98 
   1600x900      59.95    60.00    59.82 
   1280x1024     75.02    60.02 
   1440x900      60.00    59.89 
   1400x900      59.96    59.88 
   1280x960      60.00 
   1440x810      59.97 
   1368x768      59.88    59.85 
   1360x768      59.80    59.96 
   1280x800      59.99    59.97    59.81    59.91 
   1152x864      75.00    75.00    70.00    60.00 
   1280x720      60.00    59.99    59.86    60.00    50.00    59.94    59.74 
   1024x768      75.05    60.04    75.03    70.07    60.00 
   960x720       75.00    60.00 
   928x696       75.00    60.05 
   896x672       75.05    60.01 
   1024x576      59.95    59.96    59.90    59.82 
   960x600       59.93    60.00 
   832x624       74.55 
   960x540       59.96    59.99    59.63    59.82 
   800x600       75.00    70.00    65.00    60.00    72.19    75.00    60.32    56.25 
   840x525       74.96    69.88    60.01    59.88 
   864x486       59.92    59.57 
   720x576       50.00 
   800x512       60.17 
   700x525       74.76    70.06    59.98 
   800x450       59.95    59.82 
   720x480       60.00    59.94 
   640x512       75.02    60.02 
   720x450       59.89 
   700x450       59.96    59.88 
   640x480       60.00    75.00    72.81    75.00    60.00    59.94 
   720x405       59.51    58.99 
   720x400       70.08 
   684x384       59.88    59.85 
   680x384       59.80    59.96 
   640x400       59.88    59.98 
   576x432       75.00    75.00    70.00    60.06 
   640x360       59.86    59.83    59.84    59.32 
   512x384       75.03    70.07    60.00 
   512x288       60.00    59.92 
   416x312       74.66 
   480x270       59.63    59.82 
   400x300       72.19    75.12    60.32    56.34 
   432x243       59.92    59.57 
   320x240       72.81    75.00    60.05 
   360x202       59.51    59.13 
   320x180       59.84    59.32

Ich weiß grade nur nicht, warum das Programm "Anzeige" mir diese nicht unterstützte Refreshrate anbietet. (Bild)

Grundsätzlich kann ich es ja manuell auswählen, was ja okay wäre. Nur hab ich da das eine oder andere Spiel bei Lutris, wo in der Konfiguration der Wechsel der Auflösung notwendig ist für den Vollbildmodus im Spiel. Der wird aber immer auf die höchstmögliche Frequenz durchgeführt.

Ich denke an der Stellschraube, wo ich drehen muss um das Programm "Anzeige" zur Vernunft zu bringen, muss ich was ändern um den gewünschten Erfolg zu bekommen.
Das Problem trat "vorher" nicht auf, erst als ich den Monitor wechseln musste, weil der alte defekt war.

launacorp@Moon:~$ tree /etc/X11/Xsession.d/
/etc/X11/Xsession.d/
├── 20dbus_xdg-runtime
├── 20flatpak
├── 20x11-common_process-args
├── 30x11-common_xresources
├── 35x11-common_xhost-local
├── 36x11-common_xhost-boinc
├── 40x11-common_xsessionrc
├── 50x11-common_determine-startup
├── 55xfce4-session
├── 60x11-common_localhost
├── 60x11-common_xdg_path
├── 60xbrlapi
├── 65compiz_profile-on-session
├── 70gconfd_path-on-session
├── 70im-config_launch
├── 75dbus_dbus-launch
├── 90atk-adaptor
├── 90gpg-agent
├── 90qt-a11y
├── 90x11-common_ssh-agent
├── 95dbus_update-activation-env
├── 99mint
├── 99qt5ct
└── 99x11-common_start

0 directories, 24 files
System:    Host: Moon Kernel: 5.4.6-050406-generic x86_64 bits: 64 Desktop: Xfce 4.14.1 Distro: Linux Mint 19.3 Tricia
Machine:   Type: Desktop Mobo: ASUSTeK model: PRIME X370-PRO v: Rev X.0x serial: <filter> UEFI: American Megatrends v: 5216
           date: 09/02/2019
CPU:       Topology: 6-Core model: AMD Ryzen 5 2600X bits: 64 type: MT MCP L2 cache: 3072 KiB
           Speed: 1984 MHz min/max: 2200/3600 MHz Core speeds (MHz): 1: 1984 2: 1933 3: 2188 4: 2150 5: 1901 6: 2169 7: 2179
           8: 2074 9: 1996 10: 2071 11: 2170 12: 2190
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] driver: amdgpu v: kernel
           Display: x11 server: X.Org 1.19.6 driver: ati,modesetting unloaded: fbdev,radeon,vesa resolution: 1920x1080~60Hz
           OpenGL: renderer: AMD Radeon RX 5700 (NAVI10 DRM 3.35.0 5.4.6-050406-generic LLVM 9.0.0)



EDIT:
Hab mal wie im UU-Wiki beschrieben eine xorg.conf erstellt mit Standardparametern. Nach nem Neustart hatte ich dann nur noch Konsole. Dort dann die xorg.conf gelöscht, Neustart und wech war das Problem.
« Letzte Änderung: 30.12.2019, 08:55:03 von launacorp »

Hi @all

Beim wechsel in eine andere Auflösung wird scheinbar immer die höchstmögliche Refreshrate bevorzugt. Leider ist die bei mir aus irgendeinem Grund eine, die nicht vom Monitor unterstützt wird.

......

EDIT:
Hab mal wie im UU-Wiki beschrieben eine xorg.conf erstellt mit Standardparametern. Nach nem Neustart hatte ich dann nur noch Konsole. Dort dann die xorg.conf gelöscht, Neustart und wech war das Problem.

Na das ist ja geil.. hört sich ziemlich ähnlich dem meinen Problem an

Ich habe derzeit das Problem, daß ich nach drei reibungsfreiem Jahren Betrieb (Mint 18.1/2 auf Zbox Nano CI327 an einem Samsung 4k 50Zoll Fernseher nun endlich mal updaten wollte (eigentlich hat mich nur pavucontrol genervt - ich mußte immer manuell den ausgang umstellen, ansonsten hätt ich es gelassen) und bei mir genau das beschriebene Problem aufgetaucht ist. Installation "brach immer ab" mit der Meldung des Fernsehers, daß die Auflösung nicht erkannt wird. Mit Mint 18, 19.1, 19.2 klappte das problemlos. Nutze immer MATE.

Nun muß ich also 19.2 installieren, mir die Auflösungen ansehen, mit denen es funzt und diese dann manuell mit einem anderen Monitor einstellen, Monitor umstöpseln (in der Hoiffnung, die einstellungen bleien so)dann hochfahren. Man gut, daß es bootfähige USB Sticks gibt :-))

Meint Ihr, das könnte zum Erfolg führen? Ich hatte bereits versucht, das System am kleinen Monitor mit 1920 x 1080 abzuspeichern - diese Auflösung kennt der Moni, aber leider fährt der Rechner wohl, wie oben beschrieben in irgendeiner andere Auflösung hoch :-|

@Launacorb, darf ich dich evtl. dazu nochmal nerven, wenn ich nicht ganz zurecht komme?
Bin jetzt nicht der Linux-Oberguru..  aber ein paar zeilen in xorg.conf werde ich schon hinbekommen..

Kann ich evtl. die xorg.conf von 19.1 einfach kopieren?? Dann betshet nicht die gefahr, dß ich dummes zeug schreibe ...


Gruß!

 



Kann ich evtl. die xorg.conf von 19.1 einfach kopieren?? Dann betshet nicht die gefahr, dß ich dummes zeug schreibe ...
Solange du deine jetzige xorg.conf sicherst und wieder zurückspielen kannst, dann is es ein Versuch wert.


Bei mir tritt das Symptom sporadisch immer noch auf. Evtl auch öfters. Das kann ich aber so nicht sagen, da ich nicht jedes Mal, wenn ich den PC nutze auch in ne 1024er Auflösung wechsel.

@onkelhotte
Die Symptome sehen sehr sehr ähnlich aus, da gebe ich dir Recht. Allerdings haben will ich mein Symptom nicht auf Mint per se schieben, da ich doch ziemlich experimentell unterwegs bin mit meinem System. Mein System startet ja immer mit der höchst möglichen Auflösung. Das wäre an deinem 4K TV immerhin 4K. Da bezweifel ich doch stark, dass deine Grafikkarte mehr als 60Hz schafft, zumindest laut Zotac schafft die es nicht. 4K sollte dein PC dann schon liefern mit einer Refreshrate von 60Hz, die vermutlich dein TV auch schaffen sollte.

Bin jetzt nicht der Linux-Oberguru
ich auch nicht  ;)
ein paar zeilen in xorg.conf werde ich schon hinbekommen
Ich halte dich nicht auf. Kopiere deine originale vorher. Laut UU-Wiki ist eine xorg.conf aber nicht (mehr) zwingend notwendig, also auch mal ohne testen.

Viel Zeit werde ich wohl nie nächsten 2-3 Tage nicht haben mich weiter mit diesem Problem zu beschäftigen. Heute muss ich am Auto schrauben, damit ich unseren Besuch Neujahr auch sicher Abholen kann. Hausputz etc muss auch noch erledigt werden. Gutes gelingen also bei dir. Ich bin dann wohl erst im neuen Jahr wieder aktiv.

EDIT:
https://www.reddit.com/r/Ubuntu/comments/9kzmxa/is_it_normal_that_ubuntu_shows_me_the_11994_hz/

Scheint, als hätten nicht nur wir solch ein Problem
« Letzte Änderung: 30.12.2019, 09:21:58 von launacorp »

Hi,

erstmal vielen Dank für die schnelle Antwort - find ich immer prima, wenn andere sich bei Problemen mitteilen.

Also da die Kiste vorher anstandslos mit 18.1 und 2 lief und ich - man lernt ja dazu - 19.1 und 19.2 installieren und die Auflösung ändern konnte, schiebe ich es jetzt mal nicht auf die Hardware.

Solong! 

ps-
eine xorg.conf finde ich leider nicht im System. (Nirgendwo. auch keine xorg.cnf) - das wäre sicher zu einfach ;-) 
Bin gerade auf der Suche, wo Mint die Auflösungen "hingeworfen" hat, um anhand der Zeilen, die mir 19.2 rausgibt, diese manuell in 19.3 einzuimpfen - bislang vergeblich ???.

und zu Deinem Link:

ja, bei der Installation von 19.2 konnte ich teilweise 125 Hz auswählen - was definitiv nincht geht.

Tatsache ist:
18, 19.1 und 19.2 funktionieren am Fernseher, 19.3 nicht:
Der Fernseher (nicht Mint) gibt mir den Fehler: undefinierte Auflösung (sonst könnte ich ja was sehen :-)

Ich suche mal den Typ des Fernsehers raus und poste den - evtl. interssiert das ja auch andere


Hi,

so das war es jetzt erstmal,  mein Abenteuer mit Mint 19...
19.3 ging ja gar nicht; 190.2 blieb immer wieder in der Installation stecken und 19.1 zeigte mir zu Begin der Installation diverse Auflösungen, wonach im folgenden dann aber die große schlict nicht mehr gelistet wurde.

Ich habe nach einem kurzen Umweg über Ubuntu 18.4 (bringt den selben Fehler wie mint 19.3 ->  Auflösung und nem alten Antergos  Stick -- der lief..) nun wieder 18.3 drauf - das funktioniert tadellos - wie vorher.  Installiert wurtde mit Kernel 4.10.0-38, aktuell läuft 4.15.0-72.

Auflösung 3840 x 2160 (30 Hz), 55Zoll (war wohl doch kein 4K-moni, oder was haben  die für Auflösungen, reicht aber dennoch um ruckelfrei youtube o.ä. sehen zu können...

Das nervige Problem mit pavucontrol (nicht minimiert startbar.) nehm ich nun in Kauf, evtl. wird es ja bei Mint 19.4 ... 20 eine Lösung geben. Ich brauche das eben, da ich noch eine Uralt-Analog Anlage aus den 90ern habe und da braucht es halt einen Digital-> Analog Wandler, den ich nur über USB ansprechen kann, dann funzt es auch mit meinen geliebten Infinitiy Kappa 8a :-)

Spiele jetzt erstmal wieder alles drauf.

Wenn jemand eine Lösung findet, bitte "Bescheided" mir!

Danke!



Off-Topic:
hmmmm Kappa's. Sehr fein :)
Ja, die 2160 sind die 4K Auflösung.

In 19.3 versucht mal den 5.3er.Kernel. Bringen die aktuelleren AMD-Treiber darin auch nur 30 Hz, schaffen die Grafikeinheiten nicht mehr.

Die Auflösung / Einstellungen sind in der versteckten monitors. xml im /home/.config/ drin, sollte man das Minttool benutzt haben.
Bei mir wollte mal der Monitor die Frequenzeinstellung vom Nvidia Treiber nicht speichern, da standen bei mir in der besagten Datei die Einstellungen unter dem falschen DisplayPort. Ein manuelles Anpassen half.
« Letzte Änderung: 07.01.2020, 22:45:47 von Mintnix »

Hi, Launacorp,  Hier mal total OT: 

Off-Topic:
hmmmm Kappa's. Sehr fein :)
Ja, die 2160 sind die 4K Auflösung.

ja, die Kappas... Mußte einfach sein... Allein wegen der Optik - traumhaft schönes rötliches Eichenhholz - eher eine Art Möbelstück, das zudem noch gut klingt.  Aber "nur" die 8er - sonst hätte meine Frau mich erwürgt..

Wollte ich schon vor 25 Jahrenn im Studium haben, damals unerschwinglich - heute ziemlich rar und der Verstärker muß ordentlich heizen  - noch nicht 100% gelöst, das Prob.. ;D


Hi, Geobart und Mintnix,

auch Euch beiden vielen Dank für die Antworten

@Mintix,
da werde ich mal nachsehen, das Experiment mache ich aber auf einer neuen Platte, es liegen noch genug herum ;D

Nachtrag: kein minttool und keine monitors.xml vorhanden :-(

@Geobart, OK, ich hatte glaube ich in 19.1 den 5.4(?) gewählt - kann mich nicht  mehr erinnern.
Problem bei 19.3 und 19.2 war, daß ich gar nicht erst dahin kam.

Nach oder während der Installation stieg ja der Fernseher mit der Meldung "falsche Bildrate" o.ä. aus. d.h. ich konnte überhaupt nichts ändern - weil nichts gesehen...

Habe daher einen alten 1024 x 768 Moni benutzt, ebenjene Auflösung eingestellt (in der fälschlichen Hoffnung, diese wird beim Booten benutzt) dann heruntergefahren, Fernseher wieder dran, hoch gefahren -> "ungültige refreshrate"

Mit angeschlossenem Fernseher weiß ich schlicht nicht, wie ich durch die Installation komme, um etwas zu ändern. Dazu bin ich nicht Guru genug.

Das ganze führt also zur Frage:
Wie kann ich elegant im Textmodus installieren und die gewünschte Refreshrate zwingend vorgeben?
Der Fernseher macht es ja definitiv in für mich vollkommen ausreichender Qualität.

Ich weiß noch, früher zu meinen SUSE-Zeiten (ca. vor 12 Jahren..), da gab es ein Installationsprgramm (YAST), mit dem konnte man sowas im Textmodus vorwählen und erst dann die Grafik starten, aber ob es sowas überhaupt noch gibt? 
 
Vielen Dank für Eure Mühen bisher !
« Letzte Änderung: 14.01.2020, 11:13:19 von onkelhotte »

Zitat
Nachtrag: kein minttool und keine monitors.xml vorhanden :-(

Ich meine das, wo man in den Einstellungen die Bildschirmauflösung einstellen kann.
Hat man das einmal benutzt gibts auch die versteckte Datei "monitors.xml".
« Letzte Änderung: 15.01.2020, 20:23:12 von Mintnix »

ob es sowas überhaupt noch gibt?
   
Nicht in Mint.
 Aber es gibt Bootoptionen wie nomodeset , mit denen du auf einen Desktop kommst, wo du dann "Bildschirme" für die Einstellung nehmen kannst.

ob es sowas überhaupt noch gibt?
   
Nicht in Mint.
 Aber es gibt Bootoptionen wie nomodeset , mit denen du auf einen Desktop kommst, wo du dann "Bildschirme" für die Einstellung nehmen kannst.

 
 ;)
Das könnt ich mal testen ...

Danke für den Tip ..