Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
22.01.2020, 22:12:05

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 23243
  • Letzte: therob
Statistiken
  • Beiträge insgesamt: 633902
  • Themen insgesamt: 51290
  • Heute online: 2287
  • Am meisten online: 2287
  • (Heute um 19:20:24)
Benutzer Online

Autor Thema:  Linux Mint bootet langsam nach Kernel update [4.15.0-72]  (Gelesen 468 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Ich habe mein Linux von 19.1 auf 19.2 aktualisiert und dannach auch ein Kernelupgrade durchgeführt. Die Aktualiserung hat super funktioniert. Nur seitdem Kernelupgrade dauert der Bootvorgang eine gefühlte Ewigkeit.
Ich verwende den GNOME Cinnamon Desktop und folgenden Kernel 4.15.0-72-generic #81-Ubuntu SMP Tue Nov 26 12:20:02 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

dmesg gibt folgendes aus:

...
[   56.334380] thinkpad_acpi: EC reports that Thermal Table has changed
[   61.148181] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[   71.388174] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:28:primary A] flip_done timed out
[   81.628166] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[   92.033969] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  102.315824] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:28:primary A] flip_done timed out
[  112.566438] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  122.807536] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  133.047879] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:28:primary A] flip_done timed out
[  141.735875] thinkpad_acpi: EC reports that Thermal Table has changed
[  143.288071] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  151.530182] thinkpad_acpi: EC reports that Thermal Table has changed
[  153.528216] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  163.768311] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:28:primary A] flip_done timed out
[  174.008413] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  184.247950] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  194.487349] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:28:primary A] flip_done timed out
[  204.726882] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  214.966553] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  225.206318] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:28:primary A] flip_done timed out
[  235.446108] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  235.717934] thinkpad_acpi: EC reports that Thermal Table has changed
[  252.597893] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  262.837801] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  273.077727] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  283.317662] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  286.195151] thinkpad_acpi: EC reports that Thermal Table has changed
[  286.593461] thinkpad_acpi: EC reports that Thermal Table has changed
[  335.029462] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  345.269432] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  355.509396] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  363.250932] thinkpad_acpi: EC reports that Thermal Table has changed
[  365.749365] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  375.989339] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  386.229287] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:28:primary A] flip_done timed out
[  396.469253] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  406.709235] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  416.949207] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  427.445173] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  437.685155] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  447.925109] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:34:cursor A] flip_done timed out
[  458.165108] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  474.293037] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  484.533050] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:34:cursor A] flip_done timed out
[  494.772985] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  495.651566] Bluetooth: RFCOMM TTY layer initialized
[  495.651573] Bluetooth: RFCOMM socket layer initialized
[  495.651577] Bluetooth: RFCOMM ver 1.11
[  495.918906] thinkpad_acpi: EC reports that Thermal Table has changed
[  510.514649] thinkpad_acpi: EC reports that Thermal Table has changed
[  512.948937] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  523.188912] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:34:cursor A] flip_done timed out
[  533.428879] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  533.715982] thinkpad_acpi: EC reports that Thermal Table has changed
[  548.466406] thinkpad_acpi: EC reports that Thermal Table has changed
[  551.092829] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[  551.503811] thinkpad_acpi: EC reports that Thermal Table has changed
[  567.604318] thinkpad_acpi: EC reports that Thermal Table has changed
[  571.083431] hub 1-1:1.0: hub_ext_port_status failed (err = -110)
[  573.194900] usb 1-1-port6: cannot disable (err = -110)
[  578.473604] hub 1-1:1.0: hub_ext_port_status failed (err = -110)
[ 1376.631302] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[ 1386.870972] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[ 1397.110609] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:34:cursor A] flip_done timed out
[ 1407.350220] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[ 1542.769396] [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out
[ 1553.009098] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:34:cursor A] flip_done timed out
[ 1563.248750] [drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [CRTC:37:pipe A] flip_done timed out

Basierend auf dem habe ich folgendes gemacht, da im Internet dies auch empfohlen wurde und bei den meisten funktioniert hat:

sudo apt-get remove xserver-xorg-video-intel
Anschließend habe ich noch folgendes gemacht:
xed admin:///etc/default/grub und dort dann diese Zeile angepasst GRUB_CMDLINE_LINUX_DEFAULT="video=SVIDEO-1:d quiet splash" (video-SVIDEO-1:d hinzugefügt)

Mit sudo update-grup alles abgeschlossen und anschließen neugestartet. Leider startete der Laptop wieder langsam.

Was kann ich noch tun um das Problem zu lösen?
« Letzte Änderung: 11.12.2019, 13:11:28 von user0009 »

Re: Linux Mint bootet langsam nach Kernel update [4.15.0-72]
« Antwort #1 am: 10.12.2019, 13:31:40 »
Zeig mal die Ausgabe von inxi -Fz
Zitat
video=SVIDEO-1:d
Ältere Intel Hardware?

Re: Linux Mint bootet langsam nach Kernel update [4.15.0-72]
« Antwort #2 am: 10.12.2019, 15:53:48 »
Hi :)
da der unterbau gleich ist, verändert ein mint update nichts in der richtung..

vermutlich hast du durch die installation des gnome-desktops was verändert.

das allererste was natürlich ins auge fällt
Zitat
dabei auch ein Kernelupgrade durchgeführt
also nen alten versucht?

und wenn vorher alles lief, sind die paket und grub änderung garantiert nicht sinnvoll..

Re: Linux Mint bootet langsam nach Kernel update [4.15.0-72]
« Antwort #3 am: 10.12.2019, 16:02:27 »
vergleichbare Fehlermeldungen gab es u.a. hier
https://www.linuxmintusers.de/index.php?topic=55879.msg754227#msg754227
https://www.linuxmintusers.de/index.php?topic=53449.msg726904#msg726904
https://www.linuxmintusers.de/index.php?topic=55445.msg749059#msg749059

Die Lösung mit "video=SVIDEO-1:d" scheint zu funktionieren - liegt es bei dir eventuell an
Zitat
sudo update-grup

Poste bitte einmal
cat /etc/default/grub

Re: Linux Mint bootet langsam nach Kernel update [4.15.0-72]
« Antwort #4 am: 10.12.2019, 20:34:08 »
Zeig mal die Ausgabe von inxi -Fz
Zitat
video=SVIDEO-1:d
Ältere Intel Hardware?

Die Ausgabe lautet:

System:
  Host: clemens-ThinkPad-T420 Kernel: 4.15.0-72-generic x86_64 bits: 64
  Desktop: Cinnamon 4.2.4 Distro: Linux Mint 19.2 Tina
Machine:
  Type: Laptop System: LENOVO product: 4236R80 v: ThinkPad T420
  serial: <filter>
  Mobo: LENOVO model: 4236R80 serial: <filter> UEFI: LENOVO
  v: 83ET76WW (1.46 ) date: 07/05/2013
Battery:
  ID-1: BAT0 charge: 29.8 Wh condition: 72.2/84.2 Wh (86%)
CPU:
  Topology: Dual Core model: Intel Core i5-2540M bits: 64 type: MT MCP
  L2 cache: 3072 KiB
  Speed: 797 MHz min/max: 800/3300 MHz Core speeds (MHz): 1: 857 2: 811
  3: 859 4: 815
Graphics:
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
  driver: i915 v: kernel
  Device-2: NVIDIA GF119M [Quadro NVS 4200M] driver: nouveau v: kernel
  Display: x11 server: X.Org 1.19.6 driver: modesetting,nouveau
  unloaded: fbdev,vesa resolution: 1600x900~60Hz
  OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile v: 3.3 Mesa 19.0.8
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
  driver: snd_hda_intel
  Device-2: NVIDIA GF119 HDMI Audio driver: snd_hda_intel
  Sound Server: ALSA v: k4.15.0-72-generic
Network:
  Device-1: Intel 82579LM Gigabit Network driver: e1000e
  IF: enp0s25 state: down mac: <filter>
  Device-2: Intel Centrino Ultimate-N 6300 driver: iwlwifi
  IF: wlp3s0 state: up mac: <filter>
Drives:
  Local Storage: total: 447.13 GiB used: 258.37 GiB (57.8%)
  ID-1: /dev/sda vendor: SanDisk model: SDSSDA480G size: 447.13 GiB
Partition:
  ID-1: / size: 438.62 GiB used: 258.36 GiB (58.9%) fs: ext4 dev: /dev/sda2
Sensors:
  System Temperatures: cpu: 51.0 C mobo: N/A gpu: nouveau temp: 48 C
  Fan Speeds (RPM): cpu: 3546
Info:
  Processes: 257 Uptime: 11m Memory: 7.68 GiB used: 2.56 GiB (33.3%)
  Shell: bash inxi: 3.0.32

Re: Linux Mint bootet langsam nach Kernel update [4.15.0-72]
« Antwort #5 am: 10.12.2019, 20:35:01 »
Hi :)
da der unterbau gleich ist, verändert ein mint update nichts in der richtung..

vermutlich hast du durch die installation des gnome-desktops was verändert.

das allererste was natürlich ins auge fällt
Zitat
dabei auch ein Kernelupgrade durchgeführt
also nen alten versucht?

und wenn vorher alles lief, sind die paket und grub änderung garantiert nicht sinnvoll..
Es liegt am Kernel, das Update auf 19.2 lief ohne Probleme. Das Kernelupdate habe ich schon länger aus dem Grund aufgeschoben. Nur wollte ich jetzt mal auf etwas aktuelles aktualisieren.

Re: Linux Mint bootet langsam nach Kernel update [4.15.0-72]
« Antwort #6 am: 10.12.2019, 20:36:32 »
vergleichbare Fehlermeldungen gab es u.a. hier
https://www.linuxmintusers.de/index.php?topic=55879.msg754227#msg754227
https://www.linuxmintusers.de/index.php?topic=53449.msg726904#msg726904
https://www.linuxmintusers.de/index.php?topic=55445.msg749059#msg749059

Die Lösung mit "video=SVIDEO-1:d" scheint zu funktionieren - liegt es bei dir eventuell an
Zitat
sudo update-grup

Poste bitte einmal
cat /etc/default/grub

Nein grup liegt es nicht, denn der Befehl wurde richtig eingegeben. Ich habe hier nur einen Tippfehler. Das grub update war auch erfolgreich. Aber gerne poste ich mal die grub config:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="video=SVIDEO-1:d quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Re: Linux Mint bootet langsam nach Kernel update [4.15.0-72]
« Antwort #7 am: 10.12.2019, 21:16:45 »
Was mir gerade noch aufgefallen ist, es liegt offenbar an einem Treiberproblem. Die Hintergrundbeleuchtung kann ich mittels Tasten nicht mehr anpassen. Die Anzeige am Bildschirm ändert sich zwar, aber das Licht wird nicht heller oder dunkel. Wie kann ich feststellen an welchen Treiber es liegt?

Edit: Ich habe nun folgendes noch probiert den Treiber für die Grafik von xserver auf nvidia zu ändern. Dann hat das System rasch gebootet. Allerdings nachdem Login blieb ich wieder hängen. Außerdem scheint es da noch mehr Fehler zu geben. ACPI und mi_mei verursachen auch noch Probleme. Allerdings weiß ich nicht was ich da ändern muss.

Um es abzukürzen habe nun ein Rollback gemacht und bleibe vorerst mal auf der veralteten Treiberversion 4.15.0-20

Hier noch die Ausgabe vorm Kernel update

System:
  Host: clemens-ThinkPad-T420 Kernel: 4.15.0-20-generic x86_64 bits: 64
  Desktop: Cinnamon 4.2.4 Distro: Linux Mint 19.2 Tina
Machine:
  Type: Laptop System: LENOVO product: 4236R80 v: ThinkPad T420
  serial: <filter>
  Mobo: LENOVO model: 4236R80 serial: <filter> UEFI: LENOVO
  v: 83ET76WW (1.46 ) date: 07/05/2013
Battery:
  ID-1: BAT0 charge: 72.2 Wh condition: 72.2/84.2 Wh (86%)
CPU:
  Topology: Dual Core model: Intel Core i5-2540M bits: 64 type: MT MCP
  L2 cache: 3072 KiB
  Speed: 1397 MHz min/max: 800/3300 MHz Core speeds (MHz): 1: 943 2: 894
  3: 897 4: 1011
Graphics:
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
  driver: i915 v: kernel
  Device-2: NVIDIA GF119M [Quadro NVS 4200M] driver: nouveau v: kernel
  Display: x11 server: X.Org 1.19.6 driver: modesetting,nouveau
  unloaded: fbdev,vesa resolution: 1600x900~60Hz
  OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile v: 3.3 Mesa 19.0.8
Audio:
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
  driver: snd_hda_intel
  Sound Server: ALSA v: k4.15.0-20-generic
Network:
  Device-1: Intel 82579LM Gigabit Network driver: e1000e
  IF: enp0s25 state: down mac: <filter>
  Device-2: Intel Centrino Ultimate-N 6300 driver: iwlwifi
  IF: wlp3s0 state: up mac: <filter>
Drives:
  Local Storage: total: 447.13 GiB used: 260.94 GiB (58.4%)
  ID-1: /dev/sda vendor: SanDisk model: SDSSDA480G size: 447.13 GiB
Partition:
  ID-1: / size: 438.62 GiB used: 260.93 GiB (59.5%) fs: ext4 dev: /dev/sda2
Sensors:
  System Temperatures: cpu: 49.0 C mobo: N/A gpu: nouveau temp: 42 C
  Fan Speeds (RPM): cpu: 3530
Info:
  Processes: 267 Uptime: 11m Memory: 7.68 GiB used: 3.00 GiB (39.0%)
« Letzte Änderung: 11.12.2019, 10:22:10 von user0009 »

Re: Linux Mint bootet langsam nach Kernel update [4.15.0-72]
« Antwort #8 am: 11.12.2019, 12:48:50 »
Hi :)
warum schreibst du gnome desktop, wenn du cinnamon nutzt?

Zitat
Es liegt am Kernel, das Update auf 19.2 lief ohne Probleme
ja und?.. mit nem älteren aus grub gebootet?
du hast rumgefrickelt ohne die naheliegenste option zu testen? oder nur nicht geschafft uns das klar mitzuteilen?

Re: Linux Mint bootet langsam nach Kernel update [4.15.0-72]
« Antwort #9 am: 11.12.2019, 13:16:31 »
Hi :)
warum schreibst du gnome desktop, wenn du cinnamon nutzt?
Mal wo falsch nach geschaut. Habs schon ausgebessert  :)
Zitat
Es liegt am Kernel, das Update auf 19.2 lief ohne Probleme
ja und?.. mit nem älteren aus grub gebootet?
du hast rumgefrickelt ohne die naheliegenste option zu testen? oder nur nicht geschafft uns das klar mitzuteilen?
[/quote]
Ich habe wie erwähnt zuerst auf 19.2 aktualisiert. Der Kernel blieb gleich. Bis dahin hat alles wunderbar funktioniert. Erst danach habe ich auf einen neueren Kernel aktualisiert. Dann fingen die Problem an. Meine Frage ist, wie kann ich diese Lösen ohne bei dem alten Kernel zu bleiben?

Re: Linux Mint bootet langsam nach Kernel update [4.15.0-72]
« Antwort #10 am: 11.12.2019, 13:18:52 »
Hi :)
am kopf kratz.. wenn der neue kernel probleme macht, der alte aber läuft, warum mit aller gewalt, und nichts bringenden system änderungen
unbedingt den neuen haben wollen?   versionitis?