Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
25.05.2020, 17:36:55

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 662322
  • Themen insgesamt: 53566
  • Heute online: 470
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  Bildschirm friert nach einer Weile ein  (Gelesen 1039 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Bildschirm friert nach einer Weile ein
« am: 08.12.2019, 08:26:12 »
Hallo und guten Morgen,

nach langer Zeit mit einem Laptop habe ich mir nun einen PC gekauft. Erst habe ich versucht Ubuntu darauf zu installieren, weil ich das schon davor ein wenig genutzt hatte, habe es aber nicht hinbekommen. Schätzungsweise hing das irgendwie mit den Grafiktreibern zusammen.
Mit Linux Mint ging das eigentlich alles problemlos. Nach der Installation beim ersten Booten hat es mir gleich die Treiberverwaltung angeboten und mir empfohlen das Treiberpaket 435 für Nvidia zu installieren.

Es lief dann auch immer eine Weile (ein paar Stunden) recht gut und ich war zufrieden, bis mir der Bildschirm einfror. Ich konnte nichts mehr machen und habe dann per Reset-Knopf den Rechner neu gestartet. Dann ging es wieder eine Weile, usw. Da keine Fehlermeldung kommt habe ich keine Ahnung wie ich nun dem Problem auf die Spur kommen kann und hoffe, dass mir hier jemand helfen kann? Beim letzten Mal hatte ich bspw. nur zwei Firefox-Fenster offen und plötzlich stotterte er irgendwie rum und wenig später ging gar nichts mehr...

Mein System ist:
Linux Mint 19.2 Tina Cinnamon 4.2.4

MPG X570 GAMING PLUS Motherboard
AMD Ryzen 7 2700
GeForce GTX 1660 Ti
Crucial P1 1TB SSD
« Letzte Änderung: 21.12.2019, 16:08:43 von Joggl »

Re: Bildschirm friert nach einer Weile ein
« Antwort #1 am: 08.12.2019, 10:40:34 »
Herzlich willkommen im Grünen! :)
Zeige bitte deine Hardware mit
inxi -FzAusgabe bitte zur besseren Lesbarkeit als Text im Codeblock zeigen. Dazu den Text im Editor auswählen und mit der '#' Schaltfläche formatieren. Siehe auch oben im Forums-Menü unter "Hilfe".

Ich würde bei neuer Hardware in der Akt-Verwaltung unter Linux Kernel den aktuellsten Kernel installieren. Und evtl. erstmal den freien Nouveau verwenden. Ich hatte auch mal Stabilitätsprobleme mit dem nvidia.

Re: Bildschirm friert nach einer Weile ein
« Antwort #2 am: 08.12.2019, 12:36:05 »
System:
  Host: mein-PC Kernel: 4.15.0-72-generic x86_64 bits: 64
  Desktop: Cinnamon 4.2.4 Distro: Linux Mint 19.2 Tina
Machine:
  Type: Desktop System: Micro-Star product: MS-7C37 v: 2.0 serial: <filter>
  Mobo: Micro-Star model: MPG X570 GAMING PLUS (MS-7C37) v: 2.0
  serial: <filter> UEFI: American Megatrends v: A.20 date: 06/28/2019
CPU:
  Topology: 8-Core model: AMD Ryzen 7 2700 bits: 64 type: MT MCP
  L2 cache: 4096 KiB
  Speed: 1489 MHz min/max: 1550/3200 MHz Core speeds (MHz): 1: 1476 2: 1380
  3: 1384 4: 1425 5: 1479 6: 1397 7: 1550 8: 1550 9: 1382 10: 1380 11: 1379
  12: 1450 13: 1549 14: 1550 15: 1380 16: 1508
Graphics:
  Device-1: NVIDIA driver: nvidia v: 435.21
  Display: x11 server: X.Org 1.19.6 driver: nvidia
  unloaded: fbdev,modesetting,nouveau,vesa resolution: 1920x1080~60Hz
  OpenGL: renderer: GeForce GTX 1660 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 435.21
Audio:
  Device-1: NVIDIA driver: snd_hda_intel
  Device-2: AMD Family 17h HD Audio driver: snd_hda_intel
  Sound Server: ALSA v: k4.15.0-72-generic
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
  IF: enp39s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 931.51 GiB used: 60.56 GiB (6.5%)
  ID-1: /dev/nvme0n1 vendor: Crucial model: CT1000P1SSD8 size: 931.51 GiB
Partition:
  ID-1: / size: 913.75 GiB used: 30.20 GiB (3.3%) fs: ext4 dev: /dev/dm-1
  ID-2: /boot size: 704.5 MiB used: 150.6 MiB (21.4%) fs: ext4
  dev: /dev/nvme0n1p2
  ID-3: swap-1 size: 975.5 MiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-3
Sensors:
  System Temperatures: cpu: 39.2 C mobo: N/A gpu: nvidia temp: 37 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 38%
Info:
  Processes: 346 Uptime: N/A Memory: 31.43 GiB used: 1.06 GiB (3.4%)
  Shell: bash inxi: 3.0.32

Hatte den PC gerade angemacht, wollte das erste Mal posten, dann fing er einen Neustart an, beim zweiten Mal fror er wieder ein. Das ist jetzt der dritte Versuch.

Re: Bildschirm friert nach einer Weile ein
« Antwort #3 am: 08.12.2019, 13:01:29 »
Sollte ich den Kernel dann also quasi aktualisieren? Wie mache ich das am besten?

Re: Bildschirm friert nach einer Weile ein
« Antwort #4 am: 08.12.2019, 13:13:31 »
- die Aktualisierungsverwaltung öffnen
- "Ansicht" - "Linux-Kernel" anklicken
- den Hinweis "Achtung" lesen und "Fortsetzen" anklicken
- jetzt wählst du links die "Kernel-Familie" 5.3 - siehe Bild - und installierst den obersten Kernel
- dazu klickst du ihn an - und klickst auf installieren
- nach der Kernel-Installation - den Rechner neu starten

Re: Bildschirm friert nach einer Weile ein
« Antwort #5 am: 08.12.2019, 13:37:35 »
Habe ihn nun mal so aktualisiert auf Linux 5.3.0-24-generic.

Sollte das einfach an so etwas liegen? Kann ich irgendwie feststellen ob das System nun rund läuft? Oder einfach mal abwarten?  :P

Re: Bildschirm friert nach einer Weile ein
« Antwort #6 am: 08.12.2019, 15:29:54 »
Kann ich irgendwie feststellen ob das System nun rund läuft? Oder einfach mal abwarten? 
Wenn es rund läuft, würde ich, außer dies festzustellen, erst mal nichts weiter machen.

Re: Bildschirm friert nach einer Weile ein
« Antwort #7 am: 08.12.2019, 15:31:41 »
Nach dem Neustart des Rechners steht beim 5.3.0-24 Kernel "Aktiv" ?
Wenn JA - abwarten ob sich das Problem noch einmal zeigt.

Re: Bildschirm friert nach einer Weile ein
« Antwort #8 am: 08.12.2019, 16:48:24 »
Ja, 5.3.0-24 wird als aktiv angezeigt.

Aber mir ist er vorhin gleich wieder eingefroren.  :(

Re: Bildschirm friert nach einer Weile ein
« Antwort #9 am: 08.12.2019, 20:12:56 »
Dann geh mal zurück auf den Nouveau Treiber.

PS: bitte nicht im LMDE Brett posten, wenn du keins nutzt.

Re: Bildschirm friert nach einer Weile ein
« Antwort #10 am: 08.12.2019, 21:15:08 »
War das im falschen Thread? Sorry.

Habe es auf den nouveau-Treiber geändert. Dann erfolgte ein Neustart...nun gab es bisher keinen Freeze, allerdings sieht meine Treiberverwaltung jetzt so aus wie im angehängten Bild. Wie man sieht sind die anderen Optionen auch ausgegraut, so das ich es gar nicht mehr ändern kann...

Re: Bildschirm friert nach einer Weile ein
« Antwort #11 am: 08.12.2019, 21:34:49 »
Das sollte dich für den Anfang erstmal nicht interessieren, teste weiter die Stabilität. Immer einen Schritt nach dem anderen....

Woher stammt dein zuletzt verwendeter nvidia Treiber?
« Letzte Änderung: 08.12.2019, 21:52:46 von toffifee »

Re: Bildschirm friert nach einer Weile ein
« Antwort #12 am: 08.12.2019, 22:59:47 »
Also bisher scheint es nun stabil zu laufen.

Der nvidia-Treiber 435 hatte ich direkt in der Treiberverwaltung gleich nach dem ersten Booten ausgewählt. Der wurde mir da "empfohlen".

Re: Bildschirm friert nach einer Weile ein
« Antwort #13 am: 08.12.2019, 23:11:52 »
Wenn der nouveau stabil läuft und kein zwingender Grund für den Nvidia spricht wie zb 3D Gaming, kannst du es so lassen.

Re: Bildschirm friert nach einer Weile ein
« Antwort #14 am: 09.12.2019, 15:53:40 »
Gestern als ich Programme schloß, da hat er sich wieder eingefroren. Also ganz stabil scheint es doch nicht zu sein. Mal schauen ob das nochmal passiert.