Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
12.08.2020, 17:33:04

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24386
  • Letzte: tomster
Statistiken
  • Beiträge insgesamt: 676851
  • Themen insgesamt: 54860
  • Heute online: 580
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Kein Wlan und Software Rendering Modus ist dauernd aktiv  (Gelesen 670 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo allerseits,

ich bin noch ziemlich neu was Linux angeht, weswegen ich nicht einschätzen kann ob das Problem eher klein oder groß ist. Ich nutze Linux Mint 19.3 Cinnamon.

Also folgendes:
Ich habe mir folgenden Laptop gekauft:
HP 14Zoll Slimbook
Ryzen 5 3500u
8gb Ddr4 ram
500gb SSD

Vorinstalliert ist Windows 10 was hervorragend funktioniert. Keinerlei Beschwerden. Dann habe ich zusätzlich Linux Mint installiert und ab haben die Probleme begonnen, welche ich auch nach Tagen nicht gelöst bekomme.

1.Wie im Titel schon erwähnt habe ich kein Wlan sondern komme nur mit Kabel rein. Dafür habe ich irgendwelche Realtek driver manuell installiert was dazu geführt hat das ich jetzt zwar wlan habe allerdings mit dermaßen schlechten Empfang, das ich selbst mit 2m Abstand vom Router Verbindungsabbrüche habe. Also da stimmt was nicht.

2. Ein weiteres Problem welches eventuell sogar noch wichtiger ist, ist die Tatsache, das Linux beim Start immer meldet das es im Software Rendering Modus läuft. Die Auflösung ist gelockt bei 1024*768. Ich habe folgendes probiert:
https://www.amd.com/en/support/kb/release-notes/rn-amdgpu-unified-linux

Ich habe direkt den ersten Hyperlink benutzt also die Version für Ubuntu (gibt ja keine für Mint) und dann mit ./amdgpu-install -y installiert. Hat aber nichts gebracht.

Das ist alles sehr ärgerlich und ich hoffe jemand könnte mir so einfach wie möglich erklären (am besten was ich eingeben muss) wie ich das nun behebe.
Viele Grüße :-[

Re: Kein Wlan und Software Rendering Modus ist dauernd aktiv
« Antwort #1 am: 07.12.2019, 23:25:36 »
Ein freundliches Willkommen hier im Grünen.

Fang mal damit an, dass Du zeigst, was Du so hast. Zeig mal die Terminalausgabe von
inxi -Fzhier im Codeblock.
Den Text im Terminal markieren, kopieren, hier einfügen, wieder markieren und mit dem Doppelkreuz oben (#) formatieren.

Re: Kein Wlan und Software Rendering Modus ist dauernd aktiv
« Antwort #2 am: 09.12.2019, 18:33:32 »
[code]System:
  Host: beso-HP-Laptop-14-dk0xxx Kernel: 4.15.0-20-generic x86_64 bits: 64
  Desktop: Cinnamon 4.0.8 Distro: Linux Mint 19.1 Tessa
Machine:
  Type: Laptop System: HP product: HP Laptop 14-dk0xxx v: N/A
  serial: <filter>
  Mobo: HP model: 85E0 v: 84.38 serial: <filter> UEFI: AMI v: F.38
  date: 03/13/2019
Battery:
  ID-1: BAT0 charge: 40.5 Wh condition: 40.5/40.5 Wh (100%)
CPU:
  Topology: Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx
  bits: 64 type: MT MCP L2 cache: 2048 KiB
  Speed: 1223 MHz min/max: 1400/2100 MHz Core speeds (MHz): 1: 1223 2: 1260
  3: 1223 4: 1221 5: 1222 6: 1267 7: 1223 8: 1222
Graphics:
  Device-1: AMD Picasso driver: N/A
  Display: x11 server: X.Org 1.19.6 driver: ati,fbdev
  unloaded: modesetting,radeon,vesa resolution: 1024x768~76Hz
  OpenGL: renderer: llvmpipe (LLVM 8.0 128 bits) v: 3.3 Mesa 19.0.8
Audio:
  Device-1: AMD driver: snd_hda_intel
  Device-2: AMD driver: N/A
  Device-3: AMD driver: snd_hda_intel
  Sound Server: ALSA v: k4.15.0-20-generic
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
  IF: eno1 state: down mac: <filter>
  Device-2: Realtek driver: rtl8723de
  IF: wlp2s0 state: up mac: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 9.39 GiB (2.0%)
  ID-1: /dev/sda vendor: Innovation model: IT size: 476.94 GiB
Partition:
  ID-1: / size: 114.15 GiB used: 9.36 GiB (8.2%) fs: ext4 dev: /dev/sda4
Sensors:
  System Temperatures: cpu: 29.0 C mobo: 0.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 219 Uptime: 2m Memory: 5.80 GiB used: 885.7 MiB (14.9%)
  Shell: bash inxi: 3.0.27
[/code]

Re: Kein Wlan und Software Rendering Modus ist dauernd aktiv
« Antwort #3 am: 09.12.2019, 18:35:06 »
Kann es sein, das es nicht möglich ist für die Ryzen 3500u einen Grafiktreiber auf Linux zu installieren? Die Auflösung ist schon ein wenig nervig aber ich finde dazu keine Lösung

Re: Kein Wlan und Software Rendering Modus ist dauernd aktiv
« Antwort #4 am: 09.12.2019, 18:38:57 »
Hallo Schawombo,

bei HP Laptops mit Deiner WLan-Karte kann es bezüglich der Antennen Probleme geben. Auf der nachfolgenden Seite findest Du einen Weg, das einfach zu bearbeiten:

https://easylinuxtipsproject.blogspot.com/p/realtek.html#ID2

Wegen der Grafikprobleme solltest Du in der Aktualisierungsverwaltung unter Ansicht > Linux Kernel mal ein Kernelupdate auf den aktuellsten 4.15.0er machen oder bei Deiner neuen Hardware den aktuellsten 5.3er nehmen.
« Letzte Änderung: 09.12.2019, 18:42:07 von harmless »

Re: Kein Wlan und Software Rendering Modus ist dauernd aktiv
« Antwort #5 am: 09.12.2019, 18:56:54 »
Ich nutze Linux Mint 19.3 Cinnamon
und warum machst du  inxi -Fz von einem 19.1?

Re: Kein Wlan und Software Rendering Modus ist dauernd aktiv
« Antwort #6 am: 10.12.2019, 17:57:08 »
Ok das wohl nicht so gut. Habe ein Kernel Update gemacht und jedesmal wenn ich mich nun einloggen will krieg ich die Meldung: "Unable to launch "cinnamon-session-cinnamon" X session --- "cinnamon-session-cinnamon" not found; falling back to default session." Und damit startet der Rechner neu. Sprich die Partition ist hinüber...

Gibt es eine Möglichkeit die alter Partition komplett zu löschen und Linux neu aufzusetzen? Wenn ich Linux neu installieren will wird man ja gefragt ob man Linux neben anderen Betriebssystemen installieren will oder die Festplatte löschen will (inklusive aller anderen Betriebssysteme). Wenn ich das auswähl schmeiss ich wohl auch meine Windowspartition runter  :-X

Edit: Ok Partition gelöscht und Linux neu aufgesetzt. Also wieder back to zero. Kein Wlan und 1024*768 Auflösung. Programme wie vim kann ich übrigens auch nicht über sudo apt install installieren.

Edit: Gut jetzt habe ich den aktuellsten 4.15.0 Kernel und auch alle weiteren Updates installiert. Jetzt funktioniert auch das installieren von z.b. vim. Allerdings immernoch das selbe Problem das ich kein Wlan habe und eine niedrige Auflösung... Ich weiss es ehrlich gesagt nicht was man da noch machen kann...
« Letzte Änderung: 10.12.2019, 18:39:26 von schawombo »

Re: Kein Wlan und Software Rendering Modus ist dauernd aktiv
« Antwort #7 am: 10.12.2019, 18:44:08 »
Hallo schawombo,

Du brauchst vim nicht zu installieren. Dafür gibt es bei Dir nano als Terminaleditor (statt vim also nano eingeben, wenn Du das überhaupt brauchst). Deine Fehlermeldung

Zitat
"cinnamon-session-cinnamon" X session --- "cinnamon-session-cinnamon" not found; falling back to default session."

hätte sich auch ohne neues Aufsetzen lösen lassen, entweder dadurch, daß Du den vorherigen Kernel wieder verwendet hättest oder auch durch die erneute Installation von mint-meta-cinnamon. Aber nun egal.

Für die Wlan-Treiberinstallation siehe hier:

https://easylinuxtipsproject.blogspot.com/p/realtek.html#ID8

und wenn es danach wieder Probleme geben sollte, hier die Antennen-Selektion:

https://easylinuxtipsproject.blogspot.com/p/realtek.html#ID2

Die Grafikproblematik kann danach ja angegangen werden.

Edit: So weit ich das jetzt gelesen habe, braucht Deine Grafikkarte für eine gute Unterstützung einen Kernel >= 4.20. Du müßtest also zunächst zumindestens über die Aktualisierungsverwaltung den aktuellsten 5.0er Kernel nehmen. Auf jeden Fall ruhig bleiben, sollte es nochmals Probleme geben.

https://www.phoronix.com/scan.php?page=news_item&px=AMD-Picasso-AMDGPU-Patches
 
« Letzte Änderung: 10.12.2019, 18:57:51 von harmless »

Re: Kein Wlan und Software Rendering Modus ist dauernd aktiv
« Antwort #8 am: 10.12.2019, 19:36:08 »
Nebenbei: user@TriciaX1:~$ vi --version
VIM - Vi IMproved 8.0 (2016 Sep 12, compiled Jun 06 2019 17:31:41)
Included patches: 1-1453
Modified by pkg-vim-maintainers@lists.alioth.debian.org
Compiled by pkg-vim-maintainers@lists.alioth.debian.org
Small version without GUI.  Features included [ … ]
LM-19.3 Cinnamon

Re: Kein Wlan und Software Rendering Modus ist dauernd aktiv
« Antwort #9 am: 11.12.2019, 21:31:08 »
Vielen Dank harmless! Die Anleitung war kinderleicht und nach dem Kernelupdate auf 5.3 irgendwas konnte ich die Auflösung direkt auf full hd umstellen und dann mit der Anleitung von dir den wlan Treiber installieren. Das umstellen der Antenne hat dann auch das schlechte Signal behoben Danke Danke Danke. :)

Re: Kein Wlan und Software Rendering Modus ist dauernd aktiv
« Antwort #10 am: 11.12.2019, 21:41:16 »
Hallo schawombo,

das freut mich, daß es so gut funktioniert hat und natürlich gern geschehen  :)