Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
27.09.2020, 22:46:25

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24566
  • Letzte: Mollox
Statistiken
  • Beiträge insgesamt: 685112
  • Themen insgesamt: 55446
  • Heute online: 743
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [erledigt] Grub  (Gelesen 491 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[erledigt] Grub
« am: 04.12.2019, 14:15:41 »
Mal wieder Blödsinn gemacht :o
Hab auf einer Partition LM 19.3 Beta ausprobiert und dann im laufenden System LM 19.2 bei Gparted wieder gelöscht.
Nun beim Starten komm ich nicht mehr ins Linux rein, angezeigt wird mir Grub (siehe Foto) nach dem Text kommt noch grub> _
sudo parted --list
Modell: ATA ST1000LM024 HN-M (scsi)
Festplatte  /dev/sda:  1000GB
Sektorgröße (logisch/physisch): 512B/4096B
Partitionstabelle: gpt
Disk-Flags:

Nummer  Anfang  Ende    Größe  Dateisystem  Name                  Flags
 2      20,5GB  21,0GB  537MB  fat32        EFI System Partition  boot, esp
 3      21,0GB  1000GB  979GB  ext4         Daten


Modell: ATA HFS128G39TND-N21 (scsi)
Festplatte  /dev/sdb:  128GB
Sektorgröße (logisch/physisch): 512B/4096B
Partitionstabelle: gpt
Disk-Flags:

Nummer  Anfang  Ende    Größe   Dateisystem     Name             Flags
 1      1049kB  35,4GB  35,4GB  ext4            Linux 2
 2      35,4GB  70,8GB  35,4GB  ext4            Linux 3
 5      70,8GB  81,1GB  10,2GB  linux-swap(v1)  swap
 6      81,1GB  127GB   45,9GB  ext4            LM19.2 Cinnamon
die Partition 6 ist auch nicht eingehängt
inxi -Fz
System:
  Host: mint Kernel: 4.15.0-54-generic x86_64 bits: 64
  Desktop: Cinnamon 4.2.3 Distro: Linux Mint 19.2 Tina
Machine:
  Type: Laptop System: Acer product: Aspire F5-573 v: V1.12 serial: <filter>
  Mobo: Acer model: Captain_SK v: V1.12 serial: <filter> UEFI: Insyde
  v: 1.12 date: 08/02/2016
Battery:
  ID-1: BAT1 charge: 18.7 Wh condition: 29.8/41.4 Wh (72%)
CPU:
  Topology: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP
  L2 cache: 3072 KiB
  Speed: 500 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 543 2: 525
  3: 570 4: 534
Graphics:
  Device-1: Intel HD Graphics 620 driver: i915 v: kernel
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa
  resolution: 1920x1080~60Hz
  OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2)
  v: 4.5 Mesa 19.0.2
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel
  Sound Server: ALSA v: k4.15.0-54-generic
Network:
  Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
  driver: ath10k_pci
  IF: wlp2s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
  IF: enp3s0f1 state: down mac: <filter>
Drives:
  Local Storage: total: 1.03 TiB used: 252.6 MiB (0.0%)
  ID-1: /dev/sda vendor: Seagate model: ST1000LM024 HN-M101MBB
  size: 931.51 GiB
  ID-2: /dev/sdb vendor: SK Hynix model: HFS128G39TND-N210A size: 119.24 GiB
  ID-3: /dev/sdc type: USB model: General USB Flash Disk size: 7.47 GiB
Partition:
  ID-1: / size: 3.83 GiB used: 252.6 MiB (6.4%) fs: overlay source: ERR-102
  ID-2: swap-1 size: 9.54 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb5
Sensors:
  System Temperatures: cpu: 39.0 C mobo: N/A
  Fan Speeds (RPM): N/A
Info:
  Processes: 220 Uptime: 26m Memory: 7.66 GiB used: 1.47 GiB (19.2%)
  Shell: bash inxi: 3.0.32
« Letzte Änderung: 09.12.2019, 12:40:08 von Giovanni »

tml

  • Gast
Re: Grub
« Antwort #1 am: 04.12.2019, 14:19:03 »

Re: Grub
« Antwort #2 am: 04.12.2019, 14:28:24 »
Alternativ vom LM 19.2 Livesystem aus Bootrepair versuchen.

Re: Grub
« Antwort #3 am: 04.12.2019, 14:47:58 »
vielen Dank ging ja flott, mit Boot Repair hab ich's geflickt.
Nun kommt beim Start im Grubmenu folgende Anzeige, kann ich das noch ändern?

Re: Grub
« Antwort #4 am: 04.12.2019, 14:50:26 »
Diese "Bootrepair" Sache ist auf jeden Fall geeignet um ausführliche Informationen über den gegenwärtigen Zustand des Bootloaders zu bekommen. Die Fähigkeit des Programms, den Grub erfolgreich zu reparieren, ist m.W. umstritten und vermutlich eben von den Gegebenheiten abhängig. Da würde ich lieber erst mal hinschauen, bevor die Reparatur-Automatik losgelassen wird. 

Edit
Die Boot-Option für Bootrepair habe ich allerdings selbst noch nicht probiert.
Zu UEFI kann ich mangels Erfahrung auch nicht viel sagen.
« Letzte Änderung: 04.12.2019, 15:14:22 von aexe »

Re: Grub
« Antwort #5 am: 07.12.2019, 13:53:05 »
Die 4 Einträge mit Endung .efi mittels Grub Customizer entfernt.
« Letzte Änderung: 07.12.2019, 13:58:41 von Giovanni »