Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
31.10.2020, 05:25:25

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 691769
  • Themen insgesamt: 55995
  • Heute online: 454
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 4
Gäste: 307
Gesamt: 311

Autor Thema:  Gelöst: LM19.3 Xfce Libre Writer Dokument lässt sich nicht speichern  (Gelesen 732 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Fehler beim Speichern des Dokumentes Unbenannt 1:
Kein Zugriff auf Objekt.
Aufgrund fehlender Benutzerrechte kann
auf das Objekt nicht zugegriffen werden.

Wie kann ich Libre Office die richtigen Benutzerrechte verpassen ?
Bisher war so etwas nie nötig, wenn ich ein neues Mint installiert habe.
« Letzte Änderung: 06.12.2019, 15:14:16 von mikon »

Re: LM19.3 Xfce Libre Writer Dokument lässt sich nicht speichern
« Antwort #1 am: 06.12.2019, 11:06:30 »
Da wäre schon wichtig, wohin du zu speichern versuchst....

LO braucht keine Benutzerrechte, das Verzeichnis braucht welche.

Re: LM19.3 Xfce Libre Writer Dokument lässt sich nicht speichern
« Antwort #2 am: 06.12.2019, 11:34:58 »
Ja, da liegt der Fehler.
Auf dem Schreibtisch läßt sich das Dokument speichern.

Ich habe eine spezielle Daten-Partition im NTFS-Format, welche ich jeweils nach dem Installieren eines neuen Linux-OS gemäß Anleitung einbinde.
HOWTO: Create & Use a Separate DATA Partition
https://community.linuxmint.com/tutorial/view/1609

Hat immer funktioniert, nur eben mit dem neuen LM19.3 Xfce nicht.
Die Partition ist zwar eingebunden und die symbolischen links zu "Dokumente" , "Videos" , "Bilder" usw. funktionieren auch, aber
beim Abspeichern des LO-Dokumentes kommt die genannte Fehlermeldung.

Ich habe eben nochmal den Befehl:
sudo chown -R franz:  /mnt/DATA  in der Konsole ausgeführt.  Hat leider nichts gebracht.

Wenn ich die Zugriffsrechte von Ordnern und Dateien auf der  Daten-Partition anschaue, dann steht bei Eigentümer "root" und bei Gruppe ebenfalls "root".
chown läuft zwar ohne Fehlermeldungen durch, aber der Befehl ändert den Eigentümer nicht.

Re: LM19.3 Xfce Libre Writer Dokument lässt sich nicht speichern
« Antwort #3 am: 06.12.2019, 11:39:04 »
Bei NTFS tippe ich auf ein DualBoot mit Windows!? Ist der Schnellstart deaktiviert? Obwohl eigentlich Eigentümer root schon eindeutig ist....
Zeige mal bitte deine fstab.

Re: LM19.3 Xfce Libre Writer Dokument lässt sich nicht speichern
« Antwort #4 am: 06.12.2019, 12:26:53 »
Ja, ich habe Win10 vor ein paar Tagen neu installiert.
Der Schnellstart ist deaktiviert.

Hier ist meine fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda7 during installation
UUID=190ddfff-451a-437e-82e1-3e859a706305 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda11 during installation
UUID=908abfc7-64fb-4e1f-85b8-ebbc71e015c4 none            swap    sw              0       0
# Mount DATA partition under /mnt/DATA  gilt jetzt für 530 GB Platte
UUID=1EFE3CEAFE3CBC39     /mnt/DATA     ntfs-3g     defaults,windows_names,locale=en_US.utf8     0     0

Die UUID der DATA Partition ist korrekt, habe sie mit blkid geprüft.

Eigentümer aller Dateien und Ordner auf DATA ist root.

Re: LM19.3 Xfce Libre Writer Dokument lässt sich nicht speichern
« Antwort #5 am: 06.12.2019, 12:54:51 »
Schau mal hier rein, vielleicht was brauchbares dabei:
https://ubuntuforums.org/showthread.php?t=2259665

Und versuche es mal mit:
sudo chmod -R 777 /Dein Pfad oder MountPoint

Re: LM19.3 Xfce Libre Writer Dokument lässt sich nicht speichern
« Antwort #6 am: 06.12.2019, 13:51:22 »
Schau mal hier rein, vielleicht was brauchbares dabei:
https://ubuntuforums.org/showthread.php?t=2259665

Und versuche es mal mit:
sudo chmod -R 777 /Dein Pfad oder MountPoint
Bisher gab es nichts Brauchbares und der chmod -R 777 funktioniert nicht.

Ich bin jetzt gerade im LM19.2 Xfce, wo es nie Probleme gab. Doch auch hier geht das Speichern der LO-Datei auf die eingebundene NTFS Partition nicht.

Es sieht so aus, daß Win10 irgendwas verändert hat.
Der Rat, man soll auf gar keinen Fall eine NTFS-Daten-Partition anlegen, um von Windows und von Linux darauf zugreifen zu können, gefällt mir nicht, weil ich seit Jahren
mit dieser Partition arbeite.
Probleme damit gab es immer nur dann, wenn der Schnellstart nicht ausgeschaltet war und/oder Windows die Partition irgendwie markiert oder gesperrt hatte (Hibernation oder so ähnlich).
Das ließ sich dann immer in Windows beheben und danach funktionierte der Zugriff von allen installierten Linux-OS wieder normal.

Nur eben jetzt nicht.
Ich werde jetzt mal die Partition aushängen, die ganzen symbolischen links löschen und die Prozedur nochmal durchführen.

Re: LM19.3 Xfce Libre Writer Dokument lässt sich nicht speichern
« Antwort #7 am: 06.12.2019, 14:07:41 »
Hallo mikon, auch ich speichere Daten aus LibreOffice auf NTFS Partitonen, allerdings schreibe ich in die fstab immer umask=002.
Bei dir
Zitat
UUID=1EFE3CEAFE3CBC39     /mnt/DATA     ntfs-3g     defaults,windows_names,locale=en_US.utf8     0     0
fehlt dieser Eintrag.
UUID=B48E5FB28E5F....   /win_D/Dokumente   ntfs-3g   umask=002,defaults,locale=de_DE.UTF-8   0   0
Gruß, Helmut

Re: LM19.3 Xfce Libre Writer Dokument lässt sich nicht speichern
« Antwort #8 am: 06.12.2019, 14:33:23 »
Danke Helmut,
ich werde das testen.

Momentan bin ich wieder im neuen LM19.3 , nachdem ich alles in LM19.2 zum Laufen gebracht habe.

Ok, Helmut, die Optionen, die Du benutzst ( umask=002,locale=de_DE.UTF-8) haben nicht funktioniert. Keine Rechte zum Schreiben.

Ich habe jetzt meine ursprünglichen Optionen für die fstab aktiv.
Habe diese in der fstab auf Kommentar gesetzt, damit die Partition nicht eingebunden wird, dann neu gestartet.
So konnte ich die Symlinks und die Datei "DATA" auf /mnt  löschen.
Dann den Eintrag in der fstab wieder aktiv gesetzt und neu gestartet.
Entsprechend Anleitung DATA auf /mnt  neu kreiert, dann chmod, damit ich die Schreibrechte auf /mnt/DATA habe,
danach die Symlinks neu.

Jetzt kann mit Libre Office Writer normal arbeiten, auch die Sonderzeichen im Dateinamen werden nicht beanstandet.

Damit ist das Problem gelöst.

Danke an alle für die Hilfen.
« Letzte Änderung: 06.12.2019, 15:13:42 von mikon »