Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
13.12.2019, 05:54:20

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22948
  • Letzte: Funakoshi
Statistiken
  • Beiträge insgesamt: 624332
  • Themen insgesamt: 50422
  • Heute online: 455
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online
Mitglieder: 5
Gäste: 302
Gesamt: 307

Autor Thema:  Ständige Cinnamon-Abstürze (Rückfallmodus) bei Verwendung des Dateimanagers etc.  (Gelesen 1272 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Dann hat der Nvidia Treiber nie gearbeitet.

Oh... Vielleicht kommen wir langsam dem Problem auf die Spur...


Läuft der Nvidia Treiber jetzt?
inxi -G
ls@ls-MACH-WX9:~$ inxi -G
Graphics:
  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
  Device-2: NVIDIA GP108M [GeForce MX150] driver: N/A
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa
  resolution: 3000x2000~60Hz
  OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2)
  v: 4.5 Mesa 19.0.8


Geht Cinnamon immer noch in den Rückfallmodus?

Leider ja

Kein Wunder, es hat sich ja nix verändert. Es läuft nach wie vor die Intel Grafikeinheit.
Zeig mal bitte die Ausgabe von
dpkg -l nvidia* | grep ii

Das ergibt Folgendes:

ls@ls-MACH-WX9:~$ dpkg -l nvidia* | grep ii
ii  nvidia-compute-utils-435 435.21-0ubuntu0.18.04.2 amd64        NVIDIA compute utilities
ii  nvidia-dkms-435          435.21-0ubuntu0.18.04.2 amd64        NVIDIA DKMS package
ii  nvidia-driver-435        435.21-0ubuntu0.18.04.2 amd64        NVIDIA driver metapackage
ii  nvidia-kernel-common-435 435.21-0ubuntu0.18.04.2 amd64        Shared files used with the kernel module
ii  nvidia-kernel-source-435 435.21-0ubuntu0.18.04.2 amd64        NVIDIA kernel source package
ii  nvidia-prime             0.8.8.2                 all          Tools to enable NVIDIA's Prime
ii  nvidia-settings          390.77-0ubuntu0.18.04.1 amd64        Tool for configuring the NVIDIA graphics driver
ii  nvidia-utils-435         435.21-0ubuntu0.18.04.2 amd64        NVIDIA driver support binaries

Installiert ist der Treiber, wird aber leider nicht geladen. Im Menü sollten sich nun die Nvidia XServer Settings befinden.
Startet Nvidia XServer Settings wenn du es aufrufst und falls ja, kannst du dort auf die Nvidia Karte umstellen? 

Die Settings lassen sich aufrufen, aber  leider weiß ich nicht, wie ich dort auf die Nvidia Karte umstellen kann. Ich hänge mal zwei Screenshots an.

Du kannst auch nvidia-prime-applet installieren:
zeigt die aktive GPU im Panel und ermöglicht das Umschalten bei Optimus-Karten

Danke für den Tipp, ich habe soeben nvidia-prime-applet installiert, doch leider ist das applet nirgendwo in meinem System zu finden, auch nicht nach einem Neustart... Vielleicht habe ich etwas falsch gemacht?

Danke, dass ihr so geduldig mit mir seid!

Das der Nvidia Treiber nicht geladen wird macht mich stutzig.
Hast du Secure Boot im Bios deaktiviert?
Ich bin nicht sicher ob der Treiber digital signiert ist und wenn nicht verhindert Secure Boot das der Treiber verwendet werden kann.

Ob Secure Boot deaktiviert ist, weiß ich leider nicht. Ich wollte soeben ins Bios, um nachzusehen und es ggf. zu deaktivieren, nun habe ich aber das Problem, dass im Bios meine Pfeiltasten nicht funktionieren und ich somit nicht ins Bootmenü navigieren kann. Ich nutze meine normale Laptoptastatur, keine externe.
Gibt es noch eine andere Möglichkeit, zu den Secure Boot Einstellungen zu kommen bzw wie bekomme ich meine Pfeiltasten dazu, dass sie im Bios funktionieren?

Tut mir leid, dass hier eine Komplikation nach der anderen aufkommt... Danke für eure Hilfe und Geduld!

Ich nutze meine normale Laptoptastatur, keine externe.

Hast du eine? Ist einen Versuch wert.

Bei einigen UEFI die ich hier habe, meist HP-Rechner oder Laptop's, geht das mit der Maus.

Nachdem der Status des Betriebssystem ziemlich unklar ist, die bisherigen Lösungsversuche offenbar eher eine Verschlechterung bringen und die Installation neu ist, würde ich eine Neuinstallation in Betracht ziehen.
Dann einen neuen Versuch starten, die Grafik unter Berücksichtigung der bisherigen Erkenntnisse zum Funktionieren zu bringen.

Zu Nvidia kann ich nur wenig Erfahrungen beitragen.
Ich hatte bisher nur eine etwas ältere Nvidia Hardware, bei der ich die Karte mit folgendem Vorgehen in Gang gebracht habe::

1) automatisch installierte Software entfernen, mit apt purge nvidia* apt autoremove 
2) Grafik-PPA einrichten, mit sudo add-apt-repository ppa:graphics-drivers apt update
3) Passende Treiber und weitere Software installieren, mit sudo ubuntu-drivers autoinstall Der Vorteil der Terminalanwendung ist die ausführliche Rückmeldung.
Alternativ mittels der grafischen Treiberverwaltung: pkexec driver-manager  Dies dauert und erfordert Geduld!
Anschließend Rechner neu starten.

Gilt für LM-19.2 Cinnamon
« Letzte Änderung: 02.12.2019, 11:24:09 von aexe »

Gibt es noch eine andere Möglichkeit, zu den Secure Boot Einstellungen zu kommen
Du kannst Linux anweisen Secure Boot zu ignorieren.
sudo apt install mokutil
sudo mokutil --sb-state
sudo mokutil --disable-validation

Lieben Dank für eure zahlreichen Antworten!

Ich habe nun versucht sowohl mit einer externen Tastatur als auch mit einer Maus im Bios zu navigieren - beides hat leider nicht funktioniert.

Da ich aktuell gar nicht weiß, ob ich Secure Boot aktiviert oder deaktiviert habe, kann ich nur soviel sagen, dass ich während der Installation von Linux alles so gelassen hatte, wie es vorgegeben war. Wenn ich mich recht erinnere, war da auch irgendwas mit Secure Booth, wo man ein Häkchen setzen oder entfernen konnte. Ich hatte das so gelassen, wie es war. Vielleicht wisst ihr spontan, ob das somit aktiviert oder deaktiviert ist.

Eure anderen Vorschläge werde ich am Mittwoch ausprobieren, bin jetzt erstmal zwei Tage unterwegs. Ich melde mich dann wieder!

Danke nochmal!

Guten Abend allerseits!

Ich konnte mich nun doch schon heute dem Problem widmen.

Zuallererst habe ich das hier gemacht:

Du kannst Linux anweisen Secure Boot zu ignorieren.
Code: [Auswählen]
sudo apt install mokutil
sudo mokutil --sb-state
sudo mokutil --disable-validation

Anschließend habe ich mithilfe Methode 2 in folgender Anleitung Secure Boot deaktiviert: https://wiki.ubuntu.com/UEFI/SecureBoot/DKMS

Nach dem Neustart erschienen dann sofort von selbst die Nvidia X Server Settings unten in meiner Leiste. Dort sind nun ganz andere Dinge zu sehen als vorher - ich hänge euch mal einen Screenshot an.

inxi -G sagt jetzt Folgendes:

ls@ls-MACH-WX9:~$ inxi -G
Graphics:
  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
  Device-2: NVIDIA GP108M [GeForce MX150] driver: nvidia v: 435.21
  Display: x11 server: X.Org 1.19.6 driver: modesetting,nvidia
  unloaded: fbdev,nouveau,vesa resolution: 3000x2000~60Hz
  OpenGL: renderer: GeForce MX150/PCIe/SSE2 v: 4.6.0 NVIDIA 435.21

Ist das so okay oder muss ich noch irgendetwas ändern?

Leider geht Cinnamon noch immer bei der kleinsten Bemühung in den Rückfallmodus.


Und dann nochmal zum Thema Secure Boot deaktivieren:

Wenn ich richtig verstehe, kann ich mit dem Befehl sudo mokutil --sb-state überprüfen, ob Secure Boot aktiviert ist, ja? Wenn ich den Befehl ausführe, heißt es bei mir "SecureBoot enabled".
Wie kann das sein, wenn ich es doch vorhin deaktiviert habe? Da ich mir dann unsicher war, habe ich den Deaktivierungsprozess noch ein zweites Mal durchgeführt (das hier: https://wiki.ubuntu.com/UEFI/SecureBoot/DKMS, Methode 2), aber noch immer heißt es "SecureBoot enabled".

Was mache ich falsch?

Was mich stört ist das der Intel-Kernel Treiber immer noch an erster Stelle steht und demzufolge auch verwendet wird.
Ziel ist es aber, den Intel Treiber zu deaktivieren und als primären Treiber die Karte von NVIDIA zu etablieren.
Das scheint aber nicht zu funktionieren.
Wie gut kennst du dich mit deinem BIOS aus? Höchstwahrscheinlich mußt du die Intel-Grafik im BIOS deaktivieren und den NVIDIA aktivieren. Obwohl diese eigentlich automatisch die Grafikfunktion übernehmen sollte, sobald der Intel deaktiviert wurde.
Im BIOS allerdings sollte man wissen WAS man WO tun kann. Sonst kann es passieren, das der PC nie wieder startet.