Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
13.12.2019, 06:11:38

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22948
  • Letzte: Funakoshi
Statistiken
  • Beiträge insgesamt: 624332
  • Themen insgesamt: 50422
  • Heute online: 455
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online
Mitglieder: 5
Gäste: 280
Gesamt: 285

Autor Thema:  Ständige Cinnamon-Abstürze (Rückfallmodus) bei Verwendung des Dateimanagers etc.  (Gelesen 1273 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Vom Bios habe ich leider Null Ahnung und kann da kein Risiko eingehen...

Gibt es noch irgend eine andere Möglichkeit?

Vielleicht, das was aexe vorgeschlagen hatte?


Nachdem der Status des Betriebssystem ziemlich unklar ist, die bisherigen Lösungsversuche offenbar eher eine Verschlechterung bringen und die Installation neu ist, würde ich eine Neuinstallation in Betracht ziehen.
Dann einen neuen Versuch starten, die Grafik unter Berücksichtigung der bisherigen Erkenntnisse zum Funktionieren zu bringen.

Zu Nvidia kann ich nur wenig Erfahrungen beitragen.
Ich hatte bisher nur eine etwas ältere Nvidia Hardware, bei der ich die Karte mit folgendem Vorgehen in Gang gebracht habe::

1) automatisch installierte Software entfernen, mit apt purge nvidia* apt autoremove 
2) Grafik-PPA einrichten, mit sudo add-apt-repository ppa:graphics-drivers apt update
3) Passende Treiber und weitere Software installieren, mit sudo ubuntu-drivers autoinstall Der Vorteil der Terminalanwendung ist die ausführliche Rückmeldung.
Alternativ mittels der grafischen Treiberverwaltung: pkexec driver-manager  Dies dauert und erfordert Geduld!
Anschließend Rechner neu starten.

Gilt für LM-19.2 Cinnamon

Wenn ich den Befehl ausführe, heißt es bei mir "SecureBoot enabled".
Wie kann das sein, wenn ich es doch vorhin deaktiviert habe?
Nein, Secure Boot ist nicht abgeschaltet,  Linux wird dadurch nur angewiesen Secure Boot zu ignorieren.
Was mich stört ist das der Intel-Kernel Treiber immer noch an erster Stelle steht und demzufolge auch verwendet wird.
Dem Irrglaube bin ich auch mal aufgesessen. Ausschlaggebend ist diese Zeile
OpenGL: renderer: GeForce MX150/PCIe/SSE2 v: 4.6.0 NVIDIA 435.21Der renderer zeigt an welche Karte zum Einsatz kommt. In dem Fall  läuft nun die Nvidia.

Nun, da es scheinbar nicht mangels Nvidia Treiber war, dass Cinnamon ständig abstürtzt, an was könnte es denn noch liegen bzw. was könnte ich noch probieren? Ich würde mich sehr freuen, wenn noch jemand eine Idee hätte...

Vielen Dank für eure Hilfe soweit!
« Letzte Änderung: 04.12.2019, 16:45:20 von Lischnig »

Bin jetzt zu Mate gewechselt und hoffe, dass es da besser klappt...

Hallo, ich hätte zuerst den Vorschlag von @aexe versucht:
Nachdem der Status des Betriebssystem ziemlich unklar ist, die bisherigen Lösungsversuche offenbar eher eine Verschlechterung bringen und die Installation neu ist, würde ich eine Neuinstallation in Betracht ziehen.
dann hättest du gesehen ob es tatsächlich an der Cinnamon Installation lag.

Zu deinem Secure Boot, ist denn kein Verwandter / Bekannter / Händler in der Nähe der dir das im BIOS deaktivieren könnte? Grosses Hexenwerk ist es nicht, du könntest auch mal im Huawai Handbuch nachlesen.

Abgesehen davon, beachte den Hinweis in Antwort #3 zur Aktualisierung nach der Installation. Wobei der Befehl bestimmt so lauten sollte:apt update && apt dist-upgradeRichte zuerst Timeshift ein, so hast hast du nach jedem Installations Schritt einen Weg zurück. Und verwende möglichst nur den angebotenen nVidia Treiber aus der Treiberverwaltung, die direkt von nVidia angebotenen Treiber bereiteten mir auch schon größeren Ärger.
« Letzte Änderung: 06.12.2019, 09:48:49 von kuehhe1 »

Hallo kuehhe1, vielen Dank für deine Antwort!
Ja, stimmt, eine Neuinstallation hatte ich noch nicht probiert. Wegen dem Bios - da war das Problem, dass ich im Bios weder mit meinen Pfeiltasten noch mit Maus oder Tastatur ins Bootmenü navigieren kann. Aber ich werde nochmal googeln bzw mich umhören, ob mir da jemand in meinem Umfeld helfen kann.
Ich werde mich da morgen nochmal reinknien und hoffe, dass ich dann positive Ergebnisse vermelden kann!

Noch eine Frage: was meinst du mit "direkt von Nvidia angebotenen Treibern"?
« Letzte Änderung: 05.12.2019, 22:34:08 von Lischnig »

was meinst du mit "direkt von Nvidia angebotenen Treibern"?
damit meinte ich die direkt auf: "https://www.nvidia.de/Download/index.aspx?lang=de" angebotenen Treiber, aber auch die durch ein hinzugefügtes PPA zur Verfügung gestellten Treiber bereiten bisweilen Probleme.

Wenn schon nVidia Treiber dann ist es sicherer nur den "empfohlenen" Treiber der Mint Treiberverwaltung zu installieren. Denn vor jedweden Experimenten sollte zuerst mal das System als solches rund laufen.
« Letzte Änderung: 06.12.2019, 22:02:47 von kuehhe1 »

Okay, verstehe. Danke für die Erklärung!

Ich habe nun Linux Mint 19.2 Cinnamon neu installiert und danach gleich wie von opajoerg empfohlen folgenden Befehl ausgeführt, anschließend Systemneustart:

sudo apt update && apt dist-upgrade
(Ist das eigentlich ein Unterschied ob ich das so mache oder ob ich in der Aktualisierungsverwaltung alles aktualisieren lasse, was eben angezeigt wird?)

Leider geht Cinnamon noch immer in den Rückfallmodus, wenn ich mich durch meine Dateien klicke. Ich gebe dann hiermit auf und wechsle zu Mate…


Ich hätte dann noch zwei grundlegende Fragen:

1. Da wir ja nun festgestellt haben, dass Cinnamon bei mir nicht funktionert, ganz egal welchen Kernel ich verwende, ist es dann grundsätzlich trotzdem besser, den aktuellsten Kernel, also 5.3, zu verwenden oder kann ich ihn getrost auf 4.15 lassen, so wie es nach der Neuinstallation von selber war?

2. Muss ich denn eigentlich den vom System empfohlenen Nvidia-Treiber installieren oder kann ich auch einfach darauf verzichten?
Ich frage aus dem Grund, weil mir folgendes aufgefallen ist:
Als ich mit eurer Hilfe mein System endlich so weit hatte, dass der Nvidia-Treiber lief, lief immer nach kürzester Zeit mein Lüfter auf Hochtouren, sehr laut, auch wenn ich einfach nur einen Browser offen hatte, sonst nichts.
Gestern habe ich testweise wieder auf Intel gewechselt und schon war Ruhe… Der Lüfter geht kaum mal an – und wenn, dann relativ leise.
Sollte das also kein schlichter Zufall sein (habe leider keine Ahnung von sowas) und es keine Nachteile bringt, dann würde ich darauf verzichten, den Nvidia-Treiber zu installieren.

Da die Nvidia mal deutlich weniger sparsam -dafür aber schneller ist- muss der Lüfter dann auch mehr arbeiten. Wenn du nicht zwingend auf die Nvidia angewiesen bist (Spiele/Grafik-/Videobearbeitung), dann lass die Intel aktiv sein. Dein Akku wirds dir unterwegs danken ;)

Man könnte auch versuchen in nvidia-settings, Screenshot #28, in PowerMizer die Einstellung auf Energiesparend zu setzen. Soweit ich weiß gibt's dort drei (3) Einstellmöglichkeiten.

Wenn aber kein Grund für die Aktivierung der nVidia besteht dann belasse es doch, wie auch @lunacorp schreibt, bei der Intel. Die reicht allemal auch zum Video gucken.

Zu Frage 1.
der Kernel 4.15 kommt ja standardmäßig, gäbe es damit bei neuerer Hardware Probleme wäre die 5.x Linie eine Option.
Zu Frage 2.
Du muss nicht unbedingt den empfohlenen nVidia Treiber installieren, du kannst auch es auch erst einmal beim quelloffenen nouveau belassen und ausgiebig testen.
« Letzte Änderung: 06.12.2019, 21:59:28 von kuehhe1 »

Muss ich denn eigentlich den vom System empfohlenen Nvidia-Treiber installieren oder kann ich auch einfach darauf verzichten?
Installieren würde ich den Nvidia Treiber schon. Wenn du die Performace der Nvidia nicht brauchst, schalte in den Nvidia-Settings einfach auf die Intel um.

Alles klar, dann werde ich es so handhaben! Ich danke euch!