Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
22.11.2019, 18:31:03

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 620714
  • Themen insgesamt: 50117
  • Heute online: 743
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema: [gelöst]  Linux Mint 19.2 startet langsam,Startup finished in 37.600s (kernel)...  (Gelesen 830 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Re: Linux Mint 19.2 startet langsam,Startup finished in 37.600s (kernel)...
« Antwort #15 am: 20.10.2019, 18:55:07 »
Hallo BR01,

habe den Dienst nmbd.service wie beschrieben gestoppt und dann deaktiviert, (er scheint für meine Zwecke wirklich überflüssig zu sein )
und dann neu gestartet:

jb@jb-HP-EliteBook-8570p:~$ systemd-analyze critical-chain
The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @8.046s
└─multi-user.target @8.046s
  └─virtualbox.service @7.968s +77ms
    └─network-online.target @7.966s
      └─NetworkManager-wait-online.service @1.651s +6.314s
        └─NetworkManager.service @1.359s +288ms
          └─dbus.service @1.335s
            └─basic.target @1.311s
              └─sockets.target @1.311s
                └─dbus.socket @1.311s
                  └─sysinit.target @1.309s
                    └─systemd-timesyncd.service @1.172s +136ms
                      └─systemd-tmpfiles-setup.service @1.154s +15ms
                        └─local-fs.target @1.152s
                          └─local-fs-pre.target @1.152s
                            └─keyboard-setup.service @162ms +988ms
                              └─systemd-journald.socket @149ms
                                └─system.slice @149ms
                                  └─-.slice @146ms

jb@jb-HP-EliteBook-8570p:~$ systemd-analyze
Startup finished in 37.469s (kernel) + 8.054s (userspace) = 45.523s
graphical.target reached after 8.046s in userspace

jb@jb-HP-EliteBook-8570p:~$ systemctl status nmbd.service
● nmbd.service - Samba NMB Daemon
   Loaded: loaded (/lib/systemd/system/nmbd.service; disabled; vendor preset: enabled)
   Active: inactive (dead)
     Docs: man:nmbd(8)
           man:samba(7)
           man:smb.conf(5)
jb@jb-HP-EliteBook-8570p:~$



Was mich wundert ist: Startup finished in 37.469s (kernel) denn ich habe auf meinem alten "Bastelrechner"
mit Amd Turion 64 X2 Mobile TL-50 max 2x1600 MHz,2 GB Ram, der zwar auch mit einer SSD ausgestattet ist
und auf dem das gleiche Linux installiert ist, aber ohne Verschlüsselung,
ein Startup finished in 5.436s (kernel) + 44.483s (userspace).

Frage: kann man die Verschlüsselung aufheben ohne das System ganz neu aufzusetzen?
         


Also zu Verschlüsselung kann ich nicht all zu viel schreiben, wieviel die das System "gewöhnlich" ausbremst beim booten. Auch hatte ich so etwas noch nie, bewusst nie gemacht.
Für mich macht Verschlüsselung keinen Sinn, da meine Rechner nie das Haus verlassen. Und das Netbook was es ganz wenig mal macht, da ist nichts wichtiges drauf.
So nur zu Hause bringt mir Verschlüsselung keinen Nutzen, eher Nachteile, also u.U. längeres booten oder halt sich im Extremfall "aussperren".
Verschlüsselte Container sind sicher etwas anderes, brauche ich aber auch nicht.

Die umseitig genannten anderen 3 Dienste würde ich auch einmal deaktivieren und anschließend neu starten.
Dann kontrollierst du den Boot noch mal mit bekannten Befehl oder wenn du es grafisch magst, so:
systemd-analyze plot > ~/plot1.svg && firefox ~/plot1.svgDa öffnet sich dann der Firefox zum betrachten.
Oder nimmst dmesg im Terminal. Das geht auch auf die Schnelle.

P.S.: Es war gestern Abend schon spät, einen deaktivierten Dienst wieder aktivieren, geht man so vor (die erste Zeile fehlte in meinen #14):
sudo systemctl enable smbd.servicesudo systemctl start smbd.service

Hallo BR01,

Off-Topic:
Habe deinen Tipp den nmbd.service zu deaktivieren auf meinem "Bastelrechner" angewendet,
und siehe da:
jb@jb-Aspire-5110:~$ systemd-analyze
Startup finished in 5.899s (kernel) + 4.750s (userspace) = 10.649s
graphical.target reached after 4.693s in userspace
jb@jb-Aspire-5110:~$

vorher waren es:
Startup finished in 5.4s (kernel) + 44.5s (userspace)
um so mehr reizt es mich jetz dem HP auf die Sprünge zu helfen ;)

Hallo, und was macht der Rechner um den es hier im Eingangspost ging? Ist der wenigstens etwas schneller geworden? Hast du da Dienste nun deaktiviert wie beschrieben?

swap-1 size: 2.00 GiB

Memory: 7.73 GiB

Trotzdem muss ich mal Fragen, was soll eine SWAP-Partition von 2 GiB bei 7.73 GiB RAM?

Dann lasse ich bei LM 19.X die SWAP - Partition gleich weg und nutze SWAP - File!?
« Letzte Änderung: 20.10.2019, 21:15:19 von tommix »

@tommix, ist zwar richtig, bringt ihm jetzt aber auch nicht all zu viel im Nachgang. Zumal verschlüsseltes System...

Kann aber auch dafür eine Rolle spielen:  Linux Mint 19.2 startet langsam.

Lies mal #6 bis #8. Das wurde schon ohne Ergebnis gemacht...

Off-Topic:
JB.Technik
Zeig doch bitte die Ausgabe von
sudo parted --listdamit ein per "Ungläubige" hier sehen, dass die swap keine Partition ist.

Die Verschlüsselung mit ecryptfs kann man tatsächlich ohne Neuinstallation aufheben.
https://wiki.ubuntuusers.de/ecryptfs/Einrichten/#Verschluesselung-des-Homeverzeichnisses-entfernen

Ich denke aber nicht, dass das das Problem löst. Ich verwende auch verschlüsselte Benutzerverzeichnisse und habe keine Probleme mit der Startzeit. (Außer bei LM 19, aber da hat die Installationsroutine Murks gebaut; Der Bug ist in späteren Versionen gefixt.)

Wie gewünscht:
jb@jb-HP-EliteBook-8570p:~$ sudo parted --list
[sudo] Passwort für jb:     
Modell: ATA CT500MX500SSD1 (scsi)
Festplatte  /dev/sda:  500GB
Sektorgröße (logisch/physisch): 512B/4096B
Partitionstabelle: msdos
Disk-Flags:

Nummer  Anfang  Ende   Größe  Typ      Dateisystem  Flags
 1      1049kB  500GB  500GB  primary  ext4         boot


Modell: Linux device-mapper (crypt) (dm)
Festplatte  /dev/mapper/cryptswap1:  2147MB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: loop
Disk-Flags:

Nummer  Anfang  Ende    Größe   Dateisystem     Flags
 1      0,00B   2147MB  2147MB  linux-swap(v1)


jb@jb-HP-EliteBook-8570p:~$

Hallo BR01,
das was dmesg ausgibt ist zu lang für das Code-Fenster,
daher habe ich es in die angehängte Datei dmesg.txt kopiert.
Wobei ich zugeben muss, dass der Inhalt sich mir nicht erschließt,
zu mindestens noch nicht.

bei der Bootzeit ist wohl das hier das Problem (Auszug aus dmesg)
Zitat
    4.594986] Btrfs loaded, crc32c=crc32c-intel
[    9.288208] radeon_dp_aux_transfer_native: 368 callbacks suppressed
[   37.220531] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)

[   37.375607] ip_tables: (C) 2000-2006 Netfilter Core Team

aber richtig deuten kann ich das auch nicht.

vllt. hilft das hier
https://askubuntu.com/questions/1029598/xubuntu-18-04-kernel-takes-long-to-boot

Kontrolliere bitte einmal - etc/initramfs-tools/conf.d
Gibt es da die Datei "resume" ?
Wenn JA - mit welchem Inhalt ?
« Letzte Änderung: 22.10.2019, 09:49:55 von billyfox05 »

Hallo billyfox05,

Der Tipp:
Zitat
I had same problem.
During boot messages it would say that it timed out waiting for resume device.
Check in /etc/initramfs-tools/conf.d/resume if there is UUID in it like
RESUME=some-uuid remove uuid and replace with "none" to be RESUME=none.
After that run sudo update-initramfs -uk all and it should be good to go.

Kontrolliere bitte einmal - etc/initramfs-tools/conf.d/resume

Sie hatte den Inhalt:
RESUME=UUID=6eef7bd1-7940-4c56-82ac-db90299d951f

Das habe ich wie beschrieben geändert in:
# RESUME=UUID=6eef7bd1-7940-4c56-82ac-db90299d951f
RESUME=none
abgespeichert,
und dann:
sudo update-initramfs -uk all
hat etwas gedauert bis der Befehl abgearbeitet war.
Dann das System neugestartet und siehe da:

jb@jb-HP-EliteBook-8570p:~$ systemd-analyze
Startup finished in 4.914s (kernel) + 8.046s (userspace) = 12.961s
graphical.target reached after 8.040s in userspace
jb@jb-HP-EliteBook-8570p:~$

Super! und danke an dich und alle, die mir geholfen haben.

Es hat Spas gemacht und ich hab einiges gelernt.