Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
01.12.2020, 06:33:41

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24840
  • Letzte: Foxinity
Statistiken
  • Beiträge insgesamt: 697735
  • Themen insgesamt: 56462
  • Heute online: 475
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema: [gelöst]  Bilder u. Schrift mit LO an die richtige Stelle bringen, für epub-Konvertierung?  (Gelesen 771 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

LMM18.03

Hallo,

ich möchte mit LO-Writer2epub ein E-Book erstellen.

Dabei habe ich Schwierigkeiten bestimmte kleinere Bilder und auch die Schrift an die richtige Stelle zu bekommen.

Im ODT-Original sieht alles noch richtig aus und im konvertierten epub-format sind dann die kleinen Bilder z.B. nicht in der Mitte der Seite (obwohl zentriert) sowie z.B. die Schrift auf der entsprechenden Seite (bei zentrierter Schrift), sondern verschoben nach rechts oder links, an den Seitenrand.

Die Schrift in der ersten Zeile beginnt nicht am linken Seitenrand (Bei Blocksatz), sondern mit etwas Abstand dazu.

            Also quasi so, khkkhkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkk
khkkhkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkfgghhhjjjjjjjjjdaokikisuiw
khkkhkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkkfgghhhjjjjjjjjjdaokikisuiw

Ich habe schon alles möglich versucht um das zu korrigieren. Z.B. den Einzug verändert. Aber das hat bislang nichts gebracht.

Mit dem FBReader (epub) wird alles richtig angezeigt. Also so, wie ichs im groben in der odt auch angelegt habe. Mit dem ebook-betrachter von Calibre sind kleine Bilder und Schriften verschoben und auch mit Sigil sind kleine Bilder und Schrift verschoben.

Weiß jemand einen Rat, wie man das korrigieren und in den Griff bekommen kann?

Bei Sigil habe ich mal kurz probiert den Einzug zu verändern. Das hat insofern funktioniert als sich bei dem drücken von "Einzug vergrößern" die Schrift richtig untereinander ausgerichtet hat, aber dabei der gesamte Abschnitt nach rechts verrutscht ist und somit zwar die Anfangswörter untereinander richtig stehen, der gesamte Abschnitt eben aber dann in Richtung Mitte der Seite steht, wo er nicht hingehört.

« Letzte Änderung: 27.09.2019, 21:16:31 von Michel »

Also die kleinen Bilder habe ich jetzt in Position bekommen, indem ich dafür gesorgt habe, dass bei ihnen keine Absatzmarken (Steuerzeichen) mehr sind. So bleiben sie auch horizontal in der richtigen Position.

Für die Sätze habe ich bislang keine Lösung gefunden, wie man die so hinbekommt, dass diese auch nach der Konvertierung noch bündig mit dem linken Rand sind.

Falls jemand dazu ne Idee oder Kenntnis hat, freue ich mich über einen Hinweis. Danke.

Hallo,

ich gebs jetzt auf.

Ich kann einfach nix dazu finden, wie man das mit dem Schrifteinzug abschalten kann.

Hab jetzt alles mittig gesetzt, dann sieht es wenigstens nicht so SchXXXX aus.

Folgendes wurde mir noch herangetragen:

Scheinbar haben manche die Meinung, dass ein Einzug das Lesen von Texten erleichtert. Das ist evtl. auch ein bisschen der Fall, wenn man elendslange Vorträge liest, bei dem einem die Gehirnzellen einschlafen, da ist so ein verrückter Anfang des Abschnittes evtl. etwas wiederbelebendes. So kann man das natürlich sehen und vielleicht ist das aus diesem Grund auch irgendwie automatisch so eingestellt.

https://www.typolexikon.de/texteinzug/

Generell bin ich allergisch, wenn mir was vorgeschrieben wird und ich nicht selbst entscheiden kann, wie das aussehen soll......und außerdem passt das für meinen Zweck absolut gar nicht.

Falls doch noch jemand ne Idee hat, wie man das Ganze überlisten und einstellen kann, bin ich ganz Ohr.

Hallo Michel,

bei meiner LO Version 6.2 habe ich die Möglichkeit ohne Hilfsmittel direkt als ePub zu exportieren (Datei, Exportieren als...). Dort finde ich aus solche Optionen wie "fließend" (das klingt für mich wie "dynamisch") oder "fest" (klingt für mich wie "so wie ich es in LO Writer gestaltet habe").

Nutzt dir das etwas?

Edit: Writer2Epub erscheint mir etwas verstaubt - dort wird auf die LO Versionen 3 und 4 verwiesen (aktuell ist 6.3).
« Letzte Änderung: 25.09.2019, 08:07:28 von Isolator »

Hallo Isolator,

vielen Dank für den Tipp.

Klingt interessant. Ich schau mir das mal an.



Jetzt sehe ich noch etwas: Du hast LM 18.3 (ich auch), ich habe aber händisch (hinzufügen des entsprechenden PPA) auf LO 6.2 upgedatet, würde demnächst sogar auf 6.3 gehen.

Vielleicht kann ja jemand hier aus dem Forum berichten, ob LO 6.3 auf Mint 18.3 problemlos läuft (so wie es die 6.2er Version tut).

Hier ist der Link für das PPA (inkl. Anleitung zum Hinzufügen):

https://launchpad.net/~libreoffice/+archive/ubuntu/libreoffice-6-2

(Für die 6.3 einfach die 2 am Ende des Links durch 3 ersetzen.

nein, das geht nicht.

https://launchpad.net/~libreoffice/+archive/ubuntu/libreoffice-6-3

Einfach mal reingucken. Für Ubuntu xenial (Basis der LM 18ner Versionen) sind keine Pakete im ppa.

Hallo zusammen,

weil ich irgendwo gelesen habe, dass die neuen Versionen von LO auf dem alten System wohl nicht funktionieren, habe ich mir gleich mal 19.1 auf dem anderen PC installiert.

Auf dieser LM Version befindet sich die LO-Version: 6.0.7.3

Mit dieser ist zwar das exportieren von epub möglich, jedoch ohne die von Isolator erwähnten Einstellmöglichkeiten (fließend etc.) beim Exportieren. Da gibt es nur die Option Überschrift oder Seitenumbruch.

Und nun kommt das Beste ;) - nach dem exportieren ist zwar die Schrift exakt da wo sie sein soll und das Ganze sieht echt ordentlich und sauber aus, ABER es fehlen alle Bilder die in der Datei sind und diese sind wesentlich.......

Der Versuch Version 6.3 upzugraden ist misslungen, vermutlich habe ich einen Schritt nicht gemacht. Vielleicht kann mir jemand Schritt für Schritt erklären, was ich dazu machen muss.

Ich habe den Terminal geöffnet und sudo add-apt-repository ppa:libreoffice/libreoffice-6-2 eingegeben. Dann habe ich noch sudo apt-get update. Aber ich kann nach dem Neustart nichts verändertes erkennen und unter Hilfe "Über LibreOffice" steht weiterhin Version: 6.0.7.3

Kein Wunder. apt-get update installiert auch überhaupt nichts. Das frischt nur die Quellen auf.
Aber schau doch mal in der Aktualisierungsverwaltung nach......
« Letzte Änderung: 25.09.2019, 16:53:12 von toffifee »

@toffifee Ich habe heute schon, gleich nach dem Installieren von 19.1, die Aktualisierungen durchlaufen lassen und alles herunter geladen. Nach Deinem Hinweis habe ich gerade nochmal nachgeschaut und da waren dann tatsächlich nochmal 2 neue Sachen, unter anderem LibreOffice. Und was soll ich sagen? ;) Es läuft :)

Mit dem 6.3. Ist bzgl. der Einstellmöglichkeiten alles wie von Isolator beschrieben. Beim Exportieren kommen jetzt auch die Bilder mit.

Es sind noch ein paar andere Sachen etwas verschoben, die vorher korrekt dargestellt wurden, aber das lässt sich sicher noch hinbekommen.

Mein erster Eindruck: So macht das Sinn und scheint wirklich zu funktionieren.

Den Rest kann man dann, wenn nötig, z.B. mit Sigil noch nachschleifen.

Vielen Dank Euch für die Hilfe.

Die Lösung für ein ordentliches formatieren auf epub heißt also LO 6.3.

Hoffe mal das ist jetzt nicht zu weit vorgegriffen.

Jetzt sehe ich noch etwas: Du hast LM 18.3 (ich auch), ich habe aber händisch (hinzufügen des entsprechenden PPA) auf LO 6.2 upgedatet, würde demnächst sogar auf 6.3 gehen.

Vielleicht kann ja jemand hier aus dem Forum berichten, ob LO 6.3 auf Mint 18.3 problemlos läuft (so wie es die 6.2er Version tut).

Das Thema war schon mal durch LO 6.2 auf Mint 17
https://www.linuxmintusers.de/index.php?topic=56116.0

Hallo zusammen,

weil ich irgendwo gelesen habe, dass die neuen Versionen von LO auf dem alten System wohl nicht funktionieren, habe ich mir gleich mal 19.1 auf dem anderen PC installiert.

Auf dieser LM Version befindet sich die LO-Version: 6.0.7.3

Mit dieser ist zwar das exportieren von epub möglich, jedoch ohne die von Isolator erwähnten Einstellmöglichkeiten (fließend etc.) beim Exportieren. Da gibt es nur die Option Überschrift oder Seitenumbruch.

Und nun kommt das Beste ;) - nach dem exportieren ist zwar die Schrift exakt da wo sie sein soll und das Ganze sieht echt ordentlich und sauber aus, ABER es fehlen alle Bilder die in der Datei sind und diese sind wesentlich.......

Der Versuch Version 6.3 upzugraden ist misslungen, vermutlich habe ich einen Schritt nicht gemacht. Vielleicht kann mir jemand Schritt für Schritt erklären, was ich dazu machen muss.

Ich habe den Terminal geöffnet und sudo add-apt-repository ppa:libreoffice/libreoffice-6-2 eingegeben. Dann habe ich noch sudo apt-get update. Aber ich kann nach dem Neustart nichts verändertes erkennen und unter Hilfe "Über LibreOffice" steht weiterhin Version: 6.0.7.3

Es gibt noch ein weiteres LO ppa. Da braucht man nicht mit den Versionen zu hantieren.

Das hier ppa:libreoffice/ppa hat immer nur die aktuelle Version vorrätig. Aber eben auch erst ab Ubuntu bionic / LM 19 ff.

Edit: huch... gerade gesehen. Es ist dasselbe ppa.  ;) Ich hab halt ohne Versionsangabe daraus installiert und die aktuellste 6.3.1 erhalten.
« Letzte Änderung: 26.09.2019, 14:03:07 von dphn »

Zitat
Hoffe mal das ist jetzt nicht zu weit vorgegriffen.


War leider vorgegriffen - Man soll den Tag nicht vor dem Abend loben.

Also mit dem LO 6.3 ist jetzt die Schrift genau da wo sie sein soll. Sieht sauber aus und funktioniert.

Das kann ich nun von den Bildern leider gar nicht mehr behaupten. Die stehen meistens ganz links und lassen sich mit nix in LO in die Mitte bewegen (Also in LO schon, aber nach dem exportieren in epub sind sie wie mit einem Magneten linksbündig angenagelt).

Ich kämpfe jetzt seit 2 Tagen mit sämtlichen Versuchen und ich bekomme keine verlässliche Handhabe. Ich hab echt alles erdenklich probiert und versucht nachzulesen.

Bei einem Bild funktionieren bestimme Befehle, beim anderen wieder nicht.

Von 6 Seiten mit der gleichen Anordnung (zwei Bilder nebeneinander) sind 5 Seiten so wie sie sollen und eine Seite verdreht die beiden Bilder, so dass das eine plötzlich links anstatt rechts steht. Also die Bilder beim exportieren plötzlich die Plätze tauschen. Da ist so viel Eigenleben, was für mich nicht nachvollziehbar ist.

Um vielleicht doch noch eine Lösung zu finden benötige ich Hilfe.

Ich habe versucht mit entsprechenden Programmen direkt die Befehle umzuschreiben. Doch das gelingt mir nicht, weil mir a) die dort befindlichen Befehle unbekannt sind (z.B. frame, para, span. Wobei ich mittlerweile herausgefunden habe, was es mit dem frame auf sich hat) und b) ich nicht weiß wo genau ansetzen (also welche Befehle wo einsetzen und welche unter diesem System überhaupt funktionieren).

Ich hab hier mal ein einfaches Beispiel ausgesucht, vielleicht kann mir jemand der etwas Ahnung hat an diesem Beispiel aufzeigen, wie ich das Bild in die Mitte der Seite bekomme und zwar so, dass wenn ich später das Fenster größer und kleiner mache, das Bild immer in der Mitte des Fensters bleibt.

<?xml version="1.0" encoding="UTF-8"?>
<html xmlns="http://www.w3.org/1999/xhtml"><head><link href="../styles/stylesheet.css" rel="stylesheet" type="text/css"/></head><body class="body0" xmlns:epub="http://www.idpf.org/2007/ops"><p class="para0"><img alt="OEBPS/images/image0001.png" class="frame0" src="../images/image0001.png"/><br style="clear: both;"/> </p></body></html>

So wie es in diesem Beispiel geschrieben steht, bleibt das Bild links stehen.

Wäre super, wenn mir da jemand helfen könnte. Vielen Dank


Jubel!

Ich glaube ich habe die Lösung endlich gefunden.

Also bei dem oben aufgeführten Beispiel habe ich vor   src=    class="scalled"   eingegeben (anstatt class=frame0). So bliebt das Bild immer in der Mitte, egal wie groß man das Fenster macht.

Bei einer anderen Seite hatte ich noch zusätzlich das Problem, dass bei scaled alleine, das Bild dann viel zu groß wurde. Da habe ich dann nach  src="image...." noch zusätzlich  width="200" eingegeben und so bleibt das Bild dann auch in der Größe die es haben soll.

Puuuh war das jetzt ein Aufrieb.....;)

Danke nochmal, ich denke jetzt müsste alles passen.

« Letzte Änderung: 27.09.2019, 21:15:38 von Michel »

 

1. Advent
1. Advent