Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
28.11.2020, 09:09:04

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24828
  • Letzte: kohlhaas
Statistiken
  • Beiträge insgesamt: 697112
  • Themen insgesamt: 56413
  • Heute online: 447
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  grub konnte nicht auf /dev/sda installiert werden  (Gelesen 1058 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

grub konnte nicht auf /dev/sda installiert werden
« am: 23.09.2019, 10:18:50 »
Hallo in die Runde,
wollte soeben Linux Mint 19.1 auf einem MSI GE 60 Laptop installieren und kurz vor Aschluss bekam ich eine schwerwiegende Fehlermeldung

grub konnte nicht auf /dev/sda installiert werden

Wie soll ich nun vorgehen? Was könnte der Fehler sein?

Ich bekomme als Auswahl

die Installation abbrechen (mit dem Vermerk dass dann der Computer nicht mehr starten könnte)
Fortsetzen ohne die Installation eines Boot-Loaders
oder die Auswahl auf eine anderes Gerät zu speichern sprich festplatten

ich würde aber gerne den Bootloader auf der gleichen Festplatte wie das Betriebssystem haben.

Wieso kommt es überhaupt zu einer solchen Fehlermeldung? Liegt das an einer Einstellung im Bios?

Über schnelle Hilfe wäre ich sehr dankbar.

Gruß in die Runde.
« Letzte Änderung: 23.09.2019, 14:17:25 von Tomtetom »

Re: grub konnte nicht auf /dev/sda installiert werden
« Antwort #1 am: 23.09.2019, 10:31:13 »
Wie soll ich nun vorgehen? Was könnte der Fehler sein?
Schwer zu sagen.
Wichtig wäre zu wissen, was vorher gemacht wurde. ;)
Wie sieht es auf dem Rechner aus? inxi -Fz sudo parted --list gibt Antwort.

Warum LM-19.1?
es gibt schon LM-19.2

Re: grub konnte nicht auf /dev/sda installiert werden
« Antwort #2 am: 23.09.2019, 10:34:27 »
Die Installation ist nicht beendet und sollte ich sie beenden ohne einen installierten Bootloader kann ich nicht booten und das system hochfahren. Von daher werde ich wohl schlecht deine Befehl im terminal ausführen können.

Re: grub konnte nicht auf /dev/sda installiert werden
« Antwort #3 am: 23.09.2019, 10:43:26 »
ich  bin jetzt im System ohne einen Restart nach der Installation.

Zitat
mint@mint:~$ inxi -Fz
System:    Host: mint Kernel: 4.15.0-20-generic x86_64 bits: 64
           Desktop: Cinnamon 3.8.9  Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: Micro-Star product: GE60 2OC\2OD\2OE v: REV:1.0 serial: N/A
           Mobo: Micro-Star model: MS-16GC v: REV:0.B serial: N/A
           BIOS: American Megatrends v: E16GCIMS.611 date: 08/27/2013
Battery    BAT1: charge: 45.8 Wh 100.0% condition: 45.8/48.8 Wh (94%)
CPU:       Quad core Intel Core i7-4700MQ (-MT-MCP-) cache: 6144 KB
           clock speeds: max: 3400 MHz 1: 1090 MHz 2: 1263 MHz 3: 1028 MHz
           4: 1268 MHz 5: 1170 MHz 6: 1088 MHz 7: 1100 MHz 8: 1038 MHz
Graphics:  Card-1: Intel 4th Gen Core Processor Integrated Graphics Controller
           Card-2: NVIDIA GK107M [GeForce GT 750M]
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting,nouveau (unloaded: fbdev,vesa)
           Resolution: 1920x1080@59.93hz
           OpenGL: renderer: Mesa DRI Intel Haswell Mobile
           version: 4.5 Mesa 18.0.5
Audio:     Card-1 Intel 8 Series/C220 Series High Def. Audio Controller
           driver: snd_hda_intel
           Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.15.0-20-generic
Network:   Card-1: Qualcomm Atheros Killer E220x Gigabit Ethernet Controller
           driver: alx
           IF: enp3s0 state: down mac: <filter>
           Card-2: Realtek RTL8723AE PCIe Wireless Network Adapter
           driver: rtl8723ae
           IF: wlp5s0 state: up mac: <filter>
Drives:    HDD Total Size: 643.6GB (1.3% used)
           ID-1: /dev/sda model: HGST_HTS545050A7 size: 500.1GB
           ID-2: /dev/sdb model: Crucial_CT128M55 size: 128.0GB
           ID-3: USB /dev/sdc model: Slim_Line size: 15.5GB
Partition: ID-1: / size: 3.9G used: 190M (5%) fs: overlay dev: N/A
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 64.0C mobo: 27.8C gpu: 58.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 255 Uptime: 17 min Memory: 1685.1/7897.4MB
           Client: Shell (bash) inxi: 2.3.56
mint@mint:~$


mint@mint:~$ sudo parted --list
Modell: ATA HGST HTS545050A7 (scsi)
Festplatte  /dev/sda:  500GB
Sektorgröße (logisch/physisch): 512B/4096B
Partitionstabelle: msdos
Disk-Flags:

Nummer  Anfang  Ende   Größe  Typ      Dateisystem  Flags
 1      32,3kB  500GB  500GB  primary  ntfs


Modell: ATA Crucial_CT128M55 (scsi)
Festplatte  /dev/sdb:  128GB
Sektorgröße (logisch/physisch): 512B/4096B
Partitionstabelle: msdos
Disk-Flags:

Nummer  Anfang  Ende   Größe  Typ      Dateisystem  Flags
 1      1049kB  128GB  128GB  primary  ext4


Modell: Intenso Slim Line (scsi)
Festplatte  /dev/sdc:  15,5GB
Sektorgröße (logisch/physisch): 512B/512B
Partitionstabelle: msdos
Disk-Flags:

Nummer  Anfang  Ende    Größe   Typ      Dateisystem  Flags
 2      459kB   2851kB  2392kB  primary               esp


mint@mint:~$


Re: grub konnte nicht auf /dev/sda installiert werden
« Antwort #4 am: 23.09.2019, 10:45:30 »
Linux Mint 19.2 wollte ich über die update Funktion nachinstallieren.


Re: grub konnte nicht auf /dev/sda installiert werden
« Antwort #5 am: 23.09.2019, 10:47:35 »
auf dem Rechner war vorher eine Windows 7 installiert welches durch Linux Mint ersetzt werden sollte. Konnte endlich meine Frau überzeugen umzusteigen. Ich habe dann von einem USB Stick aus Linux Mint von einem USB Live Stick installiert. D h ich habe Linux erst gebootet und dann von Linux Mint installieren Button aus installiert.
« Letzte Änderung: 23.09.2019, 10:54:25 von Tomtetom »

Re: grub konnte nicht auf /dev/sda installiert werden
« Antwort #6 am: 23.09.2019, 11:03:48 »
Von daher werde ich wohl schlecht deine Befehl im terminal ausführen können.
Irrtum.
Die gehen auch mit dem Live-System, welches man ja zur Installation braucht.
Und es gibt dort einen Firefox, mit dem man ins Forum kommen kann.

Aber wenn das System startet ("Bin im System"), ist jetzt alles i.O.?
« Letzte Änderung: 23.09.2019, 11:16:04 von aexe »

Re: grub konnte nicht auf /dev/sda installiert werden
« Antwort #7 am: 23.09.2019, 11:21:10 »
Nein. wenn ich neustart mache startet er nicht, weil kein grub installiert ist. Komme nur über das Live System rein.

Re: grub konnte nicht auf /dev/sda installiert werden
« Antwort #8 am: 23.09.2019, 11:25:44 »
Zeige bitte mal die Ausgabe von
[ -d /sys/firmware/efi ] && echo UEFI || echo BIOS

Re: grub konnte nicht auf /dev/sda installiert werden
« Antwort #9 am: 23.09.2019, 11:31:37 »

https://www.linuxmint.com/rel_tina_cinnamon_whatsnew.php

Das gibt es seit LM-19.2 Cinnamon, deswegen die Frage danach:
Zitat
"Boot-Repair" was added to the installation ISO images.
It's able to repair most boot configuration problems.

Re: grub konnte nicht auf /dev/sda installiert werden
« Antwort #10 am: 23.09.2019, 12:13:39 »
Zitat
grub konnte nicht auf /dev/sda installiert werden

Zitat
ich würde aber gerne den Bootloader auf der gleichen Festplatte wie das Betriebssystem haben.

Laut "sudo parted --list" liegt das Betriebssystem auf sdb ?!

Re: grub konnte nicht auf /dev/sda installiert werden
« Antwort #11 am: 23.09.2019, 13:45:53 »
Ich denke ich habe es hinbekommen. Habe das System nochmal neu installiert und bei manueller Eingabe eine Partition gelöscht und dann ging es.

Bin mir nicht sicher was ich getan habe von daher keine genaueren Angaben möglich.  :o :o :o

$ sudo parted --list
[sudo] Passwort für ranjana:           
Modell: ATA HGST HTS545050A7 (scsi)
Festplatte  /dev/sda:  500GB
Sektorgröße (logisch/physisch): 512B/4096B
Partitionstabelle: msdos
Disk-Flags:

Nummer  Anfang  Ende   Größe  Typ      Dateisystem  Flags
 1      32.3kB  500GB  500GB  primary  ntfs


Modell: ATA Crucial_CT128M55 (scsi)
Festplatte  /dev/sdb:  128GB
Sektorgröße (logisch/physisch): 512B/4096B
Partitionstabelle: msdos
Disk-Flags:

Nummer  Anfang  Ende   Größe  Typ      Dateisystem  Flags
 1      1049kB  128GB  128GB  primary  ext4         boot


Re: grub konnte nicht auf /dev/sda installiert werden
« Antwort #12 am: 23.09.2019, 14:00:28 »
Off-Topic:
Bin mir nicht sicher was ich getan habe von daher keine genaueren Angaben möglich.
Willst Du uns für blöd verkaufen?
Falls doch nicht alles wie erwartet funktioniert, solltest Du das bei Deiner nächsten Anfrage gleich erwähnen. ::)

Re: grub konnte nicht auf /dev/sda installiert werden
« Antwort #13 am: 23.09.2019, 14:14:12 »
Mit Sicherheit will ich euch nicht für blöd verkaufen. Ich weiß echt nicht was ich genau getan habe. Ich habe bei der manuellen Einstellung der Festplattenauswahl eine Partition gelöscht, bin mir aber nicht sicher.

Re: grub konnte nicht auf /dev/sda installiert werden
« Antwort #14 am: 23.09.2019, 14:15:38 »

https://www.linuxmint.com/rel_tina_cinnamon_whatsnew.php

Das gibt es seit LM-19.2 Cinnamon, deswegen die Frage danach:
Zitat
"Boot-Repair" was added to the installation ISO images.
It's able to repair most boot configuration problems.


coole Sachen. Danke für den Tipp.