Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
15.09.2019, 20:45:26

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22538
  • Letzte: Kenobi
Statistiken
  • Beiträge insgesamt: 607923
  • Themen insgesamt: 49200
  • Heute online: 573
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema: [gelöst]  Probleme mit Einstellungen in LibreOffice 6.0.7.3  (Gelesen 485 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Probleme mit Einstellungen in LibreOffice 6.0.7.3
« am: 08.09.2019, 22:14:30 »
Liebe Linuxgemeinde

ich möchte mich nun doch mit einem LibreOffice-Problem an euch wenden, da ich es alleine nicht hinbekomme.
Ich hoffe, das hier im Forum ein paar LibreOffice-Hardliner rumstöbern, die mir vieleicht Helfen oder ein paar Tipps geben können.

Wie schon in anderen Beiträgen erwähnt haben wir bei uns im Betrieb komplett auf Linux Mint Mate 19.2 Caja umgestellt,
dieses Betriebssystem läuft nun auf allen Rechnern.
Wir arbeiten hier seit jeher mit StarOffice, seit 2012 mit OpenOffice 3.4.1

Da in Linux Mint Mate 19.. aber LibreOffice Standardmäßig enthalten und dies ja mit OpenOffice stark Verwand ist,
war klar, das wir ab Linux mit LibreOffice arbeiten würden. Dies hat sich aber schnell als sehr schwierig entpuppt.
Nicht nur ich, sondern auch meine Mitarbeiter tun sich mit einigen uneigenarten sehr schwer.
Da aber OpenOffice nur sehr mäßig von den Entwicklern gepflegt wird und ich davon ausgehe, das dieses Projekt auf früh oder lang
eingestellt wird, habe ich mich entschlossen, bei LibreOffice zu bleiben.

Vieleich kann mir jemand helfen, ein paar kleine wehweh'chen abzustellen.


1. Kein Schnellstarter in der Taskleiste (sicher, es geht auch ohne, aber....)
2. Extrem lästig: Beim Suchen in Calc wird die Suche nicht am Ende der Tabelle beendet
   Wenn man "mal schnell" nach etwas Sucht (kommt bei uns oft vor) merkt man oft nicht, das man wieder von vorne anfängt,
   so geht unnötig Zeit verloren. Bei OpenOffice wurde am ende der Tabelle gestoppt und gefragt, ob man wieder von vorne Suchen will.
   Natürlich nicht, macht ja wenig Sinn.
3. Wenn man etwas Kopiert und will es wieder Einfügen, klickt man dauernd auf das falsche Einfügen (Ist 2x da)
4. Beim schnellen Mausklick links/rechts zum Einfügen in eine Zelle öffnet sich an statt dessen das "Kommentar-Eingabefeld"
   Das ist extrem lästig, wenn man gewohnt ist schnell und flüssig zu Arbeiten und man jetzt bedacht und langsam machen
   muß, weil man sonst was falsches tut.
5. Dann ist es sehr Irritierend, das beim Kopieren eines Zeilenbereiches dieser danach weit über diesen Arbeitsschritt hinaus
   animierend markiert bleibt, obwohl ich schon lange etwas anderes mache.
6. Eine Tabelle, die rechts über den Bildschirmrand hinaus geht, soll fixiert bleiben, weil in dem verdeckten Teil z.B.
   Lieferanten, original Teile-Nummern oder Einkaufspreise und Umsätze stehen, die der Kunde niemals sehen soll.
   Bei einem klick in die letzte Spalte springt die Tabelle jedoch nach rechts und offenbart alles das, was eigentlich verborgen bleiben soll.
   NoGo, wenn der Kunde neben einem steht.

Dies sind nur einige der uneigenarten, die ich und meine Mitarbeiter lästig finden und die wir irgendwie beheben möchten.
Wenn das eine oder andere nicht mit Einstellungen zu beheben ist, bleibt nur die Alternative, auf OpenOffice 3.4.1 oder 4.1.6 umzusteigen.
Das wollen wir aber eigendlich nicht.

Weis einer hier einen Rat?

Linux Mint Mate 19.2 Caja  /  LibreOffice 6.0.7.3
« Letzte Änderung: 10.09.2019, 21:50:07 von Aramis »

Re: Probleme mit Einstellungen in LibreOffice 6.0.7.3
« Antwort #1 am: 09.09.2019, 09:43:00 »
Hallo,

1. einen Schnellstarter in die Taskleiste hinzuzufügen, sollte eigentlich kein Problem sein. Weil ich MATE nicht nutze,  lasse ich diese Frage offen,  vielleicht antworten darauf Benutzer, die mit Mate Erfahrung haben

2. wenn ich nach etwas schnell suche, klicke ich auf Suchen und Ersetzen (Lupe mit einem Bleistift oder Ctrl +Alt + F) , ins Suchfeld schreibe ich, wonach ich suche + ENTER und bekomme schnell Ergebnisse → entweder Suchbegriff nicht gefunden oder alle Treffer
...oder meinst Du eine andere Art des Suchens in Calc?

3. Stimmt, im Kontextmenü sind 2x Einfügen: Einfügen → fügt den kopierten Text ein und Einfügen…. → bekommt man Möglichkeit Zellen und Spalten einzufügen.

Das Kontextmenü in Calc lässt sich aber ganz einfach bearbeiten und alles, was man nicht will und nicht braucht, kann man aus dem Kontextmenü entfernen: LibO Calc → Extras → Anpassen →Kontextmenüs → Zellen → Einfügen…. markieren und mit Button mit einem Pfeil entfernen (siehe Anhang)

4. siehe Punkt 3

5. das ist nicht nur bei LibO so, sondern auch bei MS Office. Die Lösung ist ganz einfach → Doppelklick im kopierten Beireich oder irgendwo – egal wo in der Tabelle in Calc und die Animierung des kopierten Bereiches verschwindet

6. das habe ich irgendwie nicht verstanden → wie ich die Tabelle in Calc auf dem Bildschirm positioniere, so bleibt sie auch, egal, auf welche Zelle ich klicke.

EDIT// auf dem Bild im Anhang habe ich aus Versehen Löschen... markiert. Ich wollte Einfügen... markieren.
« Letzte Änderung: 09.09.2019, 10:17:31 von janek-m »

Re: Probleme mit Einstellungen in LibreOffice 6.0.7.3
« Antwort #2 am: 09.09.2019, 10:44:22 »
1. Kein Schnellstarter in der Taskleiste
Rechtsklick auf die Leiste --> + Zur Leiste hinzufügen... --> Anwendungsstarter --> Klick auf > vor "Büro" --> gewünschte Anwendung auswählen, dann Rechtsklick auf neues Symbol in der Leiste --> Verschieben


Re: Probleme mit Einstellungen in LibreOffice 6.0.7.3
« Antwort #3 am: 09.09.2019, 11:46:06 »
Hallo janek-m

vielen Dank für die Hinweise.

zu 1:
Das mit dem Schnellstarter ist ein "Nebenkriegsschauplatz", aber zum flüssigen Arbeiten ist dieser sehr nützlich.
Dieser hat aber, wie ich Denke, nichts mit Mint-/und/oder Caja zu tun, sondern dieser wurde in OpenOffice aktiviert.
(Extras/Optionen/OpenOffice/Allgemein/Schnellstarter in Taskleiste anzeigen)
Wenn dieser in OpenOffice aktiviert war, wurde glaube ich OpenOffice schon größten Teils beim Systemstart in den Speicher geladen,
auf jeden Fall öffnete es viel schneller als LibreOffice und ohne ein Logo beim öffnen anzuzeigen.

zu2:
Wir haben "Suchen und Ersetzten" mit einem "Eingabefeld" oben in die Symbolleiste gesetzt, hier wird der Suchbegriff eingegeben
und die Suche einfach mit "Enter" gestartet.
Das funktioniert auch, nur oft wird ein falscher Suchbegriff eingegeben, der nicht zum gewünschten Erfolg führt.
Da ist es eben Hilfreich, wenn man merkt, das man am Ende der Tabelle angekommen ist, um ggf. den Suchbegriff zu ändern und
noch einmal zu suchen.
GENAU DAS MERKT MAN ABER NICHT, weil LibreOffice nicht so wie OpenOffice auf das Ende der Tabelle aufmerksam macht.
Irgendwann merkt man es dann.
Ich suche nach einer Einstellungsmöglichkeit, das LibreOffice anzeigt, das das Tabellenende erreicht ist.

zu3 und zu4:
PERFEKT..... Ins schwarze getroffen   :D    Danke
Wir haben uns zusammengesetzt und einheitlich auf allen Rechnern das Kontextmenü nach unseren Vorstellungen geändert.

zu5:
Ja Ja, die haben sich ein wenig angepaßt (MS Office), das wird eine Gewöhnungssache.....

zu6:
Beispiel: Unsere Inventurliste hat 11 Spalten und über 5000 Zeilen
Nach dem öffnen sin Sichtbar spalte A bis H, Spalte I, J und K sind verdeckt.
Wenn ich nun in Spalte H klicke, um eine Eingabe zu ändern, verschiebt sich die Tabelle, so das I, J und K sichtbar werden.
Dummerweise sind in I, J und K aber Werte, die z.B. der Kunde nicht einsehen darf.
In OpenOffice ist die Tabelle wie "Festbetoniert" stehengeblieben, wenn wir in Spalte "H" geklickt haben,
das müssen wir irgendwie wieder hinbekommen....

Re: Probleme mit Einstellungen in LibreOffice 6.0.7.3
« Antwort #4 am: 09.09.2019, 11:51:04 »
Danke tml,

das hat auch geklappt, nur schneller Laden tut es jetzt immer noch nicht, aber man kann nicht alles haben  ;D

Re: Probleme mit Einstellungen in LibreOffice 6.0.7.3
« Antwort #5 am: 09.09.2019, 12:24:07 »
Hallo,
zu6:
Beispiel: Unsere Inventurliste hat 11 Spalten und über 5000 Zeilen
Nach dem öffnen sin Sichtbar spalte A bis H, Spalte I, J und K sind verdeckt.
Wenn ich nun in Spalte H klicke, um eine Eingabe zu ändern, verschiebt sich die Tabelle, so das I, J und K sichtbar werden.
du/ihr könntet den Spalten-Kopf I, J, K markieren und im Re-Maus Kontext "Spalten ausblenden" zumindest wäre das im Kundengespräch eine temporäre Lösung.

Re: Probleme mit Einstellungen in LibreOffice 6.0.7.3
« Antwort #6 am: 09.09.2019, 12:27:48 »
Hmm....
Kann man dieses "Spaltenspringen" in LibreOffice nicht einfach irgendwie abschalten ?

Re: Probleme mit Einstellungen in LibreOffice 6.0.7.3
« Antwort #7 am: 09.09.2019, 12:50:09 »
Nach dem öffnen sin Sichtbar spalte A bis H, Spalte I, J und K sind verdeckt.
Wenn ich nun in Spalte H klicke, um eine Eingabe zu ändern, verschiebt sich die Tabelle, so das I, J und K sichtbar werden.
Ich weiß nicht, wie LibO sich in LM Mate verhält, aber in LM Cinnamon funktioniert Positionierung von LibO Calc problemlos. Wie ich Calc auf dem Bildschirm öffne und nach dem Wunsch verschiebe, bleibt es, wie Du schreibst wie  Festbetoniert :) – ich kann Calc minimieren und wieder maximieren oder die Spalten wählen und in die Zeilen schreiben, Tabelle bleibt fix auf ihrem Platz.
Oder man kann das Fenster mit der Calc-Tabelle so anpassen, dass nur gewünschte Spalten sichtbar sind.

Die Spalten auszublenden und nach dem Bedarf wieder eizunblenden, wie kuehhe1 vorgeschlagen hat, ist auch eine gute Idee – kleine Anleitung dazu HIER

Kann man dieses "Spaltenspringen" in LibreOffice nicht einfach irgendwie abschalten ?
Ich denke, wenn das Fenster seine feste Position auf dem Bildschirm immer wieder vergisst, hat das mit LibO – Einstellungen sehr wenig zu tun. Ich würde in den Systemeinstellungen unter Fenster schauen, wie das Fensterverhalten eingestellt ist.

Re: Probleme mit Einstellungen in LibreOffice 6.0.7.3
« Antwort #8 am: 09.09.2019, 13:14:13 »
Hmm....
Kann man dieses "Spaltenspringen" in LibreOffice nicht einfach irgendwie abschalten ?

Mal so nebenbei, vielleicht ist  besser im https://www.libreoffice-forum.de/
die Fragen zu stellen. Es hat wohl nichts mit dem Betriebssystem Linux Mint zu tun.
LibreOffice Calc als Teil von LibreOffice wird auch unter MS Windows und oder OS X und Linux.
Im Detail ist in o.g. Forum der bessere Rat zu erwarten, ohne den anderen Usern die immer helfen die Kompetenz ab zu sprechen.

Re: Probleme mit Einstellungen in LibreOffice 6.0.7.3
« Antwort #9 am: 09.09.2019, 13:42:59 »
Hallo,
6. das habe ich irgendwie nicht verstanden → wie ich die Tabelle in Calc auf dem Bildschirm positioniere, so bleibt sie auch, egal, auf welche Zelle ich klicke.
merkwürdig, dass geschilderte "Problem" kann ich hier mit LO-6.0.7.3 nachvollziehen.

Allerdings zeigt LO-Calc ein unterschiedliches Verhalten bei maximiertem und verkleinertem Fenster:
Maximiertes Fenster: ein leeres Tabellenblatt wird mit den Spalten A-R angezeigt, klicke ich in die Zelle R1 verschiebt sich das Arbeitsblatt nicht.

Verkleinertes Fenster: ein leeres Tabellenblatt wird mit den Spalten A-L angezeigt, wobei die Spalte S nicht in voller Breite dargestellt wird, klicke ich in die Zelle L1 verschiebt sich das Arbeitsblatt und die Bildlaufleiste nach Rechts und macht auch die ganze Spalte M sichtbar.
« Letzte Änderung: 09.09.2019, 14:16:17 von kuehhe1 »

Re: Probleme mit Einstellungen in LibreOffice 6.0.7.3
« Antwort #10 am: 09.09.2019, 13:59:45 »
Hallo Urmel,
da hast Du natürlich recht, ich war aber so stark auf unser neues "Linux" fixiert, das ich gar nicht so weit gedacht habe....
Bis auf das Spaltenspringen ist eigendlich ja aber schon nahezu alles geklärt.

Ja und kuehhe1 hat recht, die letzte Spalte ist bei uns auch nicht ganz verdeckt, wenn man in diese klickt, verschiebt sich alles und die nächste Spalte wird mit sichtbar.
Das schlimme:
Klicke ich dann wieder eine Zelle vorne an, bleibt die Tabelle so und die erste Spalte ist verdeckt.

Re: Probleme mit Einstellungen in LibreOffice 6.0.7.3
« Antwort #11 am: 09.09.2019, 14:14:47 »
Klicke ich dann wieder eine Zelle vorne an, bleibt die Tabelle so und die erste Spalte ist verdeckt.
Zelle A1, den Tabellenanfang, erreicht man mit der Tastatur, Taste: [Pos1]
« Letzte Änderung: 09.09.2019, 16:32:07 von kuehhe1 »

Re: Probleme mit Einstellungen in LibreOffice 6.0.7.3
« Antwort #12 am: 10.09.2019, 21:49:20 »
Das Problem mit dem Spaltenspringen ist nun auch gelöst, wenn auch nicht "Seriös"
Die Tabelle "Springt" immer dann um, wenn man in die letzte Spalte rechts klickt, und zwar immer dann, wenn diese Spalte über den Bildschirmrand hinaus geht. Ich habe die Spaltenbreiten der Tabelle leicht geändert, so das die letzte rechte Spalte gerade noch vollständig im Bild ist. Jetzt bleibt die Tabelle stehen, damit kann ich leben.

Das zweite Problem mit "Suchen und Ersetzten" über das Ende der Tabelle hinaus werde ich wie Urmel es vorgeschlagen hat, ins libreoffice-Forum stellen.

Trotzdem Danke an alle, die geholfen haben.

Re: Probleme mit Einstellungen in LibreOffice 6.0.7.3
« Antwort #13 am: 11.09.2019, 07:24:18 »
Zu 1:
Mit Schnellstart ist gemeint, dass Office schon beim Systemstart im Hintergrund geladen wird und dadurch bei Bedarf schneller einsatzbereit ist. Das lässt sich bestimmt mit einem Starter in „Startprogramme“ umsetzen.
Da ich aber kein MATE Nutzer bin, überlasse ich die Umsetzung kundigen Helfern.

Dafür werden aber Systemressourcen verbraucht. Wenn das öffnen schon jetzt Probleme bereitet, ist das vielleicht keine gute Idee.

Re: Probleme mit Einstellungen in LibreOffice 6.0.7.3
« Antwort #14 am: 11.09.2019, 09:46:28 »
Hallo,
zu 1:
Das mit dem Schnellstarter ist ein "Nebenkriegsschauplatz", aber zum flüssigen Arbeiten ist dieser sehr nützlich.
Dieser hat aber, wie ich Denke, nichts mit Mint-/und/oder Caja zu tun, sondern dieser wurde in OpenOffice aktiviert.
(Extras/Optionen/OpenOffice/Allgemein/Schnellstarter in Taskleiste anzeigen)
Im Menü des LO 6.0.3.7 ist die Schnellstartoption nicht mehr vorhanden.

Ich verwende hier LM19.2 Cin. mit LO 6.0.3.7 und hab da was gefunden das auch bei Mate funktionieren sollte.
Habe in dazu in Startprogramme einen Starter angelegt, auf das + Zeichen klicken >Anwendung auswählen> Libreoffice und den Startbefehl mit der Option :libreoffice --quickstartangepasst und gespeichert. Nach dem Starten des Befehls oder bei Neustart wird der Prozess >soffice.bin< in der Systemüberwachung angezeigt, siehe Anhang, jedoch erscheint entgegen der alten LO-Version kein Icon in der rechten Leiste.

Der Befehl bewirkt das LO bereits beim Systemstart im Hintergrund gestartet wird und das erstmalige Öffnen von Dokumenten beschleunigt, beim Schliessen mit [X] des LO-Fensters wird leider auch der Prozess >soffice.bin< beendet.

Eine anderer optionaler Startbefehl wäre:libreoffice --minimizeddas Ergebnis ist aber das Selbe wie die vom bereits durch die Installation vorhandenen Starter in Menü>Büro>LibreOffice und dessen Befehllibreoffice %ULO öffnet sich mit minimiertem Fenster in der Leiste.

Quellen:
http://www.ooowiki.de/WortIndex.html
http://www.ooowiki.de/SchnellStarter.html
Zitat letzte Zeile:
Zitat
Sie können den Schnellstarter auch starten, indem Sie OpenOffice.org mit dem Kommandozeilenparameter -quickstart aufrufen....

Edit: und die  6.0 Hilfe/Handbuch/Vorlagen/Tips/Videos: https://de.libreoffice.org/get-help/documentation/
« Letzte Änderung: 11.09.2019, 14:51:36 von kuehhe1 »