Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
19.09.2019, 11:11:47

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22558
  • Letzte: Weber-J
Statistiken
  • Beiträge insgesamt: 608559
  • Themen insgesamt: 49264
  • Heute online: 595
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema: [gelöst]  Grafikprobleme mit HP Notebook mit Ryzen 5 3500u und Vega8 onboard Grafik  (Gelesen 531 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo,
ich habe seit kurzem ein HP Notebook mit Ryzen 5 3500u Prozessor. Leider habe ich meine Schwierigkeiten Linux Mint Tina Cinnamon darauf zu installieren.
Ich benutze zum Testen einen USB-Stick mit dem aktuellen Image, welches ich hier im Forum heruntergeladen habe. Bis auf die Grafikkarte läuft alles super. Leider habe ich keinen blassen Schimmer, wieso die nur im Software-Rendering-Modus mit 1024 * 768 Auflösung startet.
Beim Starten kommt eine ahci-Fehlermeldung. Mehr konnte ich bisher nicht mitlesen...

Kann mir jemand einen Hinweis geben, wie ich die Grafikkarte mit voller Auflösung zum Laufen kriege?

Schon mal vielen Dank im voraus.

Hier noch ein paar Daten zum System (inxi -Fx):
System:
  Host: mint Kernel: 4.15.0-54-generic x86_64 bits: 64 compiler: gcc
  v: 7.4.0 Desktop: Cinnamon 4.2.3 Distro: Linux Mint 19.2 Tina
  base: Ubuntu 18.04 bionic
Machine:
  Type: Laptop System: HP product: HP Laptop 17-ca1xxx v: N/A
  serial: <root required>
  Mobo: HP model: 85B3 v: 91.40 serial: <root required> UEFI: AMI v: F.41
  date: 05/29/2019
Battery:
  ID-1: BAT0 charge: 33.7 Wh condition: 41.0/41.0 Wh (100%)
  model: Hewlett-Packard Primary status: Charging
CPU:
  Topology: Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx
  bits: 64 type: MT MCP arch: Zen rev: 1 L2 cache: 2048 KiB
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  bogomips: 33535
  Speed: 1223 MHz min/max: 1400/2100 MHz Core speeds (MHz): 1: 1255 2: 1236
  3: 1223 4: 1227 5: 1340 6: 1234 7: 1247 8: 1228
Graphics:
  Device-1: AMD Picasso vendor: Hewlett-Packard driver: N/A bus ID: 04:00.0
  Display: x11 server: X.Org 1.19.6 driver: ati,fbdev
  unloaded: modesetting,radeon,vesa resolution: 1024x768~76Hz
  OpenGL: renderer: llvmpipe (LLVM 8.0 128 bits) v: 3.3 Mesa 19.0.2
  direct render: Yes
Audio:
  Device-1: AMD vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
  bus ID: 04:00.1
  Device-2: AMD vendor: Hewlett-Packard driver: N/A bus ID: 04:00.5
  Device-3: AMD vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
  bus ID: 04:00.6
  Sound Server: ALSA v: k4.15.0-54-generic
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: Hewlett-Packard driver: r8169 v: 2.3LK-NAPI port: f000
  bus ID: 02:00.0
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: 80:e8:2c:bd:7c:a9
  Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter
  vendor: Hewlett-Packard driver: N/A port: e000 bus ID: 03:00.0
Drives:
  Local Storage: total: 1.26 TiB used: 94.7 MiB (0.0%)
  ID-1: /dev/nvme0n1 vendor: Toshiba model: KBG30ZMV256G size: 238.47 GiB
  ID-2: /dev/sda vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB
  temp: 31 C
  ID-3: /dev/sdb type: USB vendor: SanDisk model: Extreme Pro
  size: 119.25 GiB
Partition:
  ID-1: / size: 6.84 GiB used: 94.7 MiB (1.4%) fs: overlay source: ERR-102
Sensors:
  System Temperatures: cpu: 45.2 C mobo: 0.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 211 Uptime: 8m Memory: 13.67 GiB used: 958.5 MiB (6.8%)
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.19
  inxi: 3.0.32
« Letzte Änderung: 04.09.2019, 00:39:37 von Doppelkeks »

Da solltest du es erst mal mit dem 5.0er Kernel versuchen.
Sollte es dann immer noch Probleme geben könnte auch ein Mainline - Kernel hilfreich sein 5.2.11 ist der aktuellste.

Momentan starte ich von einem USB-Stick. Nach jedem Neustart sind die Einstellungen weg...
Kann ich den installierten Kernel aus dem laufenden System aktivieren oder muss ich dazu zwingend neu starten?
sudo grub-config wirft folgende Meldung:
/usr/sbin/grub-probe: Fehler: Kanonischer Pfad von »/cow« konnte nicht ermittelt werden.

Mein ursprünglicher Plan war, erst mittels USB-Stick zu testen, ob die Hardware unterstützt wird, bevor ich das vorhandene Windows komplett herunterwerfe und mit Mint ersetze.
Falls das so nicht klappt, kann ich allerdings Mint auch neben Windows installieren...

Danke für die Hilfe.

Kann ich den installierten Kernel aus dem laufenden System aktivieren oder muss ich dazu zwingend neu starten?
Das Aktivieren eines nachinstallierten Kernels erfordert natürlich einen Neustart! Du kannst aber versuchen, dein Live-System mit persistentem Speicher zu erstellen. Unetbootin z.B. kann so was. Dann bleiben Veränderungen erhalten.

Kernel-Aktualisierungen sind bei Live-Systemen nicht zu empfehlen!
Geht meist in die Hose.
Mit oder ohne persistenten Speicher.
Mint auch neben Windows installieren...
halte ich für eine gute Idee.

Zum Testen evtl. mal das neueste Ubuntu (19.04) als Live-System nehmen. Das sollte einen neueren Kernel bereits eingebaut haben.
« Letzte Änderung: 03.09.2019, 19:23:41 von aexe »


Super Leute,
mit Ubuntu 19.04 hat es funktioniert!  ;D

Jetzt bin ich am grübeln, ob ich den Rechner gleich neu aufsetzen soll, ohne Windows, oder ob eine Parallelinstallation (bis alles läuft) mehr Sinn macht. Dann müsste ich das Ganze zweimal machen...
Gibt es mit dem Kernelupdate sonst noch Nebenwirkungen, an die man denken sollte?

Also ihr habt mir echt schon sehr geholfen. Danke und Hut ab dafür...

Grüße Doppelkeks

Hast du wichtiges, termingebundenes oder so zu tun, Dualboot wenn es geht.   
Kannst Windows später löschen und mit dem laufenden Mint ersetzen, geht alles.
Macht die Installation Grafikprobleme, ev. Bootoption "nomodeset" und nach Installation gleich auf den 5er wechseln.

Ich habe mich sicherheitshalber für die Dualbootvariante entschieden.
Hier eine kurze Zusammenfassung, vielleicht hat ja jemand ähnliche Probleme

- Platz auf der Festplatte schaffen durch Verkleinern der Partition. (Die SSD bleibt für Linux erstmal ungenutzt)
- Linux Mint von Stick booten und installieren
- Per Aktualisierungsverwaltung System aktualisieren und den neusten Kernel installieren ( 5.0.0-27 in meinem Fall)
- Beim Neustart in den erweiterten Optionen vorsichtshalber den neuen Kernel ausgewählt

Tadaa, die Grafikkarte wird erkannt.

Bleibt noch zu erwähnen, dass bei mir WLAN nicht funktioniert hat. Ich musste erst noch die Treiber für den Realtek RTL8821CE  WLan-Chip nachinstallieren. Ist aber auch hier im Forum erklärt. ;-)

Wenn sich das jetzt alles als stabil erweist, werde ich den Rechner demnächst nochmal neu aufsetzen, diesmal komplett mit SSD und ohne Windows.

Danke nochmals und Grüße
Doppelkeks

Wenn dein Mint gut eingerichtet ist und gut läuft, kannst du mit Gparted, nachdem das Windows von der SSD runter ist, die Mint-Partition auf die SSD kopieren und dir eine Neuinstallation ersparen - in Kurzform.

Nach einiger Zeit läuft alles stabil! Jetzt fliegt Windows ganz runter.

@ geobart: Thx für den Tipp! Jetzt hast Du mich ins Grübeln gebracht. So ganz sicher bin ich mir nicht, ob/wie das gehen kann.
Da muss ich mich erst noch ein klein wenig einlesen. Bisher habe ich mich immer auf den Installationsassistenten verlassen, was die Partitionierung angeht.

Ich denke mal, dass ich vom Stick booten muss, die Rootpartition auf die SSD verschiebe und anschließend die Partition auf die komplette SSD erweitere (geht eventuell auch in einem Schritt).
Dann muss ich noch grub dazu bringen, von der neuen Rootpartition zu starten.
Wie gross sollte die SWAP-Partition werden, bei 16 Gb RAM (-3 für die onboard-Grafik)? 8-10 Gb? Die kommt dann auf die Festplatte, denke ich.
Als Dateisystem wäre wohl ext4 geeignet.

Stimmt das so ungefähr oder liege ich völlig daneben?

Grüße von Doppelkeks