Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
15.09.2019, 20:51:09

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22538
  • Letzte: Kenobi
Statistiken
  • Beiträge insgesamt: 607923
  • Themen insgesamt: 49200
  • Heute online: 573
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema: [gelöst]  Bei Datensynchronisation mit rsync wird unerwünscht Papierkorb mit gesichert  (Gelesen 462 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo liebe Linuxgemeide,

ich hoffe, ich gehe euch mit meinen vielen Anfragen nicht auf den "Senkel".
Habe jetzt auch nur ein kleines Problem, das eigendlich auch nur ein "Schönheitsfehler" ist.

Hier im Betrieb erfolgt die Datensicherung über rsync.
Bei jeder Syncronisation wird der Papierkorb des Quellrechners mit auf den Server gesichert, der ja eigendlich wiederum seinen eigenen Ordner ".Trash-1000" hat. Abgesehen davon das ich Sorge habe, das dies zu durcheinander führen könnte, wundere ich mich über dieses Kopierverhalten, da der Ordner ".Trash-1000" eigendlich vom Kopierbefehl ausgenommen wurde.

mate-terminal ssh -e 'rsync -avz --delete --progress --exclude /.Trash-1000 --exclude /WinTV /mnt/Dokumente/ Server:/mnt/Dokumente'
Wie kann ich dieses Kopieren verhindern und warum wird der Ordner ".Trash-1000" überhaupt kopiert?

Sorry....      Linux Mint 19.2 Mate Caja
« Letzte Änderung: 02.09.2019, 23:26:16 von Aramis »

Hallo

Vor dem /.Trash-1000 fehlt vermutlich eine Tilde (~).
Bei mir ist es übrigens ~/.local/share/Trash/files unter Cinnamon.

Die Angaben zu deinem Betriebssystem in der Signatur zu haben ist auf Dauer nicht sinnvoll. Du wirst dein System ja nicht "lebenslang" auf dieser Version lassen, und dann passt es später nicht mehr, Also die Angaben zu deinem System immer direkt dazu schreiben. Zumindest das OS.
« Letzte Änderung: 31.08.2019, 13:36:17 von macromat »

Die Angaben zu deinem Betriebssystem in der Signatur zu haben ist auf Dauer nicht sinnvoll

Nicht nur auf Dauer. 
Ich habe wie viele andere das Signaturlesen abgeschaltet. 
Wer Support hier im Forum will, sollte sich an die Regeln halten.

Wie kann ich dieses Kopieren verhindern und warum wird der Ordner ".Trash-1000" überhaupt kopiert?
Benutze vollständige, also absolute Pfade, dann klappt es auch. ;)

Benutze vollständige, also absolute Pfade, dann klappt es auch. ;)
Hat er doch:
... /.Trash-1000 ...
Ein versteckter Trashordner direkt auf dem Rootverzeichnis. Extremst selten, würde ich sagen.   :D

Hi :)
sollte doch eigentlich unter
/.local/share/Trash
liegen.

Guckst du:
find ~ -type d -iname '*trash*'

/.local/share/Trash
Besser ~/.local/share/Trash  ;)

Benutze vollständige, also absolute Pfade, dann klappt es auch.
Das ist m.E. bei rsync ein wenig anders, in obigem Beispiel müsste eigentlich /mnt/Dokumente/.Trash-1000 ausgeschlossen werden, also der Mülleimer auf einer Platte außerhalb des home-Verzeichnisses (siehe auch https://wiki.ubuntuusers.de/rsync/#Verzeichnisse-von-der-Sicherung-ausschliessen).

@Aramis
Wo genau befindet sich der Mülleimer (Pfad)?
« Letzte Änderung: 31.08.2019, 15:51:49 von tml »

Es kann auch mehrere Mülleimer geben.
Der Benutzer hat normalerweise find ~ -type d -iname '*trash*'
/home/user/.local/share/Trash


Off-Topic:
Warum nicht grsync verwenden?
Da hat man das Terminal-Gefrickel nicht und sinnvolle Voreinstellungen und verschiedene vorgefertigte Optionen.


Edit
Was ist denn nun das Ergebnis der Erforschung?
Bei manchen Anfragen unangenehm ist weniger die Frage an sich, sondern das Ausbleiben einer Rückmeldung.
« Letzte Änderung: 31.08.2019, 22:54:19 von aexe »

Ich finde das mit dem Mülleimer auch etwas seltsam, aber Linux ist eben noch etwas neu für mich.
Unter Windows kannte ich das so, das sich in jeder Festplatten-Partition ein versteckter Mülleimer "Recycle.bin" befunden hat.
Wo und wie diese Mülleimer im Linux untergebracht sind, entzieht sich bisher meiner Kenntnis.

Ich habe aber nun gelernt, einer liegt auf sda1 in:
/home/user/-local/share/Trash
Das sieht bei mir dann so aus:
mbts@E-Lager:~$ find ~ -type d -iname '*trash*'
/home/mbts/.local/share/Trash

Meine Festplatte ist in drei ext4 Partitionen eingeteilt, und ich stelle mir da die sicherlich berechtigte Frage, warum um Himmels Willen ist in sda1 und sda2 ein Mülleimer, und in sda3 nicht. Und wie kommt der Mülleimer in sda2 da hin, diese Partition ist Reserviert nur für MEINE Daten. OK, mit einem Mülleimer kann ich Leben, aber den möchte ich eben nicht im Backup mit Sichern.

Warum sich das jetzt nicht mit untem stehendem --exclude unterbinden lässt, entzieht sich meiner Kenntnis.
--exclude /.Trash-1000
Der Pfad ist ganz klar angegeben: Quelle = /mnt/Dokumente
Alles, was sich hier befindet soll ins Ziel kopiert werden, ausgenommen eben dem blöden Mülleimer, warum der auch immer da sein mag.
Löschen läßt sich der Mülleimer übrigens, aber wenn das System ihn wieder anlegen sollte, ist die Seuche wieder da.
Keine Ahnung, ob das so passieren wird.

Aber meine eigendliche Frage war ja: Warum greift hier beim Backup per rsync der Befehl "--exclude" nicht?
« Letzte Änderung: 02.09.2019, 01:22:07 von Aramis »

Off-Topic:
Ein Mülleimer wird auf der entsprechenden Partition angelegt, sobald du dort das erste Mal etwas löschst. Das macht ja auch Sinn, denn sonst müssten die Dateien beim "Verschieben" in den Müll zunächst auf eine andere Partition, nämlich die, auf welcher sich dein Heimatverzeichnis befindet, kopiert werden, bevor sie letztendlich von der ursprünglichen gelöscht werden können.

Die Dateien werden trotzdem im Mülleimer angezeigt, auch wenn sie sich im .Trash-1000 befinden und beim Aushängen der Partiton erscheint zudem noch die Frage, ob der Inhalt des Mülleimers geleert werden soll oder nicht.

Hier läuft zwar Cinnamon, bei Mate dürfte das Verhalten aber identisch sein.

Zum Thema: Ich habe es einmal getestet, hier wird der .Trash-1000 sowohl mit führendem "/" als auch ohne immer ausgeschlossen:
 ~ $ ls -a /media/test/730GB_ext4/
.  ..  1  2  3  lost+found  .Trash-1000  WinTV
rsync -e ssh -avz --delete --progress --exclude={.Trash-1000,WinTV,lost+found} /media/test/730GB_ext4/ /media/test/1000GB_ext4/rsync_test/rsync -e ssh -avz --delete --progress --exclude={/.Trash-1000,/WinTV,lost+found} /media/test/730GB_ext4/ /media/test/1000GB_ext4/rsync_test/~ $ ls -a /media/test/1000GB_ext4/rsync_test/
.  ..  1  2  3

Hatte sich bei dir vielleicht ein Schreibfehler eingeschlichen?

Hinweis:
An der von mir verwendeten Schreibweise kann es eigentlich nicht liegen, ich spare mir damit nur die vielen "--exclude". Ist auch übersichtlicher...

Vielen Dank tml,

ich werde das erst heute Abend spät Probieren können, hier herrscht jetzt der Alltagsstress.
Alleine schon die Schreibweise mit {} um die vielen --exclude zu sparen ist ein Klasse Tip!  :D
In anderen Sicherungspfaden stehen diese --exclude bei uns nämlich Reihenweise.
(--exclude /"System Volume Information" --exclude /Recycle.BIN -- exclude /WinTV --exclude /Lost+Found --exclude /.Trash-1000 usw.)

Danke

Ich gebe dann Feedback
« Letzte Änderung: 02.09.2019, 10:53:36 von Aramis »

rsync kann sich die Muster für "exclude" auch aus einer Datei holen:        --exclude-from=FILE
              This  option is related to the --exclude option, but it specifies a FILE that contains exclude patterns
              (one per line).  Blank lines in the file and lines starting with ’;’ or ’#’ are ignored.  If FILE is -,
              the list will be read from standard input.
man rsync

Danke aexe, das mit der Datei für "exclude" wußte ich, aber das war mir irgendwie zu kompliziert.
Dann lieber ein paar mal exclude Schreiben, aber das mit "{ }" gefällt mir dann doch besser.

Ich habe die Abläufe eben noch einmal getestet.
Die Aussage von tml ist zutreffend:
Auf sda1 befindet sich ein Papierkorb in /home/user/.local/share/Trash
Auf sda2 erscheint ein Papierkorb, sobald da was gelöscht wird
Auf sda3 erscheint logischerweise ebenfalls nach einem beliebigen Löschvorgang ein Papierkorb

Bei der Datensicherung mit rsync wird der Papierkorb jetzt auch nicht mehr mit kopiert, wenn ich ihn mit "exclude" ausschließe.

Ich verstehe nicht, warum das jetzt plötzlich Funktioniert. Sorry, aber vermutlich hatte tml recht, und es war wirklich ein Schreibfehler
(ein Leerzeichen zwischen Slash und Punkt oder irgend so was blödes)

Auf jeden Fall geht alles und ich bin wieder schlauer.....