Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
22.10.2019, 08:37:51

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22702
  • Letzte: TheoRist
Statistiken
  • Beiträge insgesamt: 614654
  • Themen insgesamt: 49669
  • Heute online: 526
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online
Mitglieder: 8
Gäste: 460
Gesamt: 468

Autor Thema: [gelöst]  Kopiervorgang sehr langsam  (Gelesen 728 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

odbThreadstarter

  • ***
[gelöst] Kopiervorgang sehr langsam
« am: 23.08.2019, 00:57:28 »
hallo zusammen
kleines problem und hoffe auf eure hilfe
in letzter zeit ist mir aufgefallen, dass kopiervorgänge auf einen usb 3.0 stick sehr lange dauern. eben noch mit einem sandisk 128gb und lexar 64gb stick getestet. kopiert wird von der festplatte direkt auf den stick, der an einem 3.0 port hängt. format des sticks ist fat32.
wenn ich eine 3gb datei mit kopieren und einfügen oder kopieren nach auf den stick übertrage fängts schnell an und bei 30% ca gehts dann nur noch blöckeweise weiter. ne zeit lang passiert nix, dann gehts auf 45% hoch, dann wieder nix, dann auf 70% hoch usw. .. bei 99% blinkt der stick auch noch mal ne ganze weile und dann nach 5 minuten ist es dann mal beendet.

damit hatte ich ganz zu anfang nie probleme, selbst mit billigen sticks nicht. und die zwei oben genannten liefen auch problemlos. das kopieren unterhalb der eingebauten ssds läuft super. habe das ganze auch mal unter Windows getestet, keine probleme.
vielleicht habt ihr ne lösung, würde mich freuen.
danke

nutze ciannamon mint 18.3 64bit
« Letzte Änderung: 23.08.2019, 20:52:00 von odb »

Re: Kopiervorgang sehr langsam
« Antwort #1 am: 23.08.2019, 07:12:02 »
Fat32 ist bei 128gb und 64gb das falsche Dateisystem.
Das Dateisystem erlaubt eine maximale Partitionsgröße von 32 GB (- ist so gewollt vom MS), in der Theorie bis zu 8 Terabyte.

Dazu weiter, etwas zum schmökern.:
https://www.allround-pc.com/artikel/wissen/2009/fat32-ntfs-exfat-was-man-ueber-diese-dateisysteme-wissen-sollte
https://www.allround-pc.com/artikel/wissen/2009/grosse-fat32-partitionen-schnell-einfach-erstellen

Kleinere Dateien werden bei Fat32 langsamer geschrieben. Einer der Nachteile von Fat32.
Als reinen Datenstick wäre ich für NTFS - Windows oder Ext4 - Linux.

Linux kann auch NTFS verstehen > https://wiki.ubuntuusers.de/Windows-Partitionen_einbinden/NTFS-3G/
« Letzte Änderung: 23.08.2019, 07:21:53 von Moridian »

Re: Kopiervorgang sehr langsam
« Antwort #2 am: 23.08.2019, 07:45:53 »
Ich empfehle einen systematischen Test mittel des Tools "Laufwerke". Habe hier auch USB 3.0 Sticks die mit lächerlichen 5 MB/s schreiben (Transcend). Diese Werte kann ich in den Rezensionen von Amazon nachvollziehen.

Man beachte auch die teils extrem schwankenden Werte der verschiedenen Sticks.

Getestet an einem USB 3.0 Anschluss.

odbThreadstarter

  • ***
Re: Kopiervorgang sehr langsam
« Antwort #3 am: 23.08.2019, 08:56:54 »
Guten Morgen und danke für eure Hilfe
Was mir beim Lesen eingefallen ist, dass ich vorher NTFS genutzt habe, zu fat32 gewechselt bin, weil ich auf den Sticks mp3 hatte und das Autoradio nichts erkannte. War allerdings zu aktiven Windows Zeiten. Dann teste ich es mal mit NTFS und exfat32.
Oder was sollte ich nehmen, denn ich wechsle schonmal zwischen Linux und Windows?
Ich danke euch

Re: Kopiervorgang sehr langsam
« Antwort #4 am: 23.08.2019, 09:35:39 »
Wenn doch zwischen Windows und Linux wechselst, kannst du eigentlich nur ntfs nehmen.

Re: Kopiervorgang sehr langsam
« Antwort #5 am: 23.08.2019, 10:14:13 »
LM 18.3 Mate 64
Kurz mein Senf, habe mit diversen USB-Sticks ein ähnliches Phänomen, Dateien so plus/minus 1GB werden in nullkommanix bis auf ca. 80% auf den USB-Stick geladen, dann hakt's und dauert bis zu 10 Minuten bis der USB-Stick vollständig aufgeladen ist, derselbe Rechner mit Windows10, kein Problem.

Off-Topic:
Bei Windows10 habe ich das Phänomen dass große Dateien oft ewig brauchen um von einem Ordner zum anderen kopiert zu werden, unter LM geht das in Sekundenbruchteilen

 
Wenn doch zwischen Windows und Linux wechselst, kannst du eigentlich nur ntfs nehmen.

Ich verwende auch FAT32, da motzt zwar Windows10 kurz und will reparieren, ich ignoriere das und habe dann keine Problem auf die Dateien zuzugreifen.

odbThreadstarter

  • ***
Re: Kopiervorgang sehr langsam
« Antwort #6 am: 23.08.2019, 17:21:57 »
hey leute
jute neuigkeiten. die sticks auf NTFS formatiert und es läuft so wie ich es kenne, ca 45MB/sek. ne 3gb datei in ca 5 minuten statt vorher fast 10.
ich danke für eure hilfe und schönes wochenende

DeVIL-I386

  • Administrator
  • *****
Re: Kopiervorgang sehr langsam
« Antwort #7 am: 23.08.2019, 21:47:37 »
Dass der Kopiervorgang am Anfang scheinbar blitzschnell abläuft, liegt daran, dass der größte Teil der Daten in Wirklichkeit erstmal im Zwischenspeicher (RAM) landet.

losrobos

  • Gast
Re: Kopiervorgang sehr langsam
« Antwort #8 am: 24.08.2019, 00:43:17 »
Dass der Kopiervorgang am Anfang scheinbar blitzschnell abläuft, liegt daran, dass der größte Teil der Daten in Wirklichkeit erstmal im Zwischenspeicher (RAM) landet.

Man sollte dies etwas näher erklären damit auch nicht-Profis verstehen was eigentlich geschieht. Wenn ich jetzt eine große Datei egal unter welchem  System auf einen USB-Stick oder auf einen anderen mobilen Datenträger kopiere, da gibt es einen netten Fortschittsbalken der zeigt die Datei ist fertig kopiert oder verschoben, schließt man jedoch den Datenträger ab  und wieder an ist die Datei nicht da,

Wie unter Windows gibt es auch unter Linux im Dateimanager oder einer kleiner Applikation im Panel, Kontrollleiste oder eben der Taskleiste die manchmal leider zu zaghafte genutzte Option den mobilen Datenträger sicher zu entfernen. Der Grund ist dieser das das System den Schreib-Vorgang selbst verlangsamt um eben das System wie den Datenträger zu entlasten - dazu wird der Cache eingesetzt, der Vorgang des Schreibens wird verzögert, verlangsamt.

Und auch heute würde ich mich unter Windows nicht darauf verlassen das wenn der Fortschrittsbalken fertig ist das auch alles drauf ist was soll.

Bei großen Dateien zum Tausch zwischen Linux und Windows würde ich einfach NTFS nutzen, es läuft auch unter Linux recht problemlos, will Windows drüber meckern einfach ignorieren und fort fahren

Re: Kopiervorgang sehr langsam
« Antwort #9 am: 24.08.2019, 08:51:05 »
Der Grund ist dieser das das System den Schreib-Vorgang selbst verlangsamt um eben das System wie den Datenträger zu entlasten - dazu wird der Cache eingesetzt, der Vorgang des Schreibens wird verzögert, verlangsamt.

Und auch heute würde ich mich unter Windows nicht darauf verlassen das wenn der Fortschrittsbalken fertig ist das auch alles drauf ist was soll.
das schreiben auf dem stick wird durch den cache NICHT verzögert, sondern auf der festplatte wird sehr viel schneller gelesen, als auf dem stick geschrieben werden kann. das was schneller gelesen, als geschrieben ist, landet derweilen im cache.

genau, fortschrittsbalken sind nett, aber fertig geschrieben ist erst, wenn der stick nicht mehr "blinkt".

EAE

  • **
Re: Kopiervorgang sehr langsam
« Antwort #10 am: 24.08.2019, 11:17:22 »
Ist hier glaube ich noch nicht erwähnt worden, oder ich hab's überlesen:
3 GB Film auf ein USB 3 Stick, schwupp und drauf.
3 GB Ordner mit vielen, vielen kleinen Dateien wie mp3`s, kannst Du nebenbei Marmelade einkochen, systembedingt, war schon immer so.

C.

DeVIL-I386

  • Administrator
  • *****
Re: Kopiervorgang sehr langsam
« Antwort #11 am: 25.08.2019, 18:06:51 »
Und wenn man (wie ich hauptsächlich) USB-Sticks ohne LED hat, führt man im Terminal den Befehl aus: sync

Re: Kopiervorgang sehr langsam
« Antwort #12 am: 25.08.2019, 18:22:08 »
Ich persönlich ziehe USB-Sticks erst von meinem System (xfce)
ab, wenn ich auf den Reiter "Aushängen" geklickt habe.
Mitunter kommt es häufig vor (Timeshift z.B.), dass nach dem Aushängen,
sich noch ein Benachrichtigungsfenster öffnet mit dem Hinweis:
"Aushängen nicht möglich, da noch Daten auf den Datenträger geschrieben werden".
Das kann so 5-60 sec. schon mal dauern.