Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
11.07.2020, 09:53:39

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 670051
  • Themen insgesamt: 54285
  • Heute online: 366
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online

Autor Thema:  Virtualisierung funktioniert, das Netzwerk nicht  (Gelesen 518 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Virtualisierung funktioniert, das Netzwerk nicht
« am: 18.08.2019, 21:21:18 »
Host: Linux Mint XFCE 19.2 Gast: Windows 10

Hallo!

Ich versuche mich gerade an der Virtualisierung von Windows 10 inkl. GPU passthrough. Ich habe diese Tutorials durchgearbeitet: https://forums.linuxmint.com/viewtopic.php?t=212692 und https://heiko-sieger.info/running-windows-10-on-linux-using-kvm-with-vga-passthrough/

Es klappt auch alles, die GPU wird an die VM durchgereicht und Windows 10 ist installiert. Aber das Netzwerk tut keinen Mucks, der Treiber für die virt. Netzwerkkarte ist installiert. Ich habe jetzt schon ein paar Stunden an den Netzwerkeinstellungen beim Host und Gast rumgeschraubt, ich komme aber keinen Schritt weiter.

Habt ihr vielleicht eine Idee oder einen Ansatzpunkt? Auf dem Host wird eine Bridge aufgemacht, die das Netzwerk an die VM weitergeben soll.

Vielen Dank schonmal im Voraus!
« Letzte Änderung: 18.08.2019, 21:33:42 von fliwatuet »

losrobos

  • Gast
Re: Virtualisierung funktioniert, das Netzwerk nicht
« Antwort #1 am: 19.08.2019, 11:03:55 »
So wie ich das sehe hast Du die Maschine über die Shell angelegt, gestartet, ... Dazu ist einiges an Kenntnis über die Optionen nötig mit KVM.

Wenn Du über die Paket-Verwaltung zusätzlich das Paket 'virt-manager' installierst hast Du eine grafische Oberfläche um die virtuelle Maschine (wozu natürlich auch das Netzwerk gehört) einfach per Mausklick anlegst, konfigurierst, ...

Willst Du ein wenig weiter gehen, Anzeige des Desktops an das Linux-Fenster anpassen, Speicher-Verwaltung optimieren, Verzeichnis zwischen Host und Gast teilen braucht Win einige zusätzliche Treiber

Re: Virtualisierung funktioniert, das Netzwerk nicht
« Antwort #2 am: 20.08.2019, 11:26:05 »
Danke für die Antwort.

Den virtmanager hatte ich zuerst ausprobiert, damit läuft das Netzwerk, ich bekomme aber das passthrough der Grafikkarte nicht hin. Für Win10 hatte ich die VIRTIO Treiber installiert: https://docs.fedoraproject.org/en-US/quick-docs/creating-windows-virtual-machines-using-virtio-drivers/index.html Im Gerätemanager ist alles sauber, es gibt nur kein Netzwerk und damit natürlich auch kein Internetzugriff.

losrobos

  • Gast
Re: Virtualisierung funktioniert, das Netzwerk nicht
« Antwort #3 am: 20.08.2019, 11:34:57 »
Hast Du unter Virt-Manager nach der Installation in den Einstellungen (Anzeigen / Details) auch die Optionen auf VirtIO gesetzt?

losrobos

  • Gast
Re: Virtualisierung funktioniert, das Netzwerk nicht
« Antwort #4 am: 20.08.2019, 11:41:30 »
Ich mach es immer so (nur die Netzwerk-Einstellungen):

-device driver=virtio-net,netdev=n1,mac=xx:xx:xx:xx:xx:xx -ntdev user,hostfwd=tcp::12345-:22,id=n1
                                            beliebige MAC-Adresse                    Port