Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
18.08.2019, 11:25:13

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22407
  • Letzte: Olltsche
Statistiken
  • Beiträge insgesamt: 603983
  • Themen insgesamt: 48910
  • Heute online: 675
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema:  Probleme mit OPERA unter Linux 19.1 (Videoformate) und Neuinstallation  (Gelesen 352 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo.

Seit etwa einem Monat habe ich Linux Mint 19.1 als Dualboot auf einem ACER A515-52G installiert und versuche mich, nach meinem langen Windows User Dasein (seit Win 3.1) in dieser neuen Welt zurechtzufinden. Bisher klappt das ganz gut, aber der Teufel steckt im Detail.
Ich liebe den OPERA Browser! Also habe ich den (wider besseren Wissens) direkt von der Webseite installiert. Ich konnte auch Videos von YouTube ansehen, nur bei einem Detail bin ich hängen geblieben. Ich mache einen gerade einen Onlinekurs, der über einen Plattform angeboten wird, die "HOTMART" heißt.
Über Firefox gibt es kein Problem, aber eben mit OPERA konnte ich die Videos nicht öffnen, ich bekam immer eine Fehlermeldung im Videofenster, dass es ein Problem mit dem Player gäbe.

Nachdem ich mich durch zig Threads im Forum gewühlt hatte, konnte ich das Problem immer noch nicht lösen und beschloss OPERA zu deinstallieren und wollte nun den Browser über die Anwendungsverwaltung installieren, was nicht so recht gelingen will.

Die Paketabhängigkeiten können nicht aufgelöst werden

Dieser Fehler könnte durch weitere erforderliche Software-Pakete, die jedoch fehlen oder nicht installiert werden können, verursacht worden sein. Außerdem könnte es einen Konflikt zwischen Paketen geben, die nicht zur selben Zeit installiert sein dürfen.

Die folgenden Pakete haben nicht erfüllte Abhängigkeiten:

opera: Depends: libgcc1 (>= 1:4.1.1) aber 1:8.3.0-6ubuntu1~18.04.1 soll installiert werden
       Depends: libgstreamer-plugins-base0.10-0 (>= 0.10.16) aber es soll nicht installiert werden
       Depends: libgstreamer0.10-0 (>= 0.10.15) aber es soll nicht installiert werden
       Depends: gstreamer0.10-plugins-good aber es soll nicht installiert werden

Was kann ich jetzt machen?
Vielen Dank und habt Geduld mit mir, ich bin ein totaler Linux Anfänger  ::)

Du lädst die Software noch einmal von der Webseite runter, lässt die DEB-Datei unter Downloads, öffnest nun das Terminal und wechselst in das Verzeichnis:

cd Downloads/
Nun installierst Du die Software:

sudo apt update
sudo apt install ./opera-dateiname.deb

Einfach die ersten Buchstaben eingeben und die Tabulator-Taste drücken - der Dateiname wird vervollständigt, mit der Eingabe-Taste bestätigen, die Software wird installiert. Wenn die Software nun installiert ist führst Du folgenden Befehl aus:

sudo apt install -f
Laufen die Videos nun?

Los robos.

Vielen Dank für die schnelle Antwort. Die Installation hat offensichtlich geklappt, auch wenn hier ein paar Einträge erscheinen (mein System in Portugiesisch, da ich in Brasilien lebe), die nicht existieren. Aber ich habe keine direkte Fehlermeldung bekommen

ndo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Note, a seleccionar 'opera-stable' em vez de './opera-stable_62.0.3331.116_amd64.deb'
Os NOVOS pacotes a seguir serão instalados:
  opera-stable
0 pacotes atualizados, 1 pacotes novos instalados, 0 a serem removidos e 0 não atualizados.
É preciso baixar 0 B/66,5 MB de arquivos.
Depois desta operação, 230 MB adicionais de espaço em disco serão usados.
Pré-configurando pacotes ...
A seleccionar pacote anteriormente não seleccionado opera-stable.
(Lendo banco de dados ... 296452 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../opera-stable_62.0.3331.116_amd64.deb ...
A descompactar opera-stable (62.0.3331.116) ...
A processar 'triggers' para mime-support (3.60ubuntu1) ...
A processar 'triggers' para desktop-file-utils (0.23+linuxmint5) ...
Configurando opera-stable (62.0.3331.116) ...
update-alternatives: a usar /usr/bin/opera para disponibilizar /usr/bin/x-www-browser (x-www-browser) em modo auto
update-alternatives: aviso: saltar a criação de /usr/share/man/man1/x-www-browser.1.gz porque o ficheiro associado /usr/share/man/man1/opera.1.gz (do grupo de ligação x-www-browser) não existe
update-alternatives: a usar /usr/bin/opera para disponibilizar /usr/bin/gnome-www-browser (gnome-www-browser) em modo auto
update-alternatives: aviso: saltar a criação de /usr/share/man/man1/gnome-www-browser.1.gz porque o ficheiro associado /usr/share/man/man1/opera.1.gz (do grupo de ligação gnome-www-browser) não existe
A processar 'triggers' para shared-mime-info (1.9-2) ...
A processar 'triggers' para gnome-menus (3.13.3-11ubuntu1.1) ...
A processar 'triggers' para hicolor-icon-theme (0.17-2) ...

Leider laufen Videos nach wie vor nicht und es kam noch schlimmer.  :D

Jetzt kann ich nicht einmal mehr Vidos auf Youtube ansehen... lach Da erscheint nun eine Meldung bezüglich des HTML5 Formats.

Ich vermute, dass ich vorher YouTube sehen konnte, weil ich pepperflash installiert hatte. Das hatte ich als mögliche Lösung in vielen Foren (nicht nur hier) gefunden und teilweise scheint es auch funktioniert zu haben, nur halt nicht für die Videos auf Hotmart.

Vermutlich werde ich die pepperflash Lösung wieder aufnehmen, dann habe ich alles, außer dem Hotmart, was ich mir dann eben auf Firefox ansehen werde.
Vielleicht hast Du, oder noch ein anderer Forumsteilnehmer eine rettende Idee.

Danke

Welche Meldung erscheint wegen HTML5? Youtube funktioniert nämlich problemlos ohne Flash

Versuche mal nach dem Begriff 'chromium-codecs-ffmpeg-extra' zu suchen, am besten in Synaptic und installiere das Paket, Opera neu starten, funktioniert es dann?
« Letzte Änderung: 10.08.2019, 22:56:25 von losrobos »

Hallo losrobos.

noch einmal vielen Dank für Deine Antwort. Mittlerweile habe ich den Stand von vorher wieder herstellen können, das heißt

- OPERA läuft
- YouTube Videos laufen
- Die chromium-codecs-ffmpeg-extra sind installiert (waren schon installiert)

Das Einzige ist, dass ich die Videos über Hotmart weiterhin nicht aufrufen kann. Ist ein "Schönheitsfehler", denn über Firefox habe ich überhaupt kein Problem damit. Liegt "nur" an Opera und wenn ich Opera sonst benutzen kann, dann soll das erst einmal in Ordnung sein. Ich werde in Ruhe weitersuchen, habe aber durch Firefox einen perfekt funktionierenden Browser, der sowieso meine Nummer 2 schon immer war.

Dir einen schönen (Rest) Sonntag

So, mittlerweile habe ich das Problem weiter eingrenzen können - es handelt sich um Videos auf Vimeo. Die kann OPERA nicht anzeigen. Weder über die Plattform meines Fernstudiums noch bei Vimeo direkt.
Vielleicht gibt es ja hierzu irgendwelche Codecs, plugins oder was auch immer...

Du könntest mal unter Synaptic nachsehen ob alle gstreamer-Pakete installiert sind.

Hallo losrobos.

Entschuldige die späte Rückmeldung, aber ich bin erst jetzt wieder dazu gekommen mit Linux "rumzuspielen". Also ich habe nun wirklich sämtliche gstreamer-Pakete installiert und habe auch noch dazu Chrome runtergeladen, in der schwachen Hoffnung, somit vielleicht "nebenher" die Elemente runterzuladen, die auch Opera dazu veranlassen, Vimeo abzuspielen. Aber das hat nicht geklappt - ich gebe mal für den Moment auf und benutze Firefox.  ;)