Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
13.11.2019, 23:30:30

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22802
  • Letzte: F7even
Statistiken
  • Beiträge insgesamt: 619059
  • Themen insgesamt: 49963
  • Heute online: 764
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema:  LM 19.1 MATE 64bit - WLAN-Treiber restlos entfernen und neuinstallieren?  (Gelesen 742 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Ich habe einen WLAN-Stick vom Typ "TP-Link - Archer T4U, AC1300".
Die ID ist 2357:010d.
Nach einigen Versuchen mit verschiedenen rtl8812au-Treibern dafür, sind die mir wohl durcheinander geraten.
(EDIT: Besser gesagt, die jeweils vorherigen Versuche sind wohl nicht richtig entfernt)
Wie bekomme ich bitte alle Treiber restlos raus, die sich auf den Stick beziehen?
Und welcher Treiber ist nun der richtige für LM 19.1 MATE 64bit?

Eine dkms-Version ist auch noch drin, da der Treiber trotz Entfernung nach einem Reboot wieder da ist.

EDIT:
Mit
locate rtl8812habe ich schon mehrmals nach dem Treiber gesucht, aber nach einem Reboot werden immer wieder folgende Ordner/Dateien gefunden.
(Den ersten kann man nicht mitzälhlen, weil der anscheinend ein BT-Treiber ist)

/lib/firmware/rtl_bt/rtl8812ae_fw.bin
/lib/modules/4.18.0-25-generic/kernel/drivers/net/rtl8812au.ko
/usr/src/rtl8812au-4.3.14
/var/cache/apt/archives/rtl8812au-dkms_4.3.8.12175.20140902+dfsg-0ubuntu8_all.deb
/var/lib/dkms/rtl8812au

Das passiert, obwohl ich diese Ordner/Dateien schon zig mal als Admin gelöscht habe.
Aber wenn ich dort nachsehe, sind diese Ordner/Dateien dort gar nicht vorhanden.

Also wo steht da noch was, was den Treiber immer wieder zurückbringt?
« Letzte Änderung: 12.07.2019, 22:41:26 von Centauri39 »

Hallo,
die Firmware ist uninteressant und stört nicht weiter. Ein paar Abfragen werden noch benötigt um die Deinstallation sauber und vollständig durchzuführen:
dkms status
ls -l /usr/src
modprobe -c | grep -i "2357.*010d"

Hier die gewünschten Ausgaben:

dkms status
nvidia, 390.116, 4.15.0-54-generic, x86_64: installed
nvidia, 390.116, 4.18.0-20-generic, x86_64: installed
nvidia, 390.116, 4.18.0-21-generic, x86_64: installed
nvidia, 390.116, 4.18.0-25-generic, x86_64: installed

ls -l /usr/src
insgesamt 44
drwxr-xr-x 27 root root 4096 Dez 17  2018 linux-headers-4.15.0-20
drwxr-xr-x  8 root root 4096 Dez 17  2018 linux-headers-4.15.0-20-generic
drwxr-xr-x 27 root root 4096 Jun 28 02:04 linux-headers-4.15.0-54
drwxr-xr-x  8 root root 4096 Jun 28 02:04 linux-headers-4.15.0-54-generic
drwxr-xr-x 27 root root 4096 Mai 15 20:56 linux-headers-4.18.0-20
drwxr-xr-x  8 root root 4096 Mai 15 20:56 linux-headers-4.18.0-20-generic
drwxr-xr-x 27 root root 4096 Jun  4 18:52 linux-headers-4.18.0-21
drwxr-xr-x  8 root root 4096 Jun  4 18:52 linux-headers-4.18.0-21-generic
drwxr-xr-x 27 root root 4096 Jul  6 23:50 linux-headers-4.18.0-25
drwxr-xr-x  8 root root 4096 Jul  6 23:50 linux-headers-4.18.0-25-generic
drwxr-xr-x  8 root root 4096 Mai 15 19:11 nvidia-390.116

Der modprobe-Befehl ergibt keine Ausgabe.

OK, dann bleibt nichts anders übrig als die Module und den Quellcode hart aus dem System zu entfernen:
sudo rm -r /lib/modules/4.18.0-25-generic/kernel/drivers/net/rtl8812au.ko
sudo rm -r /var/lib/dkms/rtl8812au
sudo apt clean
sudo depmod -a
sudo update-initramfs -u
Das sollte es gewesen sein.

Der korrekte Treiber ist rtl8812au, kommt aber auf die verwendete Kernelversion an, ob es einen brauchbaren Quellcode gibt. Bei dem 4.15.0-54-Kernel muss man schauen ... und Secure-Boot des UEFI muss abgeschaltet sein, da der Quellcode nicht signiert ist. Du schreibst ja nicht näher was zuvor nicht funktioniert hat.

Ich würde es mit ansonsten diesem hier probieren (auch für 5.x Kernel): → https://github.com/gordboy/rtl8812au

Aha, also fehlten mir offenbar noch diese Befehle:

sudo apt clean
sudo depmod -a
sudo update-initramfs -u

Was zuvor war:

So lange Mint auf Ubuntu 16.04 basierte, hatte ich immer den rtl8812au-Treiber von hier:
https://github.com/gnab/rtl8812au

Da musste ich aber nach jedem Kernel-Update neu kompilieren, was recht nervig war.

LM 18.2 und 18.3 lies ich aus.

Also ich dann auf LM 19.1 wechselte, versuchte ich den hier:
https://github.com/abperiasamy/rtl8812AU_8821AU_linux.git

Damit ergab sich aber keine stabile WLAN-Verbindung, da die Signalstärke immer wechselte.

Dann versuchte ich den rtl8812au-dkms aus Synaptic.
Der lief aber absolut nicht.
Vermutlich muss da noch was zusätzlich eingerichtet werden, wofür ich aber keine Infos fand.

Aktuell ergaben sich immer Ruckler bis zu Freezes bei Online-Videos, die bei einer LAN-Verbindung nicht geschahen.

Deshalb wollte ich mal alles raus haben und noch mal neu installieren, was den rtl8812au betrifft.

Dein Code scheint funktioniert zu haben.

Nun weiß ich aber nicht, welchen Treiber ich am besten nehmen soll.

Am liebsten wäre mir der aus Synaptic, aber den kriege ich bisher nicht zum laufen, sodass ich mir nicht mal sicher bin, ob der überhaupt geeignet ist.


EDIT:
Ich wollte gerade den gordboy-Treiber probieren, mit dieser Anleitung.

Aber da steht Version 4.2.2.
Kann doch gar nicht sein, denn der ist doch 5.2.20.2, oder nicht?
« Letzte Änderung: 13.07.2019, 00:11:43 von Centauri39 »

Habe gerade den rtl8812au aus Synaptic installiert.
Der Stick läuft nicht, aber
modinfo 8812auergibt das hier:
filename:       /lib/modules/4.18.0-25-generic/updates/dkms/8812au.ko
version:        v4.3.8_12175.20140902
author:         Realtek Semiconductor Corp.
description:    Realtek Wireless Lan Driver
license:        GPL
srcversion:     0FE007DE1CB755560C5BB1D
alias:          usb:v056Ep4007d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0411p0242d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2019pAB32d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0846p9052d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0E66p0023d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2001p3318d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2001p3314d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v04BBp0953d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v7392pA813d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v7392pA812d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v7392pA811d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0BDAp0820d*dc*dsc*dp*icFFiscFFipFFin*
alias:          usb:v0BDAp8822d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0BDAp0821d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0BDAp0811d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0411p025Dd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2357p0103d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2357p0101d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v20F4p805Bd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2001p3316d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2001p3315d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v07B8p8812d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2019pAB30d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1740p0100d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v148Fp9097d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v13B1p003Fd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1058p0632d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2001p3313d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0586p3426d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0E66p0022d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0B05p17D2d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0409p0408d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0789p016Ed*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v04BBp0952d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0DF6p0074d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v7392pA822d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2001p330Ed*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v050Dp1109d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v050Dp1106d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0BDAp881Cd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0BDAp881Bd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0BDAp881Ad*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0BDAp8812d*dc*dsc*dp*ic*isc*ip*in*
depends:        cfg80211
retpoline:      Y
name:           8812au
vermagic:       4.18.0-25-generic SMP mod_unload
signat:         PKCS#7
signer:         
sig_key:       
sig_hashalgo:   md4
parm:           rtw_ips_mode:The default IPS mode (int)
parm:           rtw_usb_rxagg_mode:int
parm:           rtw_qos_opt_enable:int
parm:           ifname:The default name to allocate for first interface (charp)
parm:           if2name:The default name to allocate for second interface (charp)
parm:           rtw_initmac:charp
parm:           rtw_channel_plan:int
parm:           rtw_special_rf_path:int
parm:           rtw_chip_version:int
parm:           rtw_rfintfs:int
parm:           rtw_lbkmode:int
parm:           rtw_network_mode:int
parm:           rtw_channel:int
parm:           rtw_mp_mode:int
parm:           rtw_wmm_enable:int
parm:           rtw_vrtl_carrier_sense:int
parm:           rtw_vcs_type:int
parm:           rtw_busy_thresh:int
parm:           rtw_ht_enable:int
parm:           rtw_bw_mode:int
parm:           rtw_ampdu_enable:int
parm:           rtw_rx_stbc:int
parm:           rtw_ampdu_amsdu:int
parm:           rtw_vht_enable:int
parm:           rtw_lowrate_two_xmit:int
parm:           rtw_rf_config:int
parm:           rtw_power_mgnt:int
parm:           rtw_smart_ps:int
parm:           rtw_low_power:int
parm:           rtw_wifi_spec:int
parm:           rtw_antdiv_cfg:int
parm:           rtw_antdiv_type:int
parm:           rtw_enusbss:int
parm:           rtw_hwpdn_mode:int
parm:           rtw_hwpwrp_detect:int
parm:           rtw_hw_wps_pbc:int
parm:           rtw_max_roaming_times:The max roaming times to try (uint)
parm:           rtw_mc2u_disable:int
parm:           rtw_80211d:Enable 802.11d mechanism (int)
parm:           rtw_notch_filter:0:Disable, 1:Enable, 2:Enable only for P2P (uint)
parm:           rtw_hiq_filter:0:allow all, 1:allow special, 2:deny all (uint)
parm:           rtw_adaptivity_en:0:disable, 1:enable, 2:auto (uint)
parm:           rtw_adaptivity_mode:0:normal, 1:carrier sense (uint)
parm:           rtw_nhm_en:0:disable, 1:enable (uint)
parm:           rtw_amplifier_type_2g:BIT3:2G ext-PA, BIT4:2G ext-LNA (uint)
parm:           rtw_amplifier_type_5g:BIT6:5G ext-PA, BIT7:5G ext-LNA (uint)
parm:           rtw_RFE_type:default init value:64 (uint)
parm:           rtw_TxBBSwing_2G:default init value:0xFF (uint)
parm:           rtw_TxBBSwing_5G:default init value:0xFF (uint)
parm:           rtw_tx_pwr_lmt_enable:0:Disable, 1:Enable, 2: Depend on efuse (int)
parm:           rtw_tx_pwr_by_rate:0:Disable, 1:Enable, 2: Depend on efuse (int)
parm:           rtw_phy_file_path:The path of phy parameter (charp)
parm:           rtw_load_phy_file:PHY File Bit Map (int)
parm:           rtw_decrypt_phy_file:Enable Decrypt PHY File (int)

Warum läuft der Stick nicht?

Installiert ist er wohl, denn ich bekomme
dkms status
nvidia, 390.116, 4.15.0-54-generic, x86_64: installed
nvidia, 390.116, 4.18.0-20-generic, x86_64: installed
nvidia, 390.116, 4.18.0-21-generic, x86_64: installed
nvidia, 390.116, 4.18.0-25-generic, x86_64: installed
rtl8812au, 4.3.8.12175.20140902+dfsg, 4.18.0-25-generic, x86_64: installed

und laut

echo "options 8821au rtw_country_code=DE" | sudo tee /etc/modprobe.d/8821au_options.conf
options 8821au rtw_country_code=DE


hat er die deutschen Kanäle.

Aber er läuft nicht, und
sudo modprobe -v 8821au[/s]

ergibt das hier:
modprobe: FATAL: Module 8821au not found in directory /lib/modules/4.18.0-25-generic



EDIT:
Sorry, da war ein Zahlendreher drin.

Folgendes ist richtig:

sudo modprobe -v 8812au
ergibt nichts.

Aber die deutschen Kanäle habe ich.

echo "options 8812au rtw_country_code=DE" | sudo tee /etc/modprobe.d/8812au_options.conf
options 8812au rtw_country_code=DE

Was läuft da falsch?
« Letzte Änderung: 13.07.2019, 01:02:39 von Centauri39 »

Ich habe jetzt doch noch mal den hier probiert.
Dieses Mal mit ausgestöpseltem Stick.
Dann Reboot, Stick rein, Erkennung klappte, WLAN-Key neu rein. Fertig.

Damit habe ich jetzt
version:        v4.3.14_13455.20150212_BTCOEX20150128-51muss allerdings bei jedem neuen Kernel neu kompilieren.

Dann kümmerte ich mich noch um die WLAN-Ausfälle bzw. -Aussetzer, indem ich nach dieser Anleitung hier vorging (Beitrag 29 und 4).

Mal sehen, ob es nun klappt... da bin ich noch nicht sicher.

Das Paket aus den offiziellen Paketquellen (synaptic) kannst Du komplett vergessen, der ist viel zu alt. Auch den jetzigen musst Du über DKMS einbinden um diesen bei  Kernelupdates automatisch in den jeweils anderen Kernel einzubinden. Wie steht ja sogar auf der Github Seite, wobei es auch anders geht.

Zusätzlich sollte man noch die Regionseinstellung setzen um die Kanaleinstellung im a-Band zu korrigieren, was allerdings nicht immer funktioniert (verm. Fehler im Quellcode):
echo 'options 8812au rtw_country_code="DE"' | sudo tee /etc/modprobe.d/8812au_options.confTreiber entladen/laden und prüfen:
iwlist chan(war schon erledigt)
Der Stick/Treiber arbeitet nur mit dem cfg80211-Subsystem, ist also kein sog. Full-Mac Treiber und systemweite Einstellungen mittels iw funktionieren nicht! Ich hatte dir ja den hier genannt: https://github.com/gordboy/rtl8812au - funktioniert auch mit einem 4.15.x-Kernel oder höher. Aber wenn es jetzt läuft ist ja gut. Nach der Installation musst Du übrigens nicht zu rebooten, wir arbeiten hier ja nicht mit Windows  ;)

Das WLAN-Powermanagement wird aktuell dynamisch über den Network-Manager gesteuert, die verlinkte Anleitung passt hier nicht, bzw. ist viel zu umständlich. In der /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf abschalten:
sudo sed -i "s/wifi.powersave = 3/wifi.powersave = 2/g" /etc/NetworkManager/conf.d/default-wifi-powersave-on.conf
sudo systemctl restart network-manager.service
« Letzte Änderung: 13.07.2019, 07:54:55 von Flash63 »

Ich bin inzwischen doch auf den gordboy-Treiber umgestiegen, da mir der andere doch nicht stabil genug war.
Der hat den Stick immer ausgeschaltet (trotz "powersave = 2"), wenn ich mal ein paar Stunden nichts gemacht habe (so kann ich VNC- oder FTP-Zugriffe vergessen).
Zuvor bin ich beim Kernel auf den "x86_64 Linux 5.0.0-20-generic" gegangen.

Jetzt muss ich noch meine anderen 4 Distris auf den "gordboy" umrüsten und dann beobachten, ob die Sticks dann hoffentlich nicht mehr abschalten.

EDIT:
Was mich allerdings irritiert, ist, dass der Kernel "x86_64 Linux 5.0.0-20-generic" doch eigentlich schon alt ist.
Eigentlich müsste ich doch den 5.2.1 bekommen, oder nicht?
Warum bietet mir dann der Kernel-Manager in der Akt.-Verwalt. von Mint den nicht an?
« Letzte Änderung: 18.07.2019, 04:40:41 von Centauri39 »

Hi :)

Zitat
Warum bietet mir dann der Kernel-Manager in der Akt.-Verwalt. von Mint den nicht an?

weil in der 18.04 repo nur die entsprechenden point release kernel eingepflegt werden.
mit den kerneln hat hat mint nichts zu tun.

Dann muss ich die 5.2.1 mit ukuu oder Terminal holen?

Off-Topic:
... ich erstaune immer wieder neu über @Flash63´s Wissen .... Chapeau .....

Es hilft alles nichts.

Mit dem gordboy-Treiber verliere ich auch die Verbindung.
Ich habe das Notebook mit diesem Treiber mal ein paar Tage durchlaufen lassen und am dritten Tag,
nachdem ich ein paar Stunden nichts daran gemacht habe war die WLAN-Verbindung wieder weg.

Auch diese Infos helfen nicht.

Wie bekomme ich nun eine stabile Verbindung?

Hallo,
bei WLAN können die Ursachen vielfältig sein. Probiere es sonst mit einem Skript, welches die Verbindung zum Router mittels Ping im Intervall prüft und ggf. den Network-Manager neu startet:
#!/bin/bash
## Variablen
## IP-Adresse des Routers/Gateway (automatisch) oder ggf. manuell eintragen
test_ipaddress=$(ip r | grep def | awk {'print $3'})
## eigene Werte für das Intervall und Ping eintragen
pingcount=1
sleeptime=60
## be root if not
test `id -u` -eq 0 || exec sudo "$0" "$@"
## Loop
while [[ true ]]
 do
  if ping $test_ipaddress -qc $pingcount >/dev/null
then
 sleep $sleeptime
  else
    systemctl restart network-manager.service
fi
 done
## Loop wird auch nach Restart des Managers nicht beendet
Es könnte auch sein, dass der Treiber abschmiert (Hardware- oder Firmwarefehler) und entladen/geladen werden muss. Kann man ja auch noch in das Sript einbauen. Also optional so...
#!/bin/bash
## Variablen
## IP-Adresse des Routers/Gateway (automatisch) oder ggf. manuell eintragen
test_ipaddress=$(ip r | grep def | awk {'print $3'})
## eigene Werte für das Intervall und Ping eintragen
pingcount=1
sleeptime=60
## be root if not
test `id -u` -eq 0 || exec sudo "$0" "$@"
## Loop
while [[ true ]]
 do
  if ping $test_ipaddress -qc $pingcount >/dev/null
then
 sleep $sleeptime
  else
## NM stooppen, Modul enladen/laden; nm starten
   systemctl stop network-manager.service
    modprobe -rf 8812au
     modprobe 8812au
      systemctl start network-manager.service
fi
 done
## Loop wird auch nach Restart des Managers nicht beendet
« Letzte Änderung: 22.07.2019, 20:02:35 von Flash63 »