Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
25.08.2019, 16:56:42

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22439
  • Letzte: HWST
Statistiken
  • Beiträge insgesamt: 605031
  • Themen insgesamt: 48995
  • Heute online: 657
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema:  LM19 Tessa-64 Bit-8Gb-IP4 bleibt öfters hängen in den Anwendungen  (Gelesen 1294 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo harmless, ich hatte erst mal auf deine Frage nach GRUB geantwortet und auf deine Antwort gewartet. Vielleicht hast Du recht und wir überprüfen erst mal die Hardware und zum Schluss machen wir das mit dem amdgpu. Dazu benötige ich garantiert deine Hilfe, weil das bekomme ich so alleine nicht hin. Ich mach das jetzt erst mal mit "hw-probe" und stelle es dann hier rein.

So hier liegen meine Daten: https://linux-hardware.org/?probe=6b8676dfef
« Letzte Änderung: 20.07.2019, 16:30:53 von Butterklatscher »

Das sieht ja alles paletti aus! Und okay, Du hast gewonnen: Du schlägst mich mit 51 zu 49 Devices  :D

Dann werde ich die Schritte für den amdgpu-Test mal niederschreiben und es dann hier reinstellen.

Hallo Butterklatscher,

Hier ist es nun. Hätte ich die Möglichkeit, hätte ich es natürlich vorher selbst getestet. Sollte noch etwas unklar sein oder Dir komisch vorkommen, lieber vorher noch mal nachfragen und/oder die Schritte mal "trocken" durchüben, vor allem die Schritte im grub-Menü nach einem eventuellen Scheitern. Die Anleitung am besten ausdrucken, dann liegt sie gut sicht- und findbar neben einem. Auch das Video kann noch mal angeschaut werden, da mit dieser Anleitung es dann klarer wird, was dort sehr schnell vollführt wird. Im Video steht hinter "quiet splash" noch "profile". Dies ist nicht wichtig, sondern soll angeblich zur Geschwindgkeitssteigerung führen. Ob das stimmt, weiß ich nicht. Ebenso wird im Video "sudo update-grub2" (also mit einer 2 hinter grub) durchgeführt, was meines Wissens keinen Unterschied macht.

Schritt 1:
Terminal: sudo xed /etc/default/grub (Warnungen ignorieren und xed öffnen lassen: über dem Textfeld steht "Erhöhte Berechtigungen")

In grub folgenden Eintrag:
Zitat
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
ändern in:
Zitat
GRUB_CMDLINE_LINUX_DEFAULT="radeon.cik_support=0 amdgpu.cik_support=1 radeon.si_support=0 amdgpu.si_support=1 quiet splash"

Datei speichern und schließen, xed verlassen.

Schritt 2:
Terminal: sudo xed /etc/modprobe.d/amdgpu.conf
Folgenden Eintrag in das leere Textfeld machen:
options amdgpu si_support=1
options amdgpu cik_support=1

Datei speichern und schließen, xed verlassen.

Schritt 3:
Terminal: sudo xed /etc/modprobe.d/radeon.conf
Folgenden Eintrag in das leere Textfeld machen:
options radeon si_support=0
options radeon cik_support=0

Datei speichern und schließen, xed verlassen.

Schritt 4:
Terminal: sudo update-grub
Schritt 5:
Terminal: sudo reboot
Warnhinweis:
Sollte das System nach dem grub-Menü nicht weiter starten, muß noch mal neu gestartet werden und nach dem Erscheinen des grub-Menüs die Taste "E" (kleines "e"!) gedrückt werden. Zur Bearbeitung mit den Pfeiltasten bis nach unten gehen (geht in der Regel über 2 Seiten), und den Eintrag
Zitat
radeon.cik_support=0 amdgpu.cik_support=1 radeon.si_support=0 amdgpu.si_support=1
(mit Leerzeichen hinter der letzten 1), der vor "quiet splash" steht, entfernen. Dann Strg+X drücken (kein Esc), um mit dem editierten grub zu starten! Wenn man dann wieder in Linux zurück ist, muß der Schritt 1 wieder rückgängig gemacht werden. Die beiden conf-Dateien werden wieder gelöscht. Dazu am besten in nemo den Ordner /etc/modprobe.d/ als Systemverwalter öffnen (rechte Maustaste, aus Kontextmenü auswählen) und die beiden Dateien markieren und löschen. Dann im Terminal noch ein "sudo update-grub" durchführen.
« Letzte Änderung: 20.07.2019, 18:16:24 von harmless »

Hallo harmless, vielen, vielen Dank. Es hat alles geklappt und funktionippelt. Jetzt werde ich merken ob die kiste wieder ohne hängenzubleiben funktioniert. Jedenfalls gestern ist sie nicht ein einziges mal abgestürzt.

Ob Du mir auch helfen könntest meine Kiste etwas schneller zu machen beim Hochfahren? Die braucht 2 volle Minuten dafür. Ist jetzt ein kleines bissschen besser geworden nach deinen Einstellungen hier.

Das freut mich sehr, daß es alles reibungslos geklappt hat. Nun hoffe ich, daß es auch bei Deinem Problem hilft und Du auch die eine oder andere Verbesserung bemerkst. Der eine Kommentator unter dem Video schreibt ja z.B., daß er dadurch einige Spiele auf steam überhaupt erst spielen kann, was mit radeon nicht funktionierte. Hast Du noch mal mit lspci -v überprüft, ob auch wirklich der amdgpu verwendet wird? Was trotzdem wichtig ist: Sollte mal ein update für grub in der Aktualisierungsverwaltung kommen und Du installierst es, solltest Du auf jeden Fall vor dem nächsten Runterfahren/Neustart wieder die Schritt 1-Änderung in grub durchführen mit anschließendem "sudo update-grub".

Soweit es mir möglich ist, helfe ich gerne bei der Startzeit. Aber dazu solltest Du noch mal einen neuen Thread aufmachen. Den von Dir erwähnten thread, wo Du das schon mal thematisiert hast, habe ich jetzt nicht gefunden. Den neuen Thread könntest Du z.B. mit folgenden Angaben beginnen:

systemd-analyze
systemd-analyze blame
systemd-analyze chritical-chain
sudo blkid
cat /etc/fstab

Also so wie es aussieht bleibt er nicht mehr hängen. Ich habe genau das ausprobiert wo er am meisten auf dem Schreibtisch hängenblieb. Ich will noch nichts beschreien, aber auch dort bleibt er nicht mehr hängen. Leider habe ich mich mit der Startzeit vertan, es sind immer noch die berühmten 2:40 Minuten. Ich hatte mal gelesen hier im Chat wie man das Linux schneller machen kann und habe von denen das ausprobiert: sudo xed /etc/initramfs-tools/conf.d/resume

Ändern in: RESUME=none=(Zahlenreihe löschen)

Terminal: sudo update-initramfs -u
Terminal: sudo reboot

Es war danach frappierend schneller, weit unter 1:45 Min.  Aber seit einigen Wochen geht das wieder so langsam. Obwohl ich diese Einstellungen nicht verändert habe. So und nun hier deine Anforderungen:peter@peter-P5K:~$ lspci -v
00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller (rev 02)
Subsystem: ASUSTeK Computer Inc. P5K PRO Motherboard: Intel 82P35 Northbridge
Flags: bus master, fast devsel, latency 0
Capabilities: <access denied>

00:01.0 PCI bridge: Intel Corporation 82G33/G31/P35/P31 Express PCI Express Root Port (rev 02) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0, IRQ 16
Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
I/O behind bridge: 0000c000-0000cfff
Memory behind bridge: fe800000-fe8fffff
Prefetchable memory behind bridge: 00000000cf800000-00000000dfffffff
Capabilities: <access denied>
Kernel driver in use: pcieport

00:1a.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 02) (prog-if 00 [UHCI])
Subsystem: ASUSTeK Computer Inc. P5K PRO Motherboard: 82801IR [ICH9R]
Flags: bus master, medium devsel, latency 0, IRQ 16
I/O ports at b800 [size=32]
Capabilities: <access denied>
Kernel driver in use: uhci_hcd

00:1a.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 02) (prog-if 00 [UHCI])
Subsystem: ASUSTeK Computer Inc. P5K PRO Motherboard: 82801IR [ICH9R]
Flags: bus master, medium devsel, latency 0, IRQ 21
I/O ports at b880 [size=32]
Capabilities: <access denied>
Kernel driver in use: uhci_hcd

00:1a.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 02) (prog-if 00 [UHCI])
Subsystem: ASUSTeK Computer Inc. P5K PRO Motherboard: 82801IR [ICH9R]
Flags: bus master, medium devsel, latency 0, IRQ 18
I/O ports at bc00 [size=32]
Capabilities: <access denied>
Kernel driver in use: uhci_hcd

00:1a.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 02) (prog-if 20 [EHCI])
Subsystem: ASUSTeK Computer Inc. P5K PRO Motherboard: 82801IR [ICH9R]
Flags: bus master, medium devsel, latency 0, IRQ 18
Memory at fe7ffc00 (32-bit, non-prefetchable) [size=1K]
Capabilities: <access denied>
Kernel driver in use: ehci-pci

00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
Subsystem: ASUSTeK Computer Inc. P5K PRO Motherboard: 82801IR [ICH9R]
Flags: bus master, fast devsel, latency 0, IRQ 25
Memory at fe7f8000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel

00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 02) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0, IRQ 17
Bus: primary=00, secondary=04, subordinate=04, sec-latency=0
I/O behind bridge: 00001000-00001fff
Memory behind bridge: c0000000-c03fffff
Prefetchable memory behind bridge: 00000000fdf00000-00000000fdffffff
Capabilities: <access denied>
Kernel driver in use: pcieport

00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 02) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0, IRQ 17
Bus: primary=00, secondary=03, subordinate=03, sec-latency=0
I/O behind bridge: 0000d000-0000dfff
Memory behind bridge: fea00000-feafffff
Prefetchable memory behind bridge: 00000000c0400000-00000000c05fffff
Capabilities: <access denied>
Kernel driver in use: pcieport

00:1c.5 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 6 (rev 02) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0, IRQ 16
Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
I/O behind bridge: 00002000-00002fff
Memory behind bridge: fe900000-fe9fffff
Prefetchable memory behind bridge: 00000000c0600000-00000000c07fffff
Capabilities: <access denied>
Kernel driver in use: pcieport

00:1d.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 02) (prog-if 00 [UHCI])
Subsystem: ASUSTeK Computer Inc. P5K PRO Motherboard: 82801IR [ICH9R]
Flags: bus master, medium devsel, latency 0, IRQ 23
I/O ports at b080 [size=32]
Capabilities: <access denied>
Kernel driver in use: uhci_hcd

00:1d.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 02) (prog-if 00 [UHCI])
Subsystem: ASUSTeK Computer Inc. P5K PRO Motherboard: 82801IR [ICH9R]
Flags: bus master, medium devsel, latency 0, IRQ 19
I/O ports at b400 [size=32]
Capabilities: <access denied>
Kernel driver in use: uhci_hcd

00:1d.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 02) (prog-if 00 [UHCI])
Subsystem: ASUSTeK Computer Inc. P5K PRO Motherboard: 82801IR [ICH9R]
Flags: bus master, medium devsel, latency 0, IRQ 18
I/O ports at b480 [size=32]
Capabilities: <access denied>
Kernel driver in use: uhci_hcd

00:1d.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 02) (prog-if 20 [EHCI])
Subsystem: ASUSTeK Computer Inc. P5K PRO Motherboard: 82801IR [ICH9R]
Flags: bus master, medium devsel, latency 0, IRQ 23
Memory at fe7ff800 (32-bit, non-prefetchable) [size=1K]
Capabilities: <access denied>
Kernel driver in use: ehci-pci

00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92) (prog-if 01 [Subtractive decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=05, subordinate=05, sec-latency=32
I/O behind bridge: 0000e000-0000efff
Memory behind bridge: feb00000-febfffff
Capabilities: <access denied>

00:1f.0 ISA bridge: Intel Corporation 82801IB (ICH9) LPC Interface Controller (rev 02)
Subsystem: ASUSTeK Computer Inc. 82801IB (ICH9) LPC Interface Controller
Flags: bus master, medium devsel, latency 0
Capabilities: <access denied>
Kernel driver in use: lpc_ich
Kernel modules: lpc_ich

00:1f.2 IDE interface: Intel Corporation 82801IB (ICH9) 2 port SATA Controller [IDE mode] (rev 02) (prog-if 8f [PCI native mode controller, supports both channels switched to ISA compatibility mode, supports bus mastering])
Subsystem: ASUSTeK Computer Inc. 82801IB (ICH9) 2 port SATA Controller [IDE mode]
Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 22
I/O ports at a000 [size=8]
I/O ports at 9c00 [size=4]
I/O ports at 9880 [size=8]
I/O ports at 9800 [size=4]
I/O ports at 9480 [size=16]
I/O ports at 9400 [size=16]
Capabilities: <access denied>
Kernel driver in use: ata_piix
Kernel modules: pata_acpi

00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
Subsystem: ASUSTeK Computer Inc. P5K PRO Motherboard: 82801IR [ICH9R]
Flags: medium devsel, IRQ 5
Memory at fe7ff400 (64-bit, non-prefetchable) [size=256]
I/O ports at 0400 [size=32]
Kernel modules: i2c_i801

00:1f.5 IDE interface: Intel Corporation 82801I (ICH9 Family) 2 port SATA Controller [IDE mode] (rev 02) (prog-if 85 [PCI native mode-only controller, supports bus mastering])
Subsystem: ASUSTeK Computer Inc. P5K PRO Motherboard: 82801IR [ICH9R]
Flags: bus master, 66MHz, medium devsel, latency 0, IRQ 22
I/O ports at b000 [size=8]
I/O ports at ac00 [size=4]
I/O ports at a880 [size=8]
I/O ports at a800 [size=4]
I/O ports at a480 [size=16]
I/O ports at a400 [size=16]
Capabilities: <access denied>
Kernel driver in use: ata_piix
Kernel modules: pata_acpi

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii PRO [Radeon R9 290/390] (prog-if 00 [VGA controller])
Subsystem: PC Partner Limited / Sapphire Technology Hawaii PRO [Radeon R9 290/390]
Flags: bus master, fast devsel, latency 0, IRQ 24
Memory at d0000000 (64-bit, prefetchable) [size=256M]
Memory at cf800000 (64-bit, prefetchable) [size=8M]
I/O ports at c000 [size=256]
Memory at fe880000 (32-bit, non-prefetchable) [size=256K]
Expansion ROM at 000c0000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: amdgpu
Kernel modules: radeon, amdgpu

01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii HDMI Audio [Radeon R9 290/290X / 390/390X]
Subsystem: PC Partner Limited / Sapphire Technology Hawaii HDMI Audio [Radeon R9 290/290X / 390/390X]
Flags: bus master, fast devsel, latency 0, IRQ 26
Memory at fe8fc000 (64-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel

02:00.0 Ethernet controller: Qualcomm Atheros Attansic L1 Gigabit Ethernet (rev b0)
Subsystem: ASUSTeK Computer Inc. P5KPL-VM Motherboard
Flags: bus master, fast devsel, latency 0, IRQ 27
Memory at fe9c0000 (64-bit, non-prefetchable) [size=256K]
Expansion ROM at fe9a0000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: atl1
Kernel modules: atl1

03:00.0 SATA controller: JMicron Technology Corp. JMB363 SATA/IDE Controller (rev 03) (prog-if 01 [AHCI 1.0])
Subsystem: ASUSTeK Computer Inc. JMB363 SATA/IDE Controller
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at feafe000 (32-bit, non-prefetchable) [size=8K]
Expansion ROM at feae0000 [disabled] [size=64K]
Capabilities: <access denied>
Kernel driver in use: ahci
Kernel modules: ahci

03:00.1 IDE interface: JMicron Technology Corp. JMB363 SATA/IDE Controller (rev 03) (prog-if 85 [PCI native mode-only controller, supports bus mastering])
Subsystem: ASUSTeK Computer Inc. JMB363 SATA/IDE Controller
Flags: bus master, fast devsel, latency 0, IRQ 17
I/O ports at dc00 [size=8]
I/O ports at d880 [size=4]
I/O ports at d800 [size=8]
I/O ports at d480 [size=4]
I/O ports at d400 [size=16]
Capabilities: <access denied>
Kernel driver in use: pata_jmicron
Kernel modules: pata_jmicron, pata_acpi

05:03.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller (rev c0) (prog-if 10 [OHCI])
Subsystem: ASUSTeK Computer Inc. Motherboard
Flags: bus master, medium devsel, latency 64, IRQ 16
Memory at febff800 (32-bit, non-prefetchable) [size=2K]
I/O ports at ec00 [size=128]
Capabilities: <access denied>
Kernel driver in use: firewire_ohci
Kernel modules: firewire_ohci

Ja ich mache einen neuen Thread auf. Hier vorerst mal ein recht herzliches Dankeschön. Ich setze den Thread auf erledigt und hoffe dich im neuen wieder anzutreffen.



Hi :)
tolle hilfe...
Zitat
sudo xed /etc/default/grub

und schon hat er sich die rechte für die dconf zerstört...

Hallo ehtron, kannst Du bitte wenigstens dazu schreiben was das für mich im schlimmsten Falle bedeutet? Davon habe  ich keine Ahnung.
Aber mein Rechner bleibt seitdem nicht mehr hängen. Kann ich mich nun freuen oder muss ich vor einen Bluescreen jetzt Angst haben? Meinst Du das zum letzten Beitrag " Schneller machen" oder zu "harmless" seiner Hilfe. Wenn es zu "harmless" ist hat er mir viel zeit geopfert. Vielleicht können wir dann in einem neuen Thread diesen von Dir bemängelten Fehler zusammen beheben.
« Letzte Änderung: 21.07.2019, 21:06:03 von Butterklatscher »

Hi :)
dadurch das xed (ein gui progamm was konifg daten in deinem home und in der dconf ablegt) direkt als root gestartet wurde, dürfen diese dateien nun root gehören.
darum gab es früher z.b. gksudo für gui programme...
ab mint 19.x macht man das mit sudo -H programmname.....

mache dich mal über home rechte reparieren schlau. 

Danke für diese letzten Infos. Dadurch dass ich jetzt mein Zweitsystem neu installiert habe auf LM 19:2 Tessa haben sich alle Probleme gelöst. Nichts bleibt mehr hängen, die Startzeit ist unter 90 sec. (Wahnsinn) und über die Rechte werde ich noch nachlesen. Danke an Alle. Den Thread schliesse ich jetzt.

Hi :)
dann schliesse ihn bitte.. siehe hilfe hier oben auf der page... danke :)