Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
21.09.2019, 17:49:12

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22570
  • Letzte: Nixk
Statistiken
  • Beiträge insgesamt: 608947
  • Themen insgesamt: 49293
  • Heute online: 531
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema:  Steam startet nicht  (Gelesen 834 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Steam startet nicht
« am: 05.06.2019, 18:22:40 »
Wie der Name schon sagt, der Steam-Client will einfach nicht starten.

Nach viel rumprobieren habe ich steam nun entfernt, purge laufen lassen, per hand den ~/.steam ordner gelöscht und das ganze neu über die Anwendungsverwaltung installiert.


Starte ich nun Steam im Terminal sieht das ganze so aus:

$ steam
Running Steam on linuxmint 18.3 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
[2019-06-05 18:19:22] Startup - updater built Apr 29 2019 20:58:13
Looks like steam didn't shutdown cleanly, scheduling immediate update check
[2019-06-05 18:19:22] Checking for update on startup
[2019-06-05 18:19:22] Checking for available updates...
[2019-06-05 18:19:22] Downloading manifest: client-download.steampowered.com/client/steam_client_ubuntu12
[2019-06-05 18:19:22] Download skipped: /client/steam_client_ubuntu12 version 1556574584, installed version 1556574584
[2019-06-05 18:19:22] Nothing to do
[2019-06-05 18:19:22] Verifying installation...
[2019-06-05 18:19:22] Performing checksum verification of executable files
[2019-06-05 18:19:23] Verification complete

Danach öffnet sich ein kleines Fenster. Titel "Steam Error"
Darin steht "glXChooseVisual failed" darunter ist ein "OK" Knopf der das Fenster schließt.

Hier noch eine Übersicht über Gerät und Versionen:

$ inxi -Fxxxz
System:    Host: Datenschleuder Kernel: 4.15.0-51-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3) dm: lightdm
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: Dell product: Inspiron 545 v: 00 Chassis: type: 3
           Mobo: Dell model: 0N826N v: A03 Bios: Dell v: A12 date: 11/17/2009
CPU:       Quad core Intel Core2 Quad Q9650 (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 ssse3 vmx) bmips: 23940
           clock speeds: min/max: 1998/2997 MHz 1: 1995 MHz 2: 1995 MHz
           3: 1995 MHz 4: 1995 MHz
Graphics:  Card: NVIDIA GK107 [GeForce GTX 650]
           bus-ID: 01:00.0 chip-ID: 10de:0fc6
           Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1680x1050@59.95hz, 1680x1050@59.95hz
           GLX Renderer: GeForce GTX 650/PCIe/SSE2
           GLX Version: 4.6.0 NVIDIA 415.27 Direct Rendering: Yes
Audio:     Card-1 NVIDIA GK107 HDMI Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1 chip-ID: 10de:0e1b
           Card-2 Intel 82801I (ICH9 Family) HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0 chip-ID: 8086:293e
           Card-3 Logitech Webcam C270
           driver: USB Audio usb-ID: 001-002 chip-ID: 046d:0825
           Sound: Advanced Linux Sound Architecture v: k4.15.0-51-generic
Network:   Card: Realtek RTL810xE PCI Express Fast Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: ce00
           bus-ID: 03:00.0 chip-ID: 10ec:8136
           IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 2000.4GB (7.9% used)
           ID-1: /dev/sda model: ST2000DX002 size: 2000.4GB serial: Z4Z5WJDQ
Partition: ID-1: / size: 68G used: 17G (26%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 906G used: 122G (15%) fs: ext4 dev: /dev/sda3
           ID-3: swap-1 size: 11.41GB used: 0.00GB (0%) fs: swap dev: /dev/dm-0
RAID:      System: supported: N/A
           No RAID devices: /proc/mdstat, md_mod kernel module present
           Unused Devices: none
Sensors:   System Temperatures: cpu: 40.0C mobo: N/A gpu: 0.0:52C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 201 Uptime: 14 min Memory: 1520.8/7975.6MB
           Init: systemd v: 229 runlevel: 5 default: 2 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481 running in gnome-terminal-) inxi: 2.2.35

Hoffentlich hat jemand eine Idee.

Re: Steam startet nicht
« Antwort #1 am: 05.06.2019, 21:46:31 »
Hi,
sudo apt install libnvidia-gl-396:i386hilft dir weiter?

Re: Steam startet nicht
« Antwort #2 am: 06.06.2019, 12:10:56 »
Zur Erklärung:

Steam gibt es wohl zur Zeit nur als 32bit Version

Deshalb werden wohl auch die 32bit Grafiktreiber benötigt.

Re: Steam startet nicht
« Antwort #3 am: 06.06.2019, 12:32:54 »
Jo, ganz vergessen... die sollten aber aktiviert sein.  ;D

Falls das nicht der Fall ist.
sudo dpkg --add-architecture i386sudo apt updatesudo apt install steamDann sollte apt die 32Bit Bibliotheken mitziehen.
« Letzte Änderung: 12.06.2019, 19:02:32 von Moridian »

Re: Steam startet nicht
« Antwort #4 am: 12.06.2019, 13:23:29 »
$ sudo apt install libnvidia-gl-396:i386
[sudo] Passwort für avoca:
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
E: Paket libnvidia-gl-396:i386 kann nicht gefunden werden.
$  sudo dpkg --add-architecture 386
Odd number of elements in hash assignment at /usr/share/pkg-config-dpkghook line 30.


Was sitzt da nun quer? :D

$ sudo apt update
Ign:1 http://ftp-stud.hs-esslingen.de/pub/Mirrors/packages.linuxmint.com sylvia InRelease
OK:2 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu xenial InRelease
OK:3 http://ftp-stud.hs-esslingen.de/ubuntu xenial InRelease             
OK:4 http://security.ubuntu.com/ubuntu xenial-security InRelease         
OK:5 http://archive.canonical.com/ubuntu xenial InRelease                 
OK:6 http://ftp-stud.hs-esslingen.de/ubuntu xenial-updates InRelease     
OK:7 http://ftp-stud.hs-esslingen.de/ubuntu xenial-backports InRelease
OK:8 http://ftp-stud.hs-esslingen.de/pub/Mirrors/packages.linuxmint.com sylvia Release
OK:9 https://repo.skype.com/deb stable InRelease     
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Alle Pakete sind aktuell.
N: Das Laden der konfigurierten Datei »main/binary-386/Packages« wird übersprungen, da das Depot »http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu xenial InRelease« die Architektur »386« nicht unterstützt.
N: Das Laden der konfigurierten Datei »main/binary-386/Packages« wird übersprungen, da das Depot »http://ftp-stud.hs-esslingen.de/ubuntu xenial InRelease« die Architektur »386« nicht unterstützt.
N: Das Laden der konfigurierten Datei »restricted/binary-386/Packages« wird übersprungen, da das Depot »http://ftp-stud.hs-esslingen.de/ubuntu xenial InRelease« die Architektur »386« nicht unterstützt.
N: Das Laden der konfigurierten Datei »universe/binary-386/Packages« wird übersprungen, da das Depot »http://ftp-stud.hs-esslingen.de/ubuntu xenial InRelease« die Architektur »386« nicht unterstützt.
N: Das Laden der konfigurierten Datei »multiverse/binary-386/Packages« wird übersprungen, da das Depot »http://ftp-stud.hs-esslingen.de/ubuntu xenial InRelease« die Architektur »386« nicht unterstützt.
N: Das Laden der konfigurierten Datei »main/binary-386/Packages« wird übersprungen, da das Depot »http://security.ubuntu.com/ubuntu xenial-security InRelease« die Architektur »386« nicht unterstützt.
N: Das Laden der konfigurierten Datei »restricted/binary-386/Packages« wird übersprungen, da das Depot »http://security.ubuntu.com/ubuntu xenial-security InRelease« die Architektur »386« nicht unterstützt.
N: Das Laden der konfigurierten Datei »universe/binary-386/Packages« wird übersprungen, da das Depot »http://security.ubuntu.com/ubuntu xenial-security InRelease« die Architektur »386« nicht unterstützt.
N: Das Laden der konfigurierten Datei »multiverse/binary-386/Packages« wird übersprungen, da das Depot »http://security.ubuntu.com/ubuntu xenial-security InRelease« die Architektur »386« nicht unterstützt.
N: Das Laden der konfigurierten Datei »partner/binary-386/Packages« wird übersprungen, da das Depot »http://archive.canonical.com/ubuntu xenial InRelease« die Architektur »386« nicht unterstützt.
N: Das Laden der konfigurierten Datei »main/binary-386/Packages« wird übersprungen, da das Depot »http://ftp-stud.hs-esslingen.de/ubuntu xenial-updates InRelease« die Architektur »386« nicht unterstützt.
N: Das Laden der konfigurierten Datei »restricted/binary-386/Packages« wird übersprungen, da das Depot »http://ftp-stud.hs-esslingen.de/ubuntu xenial-updates InRelease« die Architektur »386« nicht unterstützt.
N: Das Laden der konfigurierten Datei »universe/binary-386/Packages« wird übersprungen, da das Depot »http://ftp-stud.hs-esslingen.de/ubuntu xenial-updates InRelease« die Architektur »386« nicht unterstützt.
N: Das Laden der konfigurierten Datei »multiverse/binary-386/Packages« wird übersprungen, da das Depot »http://ftp-stud.hs-esslingen.de/ubuntu xenial-updates InRelease« die Architektur »386« nicht unterstützt.
N: Das Laden der konfigurierten Datei »main/binary-386/Packages« wird übersprungen, da das Depot »http://ftp-stud.hs-esslingen.de/ubuntu xenial-backports InRelease« die Architektur »386« nicht unterstützt.
N: Das Laden der konfigurierten Datei »restricted/binary-386/Packages« wird übersprungen, da das Depot »http://ftp-stud.hs-esslingen.de/ubuntu xenial-backports InRelease« die Architektur »386« nicht unterstützt.
N: Das Laden der konfigurierten Datei »universe/binary-386/Packages« wird übersprungen, da das Depot »http://ftp-stud.hs-esslingen.de/ubuntu xenial-backports InRelease« die Architektur »386« nicht unterstützt.
N: Das Laden der konfigurierten Datei »multiverse/binary-386/Packages« wird übersprungen, da das Depot »http://ftp-stud.hs-esslingen.de/ubuntu xenial-backports InRelease« die Architektur »386« nicht unterstützt.
N: Das Laden der konfigurierten Datei »main/binary-386/Packages« wird übersprungen, da das Depot »http://ftp-stud.hs-esslingen.de/pub/Mirrors/packages.linuxmint.com sylvia InRelease« die Architektur »386« nicht unterstützt.
N: Das Laden der konfigurierten Datei »upstream/binary-386/Packages« wird übersprungen, da das Depot »http://ftp-stud.hs-esslingen.de/pub/Mirrors/packages.linuxmint.com sylvia InRelease« die Architektur »386« nicht unterstützt.
N: Das Laden der konfigurierten Datei »import/binary-386/Packages« wird übersprungen, da das Depot »http://ftp-stud.hs-esslingen.de/pub/Mirrors/packages.linuxmint.com sylvia InRelease« die Architektur »386« nicht unterstützt.
N: Das Laden der konfigurierten Datei »backport/binary-386/Packages« wird übersprungen, da das Depot »http://ftp-stud.hs-esslingen.de/pub/Mirrors/packages.linuxmint.com sylvia InRelease« die Architektur »386« nicht unterstützt.

$ sudo apt install steam
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
steam:i386 ist schon die neueste Version (1:1.0.0.52-5ubuntu1).
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
« Letzte Änderung: 12.06.2019, 13:30:35 von Avoca »

Re: Steam startet nicht
« Antwort #5 am: 12.06.2019, 17:23:02 »
Moridian war wohl mit seinen Gedanken schon woanders.
Die korrekte Angabe für die Architektur in dem Befehl muß i386 und nicht 386 lauten.


Re: Steam startet nicht
« Antwort #6 am: 12.06.2019, 18:03:10 »
Ändert an der Ausgabe jetzt nicht wirklich was

sudo dpkg --add-architecture i386
[sudo] Passwort für avoca:
Odd number of elements in hash assignment at /usr/share/pkg-config-dpkghook line 30.

Re: Steam startet nicht
« Antwort #7 am: 12.06.2019, 19:07:21 »
Ups... Danke lmumischabln, verbessert.

Erst einmal den anderen Mist wieder runter bringen.
sudo sudo dpkg --remove-architecture 386
Hier mal lesen.
https://bugs.launchpad.net/ubuntu/+source/steam/+bug/1784117

« Letzte Änderung: 12.06.2019, 19:13:31 von Moridian »

Re: Steam startet nicht
« Antwort #8 am: 12.06.2019, 19:17:00 »
$ sudo sudo dpkg --remove-architecture 386
[sudo] Passwort für avoca:
$

$ sudo dpkg --add-architecture i386
$

$ sudo apt update
Ign:1 http://ftp-stud.hs-esslingen.de/pub/Mirrors/packages.linuxmint.com sylvia InRelease
Holen:2 http://security.ubuntu.com/ubuntu xenial-security InRelease [109 kB]   
OK:3 http://ftp-stud.hs-esslingen.de/ubuntu xenial InRelease                   
OK:4 http://ftp-stud.hs-esslingen.de/ubuntu xenial-updates InRelease           
OK:5 http://archive.canonical.com/ubuntu xenial InRelease                     
OK:6 http://ftp-stud.hs-esslingen.de/ubuntu xenial-backports InRelease         
OK:7 http://ftp-stud.hs-esslingen.de/pub/Mirrors/packages.linuxmint.com sylvia Release
OK:8 https://repo.skype.com/deb stable InRelease                               
OK:9 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu xenial InRelease
Es wurden 109 kB in 0 s geholt (129 kB/s).         
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Alle Pakete sind aktuell.
$



$ sudo apt install steam
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
steam:i386 ist schon die neueste Version (1:1.0.0.52-5ubuntu1).
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

Re: Steam startet nicht
« Antwort #9 am: 13.06.2019, 18:05:22 »
Und nun?

Re: Steam startet nicht
« Antwort #10 am: 13.06.2019, 19:58:39 »
mintnix@mintnix-X470-AORUS-GAMING-5-WIFI:~$ steam
Running Steam on linuxmint 19.1 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
[2019-06-13 19:57:18] Startup - updater built Apr 29 2019 20:58:13
[2019-06-13 19:57:18] Installation wird überprüft...
[2019-06-13 19:57:18] Verification complete

So sollte es aussehen, wenns läuft.


Nach kurzer Suche hab ich das gefunden (wurde aber schon erwähnt, oder?).
sudo apt-get install libnvidia-gl-396:i386Das 396 muss man entsprechend anpassen. Könnte bei dir 415 sein nach deinem Nvidiatreiber.
« Letzte Änderung: 13.06.2019, 22:15:07 von Mintnix »

Re: Steam startet nicht
« Antwort #11 am: 14.06.2019, 08:08:08 »
Ich würde den nvidia Treiber und Steam entfernen, System neu booten und wieder installieren.
Du könntest aber auch von LM 18.3 auf LM 19.1 wechseln.

Re: Steam startet nicht
« Antwort #12 am: 16.06.2019, 12:44:44 »
Ich habe nun in der Treiberverwaltung auf 418 aktuallisiert und neu gestartet.

allerdings:

$ sudo apt-get install libnvidia-gl-418:i386
[sudo] Passwort für avoca:
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
E: Paket libnvidia-gl-418:i386 kann nicht gefunden werden.

.. und das sieht bei gl-396 und gl-415 genauso aus.


Re: Steam startet nicht
« Antwort #13 am: 16.06.2019, 12:50:13 »
Bei dem Befehl könntesr du mal die Autovervollständigung benutzen.
Also nach sudo apt-get install libnvidia-gl die Tabulatortaste drücken. Da sollten die verfügbaren angezeigt bzw. vervollständigt werden.

  https://bugs.launchpad.net/ubuntu/+source/steam/+bug/1784117 
« Letzte Änderung: 16.06.2019, 13:00:23 von Mintnix »

Re: Steam startet nicht
« Antwort #14 am: 16.06.2019, 18:42:47 »
$ sudo apt install nvidia-418
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
nvidia-418 ist schon die neueste Version (418.56-0ubuntu0~gpu16.04.1).
0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.

$ sudo apt install nvidia-418:i386
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
E: Paket nvidia-418:i386 kann nicht gefunden werden.

$ apt install libnv   [b] <- TAB + TAB[/b]
libnvblas7.5         libnvrtc7.5          libnvtt-bin
libnvpair1linux      libnvtoolsext1       libnvtt-dev
libnvpair1linux-dbg  libnvtt2             libnvvm3

damit bin Ich hier so weit wie beim Thema erstellen