Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
12.11.2019, 09:25:38

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22791
  • Letzte: Luxtux
Statistiken
  • Beiträge insgesamt: 618690
  • Themen insgesamt: 49934
  • Heute online: 526
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema: [erledigt] Linux und WLAN AVM 430  (Gelesen 409 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[erledigt] Linux und WLAN AVM 430
« am: 22.05.2019, 21:23:12 »
Liebe Linux-Kenner,
ich nutze einen kleinen Lautlos-PC am Fernseher fast ausschließlich für Netflix - bisher mit Win 7 und dem besagten AVM AC430 Stick, der bislang unter Linux ja nur mit viel "Geschraube" funktionierte. Als ich nun hörte, dass dieser Stick ab dem Kernel 4.19 ootb funktionieren sollte, habe ich mir LM 19 xfce 32-bit installiert und den Kernel mittels UKUU auf 4.19 upgedatet in der naiven Hoffnung, den Stick einzustecken und lossurfen zu können...dann 4.20 und mittlerweile bin ich bei Kernel 5.0.17 gelandet....
CPU: Dual Core Intel Celeron J1800 (-MCP-) speed/min/max: 1337/1333/2582 MHz
Kernel: 5.0.17-050017-generic i686 Up: 40m Mem: 735.0/3665.3 MiB (20.1%)
Storage: 111.79 GiB (7.1% used) Procs: 164 Shell: bash 4.4.19 inxi: 3.0.27
lsusb gibt folgendes aus:Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 04d9:a01c Holtek Semiconductor, Inc.
Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. Hub
Bus 001 Device 008: ID 057c:8602 AVM GmbH
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Nun fehlt wohl noch eine Linux-Firmware, habe aber keine Ahnung, welche ich da auswählen muss. Außerdem gab es hier im Forum auch schon einige Fälle, bei denen es auch mit Firmware nicht funkionierte.
Kann mir da jemand weiterhelfen, zumal das Finden eines sofort funktionierenden alternativen Sticks ja wohl auch keine hunderprozentige Garantie ist...?
Vielen Dank schon mal im Voraus
« Letzte Änderung: 12.06.2019, 20:59:46 von Anyway »

Re: Linux und WLAN AVM 430
« Antwort #1 am: 12.06.2019, 20:59:06 »
Okay - ich habe das Problem für mich jetzt gelöst. Für alle, die's interessiert:
1. D-Link SWA-140 /KD für 3,90 bei ebay gekauft
2. LM 19 xfce nun als 64-bit-Version vom Stick gebootet - der Stick wird ootb erkannt und funktioniert - na also, geht doch
3. LM auf den Rechner gespielt und Windows gleich mit gelöscht
4. AVM-Stick in die unterste Schublade geschmissen (braucht jemand noch nen WLAN-Stick?)

...und läuft! ;D

Re: Linux und WLAN AVM 430
« Antwort #2 am: 13.06.2019, 07:50:19 »
Hallo,
bei dem 430er (a/c/n Mediatek-Chipsatz / Modul mt76x0u) gibt es noch Probleme mit dem Treibermodul und der Firmware. Dies wurde bereits im April an Canonical über Launchpad gemeldet aber bisher noch nicht gelöst. Möglicherweise wird das Problem in einer der kommenden Kernelversionen behoben sein, wirf das Gerät also noch nicht weg  ;)

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1824650 (für die alte Variante des N-430)

Nachtrag:  es handelt sich um eine neue Variante des Stick mit MU-MIMO-Technik und der Bus-ID: ID 057c:8602 - Chipsatz unbekannt, Treiber unbekannt - momentan keine Linux-Unterstützung!
« Letzte Änderung: 02.08.2019, 08:13:45 von Flash63 »