Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
25.08.2019, 16:20:34

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22439
  • Letzte: HWST
Statistiken
  • Beiträge insgesamt: 605025
  • Themen insgesamt: 48995
  • Heute online: 657
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema:  GRUB konnte nicht installiert werden(Grub-efi-amd64-signed)  (Gelesen 519 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Ich weiß, es gab schon etliche Threads bezüglich dieses Problems, aber mir hat keiner der Lösungen geholfen. Wie auch schon viele wollte ich Linux Mint neben Windows 10 installieren. Es handelt sich um Linux Mint 19.1 Mate. Habe es mit Linux Live Creator auf einen USB-Stick geladen und dann vom USB Stick aus installiert. Bei der Installation manuell partitioniert(4GB für Swap, Logisch, Ende des bereichs/27GB für Linux, Primär, Anfang des Bereichs, ext4 und / ). Gerät für den bootloader auf den Windows Bootloader gesetzt. Als er dann mit der Installation fertig ist, kommt dann die Fehlermeldung: "Das Paket -Grub-efi-amd64-signed-konnte nicht in /target/ installiert werden. Ohne den GRUB-Bootlader wird das installierte System nicht booten." Linux wurde erfolgreich installiert, nur ohne den bootloader. Über UEFI Utility(durch drücken von F2 beim Systemstart) kann ich auswählen ob Windows bootlaoder oder Ubuntu gestartet werden soll.

Sudo parted --list:
Zitat
Model: ATA TOSHIBA THNSNK25 (scsi)
Disk /dev/sdb: 256GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number  Start   End    Size    File system     Name                          Flags
 1      1049kB  274MB  273MB   fat32           EFI system partition          boot, esp
 2      274MB   290MB  16,8MB                  Microsoft reserved partition  msftres
 3      290MB   224GB  223GB   ntfs            Basic data partition          msftdata
 6      224GB   251GB  27,5GB  ext4
 5      251GB   255GB  4000MB  linux-swap(v1)
 4      255GB   256GB  839MB   ntfs            Basic data partition          hidden, diag

Was ich alles schon probiert habe:
- Mit und ohne Internetverbindung(Hat es bei vielen Leuten gelöst)
- Bootloader installationspfad auf sdb gesetzt
- CSM Support deaktiviert
- GRUB manuell übers Terminal zu installieren

Ich habe einige Lösungsansätze versucht, nur denke ich habe ich es noch schlimmer gemacht. Wenn der Laptop jetzt startet dann erscheint ein schwarzer Bildschirm:
Zitat
GNU GRUB version 2.02

Minimal BASH-like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible device or file completions
Da kann ich dann Befehle eingeben. Kommt immer nur dann wenn ich linux starten will, Linux startet also nicht. Bei windows kommt es auch, aber kann es durch den exit Befehl schließen und Windows starten. Es hat wahrscheinlich etwas mit BIOS/UEFI zu tun, denn das wird ja immer als erstes gefragt, wenn man dieses Problem hat. Anscheinend habe ich UEFI, weiß aber nicht wie Linux installiert wurde, ob BIOS oder UEFI. Hoffe der lange Text hier hat niemanden abgeschreckt. Danke im Voraus.

Hier nochmal Terminal Befehle die ich eingegeben habe(in der Hoffnung, dass es hilft):
Zitat
sudo mount /dev/sdb1 /mnt
Zitat
sudo mount -o bind /dev /mnt/dev
Zitat
sudo mount -o bind /sys /mnt/sys
Zitat
sudo mount -t proc /proc /mnt/proc
Zitat
sudo cp /proc/mounts /mnt/etc/mtab
Zitat
sudo chroot /mnt /bin/bash

Zitat
grub-install /dev/sda
<- Das hier wollte er dann aber nicht mehr machen, da er irgendwas nicht gefunden hätte oder so.
Zitat
update-grub

Zitat
update-grub2
<- Die beiden Befehle haben jedoch geklappt und ich glaube das war auch der Auslöser für diesen Schwarzen Bildschirm mit der Befehlseingabe

Re: GRUB konnte nicht installiert werden(Grub-efi-amd64-signed)
« Antwort #1 am: 22.05.2019, 02:56:26 »
Bei deinen chroot-Befehlen müsste der erste
sudo mount /dev/sdb6 /mntlauten und danach fehlt noch
sudo mount /dev/sdb1 /mnt/boot/efiDer Installationsbefehl für Grub lautet dann einfach
grub-install

Re: GRUB konnte nicht installiert werden(Grub-efi-amd64-signed)
« Antwort #2 am: 22.05.2019, 12:21:24 »
Also bei
Zitat
sudo cp /proc/mounts /mnt/etc/mtab
kommt immer
Zitat
cp: '/proc/mounts' and '/mnt/etc/mtab' are the same file
und bei
Zitat
grub-install
sagt er mir
Zitat
grub-install: error: /usr/lib/grub/i386-pc/modinfo.sh doesn't exist. Please specify --target or --directory.
hab auch grub-install mit sdb1 und sdb probiert, hat auch nicht geklappt.

Re: GRUB konnte nicht installiert werden(Grub-efi-amd64-signed)
« Antwort #3 am: 22.05.2019, 15:39:53 »
Bei mir half es das Iso von Linux Mint direkt zu nehmen, statt dieses hier vom Forum, als ich dieses Problem hatte.

Re: GRUB konnte nicht installiert werden(Grub-efi-amd64-signed)
« Antwort #4 am: 22.05.2019, 16:00:26 »
Hab es von der offiziellen linux mint Seite.

Re: GRUB konnte nicht installiert werden(Grub-efi-amd64-signed)
« Antwort #5 am: 22.05.2019, 18:04:49 »
korrigiert mich bitte - wenn ich falsch liege - aber das
Zitat
grub-install: error: /usr/lib/grub/i386-pc/modinfo.sh doesn't exist. Please specify --target or --directory.
erinnert mich an "32 Bit" ?!
Laut "parted -list" sehe ich aber UEFI mit Windows - das ist "64 Bit" ?!

Ist die Iso eine "32 Bit Iso" ?

EDIT: Hmmm, liege wohl falsch - meine These passt nicht zu
Zitat
"Das Paket -Grub-efi-amd64-signed-konnte nicht in /target/ installiert werden
« Letzte Änderung: 22.05.2019, 18:10:22 von billyfox05 »

Re: GRUB konnte nicht installiert werden(Grub-efi-amd64-signed)
« Antwort #6 am: 22.05.2019, 18:09:08 »
Nein das kann nicht sein. 64 Bit steht sogar im Namen der ISO "linuxmint-19.1-mate-64bit.iso".

Re: GRUB konnte nicht installiert werden(Grub-efi-amd64-signed)
« Antwort #7 am: 22.05.2019, 18:13:12 »
Noch zwei Frage
Warum liefert "parted --list" nur ein Ergebnis von sdb ? Was ist mit sda ?
Zitat
Bei der Installation manuell partitioniert(4GB für Swap, Logisch, Ende des bereichs/27GB für Linux, Primär,
das liest sich seltsam da bei einer "Partitionstabelle: gpt" gibt es kein Primär / Logisch ?
« Letzte Änderung: 22.05.2019, 18:18:16 von billyfox05 »

Re: GRUB konnte nicht installiert werden(Grub-efi-amd64-signed)
« Antwort #8 am: 22.05.2019, 18:20:16 »
Dachte sda wäre nicht von Bedeutung, habs weggelassen. Und hab es so kopiert wie es da stand. Also es gab 3 Absätze, sda, sdb und den für den UBS Stick. Hab dann nur den mittleren(sdb) kopiert und das ist halt was raus kam. Aber habe es halt als logisch und primär eingestellt.

Re: GRUB konnte nicht installiert werden(Grub-efi-amd64-signed)
« Antwort #9 am: 25.05.2019, 13:07:37 »
Hat niemand eine Lösung? Weiß dann jemand wenigstens wie ich dieses Kommandofenster beim Start deaktivieren kann? Muss immer exit eintippen um booten zu können

Re: GRUB konnte nicht installiert werden(Grub-efi-amd64-signed)
« Antwort #10 am: 25.05.2019, 13:24:03 »
das liest sich seltsam da bei einer "Partitionstabelle: gpt" gibt es kein Primär / Logisch ?

Jein, nur noch Primär!

@Logiaa
Starte mal bitte das Live-System und zeige bitte komplett:
sudo parted --list
Eine Swap-Partition würde ich nicht einrichten. Da würde ich SWAPFILE (Standard) nutzen.

Und bitte mal da rein schauen:
https://www.linuxmintusers.de/index.php?action=wiki;page=Installationsanleitung_Linux_Mint_19_
« Letzte Änderung: 25.05.2019, 15:43:21 von tommix »