Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
27.05.2020, 08:05:20

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24043
  • Letzte: lupemi
Statistiken
  • Beiträge insgesamt: 662602
  • Themen insgesamt: 53589
  • Heute online: 339
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 8
Gäste: 282
Gesamt: 290

Autor Thema:  Aktuellste Version von dxf2gcode  (Gelesen 303 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Aktuellste Version von dxf2gcode
« am: 12.05.2019, 04:28:18 »
Habe mir die aktuelle Version von dxf2gcode auf 19.1 mate 64bit installiert.
Ist immer so ne Sache, wenn man nicht das aus dem Feed nimmt.
Habe die aktuellste von https://sourceforge.net/projects/dxf2gcode/files/latest/download genommen.
Bei
Building and Installing
- Unix (assumes bash shell):
$ ./make_tr.py # generates .qm translation files in i18 directory
$ ./make_py_uic.py # generates: dxf2gcode_ui5.py and dxf2gcode_images.qrc
$ python3 ./st-setup.py build
# python3 ./st-setup.py install
ging das Theater aber bereits los.
PyQt5.sip fehlte. Also bin ich nach https://github.com/Electron-Cash/Electron-Cash/issues/892 vorgegangen.
Iwann lief es. Aber jetzt nur, wenn ich dxf2gcode mit sudo-rechten starte.
Als normalrer User kommt:
Traceback (most recent call last):
  File "/usr/local/bin/dxf2gcode", line 4, in <module>
    __import__('pkg_resources').run_script('dxf2gcode==20190103', 'dxf2gcode')
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 658, in run_script
    self.require(requires)[0].run_script(script_name, ns)
  File "/usr/lib/python3/dist-packages/pkg_resources/__init__.py", line 1445, in run_script
    exec(script_code, namespace, namespace)
  File "/usr/local/lib/python3.6/dist-packages/dxf2gcode-20190103-py3.6.egg/EGG-INFO/scripts/dxf2gcode", line 39, in <module>
  File "/usr/local/lib/python3.6/dist-packages/dxf2gcode-20190103-py3.6.egg/dxf2gcode/globals/constants.py", line 39, in <module>
ModuleNotFoundError: No module named 'PyQt5.sip'
Hat da jemand Tipps dazu?