Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
18.07.2019, 09:20:00

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22259
  • Letzte: charblu
Statistiken
  • Beiträge insgesamt: 599054
  • Themen insgesamt: 48518
  • Heute online: 468
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema: [gelöst]  Mint 19.1 Cinnamon 4 144 Hz Performance  (Gelesen 588 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Mint 19.1 Cinnamon 4 144 Hz Performance
« am: 09.05.2019, 13:48:50 »
Hallo.

Ich wollte hier mal nachfragen, ob es einen Trick gibt, die Performance bei einem 144 Hz Monitor auf Windows 10 Niveau zu heben? Mein Mint 19.0 mit Cinnamon 4.0.10 hinkt da ganz schön hinter her. Nvidia Treiber 390 ist installiert, 144hz sind bei Systemstart per "xrandr --output DP-4 --mode 2560x1440 --rate 144.00" aktiv. Laut Monitor (BenQ X3203R) Info auch .

Oder  ist es ein generelles Mint oder Linux Problem bzw Grafiktreiber Problem? Kann man an der Konfig Schraube drehen um die Performance von Windows 10 zu erreichen? Vor allem im Browser beim Scrollen ist es deutlich merkbar.

EDIT: Ich hab gerade mal Ubuntu 18.04 probiert. Dort ist es das selbe.
« Letzte Änderung: 03.06.2019, 10:55:40 von Mistergl »

Re: Mint 19.1 Cinnamon 4 144 Hz Performance
« Antwort #1 am: 09.05.2019, 15:47:23 »
Gib doch bitte mal in einem Terminal ein:
inxi -Fz... und poste die Ausgabe hier im Codeblock (#).

Re: Mint 19.1 Cinnamon 4 144 Hz Performance
« Antwort #2 am: 09.05.2019, 19:53:23 »
Hier die Ausgabe:

System:
  Host: mint Kernel: 4.15.0-48-generic x86_64 bits: 64
  Desktop: Cinnamon 4.0.10 Distro: Linux Mint 19.1 Tessa
Machine:
  Type: Desktop System: Gigabyte product: Z370P D3 v: N/A serial: <filter>
  Mobo: Gigabyte model: Z370P D3-CF v: x.x serial: <filter>
  UEFI: American Megatrends v: F10 date: 09/18/2018
CPU:
  Topology: 8-Core model: Intel Core i7-9700K bits: 64 type: MCP
  L2 cache: 12.0 MiB
  Speed: 1044 MHz min/max: 800/4900 MHz Core speeds (MHz): 1: 800 2: 801
  3: 801 4: 800 5: 800 6: 800 7: 800 8: 800
Graphics:
  Device-1: NVIDIA GP104 [GeForce GTX 1080] driver: nvidia v: 390.116
  Display: x11 server: X.Org 1.19.6 driver: nvidia tty: N/A
  OpenGL: renderer: GeForce GTX 1080/PCIe/SSE2 v: 4.6.0 NVIDIA 390.116
Audio:
  Device-1: Intel 200 Series PCH HD Audio driver: snd_hda_intel
  Device-2: NVIDIA GP104 High Definition Audio driver: snd_hda_intel
  Sound Server: ALSA v: k4.15.0-48-generic
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  driver: r8169
  IF: enp7s0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 968.79 GiB used: 34.93 GiB (3.6%)
  ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB
  ID-2: /dev/sdb vendor: KingDian model: S200 60GB size: 55.90 GiB
  ID-3: /dev/sdc vendor: Intenso model: SSD Sata III size: 447.13 GiB
Partition:
  ID-1: / size: 18.23 GiB used: 10.96 GiB (60.1%) fs: ext4 dev: /dev/sdb1
  ID-2: /home size: 36.42 GiB used: 23.92 GiB (65.7%) fs: ext4
  dev: /dev/sdb2
Sensors:
  System Temperatures: cpu: 27.8 C mobo: 6.8 C gpu: nvidia temp: 38 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
  Processes: 250 Uptime: 2m Memory: 15.61 GiB used: 1.23 GiB (7.9%)
  Shell: bash inxi: 3.0.27

Re: Mint 19.1 Cinnamon 4 144 Hz Performance
« Antwort #3 am: 10.05.2019, 12:10:52 »
*puh.....
Ich mutmaße mal jetzt .....

Bei DER aktuellen Hardware könnte es durchaus sein, dass Du einen ganz aktuellen Kernel brauchst.... und ggfs. auch den aktuellsten Nvidia-Treiber.

Diese Treiber kannst Du Dir über das Nvidia-ppa ins System holen. Dazu gibst Du jeweils im Terminal ein - ich würde vorher in der Treiberverwaltung nochmal auf den "Nouveau" umstellen und neu booten, um ggfs. Konflikte mit Treiberresten zu vermeiden:
https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa
1. sudo add-apt-repository ppa:graphics-drivers/ppa -> Enter
2. sudo apt-get update -> Enter
3. sudo apt-get dist-upgrade -> Enter
4. dann kannst Du in der Treiberverwaltung nachsehen, was Dir angeboten wird.
5. danach natürlich neu booten
« Letzte Änderung: 10.05.2019, 12:16:01 von Michelle_Br »

Re: Mint 19.1 Cinnamon 4 144 Hz Performance
« Antwort #4 am: 11.05.2019, 13:39:49 »
Danke. ein aktueller Treiber brachte keine Besserung. EInen aktuelleren Kernel muss ich unbedingt probieren.

Mittlerweile hab ich gesagt bekommen, es läge allgemein am Compositing des jeweiligen Desktops. Hab im Nvidia Settings nun das Compositing Pipelining mal aktiviert und meine im Desktop Bereich läuft es etwas geschmeidiger.

Im Firefox hab ich Smooth Scrolling abgestellt, so das man die leichten Ghosting Effekte und die Unschärfe nicht mehr sieht. Ich hoffe Linux bzw die Desktop Manager werden bald mal darauf hin steuern das 144 Hz besser genutzt wird.

Re: Mint 19.1 Cinnamon 4 144 Hz Performance
« Antwort #5 am: 11.05.2019, 21:03:40 »
Hast du dir auch mal die OpenGL Settings angesehen?

Re: Mint 19.1 Cinnamon 4 144 Hz Performance
« Antwort #6 am: 15.05.2019, 10:55:04 »
Hallo, Kannst du mit sagen wo genau man die einsehen kann?

EDIT:
Was ich gerade gefunden habe ist folgendes:
https://news.softpedia.com/news/Firefox-Nightly-Adds-Support-for-Vsync-for-Smooth-Animations-360245.shtml

Wenn ich also den Wert "layout.frame_rate" auf 144 setze ist definitiv ein Unterschied zum Standard -1 bzw 60 festzustellen.

Allerdings zeigt der Framerate Test trotzdem nur 60 Frames max. und ic hab die hässlichen Tearings beim Scrollen^^
« Letzte Änderung: 15.05.2019, 11:47:04 von Mistergl »

Re: Mint 19.1 Cinnamon 4 144 Hz Performance
« Antwort #7 am: 15.05.2019, 16:13:50 »
Kannst du mit sagen wo genau man die einsehen kann?
NV-Settings:

Re: Mint 19.1 Cinnamon 4 144 Hz Performance
« Antwort #8 am: 03.06.2019, 10:55:19 »
Also im Firefox und Cinnamon allgemein bin jetzt zufrieden. Chromium lässt allerdings immer noch zu wünschen übrig. Schade, da es der einzige Grund ist warum ich den Chromium Browser absetzen musste.

www.testufo.com zeigt Im Firefox 144 FPS an. Im Chromium leider nur halbierte 72. 



Was ich getan habe:
1. xrandr --output DP-4 --mode 2560x1440 --rate 144.00 in den Autostart für dauerhafte 144hz
2. In den Nvidia Server Settings "Force Full Compositing Pipeline" aktiviert
3. Im Firefox unter about:config "layout.frame_rate" auf 144 gesetzt.

Wer noch Vorschläge oder Lösungen in Bezug auf den Chromium hat kann gerne posten.