Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
18.07.2019, 11:29:12

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 599066
  • Themen insgesamt: 48518
  • Heute online: 512
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema:  Fehlermeldung bei Aktualisierung der Anwendungspaketquellen  (Gelesen 501 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo,
ich verwende
Linux Mint 19  Cinnamon 3.8.9
Kernel 4.15.0-48-generic

Wenn ich eine Aktualisierung der Anwendungspaketquellen durchführe erscheint folgende Fehlermeldung:

E:The repository 'http://archive.canonical.com/ubuntu bionic Release' does not have a Release file., W:Updating from such a repository can't be done securely, and is
therefore disabled by default., W:See apt-secure( manpage for repository creation and user configuration details., E:The repository 'http://security.ubuntu.com/ubuntu bionic-
security Release' does not have a Release file.

Kann mir hier jemand weiterhelfen?

Grüße
aola2

Re: Fehlermeldung bei Aktualisierung der Anwendungspaketquellen
« Antwort #1 am: 09.05.2019, 13:49:36 »
Hi :)
zeig mal bitte als codeblock
inxi -r

Re: Fehlermeldung bei Aktualisierung der Anwendungspaketquellen
« Antwort #2 am: 09.05.2019, 19:55:38 »
Active apt sources in file: /etc/apt/sources.list.d/balena-etcher.list
           deb https://deb.etcher.io stable etcher
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://mirror.bauhuette.fh-aachen.de/linuxmint tara main upstream import backport
           deb http://ftp.uni-mainz.de/ubuntu bionic main restricted universe multiverse
           deb http://ftp.uni-mainz.de/ubuntu bionic-updates main restricted universe multiverse
           deb http://ftp.uni-mainz.de/ubuntu bionic-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ bionic partner

Re: Fehlermeldung bei Aktualisierung der Anwendungspaketquellen
« Antwort #3 am: 09.05.2019, 22:34:27 »
Die Paketquellen scheinen vollkommen in Ordnung zu sein.
Zeig mal noch die vollständigen Terminal-Ausgaben von:
sudo apt clean
sudo apt update
sudo apt dist-upgrade

Sollten wieder die Fehlermeldungen erscheinen kannst Du ausprobieren, die Paketquellen wiederherzustellen: Aktualisietungsverwaltung →Bearbeiten → Anwendungspaketquellen →Standardeinstellungen wiederherstellen

Re: Fehlermeldung bei Aktualisierung der Anwendungspaketquellen
« Antwort #4 am: 10.05.2019, 17:43:45 »
Hallo,
hier die Ausgaben:

sudo apt-clean bringt keine Ausgabe

sudo apt-update:
Ign:1 http://archive.canonical.com/ubuntu bionic InRelease
Ign:2 http://security.ubuntu.com/ubuntu bionic-security InRelease
Fehl:3 http://security.ubuntu.com/ubuntu bionic-security Release
  404  Not Found [IP: 2a01:5c0:12:2de1:a96:d7ff:fe44:31db 8182]
Fehl:4 http://archive.canonical.com/ubuntu bionic Release   
  404  Not Found [IP: 2a01:5c0:12:2de1:a96:d7ff:fe44:31db 8182]
OK:5 http://ftp.uni-mainz.de/ubuntu bionic InRelease       
Holen:6 http://ftp.uni-mainz.de/ubuntu bionic-updates InRelease [88,7 kB]     
Ign:7 http://mirror.bauhuette.fh-aachen.de/linuxmint tara InRelease           
OK:8 http://mirror.bauhuette.fh-aachen.de/linuxmint tara Release               
Holen:9 http://ftp.uni-mainz.de/ubuntu bionic-backports InRelease [74,6 kB]   
Holen:11 http://ftp.uni-mainz.de/ubuntu bionic-updates/main amd64 Packages [598 kB]
Holen:13 http://ftp.uni-mainz.de/ubuntu bionic-updates/main i386 Packages [504 kB]
Holen:14 http://ftp.uni-mainz.de/ubuntu bionic-updates/main Translation-en [220 kB]
Ign:10 https://dl.bintray.com/etcher/debian stable InRelease                   
Holen:16 http://ftp.uni-mainz.de/ubuntu bionic-updates/main amd64 DEP-11 Metadata [276 kB]
Holen:15 https://dl.bintray.com/etcher/debian stable Release [3.674 B]         
Holen:18 http://ftp.uni-mainz.de/ubuntu bionic-updates/universe amd64 Packages [930 kB]
Holen:19 http://ftp.uni-mainz.de/ubuntu bionic-updates/universe i386 Packages [918 kB]
Holen:20 http://ftp.uni-mainz.de/ubuntu bionic-updates/universe amd64 DEP-11 Metadata [227 kB]
Holen:21 http://ftp.uni-mainz.de/ubuntu bionic-updates/multiverse amd64 DEP-11 Metadata [2.468 B]
Holen:22 http://ftp.uni-mainz.de/ubuntu bionic-backports/universe amd64 DEP-11 Metadata [7.156 B]
Paketlisten werden gelesen... Fertig                                 
E: Das Depot »http://security.ubuntu.com/ubuntu bionic-security Release« enthält keine Release-Datei mehr.
N: Eine Aktualisierung von solch einem Depot kann nicht auf eine sichere Art durchgeführt werden, daher ist es standardmäßig deaktiviert.
N: Weitere Details zur Erzeugung von Paketdepots sowie zu deren Benutzerkonfiguration finden Sie in der Handbuchseite apt-secure(8).
E: Das Depot »http://archive.canonical.com/ubuntu bionic Release« enthält keine Release-Datei mehr.
N: Eine Aktualisierung von solch einem Depot kann nicht auf eine sichere Art durchgeführt werden, daher ist es standardmäßig deaktiviert.
N: Weitere Details zur Erzeugung von Paketdepots sowie zu deren Benutzerkonfiguration finden Sie in der Handbuchseite apt-secure(8).

sudo apt dist-upgrade

Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paketaktualisierung (Upgrade) wird berechnet... Fertig
Die folgenden Pakete wurden automatisch installiert und werden nicht mehr benötigt:
  linux-headers-4.15.0-36 linux-headers-4.15.0-36-generic
  linux-headers-4.15.0-38 linux-headers-4.15.0-38-generic
  linux-headers-4.15.0-43 linux-headers-4.15.0-43-generic
  linux-headers-4.15.0-44 linux-headers-4.15.0-44-generic
  linux-headers-4.15.0-45 linux-headers-4.15.0-45-generic
  linux-headers-4.15.0-46 linux-headers-4.15.0-46-generic
  linux-image-4.15.0-36-generic linux-image-4.15.0-38-generic
  linux-image-4.15.0-43-generic linux-image-4.15.0-44-generic
  linux-image-4.15.0-45-generic linux-image-4.15.0-46-generic
  linux-modules-4.15.0-36-generic linux-modules-4.15.0-38-generic
  linux-modules-4.15.0-43-generic linux-modules-4.15.0-44-generic
  linux-modules-4.15.0-45-generic linux-modules-4.15.0-46-generic
Verwenden Sie »sudo apt autoremove«, um sie zu entfernen.
Die folgenden Pakete werden aktualisiert (Upgrade):
  flatpak gir1.2-flatpak-1.0 libflatpak0
3 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
Es müssen 986 kB an Archiven heruntergeladen werden.
Nach dieser Operation werden 0 B Plattenplatz zusätzlich benutzt.
Möchten Sie fortfahren? [J/n] j
Holen:1 http://ftp.uni-mainz.de/ubuntu bionic-updates/universe amd64 flatpak amd64 1.0.8-0ubuntu0.18.04.1 [750 kB]
Holen:2 http://ftp.uni-mainz.de/ubuntu bionic-updates/universe amd64 libflatpak0 amd64 1.0.8-0ubuntu0.18.04.1 [227 kB]
Holen:3 http://ftp.uni-mainz.de/ubuntu bionic-updates/universe amd64 gir1.2-flatpak-1.0 amd64 1.0.8-0ubuntu0.18.04.1 [9.820 B]
Es wurden 986 kB in 0 s geholt (2.380 kB/s). 
(Lese Datenbank ... 590414 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../flatpak_1.0.8-0ubuntu0.18.04.1_amd64.deb ...
Entpacken von flatpak (1.0.8-0ubuntu0.18.04.1) über (1.0.7-0ubuntu0.18.04.1) ...
Vorbereitung zum Entpacken von .../libflatpak0_1.0.8-0ubuntu0.18.04.1_amd64.deb ...
Entpacken von libflatpak0:amd64 (1.0.8-0ubuntu0.18.04.1) über (1.0.7-0ubuntu0.18.04.1) ...
Vorbereitung zum Entpacken von .../gir1.2-flatpak-1.0_1.0.8-0ubuntu0.18.04.1_amd64.deb ...
Entpacken von gir1.2-flatpak-1.0:amd64 (1.0.8-0ubuntu0.18.04.1) über (1.0.7-0ubuntu0.18.04.1) ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...
/sbin/ldconfig.real: /usr/lib/libbrscandec2.so.1 is not a symbolic link

/sbin/ldconfig.real: /usr/lib/libbrcolm2.so.1 is not a symbolic link

Trigger für doc-base (0.10.8) werden verarbeitet ...
1 geänderte Doc-base-Datei wird verarbeitet...
Dokumente werden mit scrollkeeper registriert ...
Trigger für man-db (2.8.3-2ubuntu0.1) werden verarbeitet ...
Trigger für dbus (1.12.2-1ubuntu1) werden verarbeitet ...
libflatpak0:amd64 (1.0.8-0ubuntu0.18.04.1) wird eingerichtet ...
flatpak (1.0.8-0ubuntu0.18.04.1) wird eingerichtet ...
flatpak-system-helper.service is a disabled or a static unit not running, not starting it.
gir1.2-flatpak-1.0:amd64 (1.0.8-0ubuntu0.18.04.1) wird eingerichtet ...
Trigger für libc-bin (2.27-3ubuntu1) werden verarbeitet ...
/sbin/ldconfig.real: /usr/lib/libbrscandec2.so.1 is not a symbolic link

/sbin/ldconfig.real: /usr/lib/libbrcolm2.so.1 is not a symbolic link

Re: Fehlermeldung bei Aktualisierung der Anwendungspaketquellen
« Antwort #5 am: 10.05.2019, 18:32:28 »
E: Das Depot »http://archive.canonical.com/ubuntu bionic Release« enthält keine Release-Datei mehr.

Diese Fehlermeldung sollte bei den offiziellen Paketquellen nicht erscheinen. Sie taucht meistens bei den Fremdquellen auf. Da fallen mir zwei Mögliche Lösungen ein:
1. entweder den Spiegelserver zu ändern, falls der, den Du jetzt verwendest nicht sehr zuverlässig ist
und dann wieder sudo apt update im Terminal ausführen
2. oder, wenn die erste Möglichkeit nicht hilft, die Datei lists in var/lib/apt löschen:
sudo rm /var/lib/apt/lists/*und dann wieder
sudo apt update
EDIT// Ist LM 19 eine saubere Installation oder ein Upgrade aus LM 18?
Wenn es sich um ein Upgrade handelt, dann poste mal auch die Ausgabe von
lsb_release -awenn wieder die Fehlermeldungen erscheinen sollten.
« Letzte Änderung: 10.05.2019, 18:45:52 von janek-m »

Re: Fehlermeldung bei Aktualisierung der Anwendungspaketquellen
« Antwort #6 am: 10.05.2019, 18:57:00 »
Ist eine saubere Installation.
Die Fehlermeldung ist jetzt wieder aufgetaucht.

Hier die Ausgabe von lsb_release -a
No LSB modules are available.
Distributor ID: LinuxMint
Description: Linux Mint 19 Tara
Release: 19
Codename: tara

Deine anderen Vorschläge werde ich bei Gelegenheit ausprobieren, muss gleich weg.
Vielen Dank schon mal für deine Hilfe!


Re: Fehlermeldung bei Aktualisierung der Anwendungspaketquellen
« Antwort #7 am: 12.05.2019, 13:46:31 »
Diese Fehlermeldung sollte bei den offiziellen Paketquellen nicht erscheinen. Sie taucht meistens bei den Fremdquellen auf. Da fallen mir zwei Mögliche Lösungen ein:
1. entweder den Spiegelserver zu ändern, falls der, den Du jetzt verwendest nicht sehr zuverlässig ist
und dann wieder sudo apt update im Terminal ausführen
2. oder, wenn die erste Möglichkeit nicht hilft, die Datei lists in var/lib/apt löschen:

Hab ich Beides ausprobiert und trotzdem ist die Fehlermeldung wieder aufgetaucht.
Der Fehler tritt auch nicht immer auf und wenn ich danach meinen PC neu starte dann funktioniert es meistens wieder.
Aber wie gesagt, kommt auch immer wieder...

Re: Fehlermeldung bei Aktualisierung der Anwendungspaketquellen
« Antwort #8 am: 13.05.2019, 17:54:31 »
Zitat
E: Das Depot »http://security.ubuntu.com/ubuntu bionic-security Release« enthält keine Release-Datei mehr.
E: Das Depot »http://archive.canonical.com/ubuntu bionic Release« enthält keine Release-Datei mehr.

Es ist für mich ein Rätsel, wie eine Release-Datei bei den offiziellen Quellen fehlen kann. Die Paketquellen in der official-package-repositories.list sind vollkommen in Ordnung, deshalb kann ich mir die Fehlermeldungen nicht erklären.

Probier mal noch die Paketquellen über Aktualisierungsverwaltung wiederherzustellen, wie im Beitrag #3 beschrieben ist. Nach der Wiederherstellung die Aktualisierungsverw. schließen, das Terminal öffnen und noch einmal im Terminal eingeben:
sudo apt autoremove
sudo apt clean
sudo apt update
sudo apt dist-upgrade
Bei Fehlermeldungen poste mal wieder die vollständige Terminalausgabe, vielleicht fällt jemandem noch eine mögliche Lösung ein.

Re: Fehlermeldung bei Aktualisierung der Anwendungspaketquellen
« Antwort #9 am: 13.05.2019, 18:28:33 »
Probier mal noch die Paketquellen über Aktualisierungsverwaltung wiederherzustellen, wie im Beitrag #3 beschrieben ist. Nach der Wiederherstellung die Aktualisierungsverw. schließen, das Terminal öffnen und noch einmal im Terminal eingeben:
Code: [Auswählen]

sudo apt autoremove
sudo apt clean
sudo apt update
sudo apt dist-upgrade

Bei Fehlermeldungen poste mal wieder die vollständige Terminalausgabe, vielleicht fällt jemandem noch eine mögliche Lösung ein.

Hab ich ausgeführt.
Diesmal gab es keine Fehlermeldung.