Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
18.07.2019, 11:28:54

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 599066
  • Themen insgesamt: 48518
  • Heute online: 512
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema: [gelöst]  LM19.1 Cin, Schwarzer Bildschirm nach Umschaltung auf nvidia 390.116  (Gelesen 1563 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Re: LM19.1 Cin, Schwarzer Bildschirm nach Umschaltung auf nvidia 390.116
« Antwort #15 am: 07.05.2019, 20:39:55 »
Ich komme Hier mit diesem Problem nicht weiter und könnte nur mit Timeshift Zurücksetzen.
so, nach Rücksetzen ist alles wieder gut. :)
Stand 02.05.2019 vor der Hilfestellungsaktion bei der ich (voreilig) das nvidia-ppa hinzufügte:
https://www.linuxmintusers.de/index.php?topic=54883.msg743733#msg743733

Jetzt kann ich wieder mit Nvidia-Setting oder dem Prime-Applet zwischen den Karten Umschalten und ohne Black-Screen Booten und es lassen sich in den Einstellungen>Bildschirm alle verfügbaren Auflösungen auswählen.
kuehhe1@HP470:~$ xrandr
Screen 0: minimum 320 x 200, current 1600 x 900, maximum 8192 x 8192
eDP-1 connected primary 1600x900+0+0 (normal left inverted right x axis y axis) 382mm x 215mm
   1920x1080     60.02 +  60.01    59.97    59.96    59.93    40.02 
   1680x1050     59.95    59.88 
   1600x1024     60.17 
   1400x1050     59.98 
   1600x900      59.99    59.94    59.95*   59.82 
   1280x1024     60.02 
   1440x900      59.89 
   1400x900      59.96    59.88 
   1280x960      60.00 
   1440x810      60.00    59.97 
   1368x768      59.88    59.85 
   1360x768      59.80    59.96 
   1280x800      59.99    59.97    59.81    59.91 
   1152x864      60.00 
   1280x720      60.00    59.99    59.86    59.74 
   1024x768      60.04    60.00 
   960x720       60.00 
   928x696       60.05 
   896x672       60.01 
   1024x576      59.95    59.96    59.90    59.82 
   960x600       59.93    60.00 
   960x540       59.96    59.99    59.63    59.82 
   800x600       60.00    60.32    56.25 
   840x525       60.01    59.88 
   864x486       59.92    59.57 
   800x512       60.17 
   700x525       59.98 
   800x450       59.95    59.82 
   640x512       60.02 
   720x450       59.89 
   700x450       59.96    59.88 
   640x480       60.00    59.94 
   720x405       59.51    58.99 
   684x384       59.88    59.85 
   680x384       59.80    59.96 
   640x400       59.88    59.98 
   576x432       60.06 
   640x360       59.86    59.83    59.84    59.32 
   512x384       60.00 
   512x288       60.00    59.92 
   480x270       59.63    59.82 
   400x300       60.32    56.34 
   432x243       59.92    59.57 
   320x240       60.05 
   360x202       59.51    59.13 
   320x180       59.84    59.32 
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)
HDMI-2 disconnected (normal left inverted right x axis y axis)
Sollte aber mal die grafische Oberfläche wegbrechen … tty-Konsole, da gehen nur noch die Terminal-Befehle.
an Die kam ich ja noch heran, aber das Wie war mir dann doch zu Hoch. Ich denke das es an einem verkorksten x11 (Config) lag, k.A.

In solchen Fällen sind Timeshift und / oder qt5-fsarchiver feine und hilfreiche Tools.
« Letzte Änderung: 13.05.2019, 19:47:45 von kuehhe1 »

Hilfestellungsaktion bei der ich (voreilig) das nvidia-ppa hinzufügte:
Das PPA war nicht das Problem, sondern der von dir gewählte Treiber. :D

Hallo @geobart,
wieso falscher Treiber?
Eigentlich sollten doch zwischen einem 390.116 aus dem Repository und dem 390.116 aus dem eines PPA kein Unterschied bestehen.

Oder meinst du meine Aktion im anderen Thema? Wo ich den nVidia 418.56 für meine GeForce 930MX auf dem >HP Probook 470 G5< installierte und in Folge dessen "Schwarz" sah. Der  Treiber 418.56 soll laut nVidia Treiber Support Seite auch meine GeForce 930MX unterstützen. Das Ergebnis musste mit Timeshift bereinigt werden....

Ausserdem bestand seit dem Rücksetzen des initramfs mit:sudo update-initramfs -u -k all ein zeitgleiches Problem  der Bilschirm Auflösung von nur noch 960x540. Da ich das Hinzufügen des PPA und Installieren mehrfach mit zwischenzeitlichem Rücksetzen durch Timeshift versuchte ergaben sich manchmal sogar vernünftige Auflösungen die aber nur bis zum Neustart funktionierten und danach in einem Black-Screen endeten.

Das Problem besteht darin das der Treiber nach der Installation aus dem PPA eingebunden war:
kuehhe1@HP470:~$ inxi -G
Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
           Device-2: NVIDIA GM108M [GeForce 930MX] driver: nvidia v: 418.56
           Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa resolution: 960x540~60Hz
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.5 Mesa 18.2.8
Danach sieht doch alles ganz gut aus,
aber nach Neustart enthält die Zeile keinen Treiber Eintrag für die Nvidia: kuehhe1@HP470:~$ inxi -G
Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
           Device-2: NVIDIA GM108M [GeForce 930MX] driver: N/A
           Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa tty: N/A
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 620 (Kabylake GT2) v: 4.5 Mesa 18.2.8
die dicken Probleme entstehen (entstanden) immer erst nach Neustart. :-[

Erkenntnis: Nur die aus dem Repository stammenden und über die Treiberverwaltung installierten Treiber >nouveau< und >nvidia 390.116< funktionieren hier sofort und einwandfrei.

Edit: Momentan bin total verunsichert wie ich mit dem >nouveau< Eintrag im Grub umgehen soll oder muss. ::)
Fakt ist das bei einer Auswahl des Nouveau-Treibers dieser Eintrag: >nouveau.runpm=0<automatisch in: /ect/default/grub ergänzt wird:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nouveau.runpm=0"
Wenn ich in der Treiberverwaltung von Nouveau auf den nVidia-Treiber umstelle bleibt der oben genannte Eintrag in: /ect/default/grub erhalten, muss ich den nun nach einer testhalber ausgeführten Umstellung von Nouveau auf Nvidia jedesmal händisch entfernen oder kann der Eintrag bestehen bleiben da er nur im Falle des aktiven Nouveau-Treibers berücksichtigt wird?

Edit: testhalber wurde der Eintrag >nouveau.runpm=0< der Nouveau und nVidia 390-16-Treiber funktionieren auch ohne diesen Eintrag.

Oder muss wie in dieser Anleitung noch für für LM17: https://www.linuxmintusers.de/index.php?action=wiki;page=Nvidia-Grafiktreiber_installieren_(von_nvidia.de)_in_Mint_17
der Nouveau grundsätzlich mit:echo "blacklist nouveau" | sudo tee -a /etc/modprobe.d/blacklist.confauf die Blacklist gesetzt werden? In der Konsequenz das danach der Nouveau nicht mehr ausgewählt werden kann.
« Letzte Änderung: 13.05.2019, 19:48:05 von kuehhe1 »

Hallo,
da es mir doch keine Ruhe lies startete ich einen anderen Versuch, um den laut Nvidia-Seite aktuellen Treiber 418.74 für meine GeForce 930MX zu installieren.

Ich bin nun zweimal Schritt für Schritt die Anleitung für LM17 durchgegangen.

Und musste nur den in der Anleitung für LM17 angegebenen Befehl
Zitat
sudo service mdm stop
mit dem für LM19.1 Cin. passenden:sudo service lightdm stopersetzen und landete danach wie vorgesehen im Terminal.

Im Abschnitt der Treiber Installation mit: sudo sh ~/Downloads/NVIDIA-Linux-x86_64-418.74bin ich dann zweimal erfolglos gescheitert.

Während der Installation sollten bestehende DKMS Konfigurationen überschrieben werden, was ich einmal mit "Yes" erlaubte worauf hin die Installation mit Fehlermeldung ?? abbrach. Nach Neustart (reboot) erhielt ich dann einen Black-Screen und konnte  vom Live-System mit Timeshift Zurücksetzen.

Beim nächsten Installationsversuch habe ich das Überschreiben der DKMS Konfigurationen mit "No" verneint, aber auch dabei brach die Installation mit einer Fehlermeldung ?? ab. Nach Neustart (reboot) erhielt ich wieder einen Black-Screen. Mit Timeshift vom Live-System konnte ich erneut auf meinen Stand Vor diesen Installationsversuchen mit dem nvidia Treiber 390.16 aus der Treiberverwaltung zurücksetzen.

Meine Frage, lässt sich auf LM19.1 eine Nvidia Treiber Installation nicht mehr auf diese an LM17 angelehnte Anleitung durch führen oder mache ich noch etwas falsch?
Edit: Die Frage wird durch Antwort #20 beantwortet, denn die Anleitung für LM17 passt auch im wesentlichen für LM19.
« Letzte Änderung: 13.05.2019, 19:48:17 von kuehhe1 »

Hallo,

warum nimmst Du nicht den 410er, wie er auf https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa gleich oben immer noch als "Current Status" genannt wird?

Hier ist die Installation mit allem Drumherum, Für und Wider, dem Beibehalten der dann funktionierenden Version etc. detailliert beschrieben:

https://easylinuxtipsproject.blogspot.com/p/nvidia.html

Kann man sich auch übersetzen lassen, nur bei den Terminal-Eingaben muß man dann auf mögliche Fehler achten, dafür die Originalseite nehmen. Vielleicht führt Dich das zum Erfolg und es muß ja nicht immer das aktuellst Mögliche vom Aktuellsten sein, oder?

Hallo,
danke für deine Hinweis. Die Links werde ich mir ansehen.

Warum ich den 410 noch nicht getestet habe? Weil auch der 410 im PPA enthalten war aber die Installation aus dem PPA nicht gelang. Ausserdem unterstützt er laut nvidia meine Karte nicht, stattdessen wird dort der 418 empfohlen.

es muß ja nicht immer das aktuellst Mögliche vom Aktuellsten sein, oder?
Nein das muss es sicher nicht und mir reicht eigentlci der im Repository vorhandene Treiber 390.116.
Mir geht es jetzt um den grundsätzlich Weg der manuellen Installation.

Edit: die Anleitung ist sehr gut,
https://easylinuxtipsproject.blogspot.com/p/nvidia.html
Sie entspricht im wesentlichen der Installationsanleitung für LM17 hier im Linuxmintusers-Wiki anhand derer ich vorgegangen bin.

Aber es werden darin noch drei weitere Befehle und ein Hinweis zur /etc/X11/xorg.conf angezeigt die vielleicht mein Problem lösen könnten. Das werde ich erneut testen und mich melden.
« Letzte Änderung: 13.05.2019, 19:48:27 von kuehhe1 »

Der 410er war/ist aber auch für Deine Karte geeignet (Erweiterte Treiber Suche) "https://www.nvidia.de/Download/Find.aspx?lang=de"

Ich denke, auf der sonstigen nvidia-Seite, auf der man schaut, wird nur der aktuellste aufgeführt. Ich denke ebenso, auf der ppa-Seite ist der Hinweis auf die Langzeitversion
Zitat
Current long-lived branch release: `nvidia-410` (410.66)
sicher wichtig, woraus ich schließe, daß die anderen aktuelleren diesen Status eben (noch) nicht haben. Vielleicht klappt die Installation mithilfe der genannten Seite ja doch? Mal schauen, ob Du irgendwann dazu noch was berichtest.

Moin,
bevor ich weitere Versuche unternehme hab ich noch Fragen an die Experten. ;)

Bei meinen vorherigen Versuchen musste ich mit:sudo service lightdm stopdie grafische Oberfläche verlassen um das "Purgen" des alten nVidia Treibers, das "Blacklisten" des "nouveau" und  die Installation auszuführen.

Im Hintergrund hörte ich aber noch einen Benachrichtigungston, also lief LM19.1 im Hintergrund weiter.

Nach Abbruch der Installation konnte ich aber nicht mit [Strg]+[X] oder [F10] zur Oberfläche zurückwechseln.

Ist das Normal oder der Nvidia--Treiber-Deinstallation und dem Blacklisten des "Nouveau" geschudet?

Oder gibt es noch einen anderen Befehl um zurück zur grafischen Oberfläche zu gelangen?

Noch eine wichtige Frage:
laut der Anleitung: https://easylinuxtipsproject.blogspot.com/p/nvidia.html
soll bei einer Deinstallation "des nVidia mitsudo sh ~/Downloads/NVIDIA-Linux-*.run --uninstallauch die "xorg.conf" wieder zurückgesetzt werden:sudo rm -v /etc/X11/xorg.confdiesen Befehl habe ich bisher noch nicht ausgeführt, da meine "/etc/X11/xorg.conf" etliche automatisch gesetzte Einträge enthält:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 390.77  (buildd@lcy01-amd64-022)  Thu Sep  6 07:51:39 UTC 2018

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 930MX"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    DefaultDepth    24
    Option         "UseDisplayDevice" "none"
    SubSection     "Display"
        Virtual     1600 900
        Depth       24
    EndSubSection
EndSection
Meine /etc/X11/xorg.conf habe ich erstmal gesichert, darf oder sollte ich sie besser nicht neu generieren und besser unangetastet lassen?

Komplette Systemsicherungen mit qt5-fsarchiver und Timeshift Snapshot sind vorhanden.
« Letzte Änderung: 13.05.2019, 19:48:38 von kuehhe1 »

Bei meinen vorherigen Versuchen musste ich mit:
Code: [Auswählen]

sudo service lightdm stop

die grafische Oberfläche verlassen
In der 17.1 steht es etwas genauer:
Zitat
Jetzt muss der X-Server (das grafische System) beendet werden, da sonst der Nvidia-Installer die Arbeit verweigert:
sudo service mdm stop
Mit dem stop wird der Display-Manager beendet, nicht verlassen. Soll er wieder in Gang gesetzt werden, wäre das sudo service mdm start
Zitat
Mit
Strg+Alt+F1
jetzt die grafische Oberfläche verlassen, anmelden/einloggen: erst Deinen Benutzernamen eingeben, anschließend Dein Passwort.
Das habe ich damals bei 17.1 genommen, weil es einmal Terminal und PW-Eingabe erspart.

Blacklisten wie zu 17..1 Zeiten geht mittlerweile anders, frag mich nicht wie. ;)
Eine xorg.conf hat normalerweise bei Nvidia in Mint nichts mehr zu suchen. Steht auch nicht umsonst.fett in der Easy-Linux Anleitung. Auch das Löschen mit rm.
Deine xorg.conf kann einer der Gründe für deine Misserfolge mit den ppa-Treibern sein.
« Letzte Änderung: 13.05.2019, 23:22:42 von geobart »

Hallo @geobart, danke für die Tips
Mit dem stop wird der Display-Manager beendet, nicht verlassen
ok, da hab ich mich verschrieben, "beenden" ist natürlich korrekt.
Aber in der EasyLinux Anleitung wird zum Beenden der Grafischen Oberfläche auf LM19.x genau der auch von mir dazu verwendete Befehl angewendetet (mit mdm funktionierte es nicht) :
Zitat
D. Terminate the graphic session (which will make your graphical view disappear, so that you only see a black terminal), with this terminal command:

sudo service lightdm stop

Anschliessend könnte ich die Grafische Oberfläche nicht mehr mit sudo service lightdm start starten, ich erhielt dabei einen Black-Screen.
Eine xorg.conf hat normalerweise bei Nvidia in Mint nichts mehr zu suchen. Steht auch nicht umsonst.fett in der Easy-Linux Anleitung. Auch das Löschen mit rm.
Deine xorg.conf kann einer der Gründe für deine Misserfolge mit den ppa-Treibern sein.
Das muss ich mir unbedingt anschauen...... Danke

mit mdm funktionierte es nicht
Wie auch in einer normalen 19.1 Installation?  MDM war der Mint Displaymanager, jetzt ist es lightdm.

Anschliessend könnte ich die Grafische Oberfläche nicht mehr mit
sudo service lightdm startstarten, ich erhielt dabei einen Black-Screen.
Konntest du den Befehl gar nicht erst eingeben oder kam der Blackscreen nach der Eingabe?


Möglicherweise funktionieren die Befehle nicht mehr richtig, seit systemd hat sich doch einiges geändert.
Beispiel für einen Netzwerk-Neustart:
früher sudo service network-manager restart jetzt mit systemd systemctl restart network-manager
Manche der alten Kommandos gehen trotzdem (noch ?), wenn sie aus Kompatibilitätsgründen in die systemd-Syntax übersetzt werden.

Also mal testen: "systemctl start/stop mdm/lightdm.service".
« Letzte Änderung: 14.05.2019, 03:11:34 von aexe »

In Mint 18.3 funzen sie noch.

Moin,
MDM war der Mint Displaymanager, jetzt ist es lightdm.
genau deshalb hatte ich ja den Befehl für mein LM19.1 Cin. auf sudo service lightdm start geändert.

Konntest du den Befehl gar nicht erst eingeben oder kam der Blackscreen nach der Eingabe?
Erst nach Eingabe des Befehls kam der Black-Screen.

Möglicherweise funktionieren die Befehle nicht mehr richtig, seit systemd hat sich doch einiges geändert.....
Also mal testen: "systemctl start/stop mdm/lightdm.service".
Wenn ich dich richtig verstehe könnte es mit systemctl start lightdm.servicefunktionieren? Teste ich später.....

Die auf EasyLinux für LM19 gezeigten Befehle sollten eigentlich passen:
Zitat
Only for Linux Mint 19.x and Ubuntu 18.04.x
The tips and how-to's on this website are only for Linux Mint 19.x and Ubuntu 18.04.x.
Most popular pages
Quelle: https://easylinuxtipsproject.blogspot.com/p/nvidia.html#ID1

Danke für eure Unterstützung, bin jetzt erst mal ausser Haus....
« Letzte Änderung: 14.05.2019, 09:51:02 von kuehhe1 »