Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
22.07.2019, 10:43:54

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
Statistiken
  • Beiträge insgesamt: 599550
  • Themen insgesamt: 48557
  • Heute online: 503
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema:  Windows überschreibt immer den GRUB2-Bootloader - Lösung gesucht  (Gelesen 969 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

helli, Danke!!!
Grade erst gespamt und dann erst gesehen.

Ich versuchs mal

 :-* Leute

eek eek :-X

Ich würde versuchen, noch mal Grub aus dem Live-System über chroot zu installieren:

Die Befehle einzeln ins Terminal kopieren und jeweils mit Enter bestätigen.

sudo mount /dev/sdxy /mntxy muss für die Systempartiotion angepasst werden, b5 oder b9

sudo mount /dev/sda3 /mnt/boot/efi
sudo mount -o bind /dev /mnt/dev
sudo mount -o bind /sys /mnt/sys
sudo mount -t proc /proc /mnt/proc
sudo cp /proc/mounts /mnt/etc/mtab
sudo chroot /mnt /bin/bashNun bist du als root im installierten System und kannst Grub neu installieren.


grub-install
update-grub
Nun mit

exitdie Chroot-Umgebung verlassen und hoffen, dass Linux ohne das Live-Medium bootet.


Beim copieren meckert es leider, bis dahin alles gefunzt.

mint@mint:/proc$ sudo cp /proc/mounts /mnt/etc/mtab
cp: '/proc/mounts' and '/mnt/etc/mtab' are the same file
mint@mint:/proc$

----
mint@mint:/proc$ sudo cp /proc/mounts /mnt/etc/mtab
cp: '/proc/mounts' and '/mnt/etc/mtab' are the same file
mint@mint:/proc$ ll mounts
lrwxrwxrwx 1 root root 11 May  6 22:44 mounts -> self/mounts
mint@mint:/proc$ cd mounts
bash: cd: mounts: Not a directory

----

mint@mint:/proc/self$ ll mounts
-r--r--r-- 1 mint mint 0 May  6 22:41 mounts

Soll ich das nehmen_ Habe aber keine Berechtigungen
« Letzte Änderung: 07.05.2019, 00:47:05 von rattenface »

Kannst du ignorieren und weiter machen.

Kannst du ignorieren und weiter machen.

okay

mint@mint:/proc/self$ sudo chroot /mnt /bin/bash
root@mint:/# grub-install
Installing for x86_64-efi platform.
Installation finished. No error reported.
root@mint:/# update-grub
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/50_linuxmint.cfg'
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-4.15.0-48-generic
Found initrd image: /boot/initrd.img-4.15.0-48-generic
Found linux image: /boot/vmlinuz-4.15.0-20-generic
Found initrd image: /boot/initrd.img-4.15.0-20-generic
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
Adding boot menu entry for EFI firmware configuration
done
root@mint:/# exit
exit
mint@mint:/proc/self$


so ich probiers gleich mal.
es wurden noch alte imagedateien gefunden...
, schlimm?

...also nach
mint@mint:/proc$ sudo cp /proc/mounts /mnt/etc/mtab
cp: '/proc/mounts' and '/mnt/etc/mtab' are the same file

Nur um das mal zu zeigen:
Deine EFI - Partition sollte dann so aussehen!

Das ist der vorhergehende Kernel und in Ordnung.

ich checks mal out.
Danke f[r die HIlfe zu so spaeter stund :)

Du tust Dich mit der Tipperei leichter, wenn Du im Live-System die deutsche Tastaturbelegung einstellst: setxkbmap de

Danke, hehe...
Hab jetzt restartet und das gute Ding ist zwar erstmal ohne GRUBloader gestartet, aber dafür direkt ins vorinstallierte Linux (mit deutscher Tastatur). :D

Hab jetzt auf dem festen, vorinstallierten Linux nochmal grub-update laufen lassen... hat brav ohne Fehlermeldungen und in sda3 geschrieben.

Starte jetzt neu und schau mal, ob dann das GRUB Menu kommt.
Die EFI Partition grafisch öffnen , das kriege ich unter Linux noch nicht hin (zwecks bildlichen Vergleich).

Wenn nicht, dürfte ich im Bios hart einen neuen UEFI Eintrag haben.

Cool!

lol ... vergesst nicht zu schlafe, leude ...

:)

Die EFI Partition grafisch öffnen:
/boot/efi/EFI
Dort befindet sich nun ein Ordner Microsoft und der Ordner ubuntu

Off-Topic:
Schlaf wird überschätzt, zumindestens die Zeiten an dem er stattfinden soll.

Hi Leute, ich habe es zwar geschafft gehabt, aber an dem Tag, oder am Nächsten, direkt nach dem Aufruf vom Windows-Loader, wurde wieder der Grub Bootloader irgendwie außer Gefecht gesetzt.
Es ist nun nicht mehr möglich, Linux Mint (Mate) zu Starten.

Es scheint ein bekanntes Problem zu sein, dass W10 immer (oder nach einem Update vor ca 1Jahr) anfängt, Fremde Bootloader (vielleicht auch aus Sicherheitsgründen) zu überschreiben, zu resetten. Habe damals schon gesucht und ähnliche Beiträge gefunden. Weiß nur nicht, ob es vllt doch an meiner Partitionskonfiguration liegen könnte.

Finde das von Microsoft n bisschen unakzetabel, da unfair anderen BS Herstellern und löst Arroganz aus.

Großer Kaffe, wenig Sinn:
Nach einmal starten kein Grub mehr, sondern gleich Windows.



EDIT: In dem Bboot/efi Ordner auf der Linuxplatte, auf der ich zuletzt am 6.5. GRUB2 installierte, befindet sich nichts mehr.
Auch findet mein UEFI keine Linux/Grub-Loader Option zum Aufrufen mehr.


ein Start von efibootmgr unter Linux Mint USB, ergab,

mint@mint:~$ efibootmgr
BootCurrent: 0005
Timeout: 2 seconds
BootOrder: 0000,0005,0004
Boot0000* Windows Boot Manager
Boot0004* UEFI: Built-in EFI Shell
Boot0005* UEFI: ADATA USB Flash Drive 1100
mint@mint:~$ ^C
mint@mint:~$

auch beim Dr[cken von F11 die gleiche Reihenfolge im UEFI Bootmanager des Boards.
« Letzte Änderung: 25.05.2019, 19:23:17 von rattenface »

Bei den Win-Versionen muß der Schnellstart ausgeschaltet werden, sonst hat ständig Win die Platte in den Krallen.
Bei Win8/8.1 und Win10 geht das über die Energieoptionen.
Bei "Was soll beim Deckelschließen" ist diese Einstellung zu finden. Zuerst auf "Einige Einstellungen sind nicht erreichbar" klicken und dann den Schnellstart deaktivieren. Bei Win7 geht das nur über die Registry oder eventuell mit "Shift Shutdown"

https://praxistipps.chip.de/windows-10-schnellstart-deaktivieren-so-gehts_50919
http://www.heisig-it.de/windows7/w7_tipp031.htm

LG Rudi
« Letzte Änderung: 05.06.2019, 22:44:50 von rudi72 »