Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
17.09.2019, 00:56:01

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22541
  • Letzte: Bembel
Statistiken
  • Beiträge insgesamt: 608122
  • Themen insgesamt: 49216
  • Heute online: 369
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online
Mitglieder: 4
Gäste: 322
Gesamt: 326

Autor Thema:  Windows überschreibt immer den GRUB2-Bootloader - Lösung gesucht  (Gelesen 1642 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Hallo Leute, bin neu hier...  :o

Könnt ihr mir helfen?
Ich brauche eine einfache Anleitung für ein wirklich funktionierendes Dual-Boot mit Win10. Habe auch schon bisserl gesucht...


Habe jetzt im Letzten Schritt Secureboot deaktiviert auf dem Board.. Linux 19.1 MATE installiert....
 Aber selbst danach besteht immer noch das Problem, dass
Windows 10, einmal gestartet, durchstartet, also den GRUB2 überschreibt, anstatt cool zu bleiben und sich über den GRUB starten zu lassen. SecureBoot war also nicht das Problem.


Ich hab das Problem schon ewig. Deshalb nie Linux seit einem bestimmten Win10 Update mehr genießen können.

Meine HDD:
siehe Bild: Auflistung rattenface.png im Anhang.

Board:ASrock970extreme4.
AMD FX 8300
16GB RAM
nvidia gtx 780 ti

C: und D: sind SSD .
Die anderen Zwei HDD
das Letzte ist nur noch der Usb Stick mit MATE drauf.


Muss dabei gestehen, dass sdb (Datenträger 1 einst als Bootloader HDD für GRUB2 eingerichtet) als erstes ne erweiterte Partition bekommen hatte, bzw. irgendwie so geschehen.

Ist das etwa schon die Ursache, dass Grub2 vom Masosoft BS immer überschrieben wird?
Finde leider nicht mehr die Option im BIOS Setup, um hart von bestimmten Lautwerken zu booten (BOOTreihenfolge)

Dennoch Danke für eure Hilfe.

Würde gerne endlich wieder ein stabiles Linux haben.
Gruß, Rattenface  :-X

ps: Mit der Bootreihenfolge muss ich glatt nochmal schauen, wo das abgeblieben ist...

Habe jetzt im Letzten Schritt Secureboot deaktiviert auf dem Board.. Linux 19.1 MATE installiert....
 Aber selbst danach besteht immer noch das Problem, dass
Windows 10, einmal gestartet, durchstartet, also den GRUB2 überschreibt, anstatt cool zu bleiben und sich über den GRUB starten zu lassen. SecureBoot war also nicht das Problem.

Da verstehst du was vollkommen Falsch!
SecureBoot, also Reden wir über UEFI!
Bei UEFI wird Grub nicht in den MBR geschrieben sondern in die EFI Partition wo Windows und Linux unterschiedliche Verzeichnisse nutzen und somit ein Überschreiben unmöglich ist!
Du musst im UEFI die Bootreihenfolge so ändern, das "ubuntu" an Position 1 steht!

Verabschiede dich einfach von diesem Dual Boot mit Windows. Eine Maschine für Windows und eine für Linux. Wie oft muss man noch sagen das Windows und Linux getrennt laufen sollten.

Denska  >:(

Spielt sich das alles auf dem BIOS-Chip ab? Oder ist das in der EFI-Partition. Bräuchte ich für Linux eine eigene EFI Partition auf sdb?

Also kurz bevor ich das hier schrieb, habe ich beim Lesen über eine Option im BIOS-SETUP (UEFI SETUP) nachgedacht, die es mir ermöglicht, Linux als Option 1 zu setzen.
Dort wird aber nur wenig angeboten.

Nach F11 beim Booten drücken erscheint:
Fensterchen mit

Please select boot device:
UEFI: Bootloader oder so
Windows Boot Loader
UEFI: ADATA FLASH Disk

aber von Linux dort keine Spur.
... :'(

Wie oft muss man noch sagen
Das das was du von dir gibst Blödsinn ist!!

Bitte nicht beachten!
Das ist nur unser Forumstroll!

Er hat keine Ahnung, aber davon jede Menge!!  8) 8)
« Letzte Änderung: 07.05.2019, 00:11:20 von tommix »

Starte bitte mal das Live - System und Zeige bitte:
sudo parted --list
Danke

Starte bitte mal das Live - System und Zeige bitte:
sudo parted --list
Danke

mint@mint:~$ sudo parted --list
Model: ATA SanDisk SD8TB8U2 (scsi)
Disk /dev/sda: 256GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number  Start   End     Size    File system  Name  Flags
 1      1049kB  46.6GB  46.6GB  ntfs               msftdata
 2      46.6GB  47.1GB  520MB   ntfs               hidden, diag
 3      47.1GB  47.2GB  105MB   fat32              boot, esp
 4      47.2GB  256GB   209GB   ntfs               msftdata


Model: ATA ST1000DM003-1CH1 (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: msdos
Disk Flags:

Number  Start   End     Size    Type      File system     Flags
 1      9436kB  1000GB  1000GB  extended                  lba
 5      9437kB  25.8GB  25.8GB  logical   ext4
 6      25.8GB  663GB   638GB   logical   ntfs
 9      663GB   703GB   40.0GB  logical   ext4
10      703GB   713GB   9670MB  logical   linux-swap(v1)
 7      713GB   776GB   62.9GB  logical   ntfs
 8      776GB   1000GB  224GB   logical   ntfs


Model: ATA Hitachi HDS72101 (scsi)
Disk /dev/sdc: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number  Start   End     Size   Type     File system  Flags
 1      32.3kB  883GB   883GB  primary  ntfs
 2      883GB   1000GB  117GB  primary  ntfs


Model: ADATA USB Flash Drive (scsi)
Disk /dev/sdl: 15.5GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number  Start   End     Size    File system  Name                  Flags
 1      1049kB  15.5GB  15.5GB  fat32        Microsoft Basic Data  msftdata


mint@mint:~$


Hmm.

Poste bitte auch mal die Ausgabe von
sudo efibootmgr -v

Und bitte:

[ -d /sys/firmware/efi ] && echo UEFI || echo BIOS

sudo efibootmgr -v

mint@mint:~$ sudo efibootmgr -v
BootCurrent: 0005
Timeout: 2 seconds
BootOrder: 0000,0005,0004
Boot0000* Windows Boot Manager HD(3,GPT,111a7560-bf47-11e8-9769-a9885233b79b,0x57b2800,0x32000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot0004* UEFI: Built-in EFI Shell VenMedia(5023b95c-db26-429b-a648-bd47664c8012)AMBO
Boot0005* UEFI: ADATA USB Flash Drive 1100 PciRoot(0x0)/Pci(0xa,0x0)/Pci(0x0,0x0)/USB(1,0)/USB(4,0)/HD(1,GPT,13ad400b-6755-43bb-bdab-fc78ebdc08fe,0x800,0x1ce77df)AMBO
mint@mint:~$

Und bitte:

[ -d /sys/firmware/efi ] && echo UEFI || echo BIOS
mint@mint:~$ [ -d /sys/firmware/efi ] && echo UEFI || echo BIOS
UEFI
mint@mint:~$

scheint uefi yu sein.

Welche Platte gibst du bei der Installation für Grub an?
Grub muss bei Dir in sda3.

Ich würde versuchen, noch mal Grub aus dem Live-System über chroot zu installieren:

Die Befehle einzeln ins Terminal kopieren und jeweils mit Enter bestätigen.

sudo mount /dev/sdxy /mntxy muss für die Systempartiotion angepasst werden, b5 oder b9

sudo mount /dev/sda3 /mnt/boot/efi
sudo mount -o bind /dev /mnt/dev
sudo mount -o bind /sys /mnt/sys
sudo mount -t proc /proc /mnt/proc
sudo cp /proc/mounts /mnt/etc/mtab
sudo chroot /mnt /bin/bashNun bist du als root im installierten System und kannst Grub neu installieren.


grub-install
update-grub
Nun mit

exitdie Chroot-Umgebung verlassen und hoffen, dass Linux ohne das Live-Medium bootet.

Welche Platte gibst du bei der Installation für Grub an?
Grub muss bei Dir in sda3.

lol, ich hab immer sdb9 angegeben, weil ich noch im Halbwissen daran fest hing, dass ich mal im "BIOS" die BOOTREIENFOLGE einstellen konnte.
Aber dann hab ich vergessen, dass UEFI Tatsache wurde, nachdem ich es auch noch selbst eingestellt hatte ...
Und hab mich mit der technischen Erneuerung nie auseinander gesetyt...
Letztendlich hab ich den GRUB immer in sdb9 reingehauen oder auf sdb generell.. bei einem anderen Versuch.

Wenn er in sda3 rein kommt, dann sitzt er dort wie auf dem Thron, oder -
also, Windows sollte den dann nimmer ohne Neuinstallation ueberschreiben?
Und GRUB2 kann auch FAT32 wie in sda3?

Dann muss ich nur noch mal recherchieren, wie ich Grub2 neu schreiben in sda3 schreiben kann. Grub Customizer?

Sollte Linux nicht booten, bitte noch mal aus dem Live-System
sudo efibootmgr -v