Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
23.04.2019, 10:27:11

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 21869
  • Letzte: cpz390
Statistiken
  • Beiträge insgesamt: 585899
  • Themen insgesamt: 47410
  • Heute online: 334
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema: [erledigt] Beim Optimieren der Hochfahrgeschwindigkeit fstab beschädigt  (Gelesen 231 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[erledigt] Beim Optimieren der Hochfahrgeschwindigkeit fstab beschädigt
« am: 14.04.2019, 20:55:53 »
Hallo Zusammen,

System: LM19 Tara - Cinnamon
Inxi -Fz ergibt:
mint@mint:~$ inxi -Fz
System:    Host: mint Kernel: 4.15.0-20-generic x86_64 bits: 64
           Desktop: Cinnamon 3.8.8  Distro: Linux Mint 19 Tara
Machine:   Device: desktop System: extra product: H81M-D2W serial: N/A
           Mobo: Gigabyte model: H81M-D2W v: x.x serial: N/A
           BIOS: American Megatrends v: F1 EP date: 11/06/2013
CPU:       Dual core Intel Pentium G3220 (-MCP-) cache: 3072 KB
           clock speeds: max: 3000 MHz 1: 1006 MHz 2: 1060 MHz
Graphics:  Card: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: Mesa DRI Intel Haswell Desktop
           version: 4.5 Mesa 18.0.0-rc5
Audio:     Card-1 Intel 8 Series/C220 Series High Def. Audio Controller
           driver: snd_hda_intel
           Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.15.0-20-generic
Network:   Card: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169
           IF: enp2s0 state: down mac: <filter>
Drives:    HDD Total Size: 1000.2GB (0.4% used)
           ID-1: /dev/sda model: ST1000DM003 size: 1000.2GB
Partition: ID-1: / size: 1.9G used: 33M (2%) fs: overlay dev: N/A
           ID-2: swap-1 size: 4.17GB used: 0.00GB (0%)
           fs: swap dev: /dev/sda8
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 171 Uptime: 4 min Memory: 512.1/3831.4MB
           Client: Shell (bash) inxi: 2.3.56


Beim Wechsel von LM 18.3 Cinn zu LM19 Cinn wurde die SWAP-Partition vermutlich vom LM19-Lifesystem benutzt.
Das Hochfahren unter LM19 dauert spürbar länger als unter LM18.3. Und was mich fuchst: WIN-XP als virtuelle Maschine fährt schneller hoch als Linux.
Ich habe das Thema im Forum gefunden: https://www.linuxmintusers.de/index.php?topic=54101.0 und versucht die Lösung umzusetzen:
Die Swap-Partition soll dieselbe UUID haben wie die ext4-Partition, blkid zeigte verschiedene UUIDs an.

Nachdem ich zunächst nicht wusste, wie man fstab ändert, fand ich es einfacher das bei wiki.ubuntuusers.de gefundene skript uuid2swap zu nutzen. Leider ohne gewünschte Wirkung. Ich habe dann mit sudo -e die fstab geändert (Standard-System-Editor).

Leider fährt nun LM nicht mehr hoch. Und das angezeigte KERNEL-log-File ist mir zu hoch.
Blkid zeigt nun:
/dev/sda1: LABEL="Windows RE tools" UUID="68803A75803A4A38" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="d20417b7-c07a-4373-9a03-16f456bf6148"
/dev/sda2: LABEL="SYSTEM" UUID="D43D-30EB" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="76bd62cb-9196-4c48-a727-e0daf7ed708b"
/dev/sda4: LABEL="Windows" UUID="48043ECC043EBD2E" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="383cf810-7b94-4553-bc87-4a05a1152a05"
/dev/sda5: UUID="745C14365C13F19A" TYPE="ntfs" PARTUUID="7877ed3f-ad95-4c59-8f77-420d4a1a8e7a"
/dev/sda6: LABEL="Recovery Image" UUID="B688405388401471" TYPE="ntfs" PARTLABEL="Basic data partition" PARTUUID="4b1d0561-5998-4ab7-9d9c-2c68cab127a8"
/dev/sda7: UUID="c775552c-0cdc-4479-8081-12c734254256" TYPE="ext4" PARTUUID="5293df05-c47d-494c-ae92-63448d075123"
/dev/sr0: UUID="2018-07-17-14-01-15-00" LABEL="Linux Mint 19 Cinnamon 64-bit" TYPE="iso9660" PTUUID="39f675eb" PTTYPE="dos"


Die letzte Zeile wurde so von mir nicht eingegeben.

Wenn ich fstab öffne (Read-Rechte-Office-writer), erscheint wieder, was ich auch eingegeben hatte:
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda7 during installation
UUID=c775552c-0cdc-4479-8081-12c734254256 /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda2 during installation
UUID=c775552c-0dcd-4479-8081-12c734254256 /boot/efi       vfat    umask=0077      0       1
/swapfile                                 none            swap    sw              0       0


Gruß
Chris7
« Letzte Änderung: 14.04.2019, 23:16:22 von Chris7 »

Re: Beim Optimieren der Hochfahrgeschwindigkeit fstab beschädigt
« Antwort #1 am: 14.04.2019, 22:28:17 »
das kann nicht funktionieren - in der "fstab" hast du einen Fehler gemacht.

Dieser Eintrag muß geändert werden
Zitat
# /boot/efi was on /dev/sda2 during installation
UUID=c775552c-0dcd-4479-8081-12c734254256 /boot/efi

Ersetze
Zitat
c775552c-0dcd-4479-8081-12c734254256
durch
Zitat
D43D-30EB

Änderung bitte mit einem Text-Editor vornehmen - nicht mit dem "Office-Writer"

Re: Beim Optimieren der Hochfahrgeschwindigkeit fstab beschädigt
« Antwort #2 am: 14.04.2019, 23:15:06 »
Die fstab habe ich wie vorgeschlagen geändert. Ich habe den letzten snapshot via live-system zurückgespielt. Das hatte sich gerade mit Deiner Antwort überschnitten.
Gemäß Deinem Motto lasse ich von weiteren Optimierungen vorerst die Finger. Ich bin dafür noch nicht fit genug. Dann muss ich eben beim Hochfahren länger warten.

Danke für die Hilfe.

Grüße
Chris7

Linux_4_Ever

  • Gast
Re: Beim Optimieren der Hochfahrgeschwindigkeit fstab beschädigt
« Antwort #3 am: 15.04.2019, 02:47:25 »
Zitat
Ich habe den letzten snapshot via live-system zurückgespielt
Nimm doch demnächst Timeshift und sichere Dein Betriebssystem damit.
Für solche Fälle braucht man nicht den aufwändigen Vorgang mittels Life-System.
Timeshift spielt im laufenden System das Backup zurück (und das recht schnell).

Re: Beim Optimieren der Hochfahrgeschwindigkeit fstab beschädigt
« Antwort #4 am: 15.04.2019, 07:56:48 »
LM ist leider nicht mehr hochgefahren. Deshalb habe ich Timeshift über das Live-System aufgerufen. Für mich war der Rückgriff auf Timeshift eher eine Notlösung, weil ich noch beim Systemeinrichten bin und nun einige Schritte verloren habe. Gut, ich habe gelernt die Sicherung nun öfter laufen zu lassen.