Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
25.06.2019, 10:09:15

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22180
  • Letzte: benben
Statistiken
  • Beiträge insgesamt: 595422
  • Themen insgesamt: 48243
  • Heute online: 515
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema:  bringe Gerbera (Programm zum Streamen von Musik und Filmen) nicht zum Laufen  (Gelesen 1015 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Gerbera's UI is disabled. If you did not expect this, please check your configuration.
Obiges kommt unmittelbar nach dem Start des Programms. Was kann ich da tun? Verwende Linux Mint 19.1 Cinnamon. Bin nicht auf dieses Gerbera fixiert, falls es andere Programme gäbe, die funktionieren. Angeblich ist es halt eine gute Weiterentwicklung von MediaTomb und unter den Anwendungen für Mint 19.1 zu finden.

@Peter_neu

Zeig bitteapt-cache policy gerbera

gerbera:
  Installiert:           1.1.0+dfsg-2
  Installationskandidat: 1.1.0+dfsg-2
  Versionstabelle:
 *** 1.1.0+dfsg-2 100
        100 /var/lib/dpkg/status

Auf https://thelinuxcode.com/how-to-install-upnp-gerbera-media-server-on-linux/ wird u.a. empfohlen folgendes im Terminal einzugeben:

sudo add-apt-repository ppa:stephenczetty/gerbera

sudo apt update

Finally, install Gerbera using the following command:

sudo apt install gerbera


Kann man das riskieren? Auf diese Weise würde ich vielleicht zu einer aktuelleren Version kommen und vielleicht ist diese dann lauffähig..

vielleicht ist diese dann lauffähig
Deine Version ist lauffähig, du solltest der Fehlermeldung allerdings ein wenig Beachtung schenken:
Zitat
Die Benutzeroberfläche von Gerbera ist deaktiviert. Wenn du dies nicht erwartet hast, überprüfe bitte deine Konfiguration.

Konfiguration bearbeiten:
sudo -H xed /etc/gerbera/config.xml
Nach "ui" suchen, dieses hier finden:
  <server>
    <ui enabled="no" show-tooltips="yes">

Aus "no" wird "yes", speichern, dann den Service neu starten:
sudo systemctl restart gerbera.service
Auch wenn es zunächst so aussehen mag, am Programm liegt es nicht ;)
« Letzte Änderung: 08.04.2019, 10:56:26 von tml »

Vielen Dank für Deine Tipps. Gerbera habe ich auf diese Weise zum Laufen gebracht. Dennoch weiss ich nicht wie ich damit streamen kann: Ich habe ein Gerät, das über UPNP automatisch andere Geräte im Netz erkennt. Zum Beispiel meine Fritzbox.

Der Computer auf dem Gerbera läuft wird aber leider nicht angezeigt. Kannst Du mir bitte sagen was ich da ändern muss?

Um was es mir eigentlich geht: ich will das was über die Soundkarte wiedergegeben wird auf ein anderes Gerät streamen. Mir geht es weniger darum, dass ich auf dem Computer befindliche Sounddateien streamen kann. Doch auch das wäre gut wenn es ginge.

Bis jetzt funktioniert aber beides nicht. Anbei ein Bildschirmfoto wie das bei mir aussieht.
« Letzte Änderung: 08.04.2019, 11:37:30 von Peter_neu »

Kannst Du mir bitte sagen was ich da ändern muss?

Sorry, keine Ahnung, ich benutze das Programm nicht. Da hilft wahrscheinlich nur das Durcharbeiten der für das Programm bereitstehenden Infos.

Off-Topic:
Versuchsweise hatte ich vor längerer Zeit einmal den Universal Media Server im Einsatz, der ließ sich ziemlich eingängig bedienen und die mitgelieferte Dokumentation war auch recht ausführlich.

Welcher Streaming-Client läuft denn auf der anderen Seite?
Ich hatte da auch mal etwas herumexperimentiert: VLC 3.0.6 findet die Gerbera-Freigaben (VLC 2.2.2 nicht)

Auf der anderen Seite läuft ein Radio mit Multiroom-Möglichkeit: Technisat DigitRadio 3699 IR CD  silber
Diese erkennt die Fritzbox und auch meinen Kabelreceiver Technisat TECHNISTAR K4 ISIO

tml schrieb: ich benutze das Programm nicht. Da hilft wahrscheinlich nur das Durcharbeiten der für das Programm bereitstehenden Infos.
Ich komme mit dieser umfangreichen englisch geschriebenen Dokumentation nicht klar. Versteht das vielleicht jemand anders hier, wie man das Programm zum laufen bringt? Mir ist verdächtig dass ich auf meinem Radio nicht sehe, dass hier überhaupt ein Server in Betrieb ist..

gerbera.service wird automatisch eingerichtet und gestartet.
Status abfragen mit systemctl status gerberaDort werden gegebenenfalls auch Fehlermeldungen angezeigt.
Das war bei mir der Fall (Rechteproblem mit Freigaben auf einer Datenpartition).

Ich habe von Gerbera keine Ahnung. Mint installiert normalerweise alle Plugins.
Aber gucke mal in Synaptic unter codecs nach ob das Plugin xubuntu-restricted-extras
installiert ist. Mehr fällt mir da nicht ein.

Danke an Euch beiden. Ich teste das in den nächsten Tagen und melde mich dann wieder.

● gerbera.service - Gerbera Media Server
   Loaded: loaded (/lib/systemd/system/gerbera.service; enabled; vendor preset: enabled)
   Active: active (running) since Fri 2019-04-12 11:10:14 CEST; 7min ago
     Docs: man:gerbera(1)
           https://gerbera.io/
 Main PID: 906 (gerbera)
    Tasks: 12 (limit: 4468)
   CGroup: /system.slice/gerbera.service
           └─906 /usr/bin/gerbera -c /etc/gerbera/config.xml

Apr 12 11:10:26 mint-laptop gerbera[906]: 2019-04-12 11:10:26    INFO: Setting playlist charset to UTF-8
Apr 12 11:10:26 mint-laptop gerbera[906]: 2019-04-12 11:10:26 WARNING: You enabled the YouTube feature, which allows you
Apr 12 11:10:26 mint-laptop gerbera[906]:                              to watch YouTube videos on your UPnP device!
Apr 12 11:10:26 mint-laptop gerbera[906]:                              Please check http://www.youtube.com/t/terms
Apr 12 11:10:26 mint-laptop gerbera[906]:                              By using this feature you may be violating YouTube
Apr 12 11:10:26 mint-laptop gerbera[906]:                              service terms and conditions!
Apr 12 11:10:26 mint-laptop gerbera[906]: 2019-04-12 11:10:26    INFO: Configuration check succeeded.
Apr 12 11:10:26 mint-laptop gerbera[906]: 2019-04-12 11:10:26    INFO: Initialized port: 49152
Apr 12 11:10:26 mint-laptop gerbera[906]: 2019-04-12 11:10:26    INFO: Server bound to: 192.168.178.26
Apr 12 11:10:27 mint-laptop gerbera[906]: 2019-04-12 11:10:27    INFO: The Web UI can be reached by following this link: http://192.168.178.26:49152/
~
~
~
lines 1-20/20 (END)

Wenn ich das richtig verstehe läuft das Programm einwandfrei, oder? Mein Radio zeigt aber weiterhin nur die bereits vorhandenen UPNP Quellen an und nicht etwa auch den Computer auf dem Gerbera läuft..  :-(
« Letzte Änderung: 12.04.2019, 12:09:42 von Peter_neu »

Hast Du die Firewall aktiv? Gebera läuft auf Port 49152 - siehe https://linoxide.com/tools/install-gerbera-ubuntu-16-04/, die Anleitung ist zwar für Ubuntu 16.xx sollte aber trotzdem laufen

Zwecks Übersetzung hilft das Firefox-Addon https://addons.mozilla.org/de/firefox/addon/imtranslator/?src=search
« Letzte Änderung: 12.05.2019, 11:14:15 von losrobos »