Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
01.12.2020, 03:44:42

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 24840
  • Letzte: Foxinity
Statistiken
  • Beiträge insgesamt: 697731
  • Themen insgesamt: 56462
  • Heute online: 475
  • Am meisten online: 2287
  • (22.01.2020, 19:20:24)
Benutzer Online
Mitglieder: 2
Gäste: 389
Gesamt: 391

Autor Thema:  libpango zur Installation von Canon Druckertreiber lässt sich nicht installieren  (Gelesen 516 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Mein System: Mint 19.1 mit Kernel 5.0.2-050002-generic x86_64.

Ich habe den Treiber für Canon Drucker 'cnijfilter-mx920series_3.90-1_amd64.deb' heruntergeladen und will ihn installieren. Geht nicht weil:
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von cnijfilter-mx920series:
 cnijfilter-mx920series hängt ab von libpango1.0-0 (>= 1.12.3); aber:
  Paket libpango1.0-0 ist nicht installiert.

Dann dies:
carlo@PLuto:~/Downloads/cnijfilter-mx920series-3.90-1-deb/packages$ sudo apt-get install libpango-1.0-0
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
libpango-1.0-0 ist schon die neueste Version (1.40.14-1ubuntu0.1).
Probieren Sie »apt --fix-broken install«, um dies zu korrigieren.
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 cnijfilter-mx920series : Hängt ab von: libpango1.0-0 (>= 1.12.3) soll aber nicht installiert werden
E: Unerfüllte Abhängigkeiten. Versuchen Sie »apt --fix-broken install« ohne Angabe eines Pakets (oder geben Sie eine Lösung an).

Leider geht apt --fix-broken install gar nicht. Das listet nur die Kommando-Optionen. Ein 'fix-broken' gibt es nicht.

Ratlos.

@carlolf

libpango1.0-0 und libpango-1.0-0 sind (auch wenn bezogen auf die Meldung noch andere Ursachen in Frage kommen können) in der Tat zwei (2 verschiedene) Pakete.
Linux legt (nicht nur was Bindestriche angeht), anders als die Forensoftware, seine Ansprüche an eine korrekte Schreibweise etwas höher.  ;D :P
Check mal
apt-cache policy libpango1.0-0 libpango-1.0-0
Sollte das (noch/doch) nicht zutreffend sein wird ggf. der Inhalt von ~/Downloads/cnijfilter-mx920series-3.90-1-deb/packages/ interessant.
« Letzte Änderung: 15.03.2019, 13:29:13 von lmumischabln »

Ich habe es dann doch irgendwie geschafft. apt-get --fix-broken install war wohl die Lösung. Danach ging es.

 

1. Advent
1. Advent