Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
23.03.2019, 16:18:40

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 21725
  • Letzte: mel1203
Statistiken
  • Beiträge insgesamt: 580851
  • Themen insgesamt: 47031
  • Heute online: 585
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema:  HP 15-db0320ng Notebook: Erfahrungen mit Linuxtauglichkeit (insbesondere WLAN)?  (Gelesen 722 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Das die M.2 SSD nur SATA1 hat ist aber wohl echt Quatsch.

Mir kommt der Start vom Linux Mint 19.1 von der SSD langsam vor da ein 8 Jahre altes Notebook mit 18.3 Mint von einer neuen M.2 SSD schneller bootet. Mag aber andere Gründe haben als die SSD. Vielleicht prüft 19.1 mehr beim Booten. Oder ich hab bei der Installation irgendwas suboptimal eingestellt.

Angabe von Boot-Sekunden und Einzelheiten liefert systemd-analyze systemd-analyze critical-chain systemd-analyze blame (Beenden mit Strg + C)

Braucht 42 s. Mein altes nur 17 s. Ohne Ahnung zu haben erinnere ich einen Post, der anmerkte dass selbst 19.1 so neue Hardware evtl. nicht (komplett) unterstützt.

Mir kann ich vorwerfen, dass ich /tmp und /var auf die HDD ausgelagert habe. Aber daran liegt es wohl auch nicht.

systemd-analyze
Startup finished in 34.793s (kernel) + 7.557s (userspace) = 42.351s

systemd-analyze critical-chain
The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @7.550s
└─multi-user.target @7.550s
  └─getty.target @7.550s
    └─getty@tty1.service @7.549s
      └─system-getty.slice @7.548s
        └─setvtrgb.service @7.539s +8ms
          └─systemd-user-sessions.service @7.305s +7ms
            └─network.target @7.304s
              └─NetworkManager.service @7.051s +252ms
                └─dbus.service @7.005s
                  └─basic.target @6.987s
                    └─paths.target @6.987s
                      └─cups.path @6.987s
                        └─sysinit.target @6.948s
                          └─systemd-timesyncd.service @6.777s +171ms
                            └─systemd-tmpfiles-setup.service @5.557s +1.185s
                              └─systemd-journal-flush.service @1.921s +3.634s
                                └─var.mount @1.809s +109ms
                                  └─systemd-fsck@dev-disk-by\x2duuid-<...>
                                    └─dev-disk-by\x2duuid-<...>
lines 1-23

systemd-analyze blame
          9.989s ntp.service
          3.634s systemd-journal-flush.service
          1.185s systemd-tmpfiles-setup.service
           670ms systemd-fsck@dev-disk-by\x2duuid-<...>
           607ms systemd-fsck@dev-disk-by\x2duuid-<...>
           494ms dev-sdb1.device
           428ms systemd-fsck@dev-disk-by\x2duuid-<...>
           338ms systemd-logind.service
           335ms systemd-cryptsetup@cryptswap1.service
           309ms accounts-daemon.service
           300ms udisks2.service
           258ms systemd-rfkill.service
           252ms NetworkManager.service
           218ms lightdm.service
           218ms plymouth-quit-wait.service
           197ms systemd-random-seed.service
           185ms systemd-tmpfiles-clean.service
           179ms upower.service
           177ms home.mount
           177ms apparmor.service
           175ms tmp.mount
           171ms systemd-timesyncd.service
           166ms ubuntu-system-adjustments.service
lines 1-23

Für eine SSD ist das schon langsam.
Der Kernel braucht auffällig viel Startzeit.
Sonst fällt mir nichts Ungewöhnliches auf.

Zum Vergleich: systemd-analyze
Startup finished in 5.077s (kernel) + 9.135s (userspace) = 14.212s
graphical.target reached after 8.076s in userspace
LM-19.1 Cinnamon, Lenovo X240, i5, SSD

Edit
Die Startzeiten sind aber nicht jedesmal gleich.
« Letzte Änderung: 14.03.2019, 20:11:38 von aexe »

Bin happy! Hab die Bremse im System gefunden.

Aber zunächst an Euch alle ein ganz herzliches Dankeschön für die immer kompetente und zuverlässige Hilfe. Ich lerne echt viel durch Euch - Ihr seid spitze!

Wie habe ich den Fehler gefunden:
Nach aexes Ausführungen und dem Fund im Internet dass es sich entgegen meiner Blödel-Verschwörungstheorie nun doch um eine SATA-3 mit 540 MB/sec handelt, erinnerte ich mich an den Tipp eines Forumsmitglieds in einem anderen Thread und ließ beim Starten die Kernel-Bootsequenzen anzeigen. Und siehe da: 30 Sekunden fror das System ein bei folgender Ausgabe:
Scanning for Btrfs filesystem

Was macht das System denn da und wie hast du das abgestellt? *interessiert ist*

Ich weiß es nicht.

Laut diesem Link wird 30s nach einer /swap Partition gesucht (suche dort bitte nach "30 seconds"). Der Autor  hat keine swap Partition. Ich habe eine 1GB swap auf der SSD in einer erweiterten Partition. Trotzdem habe ich seine Anleitung befolgt. Mit Teilerfolg.

systemd-analyzezeigt jetzt keine Auffälligkeiten mehr. Mit der Stopuhr gemessen startet das System jetzt 10s schneller (insgesamt 30s). Das ist mir aber immer noch zu langsam für eine SSD. Verdächtig für mich als Laien ist dass er jetzt 5s einfriert bei der Ausgabe:
Reached target swapDanach kommt (vielleicht irrelvant):
Started Flush Journal to Persistent Storage.
Starting Create Volatile Files and Directories...
<Das hier kann ich nicht sehen (rauscht zu schnell durch). Muss nachher nochmal im Logfile gucken was da stand. Weiß gerade nicht wo ich das finde.>

Ich hab die Mini-swap nur eingerichtet weil ich gelesen habe es schade nie. Hab allerdings 12 GB Arbeitsspeicher und habe swap nur eingerichtet weil lt. einem Post für Hibernate wichtig. Keine Ahnung ob das stimmt.
« Letzte Änderung: 15.03.2019, 10:04:06 von hallo »

dmesg > out.txt
deckt sich nicht mit den Meldungen die über den Bildschirm huschen. Das "Reached target swap" ist z.B. in der out.txt gar nicht enthalten.

Probier es mal mit journalctl -b Dann hast Du ein paar 1000 Zeilen zur Auswahl oder zum Filtern.
Beispiel: journalctl -b | grep target
« Letzte Änderung: 15.03.2019, 18:50:20 von aexe »

Hier die Ausgabe von aexes journalctl -b (16 Zeilen) an der Stelle wo mein dmesg nur 3 Zeilen angezeigt. Es ist die Stelle wo das Durchrauschen der Bootsequenzen auf dem Bildschirm verdächtig "einfriert".

Meine 3 dmesg Zeilen habe ich mit >>> am Zeilenanfang markiert. Zwischen den beiden ersten >>> vergehen 8s. Ich sehe gerade dass die Ausgabe nicht zeitlich sortiert ist. Vielleicht daher besser das Listing danach angucken. Das ist einigermaßen sortiert.
>>> Mär 16 08:45:18 hallo-HP-Laptop-15 systemd[1]: Reached target Swap.
Mär 16 08:45:28 hallo-HP-Laptop-15 avahi-daemon[846]: New relevant interface lo.IPv6 for mDNS.
Mär 16 08:45:29 hallo-HP-Laptop-15 grub-common[823]:  * Recording successful boot for GRUB
Mär 16 08:45:29 hallo-HP-Laptop-15 grub-common[823]:    ...done.
Mär 16 08:45:18 hallo-HP-Laptop-15 systemd[1]: Started AppArmor initialization.
Mär 16 08:45:28 hallo-HP-Laptop-15 avahi-daemon[846]: Joining mDNS multicast group on interface lo.IPv4 with address 127.0.0.1.
Mär 16 08:45:29 hallo-HP-Laptop-15 thermald[827]: NO RAPL sysfs present
Mär 16 08:45:29 hallo-HP-Laptop-15 thermald[827]: Unsupported cpu model, use thermal-conf.xml file or run with --ignore-cpuid-check
Mär 16 08:45:29 hallo-HP-Laptop-15 thermald[827]: THD engine start failed
Mär 16 08:45:18 hallo-HP-Laptop-15 systemd[1]: Starting Raise network interfaces...
Mär 16 08:45:28 hallo-HP-Laptop-15 avahi-daemon[846]: New relevant interface lo.IPv4 for mDNS.
Mär 16 08:45:18 hallo-HP-Laptop-15 systemd[1]: Started Raise network interfaces.
Mär 16 08:45:28 hallo-HP-Laptop-15 avahi-daemon[846]: Network interface enumeration completed.
>>> Mär 16 08:45:26 hallo-HP-Laptop-15 systemd[1]: Started Flush Journal to Persistent Storage.
Mär 16 08:45:28 hallo-HP-Laptop-15 avahi-daemon[846]: Registering new address record for ::1 on lo.*.
>>> Mär 16 08:45:26 hallo-HP-Laptop-15 systemd[1]: Starting Create Volatile Files and Directories...

Hier nochmal aufsteigend sortiert alle Ausgaben mit gleichem Zeitstempel unmittelbar vor dem 8s Sprung. Und alle mit gleichem Zeitstempel unmittelbar danach. Leider nur aufsteigend sortiert. Also nicht nur nach Zeitstempel. Das kriege ich gerade nicht hin. Den Zeitsprung habe ich gesondert markiert:
Mär 16 08:45:18 hallo-HP-Laptop-15 audit[736]: AVC apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/lightdm/lightdm-guest-session" pid=736 comm="apparmor_parser"
Mär 16 08:45:18 hallo-HP-Laptop-15 audit[736]: AVC apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/lightdm/lightdm-guest-session//chromium" pid=736 comm="apparmor_parser"
Mär 16 08:45:18 hallo-HP-Laptop-15 audit[737]: AVC apparmor="STATUS" operation="profile_load" profile="unconfined" name="/sbin/dhclient" pid=737 comm="apparmor_parser"
Mär 16 08:45:18 hallo-HP-Laptop-15 audit[737]: AVC apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/connman/scripts/dhclient-script" pid=737 comm="apparmor_parser"
Mär 16 08:45:18 hallo-HP-Laptop-15 audit[737]: AVC apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/NetworkManager/nm-dhcp-client.action" pid=737 comm="apparmor_parser"
Mär 16 08:45:18 hallo-HP-Laptop-15 audit[737]: AVC apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/NetworkManager/nm-dhcp-helper" pid=737 comm="apparmor_parser"
Mär 16 08:45:18 hallo-HP-Laptop-15 audit[739]: AVC apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/bin/man" pid=739 comm="apparmor_parser"
Mär 16 08:45:18 hallo-HP-Laptop-15 audit[739]: AVC apparmor="STATUS" operation="profile_load" profile="unconfined" name="man_filter" pid=739 comm="apparmor_parser"
Mär 16 08:45:18 hallo-HP-Laptop-15 audit[739]: AVC apparmor="STATUS" operation="profile_load" profile="unconfined" name="man_groff" pid=739 comm="apparmor_parser"
Mär 16 08:45:18 hallo-HP-Laptop-15 audit[740]: AVC apparmor="STATUS" operation="profile_load" profile="unconfined" name="libreoffice-oopslash" pid=740 comm="apparmor_parser"
Mär 16 08:45:18 hallo-HP-Laptop-15 audit[741]: AVC apparmor="STATUS" operation="profile_load" profile="unconfined" name="libreoffice-senddoc" pid=741 comm="apparmor_parser"
Mär 16 08:45:18 hallo-HP-Laptop-15 audit[742]: AVC apparmor="STATUS" operation="profile_load" profile="unconfined" name="libreoffice-soffice" pid=742 comm="apparmor_parser"
Mär 16 08:45:18 hallo-HP-Laptop-15 audit[742]: AVC apparmor="STATUS" operation="profile_load" profile="unconfined" name="libreoffice-soffice//gpg" pid=742 comm="apparmor_parser"
Mär 16 08:45:18 hallo-HP-Laptop-15 audit[743]: AVC apparmor="STATUS" operation="profile_load" profile="unconfined" name="libreoffice-xpdfimport" pid=743 comm="apparmor_parser"
Mär 16 08:45:18 hallo-HP-Laptop-15 audit[744]: AVC apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/cups-browsed" pid=744 comm="apparmor_parser"
Mär 16 08:45:18 hallo-HP-Laptop-15 audit[745]: AVC apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/lib/cups/backend/cups-pdf" pid=745 comm="apparmor_parser"
Mär 16 08:45:18 hallo-HP-Laptop-15 audit[745]: AVC apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/cupsd" pid=745 comm="apparmor_parser"
Mär 16 08:45:18 hallo-HP-Laptop-15 audit[745]: AVC apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/cupsd//third_party" pid=745 comm="apparmor_parser"
Mär 16 08:45:18 hallo-HP-Laptop-15 audit[746]: AVC apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/ippusbxd" pid=746 comm="apparmor_parser"
Mär 16 08:45:18 hallo-HP-Laptop-15 audit[747]: AVC apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/ntpd" pid=747 comm="apparmor_parser"
Mär 16 08:45:18 hallo-HP-Laptop-15 audit[749]: AVC apparmor="STATUS" operation="profile_load" profile="unconfined" name="/usr/sbin/tcpdump" pid=749 comm="apparmor_parser"
Mär 16 08:45:18 hallo-HP-Laptop-15 systemd[1]: Activated swap /dev/mapper/cryptswap1.
Mär 16 08:45:18 hallo-HP-Laptop-15 systemd[1]: Reached target Swap.
Mär 16 08:45:18 hallo-HP-Laptop-15 systemd[1]: Started AppArmor initialization.
Mär 16 08:45:18 hallo-HP-Laptop-15 systemd[1]: Started Raise network interfaces.
Mär 16 08:45:18 hallo-HP-Laptop-15 systemd[1]: Starting Raise network interfaces...
---------- 8 Sekunden Lücke hier ----------------------------------------------------------------
Mär 16 08:45:26 hallo-HP-Laptop-15 systemd[1]: Started Create Volatile Files and Directories.
Mär 16 08:45:26 hallo-HP-Laptop-15 systemd[1]: Started Flush Journal to Persistent Storage.
Mär 16 08:45:26 hallo-HP-Laptop-15 systemd[1]: Started Update UTMP about System Boot/Shutdown.
Mär 16 08:45:26 hallo-HP-Laptop-15 systemd[1]: Starting Create Volatile Files and Directories...
Mär 16 08:45:26 hallo-HP-Laptop-15 systemd[1]: Starting Network Name Resolution...
Mär 16 08:45:26 hallo-HP-Laptop-15 systemd[1]: Starting Network Time Synchronization...
Mär 16 08:45:26 hallo-HP-Laptop-15 systemd[1]: Starting Update UTMP about System Boot/Shutdown...
« Letzte Änderung: 16.03.2019, 10:31:03 von hallo »

Letzte bzw. erste Ausgabezeile (von aexes journalctl -b) unmittelbar vor/nach dem fraglichen 8s-Sprung. Nach Zeitstempel sortiert. Andere Ausgaben mit gleichem Zeitstempel hab ich weggelassen da sie nicht unmittelbar vor/nach dem Sprung erfolgten:
Mär 16 08:45:18 hallo-HP-Laptop-15 systemd[1]: Started Raise network interfaces.
---------- 8 Sekunden Lücke hier ----------------------------------------------------------------
Mär 16 08:45:26 hallo-HP-Laptop-15 systemd[1]: Started Flush Journal to Persistent Storage.

Vielleicht ist es normal dass das Initialisieren (?=Raise) der Netzwerk Schnittstellen so lange dauert.

Manchmal hängt es an den Energiespar-Einstellungen für den Funk oder am Aufbau der Verbindung. Dann sind ein paar Sekunden Wartezeit nicht ungewöhnlich.
Beispiel: systemd-analyze blame
Zitat
          6.378s NetworkManager-wait-online.service
          4.133s fstrim.service
           748ms apt-daily.service
[ … ]
« Letzte Änderung: 17.03.2019, 10:26:58 von aexe »

Der Rechner hat ja auch so eine Combo-Karte (WLAN/Bluetooth) deren WLAN ich zu Beginn dieses Threads nicht zum Laufen bekam.
Keine Ahnung wie ich die WLAN Energiespar-Einstellungen ändere. Das ist mir aber auch nicht so wichtig.

Für mich ist wichtig, dass es scheinbar nichts mehr mit dem "30s nach /swap suchen"-Problem zu tun hat. Dir einen schönen Sonntag!