Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
20.03.2019, 23:05:55

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 21718
  • Letzte: Seppiro
Statistiken
  • Beiträge insgesamt: 580323
  • Themen insgesamt: 46994
  • Heute online: 675
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema:  WLAN erscheint nicht  (Gelesen 1434 mal)

1 Mitglieder und 2 Gäste betrachten dieses Thema.

WLAN erscheint nicht
« am: 05.03.2019, 22:16:35 »
Guten Tag - bin ganz neu hier.
Typischer Umsteiger nach gefühlten  100 Jahren in der NoWin-Welt (zeigt mein Alter, huh?  ;) )
Meine Umgebung:Mint 19.1 Cinnamon Desktop frisch installiert.Kein Windows auf diesem System!
DELL Optiplex 980 64 Bit-System.
  • Das draht-gebundene Netzwerk funktioniert tadellos (schreibe vom fraglichen System).
  • Hinter dem Symbol im System-Tray kann ich nur das Kabelnetzwerk ein-/ausschalten. Es gibt keinen Schalter für das Funknetzwerk.
  • Ich verwende den USB-WLAN-Stick von Netgear AC600 / 802.11 ac Dual Band.
   [li]Die üblichen Terminalbefehle, soweit ich diese bei der Suche eruieren konnte, ergeben den folgenden Output:[/li][/list]cus@CUS-LM-01:~$ inxi -Fz
System:    Host: CUS-LM-01 Kernel: 4.15.0-46-generic x86_64 bits: 64 Desktop: Cinnamon 4.0.9 Distro: Linux Mint 19.1 Tessa
Machine:   Type: Desktop System: Dell product: OptiPlex 980 v: N/A serial: <filter>
           Mobo: Dell model: 0D441T v: A01 serial: <filter> BIOS: Dell v: A04 date: 09/11/2010
CPU:       Topology: Quad Core model: Intel Core i7 870 bits: 64 type: MT MCP L2 cache: 8192 KiB
           Speed: 1203 MHz min/max: 1197/2927 MHz Core speeds (MHz): 1: 1197 2: 1197 3: 1197 4: 1197 5: 1197 6: 1197 7: 1197
           8: 1197
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] RV710 [Radeon HD 4550] driver: radeon v: kernel
           Display: x11 server: X.Org 1.19.6 driver: ati,radeon unloaded: fbdev,modesetting,vesa resolution: 1680x1050~60Hz
           OpenGL: renderer: AMD RV710 (DRM 2.50.0 / 4.15.0-46-generic LLVM 7.0.0) v: 3.3 Mesa 18.2.2
Audio:     Device-1: Intel 5 Series/3400 Series High Definition Audio driver: snd_hda_intel
           Sound Server: ALSA v: k4.15.0-46-generic
Network:   Device-1: Intel 82578DM Gigabit Network driver: e1000e
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Device-2: NetGear A6100 AC600 DB Wireless Adapter [Realtek RTL8811AU] type: USB driver: usb-network
Drives:    Local Storage: total: 327.97 GiB used: 19.38 GiB (5.9%)
           ID-1: /dev/sda vendor: Seagate model: ST3320418AS size: 298.09 GiB
           ID-2: /dev/sdb type: USB model: USB Flash Disk size: 29.88 GiB
RAID:      Hardware-1: Intel SATA Controller [RAID mode] driver: ahci
Partition: ID-1: / size: 292.41 GiB used: 9.69 GiB (3.3%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 2.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-0
Sensors:   System Temperatures: cpu: 31.0 C mobo: N/A gpu: radeon temp: 54 C
           Fan Speeds (RPM): N/A
Info:      Processes: 226 Uptime: 1h 10m Memory: 7.78 GiB used: 1.11 GiB (14.2%) Shell: bash inxi: 3.0.27
  • [/l]
cus@CUS-LM-01:~$ rfkill list  > Hier kein Output!

cus@CUS-LM-01:~$ lsusb
Bus 002 Device 005: ID 090c:1000 Silicon Motion, Inc. - Taiwan (formerly Feiya Technology Corp.) Flash Drive
Bus 002 Device 004: ID 046d:c05a Logitech, Inc. M90/M100 Optical Mouse
Bus 002 Device 003: ID 413c:2107 Dell Computer Corp.
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0846:9052 NetGear, Inc. A6100 AC600 DB Wireless Adapter [Realtek RTL8811AU]
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Unter Windows 7 funktioniert der Stick übrigens problemlos.Lasst es mich wissen, wenn ich via Terminal noch andere Befehle absetzen soll. Bin diesbezüglich aber noch der Papagei - d.h. ich mach nach, was Ihr mir da nennt.

Ahhh und noch einen Fakt - Siehe Attachment...


Habt viiieeelen Dank für Euren Input!

Liebe Grüsse aus BaselCharlie

« Letzte Änderung: 05.03.2019, 22:23:44 von Pilot-Charlie »

Re: WLAN erscheint nicht
« Antwort #1 am: 06.03.2019, 07:05:26 »
Das Problem wird sein, das dem Stick keine Schnittstelle zugewiesen wird. Leider weis ich nicht wie man das behebt.
Eventuell hilft ein
systemctl restart network-managerWas sagt
iwconfigWird hier eine Schnittstelle angezeigt?
« Letzte Änderung: 06.03.2019, 07:10:49 von Renalto »

Re: WLAN erscheint nicht
« Antwort #2 am: 06.03.2019, 08:11:53 »
Hallo,
das Paket aus der Treiberverwaltung ist veraltet und funktioniert nicht. Entferne es wieder.

Manuelle Installation eines aktuellen Treibers über Kabelverbindung, USB-Tethering o.ä. mittels DKMS
sudo apt install git dkms
git clone https://github.com/gordboy/rtl8812au
cd rtl8812au
sudo mkdir /usr/src/rtl8812au-5.2.20

Nachtag: die erforderliche Geräte-ID 0846:9052 für den Stick muss zunächst in der /rtl8812au/os_dep/linux/usb_intf.c eingepflegt werden:
#ifdef CONFIG_RTL8812A
/*=== Realtek demoboard ===*/
...
/*=== Customer ID ===*/
...
  {USB_DEVICE(0x0846, 0x9051), .driver_info = RTL8812}, /* Netgear A6200 v2 */
  {USB_DEVICE(0x0846, 0x9052), .driver_info = RTL8812}, /* Netgear A6100 */
...
Installation fortsetzen:
sudo cp -r * /usr/src/rtl8812au-5.2.20
sudo dkms install rtl8812au/5.2.20
Und noch den korrekten Ländercode einstellen:
echo 'options 8812au rtw_country_code="DE"' | sudo tee /etc/modprobe.d/8812au_options.confKeine Fehler? → Stick anschließen und testen:
dkms status
modinfo 8812au
sudo modprobe -v 8812au
iwconfig
iwlist chan
nmcli dev wifi list
Achtung:
* der Treiber arbeitet nur mit dem cfg80211 Subsystem und ist nicht signiert!
* Secure-Boot des UEFI muss deaktiviert werden!
* Regionseinstellungen des System (erlaubte Sendeleistung & Kanaleinstellungen) müssen den Parameter rtw_country_code oder rtw_channel_plan und  eine anzulegende Konfigurationsdatei angepasst werden (s.o.)!

« Letzte Änderung: 06.03.2019, 08:42:21 von Flash63 »

Re: WLAN erscheint nicht
« Antwort #3 am: 06.03.2019, 10:35:34 »
@ Renalto:Vielen Dank für den Input! systemctl restart network-manager  hat keine Änderung bewirkt.

iwconfig sagt das da:

cus@CUS-LM-01:~$ iwconfig
eno1      no wireless extensions.

lo        no wireless extensions.


@Flash63:
Auch Dir besten Dank für Deine ausführliche Antwort!
Bin am 'Verdauen' und Ausprobieren. Please stand by.

Charlie


Re: WLAN erscheint nicht
« Antwort #4 am: 06.03.2019, 11:39:59 »
@ Flash63:
Zwar funktioniert  das WLAN immer noch nicht, aber es gibt doch einen Fortschritt. Mittlerweile zeigt es mir das WLAN unten rechtsd im Systemtray (wie nennt man das Ding eigentlich in der Linux-Welt?):
Dort ist jetzt immerhin ein Eintrag 'Funknetzwerk' aber noch ohne Schiebeschalter, dafür nun aber mit dem Vermerk "nicht verfügbar".
Die von Dir angegebenen Befehle sind ohne Fehlermeldungen abgelaufen.Mit einer Sequenz kann ich aber (noch) nichts anfangen, Zitat: * Regionseinstellungen des System (erlaubte Sendeleistung & Kanaleinstellungen) müssen den Parameter rtw_country_code oder rtw_channel_plan und  eine anzulegende Konfigurationsdatei angepasst werden (s.o.)!   
Habe trotz Recherche nicht heraus gefunden, wo diese Parameter eingegeben werden müssen, resp. ob irgendwo noch eine entsprechende Datei von mir  geschaffen werden soll/muss?...
Ooch, wenn ich denn genau geguckt hätte, siehe Dein (s.o....) :

Gell, diese Parameter sind im File  /lib/modules/4.15.0-46-generic/updates/dkms/8812au.ko , oder?
Dort habe ich dann diese beiden Zeilen gefunden:
parm:           rtw_country_code:The default country code (in alpha2) (charp)
parm:           rtw_channel_plan:The default chplan ID when rtw_alpha2 is not specified or valid (int)
Wäre der erste Parameter dann DE? Oder müsste ich da für die Schweiz CH eintragen? Spielte das eine Rolle?

Wie sieht die Syntax dieser zwei Parameter aus? Wo schlägt man eigentlich solche Syntax'es im Linux Universe nach?
Ahh und noch was: Während der ganzen Prozedur war der Stick angeschlossen.. wäre das ein Problem gewesen (USB und NoWin gebrannt...)?

Hier mal der Output der Terminalanweisungen nachdem ich Deine Befehle umgesetzt hatte:
DKMS: install completed.
cus@CUS-LM-01:~/rtl8812au$ echo 'options 8812au rtw_country_code="DE"' | sudo tee /etc/modprobe.d/8812au_options.conf
options 8812au rtw_country_code="DE"
cus@CUS-LM-01:~/rtl8812au$
cus@CUS-LM-01:~/rtl8812au$ dkms status
rtl8812au, 5.2.20, 4.15.0-46-generic, x86_64: installed
cus@CUS-LM-01:~/rtl8812au$ modinfo 8812au
filename:       /lib/modules/4.15.0-46-generic/updates/dkms/8812au.ko
version:        v5.2.20.2_28373.20180619
author:         Realtek Semiconductor Corp.
description:    Realtek Wireless Lan Driver
license:        GPL
srcversion:     A3D3F1DCB3D356CD3A36976
alias:          usb:v7392pA822d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v7392pA812d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2604p0012d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2357p0122d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2357p010Fd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2357p010Ed*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2357p010Dd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2357p0103d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2357p0101d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v20F4p805Bd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2019pAB30d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2001p3316d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2001p3315d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2001p3313d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v2001p330Ed*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1740p0100d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v148Fp9097d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v13B1p003Fd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v1058p0632d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0E66p0022d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0DF6p0074d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0BDAp881Ad*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0BDAp8812d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0B05p17D2d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0846p9052d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0846p9051d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v07B8p8812d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0789p016Ed*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0586p3426d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v050Dp1109d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v050Dp1106d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v04BBp0952d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0411p025Dd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0409p0408d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0BDAp881Cd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0BDAp881Bd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0BDAp881Ad*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v0BDAp8812d*dc*dsc*dp*ic*isc*ip*in*
depends:        cfg80211
retpoline:      Y
name:           8812au
vermagic:       4.15.0-46-generic SMP mod_unload
parm:           rtw_ips_mode:The default IPS mode (int)
parm:           rtw_lps_level:The default LPS level (int)
parm:           rtw_usb_rxagg_mode:int
parm:           rtw_dynamic_agg_enable:int
parm:           rtw_drv_log_level:set log level when insert driver module, default log level is _DRV_INFO_ = 4 (uint)
parm:           rtw_tx_bw_mode:The max tx bw for 2.4G and 5G. format is the same as rtw_bw_mode (uint)
parm:           rtw_rx_ampdu_sz_limit_1ss:RX AMPDU size limit for 1SS link of each BW, 0xFF: no limitation (array of uint)
parm:           rtw_rx_ampdu_sz_limit_2ss:RX AMPDU size limit for 2SS link of each BW, 0xFF: no limitation (array of uint)
parm:           rtw_rx_ampdu_sz_limit_3ss:RX AMPDU size limit for 3SS link of each BW, 0xFF: no limitation (array of uint)
parm:           rtw_rx_ampdu_sz_limit_4ss:RX AMPDU size limit for 4SS link of each BW, 0xFF: no limitation (array of uint)
parm:           rtw_vht_enable:int
parm:           rtw_vht_rx_mcs_map:VHT RX MCS map (uint)
parm:           rtw_rf_config:int
parm:           rtw_country_code:The default country code (in alpha2) (charp)
parm:           rtw_channel_plan:The default chplan ID when rtw_alpha2 is not specified or valid (int)
parm:           rtw_excl_chs:exclusive channel array (array of uint)
parm:           rtw_qos_opt_enable:int
parm:           ifname:The default name to allocate for first interface (charp)
parm:           if2name:The default name to allocate for second interface (charp)
parm:           rtw_pwrtrim_enable:int
parm:           rtw_initmac:charp
parm:           rtw_special_rf_path:int
parm:           rtw_chip_version:int
parm:           rtw_rfintfs:int
parm:           rtw_lbkmode:int
parm:           rtw_network_mode:int
parm:           rtw_channel:int
parm:           rtw_mp_mode:int
parm:           rtw_wmm_enable:int
parm:           rtw_vrtl_carrier_sense:int
parm:           rtw_vcs_type:int
parm:           rtw_busy_thresh:int
parm:           rtw_ht_enable:int
parm:           rtw_bw_mode:int
parm:           rtw_ampdu_enable:int
parm:           rtw_rx_stbc:int
parm:           rtw_rx_ampdu_amsdu:int
parm:           rtw_tx_ampdu_amsdu:int
parm:           rtw_beamform_cap:int
parm:           rtw_lowrate_two_xmit:int
parm:           rtw_power_mgnt:int
parm:           rtw_smart_ps:int
parm:           rtw_low_power:int
parm:           rtw_wifi_spec:int
parm:           rtw_full_ch_in_p2p_handshake:int
parm:           rtw_antdiv_cfg:int
parm:           rtw_antdiv_type:int
parm:           rtw_drv_ant_band_switch:int
parm:           rtw_single_ant_path:int
parm:           rtw_switch_usb_mode:int
parm:           rtw_enusbss:int
parm:           rtw_hwpdn_mode:int
parm:           rtw_hwpwrp_detect:int
parm:           rtw_hw_wps_pbc:int
parm:           rtw_check_hw_status:int
parm:           rtw_max_roaming_times:The max roaming times to try (uint)
parm:           rtw_mc2u_disable:int
parm:           rtw_80211d:Enable 802.11d mechanism (int)
parm:           rtw_notch_filter:0:Disable, 1:Enable, 2:Enable only for P2P (uint)
parm:           rtw_hiq_filter:0:allow all, 1:allow special, 2:deny all (uint)
parm:           rtw_adaptivity_en:0:disable, 1:enable (uint)
parm:           rtw_adaptivity_mode:0:normal, 1:carrier sense (uint)
parm:           rtw_adaptivity_dml:0:disable, 1:enable (uint)
parm:           rtw_adaptivity_dc_backoff:DC backoff for Adaptivity (uint)
parm:           rtw_adaptivity_th_l2h_ini:th_l2h_ini for Adaptivity (int)
parm:           rtw_adaptivity_th_edcca_hl_diff:th_edcca_hl_diff for Adaptivity (int)
parm:           rtw_amplifier_type_2g:BIT3:2G ext-PA, BIT4:2G ext-LNA (uint)
parm:           rtw_amplifier_type_5g:BIT6:5G ext-PA, BIT7:5G ext-LNA (uint)
parm:           rtw_RFE_type:default init value:64 (uint)
parm:           rtw_powertracking_type:default init value:64 (uint)
parm:           rtw_GLNA_type:default init value:0 (uint)
parm:           rtw_TxBBSwing_2G:default init value:0xFF (uint)
parm:           rtw_TxBBSwing_5G:default init value:0xFF (uint)
parm:           rtw_OffEfuseMask:default open Efuse Mask value:0 (uint)
parm:           rtw_FileMaskEfuse:default drv Mask Efuse value:0 (uint)
parm:           rtw_rxgain_offset_2g:default RF Gain 2G Offset value:0 (uint)
parm:           rtw_rxgain_offset_5gl:default RF Gain 5GL Offset value:0 (uint)
parm:           rtw_rxgain_offset_5gh:uint
parm:           rtw_rxgain_offset_5gm:default RF Gain 5GM Offset value:0 (uint)
parm:           rtw_pll_ref_clk_sel:force pll_ref_clk_sel, 0xF:use autoload value (uint)
parm:           rtw_tx_pwr_by_rate:0:Disable, 1:Enable, 2: Depend on efuse (int)
parm:           rtw_target_tx_pwr_2g_a:2.4G target tx power (unit:dBm) of RF path A for each rate section, should match the real calibrate power, -1: undefined (array of int)
parm:           rtw_target_tx_pwr_2g_b:2.4G target tx power (unit:dBm) of RF path B for each rate section, should match the real calibrate power, -1: undefined (array of int)
parm:           rtw_target_tx_pwr_2g_c:2.4G target tx power (unit:dBm) of RF path C for each rate section, should match the real calibrate power, -1: undefined (array of int)
parm:           rtw_target_tx_pwr_2g_d:2.4G target tx power (unit:dBm) of RF path D for each rate section, should match the real calibrate power, -1: undefined (array of int)
parm:           rtw_target_tx_pwr_5g_a:5G target tx power (unit:dBm) of RF path A for each rate section, should match the real calibrate power, -1: undefined (array of int)
parm:           rtw_target_tx_pwr_5g_b:5G target tx power (unit:dBm) of RF path B for each rate section, should match the real calibrate power, -1: undefined (array of int)
parm:           rtw_target_tx_pwr_5g_c:5G target tx power (unit:dBm) of RF path C for each rate section, should match the real calibrate power, -1: undefined (array of int)
parm:           rtw_target_tx_pwr_5g_d:5G target tx power (unit:dBm) of RF path D for each rate section, should match the real calibrate power, -1: undefined (array of int)
parm:           rtw_phy_file_path:The path of phy parameter (charp)
parm:           rtw_load_phy_file:PHY File Bit Map (int)
parm:           rtw_decrypt_phy_file:Enable Decrypt PHY File (int)
parm:           rtw_en_napi:int
parm:           rtw_en_gro:int
parm:           rtw_iqk_fw_offload:int
parm:           rtw_led_enable:Enable status LED (int)
cus@CUS-LM-01:~/rtl8812au$ sudo modprobe -v 8812au
[sudo] Passwort für cus:           
insmod /lib/modules/4.15.0-46-generic/kernel/net/wireless/cfg80211.ko
insmod /lib/modules/4.15.0-46-generic/updates/dkms/8812au.ko rtw_country_code="DE"
cus@CUS-LM-01:~/rtl8812au$ iwconfig
wlx00e04c8e4377  unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Auto  Frequency=2.412 GHz  Access Point: Not-Associated   
          Sensitivity:0/0 
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eno1      no wireless extensions.

lo        no wireless extensions.

cus@CUS-LM-01:~/rtl8812au$ iwlist chan
wlx00e04c8e4377  32 channels in total; available frequencies :
          Channel 01 : 2.412 GHz
          Channel 02 : 2.417 GHz
          Channel 03 : 2.422 GHz
          Channel 04 : 2.427 GHz
          Channel 05 : 2.432 GHz
          Channel 06 : 2.437 GHz
          Channel 07 : 2.442 GHz
          Channel 08 : 2.447 GHz
          Channel 09 : 2.452 GHz
          Channel 10 : 2.457 GHz
          Channel 11 : 2.462 GHz
          Channel 12 : 2.467 GHz
          Channel 13 : 2.472 GHz
          Channel 36 : 5.18 GHz
          Channel 40 : 5.2 GHz
          Channel 44 : 5.22 GHz
          Channel 48 : 5.24 GHz
          Channel 52 : 5.26 GHz
          Channel 56 : 5.28 GHz
          Channel 60 : 5.3 GHz
          Channel 64 : 5.32 GHz
          Channel 100 : 5.5 GHz
          Channel 104 : 5.52 GHz
          Channel 108 : 5.54 GHz
          Channel 112 : 5.56 GHz
          Channel 116 : 5.58 GHz
          Channel 120 : 5.6 GHz
          Channel 124 : 5.62 GHz
          Channel 128 : 5.64 GHz
          Channel 132 : 5.66 GHz
          Channel 136 : 5.68 GHz
          Channel 140 : 5.7 GHz
          Current Frequency:2.412 GHz (Channel 1)

eno1      no frequency information.

lo        no frequency information.
cus@CUS-LM-01:~/rtl8812au$ nmcli dev wifi list
IN-USE  SSID  MODE  CHAN  RATE  SIGNAL  BARS  SECURITY

Danke Dir vielmals bis dahin und für's Dranbleiben - most appreciated!
Charlie




Re: WLAN erscheint nicht
« Antwort #5 am: 06.03.2019, 16:20:22 »
Hallo,
sieht doch gut aus.
Zitat
Wäre der erste Parameter dann DE? Oder müsste ich da für die Schweiz CH eintragen? Spielte das eine Rolle?
Klar, für die Schweiz natürlich CH statt DE eintragen und den Befehl einfach wiederholen. Die Kanaleinstellung wird für DE zumindest korrekt umgesetzt, wie die Bestimmungen der Schweiz sind ist mir jedoch nicht bekannt.

Die Schnittstelle mit in die Verwaltung des Network-Manager nehmen:
sudo nmcli dev set wlx00e04c8e4377 managed yes
Treibermodul nun entladen/laden und erneut testen/prüfen:
sudo modprobe -rfv 8821au
sudo modprobe -v 8821au
nmcli d
nmcli dev wifi list
iwlist chan

https://www.bakom.admin.ch/dam/bakom/de/dokumente/bakom/telekommunikation/Technologie/WLAN/factsheet_wlan.pdf.download.pdf/factsheet_wlan.pdf
« Letzte Änderung: 06.03.2019, 16:26:41 von Flash63 »

Re: WLAN erscheint nicht
« Antwort #6 am: 06.03.2019, 20:27:08 »
Hallo Flash63
Hab ganz herzlichen Dank für Deine abermalige Hilfe!Lieder stosse ich bei deren Umsetzung noch ein wenig an meine Grenzen:
- Wenn ich den File  /lib/modules/4.15.0-46-generic/updates/dkms/8812au.ko öffnen will, erhale ich nur Gibberish.  Muss ich diesen File mit einer speziellen Anwendung öffnen (Textbearbeitung und LibreOffice Writer zeigen den selben 'Salat')?
  Wollte dort das 'CH' nachtragen.
  Was ist eine chplan ID ? Aus dem angehängten PDF vom Schweizer BAKOM (danke Dir dafür!) werde ich leider nicht ganz schlau, der Begriff taucht dort auch implizit nicht auf. Oder kann ich den Parameter einfach sein lassen?
-
Der folgende Befehl  flutschte durch, allerdings hatte sich inzwischen die ID wlx00e04c8e4377 in eine andere geändert (wie ich mit iwconfig ersehen konnte):

sudo nmcli dev set wlx00e04c8e4377 managed yes
Der nächste Befehl brach dann mit einer Fehlermeldung ab:
cus@CUS-LM-01:~/rtl8812au$ sudo modprobe -rfv 8822au
modprobe: FATAL: Module 8822au not found.


Und da steht jetzt der Esel am Berge...
Sorry, dass ich da (noch) nicht durchsteige..

Liebe grüsse aus Basel!

Charlie






Re: WLAN erscheint nicht
« Antwort #7 am: 07.03.2019, 06:27:59 »
Hallo, mal bitte etwas mehr Konzentration.
Zitat
Wenn ich den File  /lib/modules/4.15.0-46-generic/updates/dkms/8812au.ko öffnen will, ...
Wie kommt man auf so etwas, das steht doch nirgendwo. Das ist der Pfad zum benötigten Kerenelmodul, da gibt es nichts zu bearbeiten.

Der Ländercode wird durch eine Moduloption gesetzt. Hast Du bereits gemacht. Dabei ist dir sogar aufgefallen, dass der Code für Deutschland ist und ersetzt werden muss (konnte ich zuvor ja nicht wissen). Ganz pfiffige hätten dies ja direkt korrigiert und nicht erst den falschen verwendet. Ok, ist ja nicht weiter schlimm und da das nicht funktioniert, hier erneut, so wie es bereits ganz oben steht:echo 'options 8812au rtw_country_code="CH"' | sudo tee /etc/modprobe.d/8812au_options.conf
Zitat
Der folgende Befehl  flutschte durch, allerdings hatte sich inzwischen die ID wlx00e04c8e4377 in eine andere geändert (wie ich mit iwconfig ersehen konnte):
Eher unwahrscheinlich, aber warum zeigst Du die Ausgaben dann nicht, dass ist doch wichtig!
Zitat
Der nächste Befehl brach dann mit einer Fehlermeldung ab:
Dazu muss man eigentlich nichts sagen, der Fehler wird doch direkt angezeigt. Wenn Du die vorgegebenen Terminalbefehle kopieren würdest, wären Tippfehler quasi ausgeschlossen.

Zitat
Aus dem angehängten PDF ... werde ich leider nicht ganz schlau
Das ist ein Merkblatt mit den zulässigen Frequenzen und Übertragungsmodi für WLAN in der Schweiz.
« Letzte Änderung: 07.03.2019, 06:34:44 von Flash63 »

Re: WLAN erscheint nicht
« Antwort #8 am: 07.03.2019, 11:20:05 »
Hi Flash63
Hab vielen Dank für Deine Hilfe!
Also so wegen Konzentration, Pfiffigkeit und so... wie früher erwähnt bin ich da mehr oder weniger noch ein 'Papagei' mir fehlen da wirklich noch die ganzen Zusammenhänge... und wegen copy/paste und so, ist das so eine Sache.  ;)
Also:
Vor den ganzen Modifikationen vorhin habe ich die fragliche ID per iwconfig nochmals abgefragt und sie ist tatsächlich schon wieder eine Andere, nämlich jetzt
wlx00e04c7941d9 (darüber weiter unten mehr):cus@CUS-LM-01:~/rtl8812au$ iwconfig
wlx00e04c7941d9  unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Auto  Frequency=2.412 GHz  Access Point: Not-Associated   
          Sensitivity:0/0 
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

lo        no wireless extensions.

eno1      no wireless extensions.
Dann bin ich hingegangen und habe die anderen Befehle wieder abarbeiten wollen, mit der selben Fehlermeldung, bis ich dann den, mit copy/paste mitgenommenen Zahlendreher gesehen habe (es war ein langer Tag und ich habe den gestern effektiv auch nicht bemerkt).
Von da an flutschten die Commands dann reibungslos durch:
cus@CUS-LM-01:~/rtl8812au$ sudo modprobe -rfv 8812au
rmmod 8812au
rmmod cfg80211
cus@CUS-LM-01:~/rtl8812au$ sudo modprobe -v 8812au
insmod /lib/modules/4.15.0-46-generic/kernel/net/wireless/cfg80211.ko
insmod /lib/modules/4.15.0-46-generic/updates/dkms/8812au.ko rtw_country_code="CH"

Und ab da kommt jetzt plötzlich wieder eine andere ID, nämlich wlx00e04cff714f:
Liegt da noch der Hund begraben?
cus@CUS-LM-01:~/rtl8812au$ nmcli d
DEVICE           TYPE      STATE            CONNECTION                 
eno1             ethernet  verbunden        Kabelgebundene Verbindung 1
wlx00e04cff714f  wifi      nicht verfügbar  --                         
lo               loopback  nicht verwaltet  --                   
cus@CUS-LM-01:~/rtl8812au$ nmcli dev wifi list
IN-USE  SSID  MODE  CHAN  RATE  SIGNAL  BARS  SECURITY
cus@CUS-LM-01:~/rtl8812au$ iwlist chan
wlx00e04cff714f  32 channels in total; available frequencies :
          Channel 01 : 2.412 GHz
          Channel 02 : 2.417 GHz
          Channel 03 : 2.422 GHz
          Channel 04 : 2.427 GHz
          Channel 05 : 2.432 GHz
          Channel 06 : 2.437 GHz
          Channel 07 : 2.442 GHz
          Channel 08 : 2.447 GHz
          Channel 09 : 2.452 GHz
          Channel 10 : 2.457 GHz
          Channel 11 : 2.462 GHz
          Channel 12 : 2.467 GHz
          Channel 13 : 2.472 GHz
          Channel 36 : 5.18 GHz
          Channel 40 : 5.2 GHz
          Channel 44 : 5.22 GHz
          Channel 48 : 5.24 GHz
          Channel 52 : 5.26 GHz
          Channel 56 : 5.28 GHz
          Channel 60 : 5.3 GHz
          Channel 64 : 5.32 GHz
          Channel 100 : 5.5 GHz
          Channel 104 : 5.52 GHz
          Channel 108 : 5.54 GHz
          Channel 112 : 5.56 GHz
          Channel 116 : 5.58 GHz
          Channel 120 : 5.6 GHz
          Channel 124 : 5.62 GHz
          Channel 128 : 5.64 GHz
          Channel 132 : 5.66 GHz
          Channel 136 : 5.68 GHz
          Channel 140 : 5.7 GHz
          Current Frequency:2.412 GHz (Channel 1)

lo        no frequency information.

eno1      no frequency information.
Hab herzlichen Dank für Deine Lehrstunden!  8)
Liebe Grüsse aus Basel
Charlie

Re: WLAN erscheint nicht
« Antwort #9 am: 07.03.2019, 17:00:17 »
Hallo,
der Stick wechselt also permanent die Geräte-Mac Adresse. Das müssen wir unterbinden. Aus der MAC-Adresse wird die Schnittstellenbezeichnung, das Interface, generiert.
Hier gerade wlx00e04c7941d9

wl = WLAN
x = USB-Gerät
00e04c7941d9 = 00:e0:4c:79:41:d9 Geräte-MAC

Versuchen wir das über eine weitere Moduloption zu korrigieren:
echo 'options 8812au rtw_country_code="CH" ifname="wlan0"' | sudo tee /etc/modprobe.d/8812au_options.confStick mehrfach abziehen und jedes mal prüfen ob sich die Bezeichnung wie gewünscht ändert, bzw. gleich bleibt (wlan0).
« Letzte Änderung: 07.03.2019, 17:18:22 von Flash63 »

Re: WLAN erscheint nicht
« Antwort #10 am: 07.03.2019, 18:59:13 »
Hi Flash63
Danke Dir für's Dranbleiben!
Die ID und damit offenbar die MAC-Adresse ändern auch nach dem Ausführen Deines Scripts nach wie vor mit jedem Ein- und Ausziehen des WLAN-Sticks!(ist das nicht ulkig? Sollte eine MAC-Adresse per Definition eigentlich nicht immer die Selbe sein / bleiben??)...

Hier der Output des Scripts, welcher mit dem Eintrag in der Datei /etc/modprobe.d/8812au_options.conf übereinstimmt:
cus@CUS-LM-01:~/rtl8812au$ echo 'options 8812au rtw_country_code="CH" ifname="wlan0"' | sudo tee /etc/modprobe.d/8812au_options.conf
[sudo] Passwort für cus:           
options 8812au rtw_country_code="CH" ifname="wlan0"
Der guten Ordnung halber der neueste iwconfig-output:cus@CUS-LM-01:~/rtl8812au$ iwconfig
wlx00e04c3208c0  unassociated  Nickname:"<WIFI@REALTEK>"
          Mode:Auto  Frequency=2.412 GHz  Access Point: Not-Associated   
          Sensitivity:0/0 
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

lo        no wireless extensions.

eno1      no wireless extensions.



Charlie.


Re: WLAN erscheint nicht
« Antwort #11 am: 07.03.2019, 19:18:43 »
Ok, funktioniert noch nicht wie gedacht. Momentan möchte ich zuerst die Bezeichnung der Schnittstelle dauerhaft anpassen.
2. Versuch:
echo 'options 8812au rtw_country_code="CH" ifname=wlan0' | sudo tee /etc/modprobe.d/8812au_options.confRechner neu starten und abfragen
ifconfig -a
Weitere Möglichkeit:
sudo sed -i 's/GRUB_CMDLINE_LINUX=""/GRUB_CMDLINE_LINUX="net.ifnames=0 biosdevname=0"/g' /etc/default/grub
sudo update-grub
Neustart und erneut abfragen:
ifconfig -a
Zitat
Sollte eine MAC-Adresse per Definition eigentlich nicht immer die Selbe sein / bleiben??)
Ja, dass sollte sie eigentlich.
« Letzte Änderung: 07.03.2019, 19:50:35 von Flash63 »

Re: WLAN erscheint nicht
« Antwort #12 am: 07.03.2019, 20:44:04 »
Hi Flash63
Habe beide Varianten ausprobiert, die ID ändert sich zwar noch immer, aber ab der 2. Variante 'heisst' die Schnittstelle jetzt immer 'wlan0'!.
Hier die Abfolge der Befehle und Ausgaben:
Script der 1. Variante, noch vor dem Reboot:
cus@CUS-LM-01:~/rtl8812au$ echo 'options 8812au rtw_country_code="CH" ifname=wlan0' | sudo tee /etc/modprobe.d/8812au_options.conf
[sudo] Passwort für cus:           
options 8812au rtw_country_code="CH" ifname=wlan0
1. Variante nach dem Reboot:
cus@CUS-LM-01:~$ ifconfig -a
.....
wlx00e04cabe793: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 00:e0:4c:ab:e7:93  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
Dann die 2. Variante, resp. deren Script und Ausgabe:
cus@CUS-LM-01:~/rtl8812au$ sudo sed -i 's/GRUB_CMDLINE_LINUX=""/GRUB_CMDLINE_LINUX="net.ifnames=0 biosdevname=0"/g' /etc/default/grub
[sudo] Passwort für cus:           
cus@CUS-LM-01:~/rtl8812au$ sudo update-grub
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/50_linuxmint.cfg'
GRUB-Konfigurationsdatei wird erstellt …
Linux-Abbild gefunden: /boot/vmlinuz-4.15.0-46-generic
initrd-Abbild gefunden: /boot/initrd.img-4.15.0-46-generic
Linux-Abbild gefunden: /boot/vmlinuz-4.15.0-45-generic
initrd-Abbild gefunden: /boot/initrd.img-4.15.0-45-generic
Linux-Abbild gefunden: /boot/vmlinuz-4.15.0-20-generic
initrd-Abbild gefunden: /boot/initrd.img-4.15.0-20-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
erledigt
Das Resultat nach der 2. Variante:
cus@CUS-LM-01:~$ ifconfig -a
...
wlan0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 00:e0:4c:86:a9:02  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Dann nach dem Entfernen und wieder Einstecken des WLAN-Sticks nach gefahrener 2. Variante:
cus@CUS-LM-01:~$ ifconfig -a
...
wlan0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 00:e0:4c:33:dd:9a  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
Also heisst die Schnittstelle jetzt dauerhaft 'wlan0' ! awesome!
Viieelen Dank soweit und einen schönen Abend noch!

Charlie


Re: WLAN erscheint nicht
« Antwort #13 am: 07.03.2019, 21:09:40 »
Prima, dass schaut soweit gut aus. Wir mach dann Fr & Sa weiter. Du kannst zwischendurch aber schon mal versuchen eine WLAN-Verbindung aufzubauen und prüfen, ob diese stabil läuft.

Re: WLAN erscheint nicht
« Antwort #14 am: 08.03.2019, 15:01:14 »
Hallo Flash63
Danke Dir für Deine Inputs!
Also, das Ding hat nach wie vor noch keine Connection über's WLAN.
Unter Netzwerk-Verbindungen konnte ich dann (das ist neu) bei Gerät wlan0 (00:E0:4C:5A:7D:97) auswählen. 
Aber unten, im Netzwerk-Menu steht immer noch 'Funknetzwerk nicht verfügbar'. Im selben Dialog hat's auch einen Eintrag 'Nach drahtlosen Netzwerken erneut suchen'. Dessen Anwahl bewirkt aber rein gar nix, d.h. es öffnet sich kein Dialog, nix.

Ich hab dann beim herum-browsen zwei Commands gefunden, um damit etwas Hintergrundinfos zu sammeln.
Hier wären diese, falls Dir der Output etwas sagt, resp. für mein Problem überhaupt relevant ist:
Gefunden mittels dmesg:
1.824101] usb 1-1.3: new high-speed USB device number 3 using ehci-pci
[    1.840219] usb 2-1.5: new low-speed USB device number 3 using ehci-pci
[    1.933556] usb 1-1.3: New USB device found, idVendor=0846, idProduct=9052
[    1.933561] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    1.933564] usb 1-1.3: Product: 802.11ac WLAN Adapter
[    1.933567] usb 1-1.3: Manufacturer: Realtek
[    1.933569] usb 1-1.3: SerialNumber: 00e04c000001

Erstellt mit journalctl:
Mär 08 09:44:44 CUS-LM-01 kernel: usb 1-1.3: new high-speed USB device number 3 using ehci-pci
Mär 08 09:44:44 CUS-LM-01 kernel: usb 2-1.5: new low-speed USB device number 3 using ehci-pci
Mär 08 09:44:44 CUS-LM-01 kernel: usb 1-1.3: New USB device found, idVendor=0846, idProduct=9052
Mär 08 09:44:44 CUS-LM-01 kernel: usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Mär 08 09:44:44 CUS-LM-01 kernel: usb 1-1.3: Product: 802.11ac WLAN Adapter
Mär 08 09:44:44 CUS-LM-01 kernel: usb 1-1.3: Manufacturer: Realtek
Mär 08 09:44:44 CUS-LM-01 kernel: usb 1-1.3: SerialNumber: 00e04c000001
Mär 08 09:44:57 CUS-LM-01 NetworkManager[900]: <info>  [1552034697.5015] hostname: hostname: using hostnamed
Mär 08 09:44:57 CUS-LM-01 NetworkManager[900]: <info>  [1552034697.5015] hostname: hostname changed from (none) to "CUS-LM-01"
Mär 08 09:44:57 CUS-LM-01 NetworkManager[900]: <info>  [1552034697.5018] dns-mgr[0x55f349173170]: init: dns=systemd-resolved, rc-manager=symlink, plugin=systemd-resolved
Mär 08 09:44:57 CUS-LM-01 NetworkManager[900]: <info>  [1552034697.5026] rfkill0: found WiFi radio killswitch (at /sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.3/1-1.3:1.0/ieee80211/phy0/rfkill0) (driver
Mär 08 09:44:57 CUS-LM-01 NetworkManager[900]: <info>  [1552034697.5028] manager[0x55f349155060]: rfkill: WiFi hardware radio set enabled
Mär 08 09:44:57 CUS-LM-01 NetworkManager[900]: <info>  [1552034697.5028] manager[0x55f349155060]: rfkill: WWAN hardware radio set enabled
Mär 08 09:44:58 CUS-LM-01 NetworkManager[900]: <info>  [1552034698.8387] wifi-nl80211: (wlan0): using nl80211 for WiFi device control
Mär 08 09:44:58 CUS-LM-01 NetworkManager[900]: <info>  [1552034698.8389] device (wlan0): driver supports Access Point (AP) mode
Mär 08 09:44:58 CUS-LM-01 kernel: IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Mär 08 09:44:58 CUS-LM-01 NetworkManager[900]: <info>  [1552034698.8396] manager: (wlan0): new 802.11 WiFi device (/org/freedesktop/NetworkManager/Devices/3)
Mär 08 09:44:58 CUS-LM-01 NetworkManager[900]: <info>  [1552034698.8404] device (wlan0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
Mär 08 09:44:59 CUS-LM-01 NetworkManager[900]: <warn>  [1552034699.4745] platform-linux: do-change-link[3]: failure changing link: failure 1 (Vorgang nicht zulässig)
Mär 08 09:44:59 CUS-LM-01 NetworkManager[900]: <info>  [1552034699.4807] modem-manager: ModemManager available
Mär 08 09:44:59 CUS-LM-01 NetworkManager[900]: <info>  [1552034699.4812] supplicant: wpa_supplicant running
Mär 08 09:44:59 CUS-LM-01 NetworkManager[900]: <info>  [1552034699.4813] device (wlan0): supplicant interface state: init -> starting

Und hier 'registrierte' journalctl mein Aus- und Einschalten des WLAN mit dem Schiebeschalter:
Mär 08 10:15:50 CUS-LM-01 NetworkManager[900]: <info>  [1552036550.7221] manager: rfkill: WiFi hardware radio set disabled
Mär 08 10:15:50 CUS-LM-01 NetworkManager[900]: <info>  [1552036550.7224] audit: op="radio-control" arg="wireless-enabled:0" pid=2678 uid=1000 result="success"
Mär 08 10:15:50 CUS-LM-01 systemd[1]: Starting Load/Save RF Kill Switch Status...
Mär 08 10:15:50 CUS-LM-01 NetworkManager[900]: <info>  [1552036550.7258] manager: rfkill: WiFi now disabled by radio killswitch
Mär 08 10:15:50 CUS-LM-01 systemd[1]: Started Load/Save RF Kill Switch Status.
Mär 08 10:15:51 CUS-LM-01 NetworkManager[900]: <info>  [1552036551.4054] manager: rfkill: WiFi hardware radio set enabled
Mär 08 10:15:52 CUS-LM-01 NetworkManager[900]: <warn>  [1552036552.0372] platform-linux: do-change-link[3]: failure changing link: failure 1 (Vorgang nicht zulässig)
Mär 08 10:15:52 CUS-LM-01 NetworkManager[900]: <info>  [1552036552.0373] audit: op="radio-control" arg="wireless-enabled:1" pid=2678 uid=1000 result="success"
Mär 08 10:15:52 CUS-LM-01 NetworkManager[900]: <info>  [1552036552.0378] manager: rfkill: WiFi now enabled by radio killswitch
Mär 08 10:15:52 CUS-LM-01 NetworkManager[900]: <warn>  [1552036552.6797] platform-linux: do-change-link[3]: failure changing link: failure 1 (Vorgang nicht zulässig)
Mär 08 10:16:14 CUS-LM-01 NetworkManager[900]: <info>  [1552036574.7841] manager: rfkill: WiFi hardware radio set disabled
Mär 08 10:16:14 CUS-LM-01 NetworkManager[900]: <info>  [1552036574.7842] audit: op="radio-control" arg="wireless-enabled:0" pid=2678 uid=1000 result="success"
Mär 08 10:16:14 CUS-LM-01 systemd[1]: Starting Load/Save RF Kill Switch Status...
Mär 08 10:16:14 CUS-LM-01 NetworkManager[900]: <info>  [1552036574.7903] manager: rfkill: WiFi now disabled by radio killswitch
Mär 08 10:16:14 CUS-LM-01 systemd[1]: Started Load/Save RF Kill Switch Status.

Das ist im Moment der Stand der Dinge hier.
Liebe Grüsse aus Basel!
Charlie