Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
10.12.2019, 00:05:53

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22927
  • Letzte: moinmuc
Statistiken
  • Beiträge insgesamt: 623778
  • Themen insgesamt: 50368
  • Heute online: 497
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema: [gelöst]  19.1.: Pulseaudio Modul und X11?  (Gelesen 1686 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #15 am: 05.03.2019, 17:57:59 »
Hi :)
pulseaudio sollte die version 1:11.1-1ubuntu7.1 sein

dpkg -l | grep pulseaudio
ii  gstreamer0.10-pulseaudio:amd64                0.10.31-3+nmu4ubuntu2.16.04.3                amd64        GStreamer plugin for PulseAudio
ii  gstreamer1.0-pulseaudio:amd64                 1.14.1-1ubuntu1~ubuntu18.04.1                amd64        GStreamer plugin for PulseAudio
ii  pulseaudio                                    1:12.2-5~bionic1                             amd64        PulseAudio sound server
ii  pulseaudio-dlna                               0.5.3+git20170406-1                          all          Stream audio to DLNA devices and Chromecasts
ii  pulseaudio-module-bluetooth                   1:12.2-5~bionic1                             amd64        Bluetooth module for PulseAudio sound server
ii  pulseaudio-module-gconf                       1:12.2-5~bionic1                             amd64        GConf module for PulseAudio sound server
ii  pulseaudio-module-zeroconf                    1:12.2-5~bionic1                             amd64        Zeroconf module for PulseAudio sound server
ii  pulseaudio-utils                              1:12.2-5~bionic1                             amd64        Command line tools for the PulseAudio sound server

Ich habe einen gstreamer zu viel  :D Wie bekomme ich den weg?

Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #16 am: 05.03.2019, 18:02:01 »
Hi :)

edit.. den habe ich auch somit nicht notwendig
ka ob der noch aus meiner vor mintupgrade zeit stammt oder für ältere programme gebraucht wird.

sudo apt-get purge gstreamer0.10-pulseaudio

aber vorher gucken was alles mit entfernt wird und das anschliessend gleich wieder installieren

sudo apt-get install paket1 paket2 ~
« Letzte Änderung: 05.03.2019, 18:07:39 von ehtron »

Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #17 am: 05.03.2019, 18:50:48 »
Hi :)

edit.. den habe ich auch somit nicht notwendig
ka ob der noch aus meiner vor mintupgrade zeit stammt oder für ältere programme gebraucht wird.

sudo apt-get purge gstreamer0.10-pulseaudio

aber vorher gucken was alles mit entfernt wird und das anschliessend gleich wieder installieren

sudo apt-get install paket1 paket2 ~

Super, danke erstmal für deine Hilfe. Ich habe jetzt alle (drittanbieter) PPA's erneuert, die Updates installiert, den Paket-cache geleert, autoremove und autoclean gemacht, es sollte eigentlich alles passen. Wenn ich jetzt mit pulseaudio-dlna über wlan streamen will, muss ich
pactl load-module module-rygel-media-server
und das gibt mir weiterhin die selbe Fehlermeldung:

E: [pulseaudio] module-rygel-media-server.c: Failed to get session bus connection: Unable to autolaunch a dbus-daemon without a $DISPLAY for X11

Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #18 am: 05.03.2019, 22:11:24 »
Zitat
Wenn ich jetzt mit pulseaudio-dlna über wlan streamen will, muss ich
pactl load-module module-rygel-media-server
Audiostreaming mit pulseaudio-dlna ok, aber warum dann Rygel, den Zusammenhang verstehe ich nicht (?)

Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #19 am: 06.03.2019, 15:28:46 »
Audiostreaming mit pulseaudio-dlna ok, aber warum dann Rygel, den Zusammenhang verstehe ich nicht (?)

Ich ehrlich gesagt auch nicht, das war damals ein Workaround für 17.x weil irgendwie nichts anderes funktioniert hat.
Die Fragestellung war: vom Laptop über Wlan zur Audioanlage streamen.

Mit dem Beitrag von Mark ziemlich weit unten hats dann endlich funktioniert, war eine unglaubliche Fummelei.

https://askubuntu.com/questions/187086/how-do-i-set-up-live-audio-streams-to-a-dlna-compliant-device

Mit 19.1 fehlt mir die Option in pavucontrol, über dnla zu streamen. Diese Option bekäme ich durch starten des Rygel Media Servers. So war es bisher.

Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #20 am: 06.03.2019, 15:41:05 »
Hi :)
sollte dir doch klar sein, pakete und befehle die für 17.x relevant waren, werden es in vielen fällen, für 18.x oder 19.x nicht mehr sein...

Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #21 am: 06.03.2019, 15:56:03 »
Hi :)
sollte dir doch klar sein, pakete und befehle die für 17.x relevant waren, werden es in vielen fällen, für 18.x oder 19.x nicht mehr sein...

Das hilft mir jetzt nur nicht weiter. Ausgehend davon, dass die obenstehende Variante nicht mehr funktioniert, muss ich wieder bei null anfangen. Ich will ja nicht von einem Medienserver lesen, sondern spezifische Dateien vom Laptop zur Anlage senden.

Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #22 am: 06.03.2019, 16:47:53 »
Umgekehrt funktioniert es übrigens: ich kann über die Anlage auf die freigegebenen Ordner auf dem Laptop zugreifen und die Musik abspielen.
Und vorher konnte ich noch über jedes beliebige Abspielprogramm an die Anlage streamen, indem ich einfach in pavucontrol dlna ausgewählt habe. Und genau das geht jetzt nicht mehr, die Option wird nicht mehr angezeigt.

Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #23 am: 06.03.2019, 17:29:30 »
Hallo,
das Streamen von Musik-Files ist mir in LM19.1 auch noch nicht wieder gelungen.
Ich hatte mich seinerzeit an diesem Thema orientiert: https://www.linuxmintusers.de/index.php?topic=28644.msg435023#msg435023

indem ich einfach in pavucontrol dlna ausgewählt habe.
diese fehlende Option habe ich ebenfalls festgestellt, muss mich da auch wieder einarbeiten.

Edit: es gibt in pavucontrol eine Option, die aber erst ermöglicht wird wenn zuvor im Terminal pulseaudio-dlna installiert wurde und im Terminal mit:pulseaudio-dlnagestartet wird.
Erst danach wird in "Klang" mein Streaming-Gerät (Medion Wlan-Radio) sichtbar und nach dessen Auswahl als Ausgabegerät darauf umgeschaltet. Ein  im Player gestartet Musik-File wird via UpnP auf dem Wlan-Radio abgespielt. ;D
Wichtig scheint die Reihenfolge, 1. Starten von pulseaudio-dlna (Server) 2. die Geräte_Auswahl in "Klang" und 3. Starten des Players. In anderer Reihenfolge wurde mein Streaming-Gerät nicht gefunden.
Klang DLNA Streaming Gerät
Klang DLNA Streaming Gerät

Installierte Pulseaudio Pakete:
dpkg -l pulseaudio* | egrep '^ii '
ii  pulseaudio                  1:11.1-1ubuntu7.2   amd64        PulseAudio sound server
ii  pulseaudio-dlna             0.5.3+git20170406-1 all          Stream audio to DLNA devices and Chromecasts
ii  pulseaudio-module-bluetooth 1:11.1-1ubuntu7.2   amd64        Bluetooth module for PulseAudio sound server
ii  pulseaudio-module-gconf     1:11.1-1ubuntu7.2   amd64        GConf module for PulseAudio sound server
ii  pulseaudio-module-zeroconf  1:11.1-1ubuntu7.2   amd64        Zeroconf module for PulseAudio sound server
ii  pulseaudio-utils            1:11.1-1ubuntu7.2   amd64        Command line tools for the PulseAudio sound server

ich kann über die Anlage auf die freigegebenen Ordner auf dem Laptop zugreifen und die Musik abspielen.
Das gelingt mir trotz Freigabe der gemounteten Laufwerke "Medien" und deren Ordner "Musik" noch nicht. Im entfernten Streaming-Gerät sehe ich mein Notebook gar nicht, die FB7490 hingegen wird mit Namen und IP-Adresse angezeigt. Ich weiss nicht Wo und Was ich noch ändern muss, (Benutzer/Gruppen Zugehörigkeit)?
« Letzte Änderung: 08.03.2019, 17:27:35 von kuehhe1 »

Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #24 am: 06.03.2019, 21:08:41 »
Wichtig scheint die Reihenfolge, 1. Starten von pulseaudio-dlna (Server) 2. die Geräte_Auswahl in "Klang" und 3. Starten des Players. In anderer Reihenfolge wurde das Streaming-Gerät nicht gefunden.

Korrekt. Aber genau das führt dazu, das Pulseaudio mit einer Fehlermeldung im Terminal startet, am Ende der ganzen Codecs:
03-06 21:03:04 pulseaudio_dlna.pulseaudio                     CRITICAL PulseAudio seems not to be running or PulseAudio dbus module could not be loaded. The application cannot work properly!

Zitat
Das gelingt mir trotz Freigabe der gemounteten "Medien" Ordner noch nicht. Im entfernten Streaming-Gerät sehe ich mein Notebook gar nicht, die FB7490 hingegen wird mit Namen und IP-Adresse angezeigt. Ich weiss nicht was ich noch ändern muss, (Benutzer/Gruppen zugehörigkeit?)

Firewall an erster Stelle, behindert regelmäßig die Kommunikation. Dann die Optionen unter Paprefs nicht vergessen, dlna muss dort aktiviert sein.

Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #25 am: 06.03.2019, 21:52:21 »
Aber genau das führt dazu, das Pulseaudio mit einer Fehlermeldung im Terminal startet
Pulseaudio ist heikel, solch ein Problem hatte ich auch mal noch unter LM18 Cin.. Das Dilemma kam durch eine Deinstallation von Kodi (zuviel gepurgt), anschliessend passten die Abhängigkeiten nicht mehr.

Hast du schon mal alles an PulseAudio deinstalliert und wieder installiert. Ich schau morgen mal nach was da mindestens reingehört und melde mich.

"Pafrefs" ist ein gutes Stichwort, Danke. Da muss ich schauen wo das steckt und Firewall ebenso nachgucken. Übrigens rygel hatte ich damals auch verwendet, scheint aber heute zum Musik-Streamen nicht mehr unbedingt erforderlich.

« Letzte Änderung: 07.03.2019, 09:30:31 von kuehhe1 »

Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #26 am: 06.03.2019, 22:23:25 »
Nur mal neben bei: ist von heute:
Update Pulsaudio.
« Letzte Änderung: 06.03.2019, 22:29:30 von tommix »

Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #27 am: 06.03.2019, 22:36:41 »
Update pulseaudio (1:11.1-1ubuntu7.2) bionic ; wurde nachmittags installiert. Danke :)

Ich schau morgen mal nach welche Pakete mindestens erforderlich sind und melde mich.
also die gehören in LM19.1 zur Standardinstallation:pulseaudio
pulseaudio-module-bluetooth
pulseaudio-module-gconf
pulseaudio-module-zeroconf
Das Paket: pulseaudio-module-x11 ist wohl in den offiziellen Quellen nicht vorhanden !?
« Letzte Änderung: 07.03.2019, 17:25:45 von kuehhe1 »

Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #28 am: 07.03.2019, 08:47:18 »
PulseAudio kann man so lassen, wie es standardmässig ausgeliefert wird.
PulseAudio-Lautstärkeregler (pavucontrol) kann man nachinstallieren; ist aber nicht notwendig (auch nicht für pulseaudio-dlna).

pulseaudio-dlna erzeugt ein neues Audio-Ausgabegerät, wenn ein kompatibler UPnP-Client im lokalen Netzwerk gefunden wird.
Hier getestet mit Kodi.
Kodi entsprechend konfigurieren: Dienste UPnP / DLNA  Fernsteuerung über UPnP erlauben

Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #29 am: 07.03.2019, 15:54:44 »
pulseaudio-dlna erzeugt ein neues Audio-Ausgabegerät, wenn ein kompatibler UPnP-Client im lokalen Netzwerk gefunden wird.
ja, aber nur wenn pulseaudio-dlna im Terminal gestartet wird ....
Hier getestet mit Kodi.
Kodi will ich erst mal nicht installieren....

@marco76,
"paprefs" fehlte hier noch und ist nun installiert.
Dann die Optionen unter Paprefs nicht vergessen, dlna muss dort aktiviert sein.
Falls du diese Einstellung meinst, die ist leider ausgegraut.
Netzwerkzugriff auf Ordner:
PulseAudio Einstellungen Netwerkzugriff
PulseAudio Einstellungen Netwerkzugriff

Freigabe als DLNA Server, warum sind die unteren Kästchen ausgegraut??
PulseAudio Einstellungen Server
PulseAudio Einstellungen Server

In der FB7490 ist das Notebook freigeschaltet (sichtbar für andere) und beide Geräte arbeiten (erst einmal) im gleichen Wlan-Funknetz. Am Notebook ist das Verzeichnis /mnt/Medien/Musik freigegeben wird aber vom Wlan-Radio nicht gefunden. Oder gelingt das Finden freigegebener Medien-Verzeichnisse tatsächlich nur mit rygel, denn samba ist hier nicht eingerichtet. Ich checks nimmer.

besser ich eröffne ein eigenes Thema, wegen LM19.1 Cin. Freigabe / Netzwerkzugriff auf Audio-Files ?
« Letzte Änderung: 10.03.2019, 19:10:20 von kuehhe1 »