Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
16.09.2019, 08:55:31

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22539
  • Letzte: KlaSchu58
Statistiken
  • Beiträge insgesamt: 607940
  • Themen insgesamt: 49203
  • Heute online: 443
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema: [gelöst]  19.1.: Pulseaudio Modul und X11?  (Gelesen 1421 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] 19.1.: Pulseaudio Modul und X11?
« am: 04.03.2019, 21:55:11 »
Hallo Leute, Upgrade von 18.3 auf 19.1 erfolgreich abgeschlossen, mit dem Mate Desktop.
Läuft soweit, bis auf Pulseaudio.

pactl load-module module-rygel-media-server
...liefert mir Fehlgeschlagen: Modulinitialisierung fehlgeschlagen

Im Syslog steht:

pulseaudio[1745]: E: [pulseaudio] module-rygel-media-server.c: Failed to get session bus connection: Unable to autolaunch a dbus-daemon without a $DISPLAY for X11
Mar  4 18:17:34 BlueEdge pulseaudio[1745]: E: [pulseaudio] module.c: Failed to load module "module-rygel-media-server" (argument: ""): initialization failed.
Mar  4 18:17:48 BlueEdge pulseaudio[1745]: E: [pulseaudio] module-rygel-media-server.c: Failed to get session bus connection: Unable to autolaunch a dbus-daemon without a $DISPLAY for X11


Der Besitzer ist root, alle Berechtigungen sind root vorbehalten.

Beim Versuch, das Modul mittels sudo -iin der Konsole zu laden, kommt die gleiche Fehlermeldung.

Das Modul ist da, unter /usr/lib/pulse-12.2/modules.

sudo -H apt install -f pulseaudio
war erfolglos.

Mehr fällt mir gerade nicht ein, weil sich pulseaudio(-dlna) grundsätzlich starten lässt:

[imarco@BlueEdge ~ $ pulseaudio-dlna
03-04 21:43:53 pulseaudio_dlna.application                    INFO     Using version: 0.5.2
03-04 21:43:53 pulseaudio_dlna.application                    INFO     Binding to *:8080
03-04 21:43:53 pulseaudio_dlna.application                    INFO     Encoder settings:
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <AVConvAacEncoder available="False" bit-rate="192">
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <AVConvFlacEncoder available="False">
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <AVConvL16Encoder available="False" sample-rate="44100" channels="2">
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <AVConvMp3Encoder available="False" bit-rate="192">
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <AVConvOggEncoder available="False" bit-rate="192">
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <AVConvOpusEncoder available="False" bit-rate="192">
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <AVConvWavEncoder available="False">
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <FFMpegAacEncoder available="True" bit-rate="192">
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <FFMpegFlacEncoder available="True">
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <FFMpegL16Encoder available="True" sample-rate="44100" channels="2">
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <FFMpegMp3Encoder available="True" bit-rate="192">
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <FFMpegOggEncoder available="True" bit-rate="192">
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <FFMpegOpusEncoder available="True" bit-rate="192">
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <FFMpegWavEncoder available="True">
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <FaacAacEncoder available="False" bit-rate="192">
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <FlacFlacEncoder available="True">
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <LameMp3Encoder available="True" bit-rate="192">
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <NullEncoder available="True">
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <OggencOggEncoder available="True" bit-rate="192">
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <OpusencOpusEncoder available="True" bit-rate="192">
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <SoxL16Encoder available="True" sample-rate="44100" channels="2">
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <SoxWavEncoder available="True">
03-04 21:43:53 pulseaudio_dlna.application                    INFO     Codec settings:
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <AacCodec enabled="True" priority="12" mime_type="audio/aac" backend="generic">
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <L16Codec enabled="True" priority="1" mime_type="audio/L16" backend="generic">
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <OpusCodec enabled="True" priority="3" mime_type="audio/opus" backend="generic">
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <Mp3Codec enabled="True" priority="18" mime_type="audio/mp3" backend="generic">
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <FlacCodec enabled="True" priority="9" mime_type="audio/flac" backend="generic">
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <WavCodec enabled="True" priority="15" mime_type="audio/wav" backend="generic">
03-04 21:43:53 pulseaudio_dlna.application                    INFO       <OggCodec enabled="True" priority="6" mime_type="audio/ogg" backend="generic">
Fehlgeschlagen: Modulinitialisierung fehlgeschlagen
03-04 21:43:53 pulseaudio_dlna.pulseaudio                     CRITICAL PulseAudio seems not to be running or PulseAudio dbus module could not be loaded. The application cannot work properly!
03-04 21:44:01 pulseaudio_dlna.discover                       INFO     SSDPDiscover.search()[/i]


« Letzte Änderung: 07.03.2019, 18:00:48 von marco76 »

Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #1 am: 05.03.2019, 08:27:35 »
Ich würde zunächst überprüfen, ob das Audio-System generell intakt ist.
Falls nicht, braucht man mit DLNA-Streaming gar nicht erst anfangen.

Wurde pulseaudio-dlna unter LM 18.3 via PPA installiert?
Das hätte vor dem Upgrade auf LM 19.1 entfernt werden müssen.
Unter LM 19.1 kann pulseaudio-dlna über die Standardquellen installiert werden (Version 0.5.3).

Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #2 am: 05.03.2019, 16:22:13 »
Ich würde zunächst überprüfen, ob das Audio-System generell intakt ist.
Falls nicht, braucht man mit DLNA-Streaming gar nicht erst anfangen.

Wurde pulseaudio-dlna unter LM 18.3 via PPA installiert?
Das hätte vor dem Upgrade auf LM 19.1 entfernt werden müssen.
Unter LM 19.1 kann pulseaudio-dlna über die Standardquellen installiert werden (Version 0.5.3).


Ja, Audio ist intakt. Musikwiedergabe funktioniert einwandfrei. Pulseaudio habe ich über ppa unter 18.3 installiert, dazu gibt es eine extra Paketquelle

deb http://ppa.launchpad.net/qos/pulseaudio-dlna/ubuntu xenial main
Also Pulseaudio entfernen, Paketquelle (s.o.) entfernen, und über die Standard ppa installieren?

Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #3 am: 05.03.2019, 16:28:07 »
Hi :)
Zitat
xenial

da dürfte das problem liegen...  du hast deine weiteren quellen nicht an bionic angepasst.

Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #4 am: 05.03.2019, 16:45:12 »
Hi :)
Zitat
xenial

da dürfte das problem liegen...  du hast deine weiteren quellen nicht an bionic angepasst.

Ich fürchte da hast du recht. Wie gehe ich jetzt vor ohne mir was zu zerschiessen? So wie oben beschrieben?

Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #5 am: 05.03.2019, 16:46:17 »
Hi :)
anwendungspaketquellen dort bearbeiten

zeig mal
inxi -rals codeblock

Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #6 am: 05.03.2019, 16:58:39 »
Hi :)
anwendungspaketquellen dort bearbeiten

zeig mal
inxi -rals codeblock


Mach ich glatt:

Repos:
  No active apt repos in: /etc/apt/sources.list
  Active apt repos in: /etc/apt/sources.list.d/additional-repositories.list
  1: deb http://downloads.sourceforge.net/project/ubuntuzilla/mozilla/apt all main
  Active apt repos in: /etc/apt/sources.list.d/clipgrab-team-ppa-bionic.list
  1: deb http://ppa.launchpad.net/clipgrab-team/ppa/ubuntu bionic main
  2: deb-src http://ppa.launchpad.net/clipgrab-team/ppa/ubuntu bionic main
  Active apt repos in: /etc/apt/sources.list.d/linrunner-tlp-xenial.list
  1: deb-src http://ppa.launchpad.net/linrunner/tlp/ubuntu xenial main
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
  1: deb http://ftp-stud.hs-esslingen.de/pub/Mirrors/packages.linuxmint.com tessa main upstream import backport
  2: deb http://ftp-stud.hs-esslingen.de/ubuntu bionic main restricted universe multiverse
  3: deb http://ftp-stud.hs-esslingen.de/ubuntu bionic-updates main restricted universe multiverse
  4: deb http://ftp-stud.hs-esslingen.de/ubuntu bionic-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ bionic partner
  Active apt repos in: /etc/apt/sources.list.d/opera-stable.list
  1: deb https://deb.opera.com/opera-stable/ stable non-free #Opera Browser (final releases)
  Active apt repos in: /etc/apt/sources.list.d/pipelight-stable-xenial.list
  1: deb http://ppa.launchpad.net/pipelight/stable/ubuntu xenial main
  Active apt repos in: /etc/apt/sources.list.d/qos-pulseaudio-dlna-xenial.list
  1: deb http://ppa.launchpad.net/qos/pulseaudio-dlna/ubuntu xenial main
  Active apt repos in: /etc/apt/sources.list.d/stebbins-handbrake-releases-xenial.list
  1: deb http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu xenial main
  2: deb-src http://ppa.launchpad.net/stebbins/handbrake-releases/ubuntu xenial main
  Active apt repos in: /etc/apt/sources.list.d/videolan-stable-daily-xenial.list
  1: deb http://ppa.launchpad.net/videolan/stable-daily/ubuntu xenial main
  2: deb-src http://ppa.launchpad.net/videolan/stable-daily/ubuntu xenial main

Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #7 am: 05.03.2019, 17:01:56 »
Hi :)
ohha da ist ja ne menge xenial gegen bionic zu ersetzten..

hast du die alten quellen einfach wieder zurück kopiert aus der sicherung nach mintupgrade?

Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #8 am: 05.03.2019, 17:09:02 »
Hi :)
ohha da ist ja ne menge xenial gegen bionic zu ersetzten..

hast du die alten quellen einfach wieder zurück kopiert aus der sicherung nach mintupgrade?


Nein, ich habe nichts kopiert, auch keine Sicherung gemacht. Ich dachte mir entweder es geht, oder auch nicht.

Xenial durch bionic zu ersetzen habe ich schon versucht, da gibts eine Fehlermeldung Datei nicht gefunden oder so ähnlich.

Edith:

E:The repository 'http://ppa.launchpad.net/pipelight/stable/ubuntu bionic Release' does not have a Release file.

Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #9 am: 05.03.2019, 17:17:19 »
Hi :)
wie hast du denn von 18.3 auf 19 upgedatet?  einfach nur die quellen geändert?

pipelight hat kein bionic.. also erstmal ausschalten.

Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #10 am: 05.03.2019, 17:19:32 »
Hi :)
wie hast du denn von 18.3 auf 19 upgedatet?  einfach nur die quellen geändert?

pipelight hat kein bionic.. also erstmal ausschalten.

Die gleiche Fehlermeldung kommt auch bei pulseaudio.

Ich habe mich an diese Anleitung gehalten:

https://www.bitblokes.de/upgrade-von-linux-mint-18-3-auf-linux-mint-19-tara-ist-ab-sofort-moeglich/

Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #11 am: 05.03.2019, 17:23:00 »
Hi :)
ohha da ist ja ne menge xenial gegen bionic zu ersetzten..

hast du die alten quellen einfach wieder zurück kopiert aus der sicherung nach mintupgrade?

Uups, ich habs doch zurück kopiert  :-[ Habs nur vergessen, sorry dafür. Steht auch in der Anleitung dass alle PPa's von alternativen Quellen gelöscht werden.

Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #12 am: 05.03.2019, 17:27:24 »
Hi :)
dir wurde bereits gesagt das die passene pulseaudio in den standard quellen ist.. also das ppa abschalten..

Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #13 am: 05.03.2019, 17:35:09 »
Hi :)
dir wurde bereits gesagt das die passene pulseaudio in den standard quellen ist.. also das ppa abschalten..

Hab ich gemacht, aufgefrischt, aber es kommt kein Update für Pulseaudio, statt dessen Kernel 4.15.0.46.48.

sudo -H apt dist-upgrade
Ich wusste nur nicht ob ich die neue Version einfach drüber installieren kann, ich wollte nichts zerschiessen. Das System läuft schön stabil, und so soll es auch bleiben  :)


Re: 19.1.: Pulseaudio Modul und X11?
« Antwort #14 am: 05.03.2019, 17:43:42 »
Hi :)
pulseaudio sollte die version 1:11.1-1ubuntu7.1 sein

und sudo  -H brauchst du nur für den start von gui programmen im terminal..

mache deine updates mit der aktualisierungsverwaltung dann machst du nicht falsch..