Willkommen Gast. Bitte einloggen oder registrieren. Haben Sie Ihre Aktivierungs E-Mail übersehen?
12.12.2019, 22:28:53

.
Einloggen mit Benutzername, Passwort und Sitzungslänge

Mitglieder
  • Mitglieder insgesamt: 22947
  • Letzte: NoBa
Statistiken
  • Beiträge insgesamt: 624326
  • Themen insgesamt: 50422
  • Heute online: 690
  • Am meisten online: 992
  • (17.11.2018, 20:17:55)
Benutzer Online

Autor Thema: [gelöst]  WLAN Aktivierung schlägt fehl, Realtek RTL8188CUS  (Gelesen 694 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

[gelöst] WLAN Aktivierung schlägt fehl, Realtek RTL8188CUS
« am: 01.03.2019, 18:52:38 »
Hallo,

an meinem uralt Laptop bekomme ich den USB WLAN Adapter nicht ans Laufen. Unter Mint 18.x war er mal erfolgreich und stabil in Betrieb, damals aber nur nach einer Anleitung im Forum der Ubuntuusers.

Die Anleitung liegt mir vor, leider funktioniert sie unter LMDE3 nicht.

Das entsprechende WLAN ist sichtbar mit plausibler Feldstärkenangabe (habe es auch mit einem Hotspot vom Smartphone mit 100% Pegel probiert), aber nach Eingabe des Passkey dauert es ca. 30 Sekunden und die Fehlermeldung:

Aktivierung der Netzwerverbindung fehlgeschlagen
erscheint als popup in Cinnamon.

Hat jemand eine Idee?


inxi -Fz
System:    Host: amilo1655g-lmde3 Kernel: 4.9.0-8-amd64 x86_64 (64 bit) Desktop: Cinnamon 4.0.9
           Distro: LMDE 3 (cindy)
Machine:   Device: laptop System: FUJITSU SIEMENS product: AMILO A Series v: 0100
           Mobo: FUJITSU SIEMENS model: AMILO A1655 v: Rev0.4b
           BIOS: FUJITSU SIEMENS v: 1.0F-8046-8A20 date: 03/07/06
Battery    BAT0: charge: 22.6 Wh 80.1% condition: 28.2/53.3 Wh (53%)
CPU:       Single core AMD Turion 64 Mobile ML-32 (-UP-) cache: 512 KB speed/max: 1600/1800 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS482M [Mobility Radeon Xpress 200]
           Display Server: X.Org 1.19.2 drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           Resolution: 1280x800@60.19hz
           GLX Renderer: Gallium 0.4 on ATI RS480 GLX Version: 2.1 Mesa 13.0.6
Audio:     Card Advanced Micro Devices [AMD/ATI] IXP SB4x0 High Definition Audio Controller
           driver: snd_hda_intel
           Sound: Advanced Linux Sound Architecture v: k4.9.0-8-amd64
Network:   Card-1: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter driver: 8139too
           IF: enp8s13 state: unknown speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Edimax EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]
           IF: N/A state: N/A mac: N/A
Drives:    HDD Total Size: 60.0GB (36.1% used)
           ID-1: /dev/sda model: SAMSUNG_MP0603H size: 60.0GB
Partition: ID-1: / size: 20G used: 6.4G (35%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 15G used: 9.1G (66%) fs: ext4 dev: /dev/sda2
           ID-3: swap-1 size: 5.37GB used: 0.00GB (0%) fs: swap dev: /dev/sda4
Sensors:   System Temperatures: cpu: 78.8C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 185 Uptime: 36 min Memory: 1175.3/1877.2MB Client: Shell (bash) inxi: 2.3.5

lsusb
Bus 001 Device 002: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

iwconfig
enp8s13   no wireless extensions.

wlx74da38050340  IEEE 802.11  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
         
lo        no wireless extensions.


Hier ist die Anleitung, ich habe die Version BIS Kernel 4.10 gewählt:

https://forum.ubuntuusers.de/topic/wlan-stick-524440/3/#post-5638107

Das passiert im Terminal nach Absetzen der ersten Zeile:

sudo apt-get install --reinstall linux-headers-$(uname -r) linux-headers-generic build-essential dkms git
[sudo] Passwort für henrik:               
Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.       
Statusinformationen werden eingelesen.... Fertig
Paket linux-headers-generic ist nicht verfügbar, wird aber von einem anderen Paket
referenziert. Das kann heißen, dass das Paket fehlt, dass es abgelöst
wurde oder nur aus einer anderen Quelle verfügbar ist.

E: Für Paket »linux-headers-generic« existiert kein Installationskandidat.

Will nix kaputt machen, daher habe ich erst mal aufgehört.

Danke für Unterstützung.
« Letzte Änderung: 02.03.2019, 19:51:57 von Isolator »

Re: WLAN Aktivierung schlägt fehl, Realtek RTL8188CUS
« Antwort #1 am: 02.03.2019, 08:25:10 »
Hallo,
lass die Header einfach weg, die sind normalerweise sowieso vorhanden. Steht ja auch in der Fehlermeldung. Du musst nur die erforderlichen Werkzeuge nachinstallieren. Prüfen:
dpkg -l linux-header* | grep ii

Re: WLAN Aktivierung schlägt fehl, Realtek RTL8188CUS
« Antwort #2 am: 02.03.2019, 18:30:33 »
dpkg -l linux-header* | grep ii
ii  linux-headers-4.9.0-7-amd64  4.9.110-3+deb9u2 amd64        Header files for Linux 4.9.0-7-amd64
ii  linux-headers-4.9.0-7-common 4.9.110-3+deb9u2 all          Common header files for Linux 4.9.0-7
ii  linux-headers-4.9.0-8-amd64  4.9.144-3.1      amd64        Header files for Linux 4.9.0-8-amd64
ii  linux-headers-4.9.0-8-common 4.9.144-3.1      all          Common header files for Linux 4.9.0-8
ii  linux-headers-amd64          4.9+80+deb9u6    amd64        Header files for Linux amd64 configuration (meta-package)

Re: WLAN Aktivierung schlägt fehl, Realtek RTL8188CUS
« Antwort #3 am: 02.03.2019, 18:56:30 »
Ja, so wie vermutet, die Header sind bereits installiert.

Re: WLAN Aktivierung schlägt fehl, Realtek RTL8188CUS
« Antwort #4 am: 02.03.2019, 19:51:33 »
Läuft!!!

Aber es gibt ein zwei Hürden, die sich durch Betätigen des Hirns meistern lassen:

1. In der Anleitung wird der RTL8192cu Treiber referenziert und auch geblacklisted. Das nutzt natürlich nix, wenn -wie in meinem Falle- ein anderer, nämlich der RTL8188cus in Benutzung ist. Dieser muss natürlich geblacklisted werden.

2. In der Beschreibung soll der Treiber mit der Version 1.10 verwendet werden, installiert wird aber der 1.11er, somit müssen die Befehle angepasst werden.

Den Tipp von Flash63 einfach in der ersten Zeile den Block mit "linux-headers-generic" auszulassen hat übrigens einwandfrei funktioniert.

Somit ist meine 13 Jahre alte Notebook Krücke tatsächlich zwar langsam, aber trotzdem vollwertig einsetzbar.

Vielen Dank!!!

Re: WLAN Aktivierung schlägt fehl, Realtek RTL8188CUS
« Antwort #5 am: 02.03.2019, 20:08:10 »
Das sind halt die kleinen Unterschiede zwischen Debian und Buntu.